(Topic ID: 106728)

ALIEN PINBALL - Game Over, Man, Game Over


By HeighwayPinball

4 years ago



Topic Stats

  • 24,463 posts
  • 984 Pinsiders participating
  • Latest reply 12 hours ago by noitbe1
  • Topic is favorited by 261 Pinsiders

You

Linked Games

  • Alien Heighway Pinball, 2017

Topic Gallery

There have been 2,795 images uploaded to this topic. (View topic image gallery).

D1D138C1-CC9C-4F78-8A5A-1124491ECEF2 (resized).jpeg
IMG_20190501_214500606 (resized).jpg
CE329737-7E39-47CC-9D4A-13949E94DA14 (resized).png
alien-le-backglass.jpg
07950BFC-FFC9-41E6-A35D-FCED929A3E2A (resized).jpeg
7C818B25-8CC2-4EAF-9BC2-C03EDA106A67 (resized).jpeg
89AEE405-FAFD-495E-A368-30619E490D3D (resized).jpeg
1C7B6E9C-DF26-42C1-8C12-A6BAB90727A3 (resized).jpeg
62F79365-2E2F-4E0B-B030-891B6D277884 (resized).png
7CEC6A26-2DE5-480B-A908-D22FFF45BF78 (resized).png
E136D65B-4C59-41E1-97B7-1547BB7A4054 (resized).png
20190429_231750.jpg
20190429_231757.jpg
7EAE8407-9C1E-4ABE-BBEB-87A755015D33 (resized).jpeg
3B481B8A-23EE-453E-8C78-1B2980553823 (resized).jpeg
817B9CE1-8167-433B-B133-D17F8CFE7C04 (resized).jpeg

Topic index (key posts)

51 key posts have been marked in this topic, showing the first 20 (Show topic index)

There are 24463 posts in this topic. You are on page 358 of 490.
#17851 1 year ago
Quoted from Indypin:

The only negative thing I can say about the play is sometimes it would take a couple of hits before the ball was ejected properly from the shooter lane. One time my daughter was playing the pin and she had a mutiball going that seemed endless. I think it happened during "Bug Ambush", but don't quote me on that. Anyway, I went ahead and turned off the pin and waiting a few seconds before re-booting it (much to my daughter's dismay LOL She had one hell of a score going) and, upon doing so, the pin played good the rest of the night. After the party I played one game and it did the same to me, but the game finally quit shooting out the balls. I don't know, maybe I was just kicking ass during that mode, but I doubt it.

On the ball launch problem, is this at the start of a ball or during multiball (or both)? I would check the alignment of the ball feed.

On the long multiball, the most likely cause is a chatty left outlane sensor. Chech the sensitivity of these two switches in single switch test. They may need adjusting slightly. I'll look into workarounds for this in the next version of the code.

Thanks for the detailed report.

#17852 1 year ago
Quoted from Indypin:

Still, if this was going to be added on later as an option, I don't know how I could do it.

https://pinside.com/pinball/forum/topic/get-away-from-her-you-bitch-alien-club-all-members-expendable

#17853 1 year ago
Quoted from bcd:

On the ball launch problem, is this at the start of a ball or during multiball (or both)? I would check the alignment of the ball feed.
On the long multiball, the most likely cause is a chatty left outlane sensor. Chech the sensitivity of these two switches in single switch test. They may need adjusting slightly. I'll look into workarounds for this in the next version of the code.
Thanks for the detailed report.

Yes sir. Thank you!

#17854 1 year ago

No idea about the fuses as I didn't see it in mine. Unfortunately garbage picked up the box today so it's gone. If someone can tell me the fuses to replace it would be appreciated.

Doesn't seem like dolphin replaced his either and his is fine but I would want to try.

Dolphin yes my launch and start light up

#17855 1 year ago

I'll check for the fuses tonight. I guess I also need to see if there is something disconnected for my button lights.

#17856 1 year ago

Dont they plug these in before they ship them out...10 lights out in playfield for delt's game...button lights out in another....these things should be seen before shipping.
Loose wire from shipping? Sure... but reflow board? Already?

#17857 1 year ago

fuse should not be the issue. fuse would just blow and you need to replace with one rated for US.

Sorry, I dont know off the top of my head what values are.

#17858 1 year ago
Quoted from Whysnow:

fuse should not be the issue. fuse would just blow and you need to replace with one rated for US.
Sorry, I dont know off the top of my head what values are.

What if the fuse is blown and therefore not working which could explain lights off? Not sure it would impact playfield insert lights though not sure.

#17859 1 year ago
Quoted from delt31:

What if the fuse is blown and therefore not working which could explain lights off? Not sure it would impact playfield insert lights though not sure.

I dont think that is possible, but honestly not sure off the top of my head.

I think fuses on thet board are for sepreate voltages (coils, lights, etc...) so if fuse is blown then it would take out all things associated and not just a subset.

If I am remembering corrcetly the swaped in fuse is for flippers.

16
#17860 1 year ago

Super huge thanks to indypin for letting me and my 7 year old come over and play Alien last night!

The game is very fun and has a ton of satisfying shots. If HW can keep it together, I will probably have one of these at some point. I'm not really sure the xenomorph head would ever get old. So cool!

alien pinball xeno.gif

37
#17861 1 year ago

It's here!

IMG_20171026_122356456 (resized).jpg

#17863 1 year ago
Quoted from Whysnow:

I dont think that is possible, but honestly not sure off the top of my head.
I think fuses on thet board are for sevoltages (coils, lights, etc...) so if fuse is blown then it would take out all things associated and not just a subset.
If I am remembering corrcetly the swaped in fuse is for flippers.

The backlight and side lights could be connected to that board. I think the main PCB it's too. Interested to get fuse info and will check asap

#17864 1 year ago

Take a picture of the fuses in that bag! ; )

#17865 1 year ago

Well deserved as you are one of the guys that has paid his dues here.

#17866 1 year ago

Just posting a pic of my board in question. Looking at the fuse chart, I believe it says 4A for 12V (which is likely what I want). The question then is it slow or fast blow for the guys who have the right ones in that baggie....

Also - does it tell you where exactly to put them?

20171024_211205 (resized).jpg

33
#17867 1 year ago

Ditto!

20171026_110410 (resized).jpg

#17868 1 year ago

Congrates guys! After the wait you have all had to endure I hope the game is everything you hoped!

Hope they are trouble free, now get those boxes open and let's see some more unboxing vids.

#17869 1 year ago

congrats to all of you!

Glad to see these 21 getting into owners hands.

#17870 1 year ago

$ HIGH CLAIM ITEM $

you better believe it!

#17871 1 year ago

I don’t see a bag of fuses in mine either.

#17872 1 year ago

Fusegate!!!

all kidding aside, for folks that have no light issues (backbox, side, etc) - can you check the type of fuses in your machine (should be on the fuse itself) so I can check against mine? I'm wondering now if it's fuse related.

I'm at work until late today otherwise I would check mine too.

#17873 1 year ago

The lack of instructions in putting this together is kinda weird. What’s best way to attach the backbox?

#17874 1 year ago

line up the metal bracket three holes with the holes on the head and put the three screws to attach. Then there are two holes in the base that you put those two longer wing braket screws to secure the head on.....I can take pics when I get home.

#17875 1 year ago

I got it. Thanks for the offer. I might need a pic of how the Ball launch button is hooked up. Mine isn’t functional right now

#17876 1 year ago

This is my ball launch mech. Doesn’t light up. Doesn’t plunge. Has those two extra electrical connections at the bottom. Bet something came loose. Have about 5 unused wires but tried hooking one up and the game went all dark. Anyone have a pic of theirs?

AD3F7E66-F07D-4289-ACAC-FD93B14D4E79 (resized).jpeg

#17877 1 year ago

Ok when I get home I'll take a pic! Do your backbox and side lights work bc if so tell me the fuses you have in there....

#17878 1 year ago
Quoted from delt31:

Ok when I get home I'll take a pic! Do your backbox and side lights work bc if so tell me the fuses you have in there....

They do - everything seems to be working. Found the right alligator clip to plug into that launch mech. It’s not lighting up though yet but at least it lights up.

You’ll have to walk me thru checking the fuses for you.

#17879 1 year ago
Quoted from delt31:

Just posting a pic of my board in question. Looking at the fuse chart, I believe it says 4A for 12V (which is likely what I want). The question then is it slow or fast blow for the guys who have the right ones in that baggie....
Also - does it tell you where exactly to put them?

Fuses are fast unless they specifically call out slow blow

#17880 1 year ago

Are these issues design issues, parts quality issues, or manufacturing line issues putting the pin together?

22
#17881 1 year ago

This game is amazing!

image (resized).jpg

#17882 1 year ago
Quoted from kklank:

This game is amazing!

Too excited....it’s happening!!!....more pics and reviews, the better....mark

24
#17883 1 year ago

Unboxing!

150906210175257046740 (resized).jpg

#17884 1 year ago
Quoted from jonesjb:

Are these issues design issues, parts quality issues, or manufacturing line issues putting the pin together?

YES

#17885 1 year ago

20171026_200126 (resized).jpg

#17886 1 year ago

20171026_200806 (resized).jpg

#17887 1 year ago

Nice pics. Yours come with fuses?

As for finding them they're right across from coin box and there is a sign that says fuses. Still not home but will take close pic.

#17888 1 year ago
Quoted from delt31:

Nice pics. Yours come with fuses?
As for finding them they're right across from coin box and there is a sign that says fuses. Still not home but will take close pic.

Mine did not come with replacement fuses.

#17889 1 year ago
Quoted from MK6PIN:

Too excited....it’s happening!!!....more pics and reviews, the better....mark

I agree love hearing about it and I already have one. Alien revolution

21
#17890 1 year ago

3 have landed in Minnesota!

Gonna be a fun night/weekend.

Thanks to Cointaker and Nitro !

IMG_4726 (resized).JPG

32
#17891 1 year ago

So how did my day go?

Got the call this morning that the truck was 30 minutes away:
20171026_104612 (resized).jpg

Alien landed:
20171026_110410 (resized).jpg

Can one man get Alien down to his basement...with stairs that have a 90 degree turn? Yes, yes he can (but not recommended) These games are modular right? So just remove the playfield and take everything down piece by piece.
These are just some of the connections...unlike FT with Alien you need to disconnect seven connections to get the playfield out.
20171026_125538.jpg
20171026_130330.jpg
20171026_130344.jpg

Getting the playfield down the stairs (with my only helper...note the 90 degree turn we just negotiated)
20171026_131135.jpg

Backbox, playfield, legs, and glass top all waiting for the cab:
20171026_131353.jpg

It's alive!
20171026_171116.jpg
20171026_171126.jpg

Everything appears to be working 100%. No extra fuses and the right one's where installed (obviously). My Alien says it's No. 20.

What a great freaking game! The theme integration is unbelievable. The lights, the sounds, the coding...it's a masterpiece. Tons of call outs and I'm sure I've just grazed the surface so far. Great lines from both movies and awesome cut scenes as well. Will take a little getting used to as far as nailing down the shots. Four flippers takes a little getting used to as well. So far I LOVE IT. The Alien ball grab appears to be working perfectly so far. Always cool to watch but I kind of hope they don't add more action to it. I like it kind of rare to keep it special. Love how different the two movies are...as they should be. Completely different sound track but both are amazing. Id have to say far and away this is the best sound package ever put into a pinball machine! (Yes I'm hooked to a sub.)

Is it all perfect no...the ball launcher sucks. Pain in the ass to adjust (IMHO)...only three screws but even when it looks good...it's not. I've tried twice so far but still cannot get consistent ball launches. In fact most end up going into the super launch mode that fires the coil like 6 or 7 times in quick succession. If those don't work (which has only happened once) then you are kind of screwed and have to open it up.

#17892 1 year ago
Quoted from jonesjb:

Are these issues design issues, parts quality issues, or manufacturing line issues putting the pin together?

I think they're just cranking them out and shipping. Probably no QC. They gotta get that money flowing. Hopefully nothing too bad will crop up....

15
#17893 1 year ago

20171026_205146 (resized).jpg

#17894 1 year ago

Does anyone's ball launch light up?

#17895 1 year ago

20171026_210327 (resized).jpg

#17896 1 year ago

I got the single coin mech (European) door for some reason.

#17897 1 year ago

Game is awesome. Kneissl is a happy man. I'll post more thoughts later. Loving it.

20171026_212158 (resized).jpg

#17898 1 year ago
Quoted from way2wyrd:

Does anyone's ball launch light up?

Mine does not currently.

#17899 1 year ago

Alien overload!!!! Great pics guys....beautiful freakin machine!!!

#17900 1 year ago

These buttons do light up, but not during ball launch.

20171026_213511 (resized).jpg

Promoted items from the Pinside Marketplace
$ 399.95
From: $ 12.00
There are 24463 posts in this topic. You are on page 358 of 490.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside