New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 47932)

CV: Ringmaster no reverse direction?


By NJGecko

7 years ago



Topic Stats

  • 16 posts
  • 7 Pinsiders participating
  • Latest reply 7 years ago by NJGecko
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

2013-05-14_20.11.21.jpg

#1 7 years ago

After putting CV back together I have one problem that I never did before, and I'm looking for suggestions.
When I power on the game, the ringmaster cycles for a few minutes and winds up erroring and saying no reverse direction. Once it errors the game actually plays OK, but it's still throwing the error.

I run through the ringmaster tests and it looks like top, middle, and down switches register when I manually run the head in both directions. Not sure what else to check.

It was working before I shopped the machine. I didn't break down the ringmaster assembly, so I don't think anything could have broken or gone missing.

#2 7 years ago

if it makes you feel any better (which i know it won't), i shorted out the audio/video board on mine today by simply putting the playfield back into the cabinet with the power on. uggghh.

-jon

#3 7 years ago

There is a board that attaches to the motor. This controls motor direction. I suggest starting there. You may need to trace the circuit in the manual the determine what causes the direction to change. My friend, pdxgeek, has the same issue and hasn't had time to solve it yet.

#4 7 years ago

OK...off to chase the board...
The weird thing is that the ringmaster will move either way in test mode...so I know it's not the motor.

#5 7 years ago

Did you test the switches/diode?

#6 7 years ago

If not related to the board as markmon stated then maybe it is one of the limit switches for upward and downward movement. Possible you knocked a wire off of its lug.

#7 7 years ago

Does anyone have any pictures or wisdom on how the switches are set up as far as wiring?

#8 7 years ago

Sounds like a switch for when it comes down. I haven't taken mine apart for a couple years so I can't recall where they are, but if it moves fine in test, sounds like what detects it dropping is the issue.

#9 7 years ago

going the other direction usually "rips" out all the switcches. We should have made those optos on that mech. Was an oversight. Jpop

#10 7 years ago

Yea, agree with that jpop...but then again with the lube in there, I could see those optos getting gunked up...

Any suggestions from your end on this? Is there any easy way to troubleshoot this without totally disassembling it further?

#11 7 years ago

I agree that if it goes reverse direction in test (something that I didn't see when making my original suggestion) that its not the board. You should be able to test the switches in edge test / ringmaster test.

#12 7 years ago

Thanks all. I'm going to hopefully spend some time in the next few days working on it. Had a migraine last night, so no pin stuff

#13 7 years ago

Update time....
Pulled everything apart. The switches all registered properly. I rotated the disc front and back and heard each switch click as the cam hit its apex in both directions. Reassembled and ran the switch test and each switch registered properly when I ran the motor manually. When I watched it, the motor only ran in one direction. So for example, it normally goes from down to middle to high. But since it's only going in one direction, for it to go from say middle to down, its going from middle to up to down.
Rebooted the machine and it still reports no reverse direction. Is it possible that there is an issue with the motor or controller board and the motor can't actually run in the reverse?

1 week later
#14 7 years ago

Spent more time, and still no closer to a resolution. I'm about to start throwing parts at it.

When I run the ringmaster test, regardless of which way I try to run the motor, it only goes in one direction. The + and - both run it the same way. Is that supposed to be the case?

When I manually rotate the disc that the motor is attached to, it moves in both directions so the motor isn't seized. I pulled the controller board and visually nothing looked out of place, cracked solder, burned, etc.

Any suggestions? I'd hate to throw a $30 motor at it, and a $50 board just to take a shot in the dark, but I'm not sure where to go next.

#15 7 years ago

Some more updates...
Wound up swapping out the power driver board with my SS. Game worked correctly.
Fellow on RGP suggested I swap the U3 chip since it controls the reverse. On the original board I noticed it was already socketed. Swapped it, no change.
Inspected the board, and whoever socketed it didn't do a wonderful job (see picture). Not sure if I want to try to repair this myself or if it should be sent out.
Also wondering if any related transistors may be suspect as well.

2013-05-14_20.11.21.jpg

1 week later
#16 7 years ago

Just as closure, I swapped in a different power driver board and all is well, works 100%..so I'm going to go with a bad U3 was the final culprit...

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 35.00
Cabinet - Other
Arcade Upkeep
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 47.00
From: $ 22.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside