(Topic ID: 79389)

Zaccaria pinball owners club! All welcome

By SpOoKyRiDeS

7 years ago


Topic Heartbeat

Topic Stats

  • 2,479 posts
  • 259 Pinsiders participating
  • Latest reply 2 days ago by gianfri
  • Topic is favorited by 95 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

135ec52c5585e2a23d0491c8fb3d26e7df617e19 (resized).jpg
image (resized).jpg
34D53F8F-ADBB-4290-B81D-E61BE4E75839.jpeg
20211024_070944 (resized).jpg
245913889_918581865414739_5852051395825042657_n (resized).jpg
245972030_899443294329329_6460410288633316623_n (resized).jpg
245525218_366675928574454_6141771762566172767_n (resized).jpg
IMG_0790 (resized).jpg
IMG_0784 (resized).JPG
Screen Shot 2021-09-23 at 4.37.40 PM (resized).png
2BA492F7-089D-42FE-9B06-8EC730A2A38F (resized).jpeg
F8E7E8C3-0F9B-4527-B4AC-CC06B440B3E7 (resized).jpeg
283D0977-D5AB-4070-8DCF-0EEB879B86ED (resized).jpeg
RIGHT (resized).jpg
LEFT (resized).jpg
784CA593-B798-426E-880F-3F3A4E27E7C4 (resized).jpeg

There are 2,479 posts in this topic. You are on page 15 of 50.
#701 5 years ago
Quoted from JReedie:

My first pinball machine is the EM "Queens Castle" from 1978. I'd love to know how many were made as later on in 1978 the game was turned into the solid state "King of Diamonds" so can't be too many of them kicking around surely?

I'm not sure... they're quite uncommon and I've never seen one in person. Well, not until next Tuesday when mine arrives.

#702 5 years ago

Looking for ribbon cable set for locomotion...
Having trouble with full sound. After sending boards out, it may be the ribbon cable set.
Where am I ever going to find this, been looking for a month now.
Thanks Eric

#703 5 years ago
Quoted from Ericpinballfan:

Looking for ribbon cable set for locomotion...
Having trouble with full sound. After sending boards out, it may be the ribbon cable set.
Where am I ever going to find this, been looking for a month now.
Thanks Eric

Email Dave Gersic.

http://www.zaccaria-pinball.com/

#704 5 years ago

I have a Soccer Kings i am looking to sell if any Zac collectors are interested.I can throw it up in the market with pics to follow the rules.
It has a nice PF,BG has a bit of flaking,cab is pretty good,boards are clean,no alkaline or hacks.
When turned on it keeps resetting the coin door coil.I havent looked into it at all.
All the displays come on and off also as it resets,so they all seem to work.
It's been placed in the market.

#706 5 years ago
Quoted from NicoVolta:

Well, not until next Tuesday when mine arrives.

Oh you suck. I've gotta take a look at it, that playfield art is crazy!

#707 5 years ago
Quoted from NicoVolta:

I'm not sure... they're quite uncommon and I've never seen one in person. Well, not until next Tuesday when mine arrives.

I don't suppose when it arrives you could PM me an image of inside the coin door? I have a loose ground wire and have no idea where it's supposed to connect up to!

#708 5 years ago
Quoted from Frax:

Oh you suck. I've gotta take a look at it, that playfield art is crazy!

That's what originally got my attention. Gorgeous! Love the backglass too... pensive queen in her pinball castle. I can relate... haha. And it looks like a good player, geometry-wise.

Quoted from JReedie:

I don't suppose when it arrives you could PM me an image of inside the coin door? I have a loose ground wire and have no idea where it's supposed to connect up to!

Will do!

#709 5 years ago
Quoted from NicoVolta:

That's what originally got my attention. Gorgeous! Love the backglass too... pensive queen in her pinball castle. I can relate... haha. And it looks like a good player, geometry-wise.

Will do!

I really appreciate that thankyou! I'm having an unbelieveable amount of trouble with mine (it only arrived last Wednesday) and so far I haven't managed to get a signle problemfree game out of it

2 months later
#710 4 years ago

For any Farfalla owners...can you tell me if this relay near the rollover switches, which controls the top bank target reset, is wired correctly? I have 5 ohms across the coils since they are wired in parallel. I see up to 20 volts going to the anode of the diode on the coils, but it does not reset. I had even changed Q22 on my driver board. This is the last issue I need to get repaired on the game that belongs to a friend. If this sounds like a relay issue, anyone know where I can buy one? Thanks all.

Farfalla relay (resized).jpg

#711 4 years ago

There is an easy to miss green/yellow wire with a spade connector that is supposed to connect to ground on the left side of the backbox, near the neon lamp transformer. This provides ground to the upper drop target bank, and it will not reset if it is disconnected. You may want to check there.

#712 4 years ago

Thank you, algum123. That fixed it. I never knew where that wire went to and could not see on the schematics that was connecting anywhere. Much appreciated.

#713 4 years ago

Glad that fixed it. I can't take full credit for the answer however. While I knew the wire was there, and always make sure it stays connected, I did not bother identifying what it did. That information I got from the excellent Zaccaria dedicated site www.zaccaria-pinball.com. It specifically mentions that connection at the bottom of the www.zaccaria-pinball.com/gen2/repairs page.

#714 4 years ago

I read that site many times and didn't notice it or what it was referring to. Pictures help!

2 weeks later
#715 4 years ago

Hey guys I figured I'd give this thread a heartbeat. I am working on my locomotion right now. I have everything working the way it should without any problems except one issue. When I hit the right flipper a
Few times, the game seems like it crashes. The left flipper does not do this, it only seems to be the right. I also would like to point out, it's not the first flip of the game, it's usually 6-15 flips deep into the game. It seems like it happens faster if I hit the flipper in repetition. I don't see any components on the flipper mech grounding anywhere they shouldn't be. It's pretty odd, and I haven't been able to figure it out yet. Anyone with any thoughts of what it could be?

#716 4 years ago
Quoted from Gundam_Pilot_:

Hey guys I figured I'd give this thread a heartbeat. I am working on my locomotion right now. I have everything working the way it should without any problems except one issue. When I hit the right flipper a
Few times, the game seems like it crashes. The left flipper does not do this, it only seems to be the right. I also would like to point out, it's not the first flip of the game, it's usually 6-15 flips deep into the game. It seems like it happens faster if I hit the flipper in repetition. I don't see any components on the flipper mech grounding anywhere they shouldn't be. It's pretty odd, and I haven't been able to figure it out yet. Anyone with any thoughts of what it could be?

Compare the flipper coil winds on each diode against the other flipper coil. Is there an ohm difference between the flipper coils?

2 weeks later
#717 4 years ago

Just one more display to work on but I can at least have the owner finally pick up this game. Every board needed some type of repair. It has been a challenge to get it working and tweaked. LEDs? Well of course, why not? It is a very nice playing game. I used non-ghosting Comet Pinball LEDs and there is no ghosting all with them in this game.

20170128_174115 (resized).jpg20170128_174257 (resized).jpg20170128_174104 (resized).jpg

#718 4 years ago

So the Farfalla owner picked it up and then dropped off this Time Machine for some minor fixes and LED upgrade. Can wait to see how bright this game will be once finished.
20170128_224328 (resized).jpg20170128_224318 (resized).jpg

#719 4 years ago
Quoted from snyper2099:

I just picked up the Pinball Champ that was on Pinside over the weekend at the CLEPIN show.
I am in need of a backglass and a spinner+cam+wire.
So far, I have fixed the sound board (bad PIA) and I have discovered a bad 5514 ram on the MPU.
Everything is working now except a stuck on lamp... Then I will be installing LEDs.
For now, I have hacked in a Willimas spinner with an adapted wireform but it does not work that well.

what did you need for the spinner? I made the cams and have them. Do you have the red towers the spinner goes into?

I don't know how this thread has snuck by me for so long. Been awhile since i've been here.

#720 4 years ago

I'm still looking for a new backbox insert for my green girl farfalla.
Or some way to fix her worn away nose and some other small wear areas.

Does anyone even do this type of meticulous repair?

A new backglass for it is also on my wish list...
Bgresto will do do my glass but hasnt commited to mirror paint yet and I like the mirror part of it, dont want a paint-over...

#721 4 years ago
Quoted from CaptainNeo:

what did you need for the spinner? I made the cams and have them. Do you have the red towers the spinner goes into?

yes, I have the towers. I just don't have to correct spinner or cams. I figured the cams wouldn't do me much good without a ZAC spinner at least. I am still trying to come up with the artwork for the BG as well...

I do have the game LED'd and everything is working now. It's a fun game.

#722 4 years ago
Quoted from snyper2099:

yes, I have the towers. I just don't have to correct spinner or cams. I figured the cams wouldn't do me much good without a ZAC spinner at least. I am still trying to come up with the artwork for the BG as well...
I do have the game LED'd and everything is working now. It's a fun game.

well zac spinners have just straight wires coming out the sides. The cam slides on the straight shaft. So you can use any spinner than has straight wire coming out of it.

#723 4 years ago

I have 3 strikes right now i'm going to be converting into 2 nicer ones. I don't remember if there are spinners on those or not. if there are, i'll have a spinner available.

1 week later
#724 4 years ago

I guess I'm an owner of a somewhat project magic castle. I hope I can get it booting up tonight

IMG_5446 (resized).JPG

IMG_5447 (resized).JPG

#725 4 years ago

looks like it's booting up to me. displays are there.

#726 4 years ago

That was before unfortunately. Now it's. It even getting blinks off the led.

IMG_5470 (resized).JPG

#727 4 years ago

first thing I would do, is pull the far bottom right plug on the PS board. (lower right corner) . check the voltages on all of those pins. There is a breakdown on what your voltages should be. Basically set it to AC. Check both of the same colors. One on one pin and one lead on the other of the same color. This works until you get to the left end of the plug. Those last 4. you have to check the yellow or is it green? to the white set right next to it. Should be 6.3 Volts if I remember correctly. I'm going off the top of my head and don't have any documentation in front of me at the moment.

#728 4 years ago

Transformer voltage is ok. When i checked the power board voltage, tp1 was in the 230 range. The board looks like it had some previous repairs, and I think it could be the issue. Now I need to decide if I want to tackle a rebuild, find someone to do it, or find a new working one.

#729 4 years ago

I don't have a manual in front of me so I don't know what the TPs are suppose to be at.

#730 4 years ago

so weird, I bought an mc last summer and it worked fine for a while, reset once in a while but it now is doing the exact same thing as this one and I haven't been able to figure it out either

#731 4 years ago

Got it booting and into attract mode!! Soldered in a new LM9331 chip, new fuse holders, and reflowed pretty much everything on the power supply.

I put some credits on the game and went to start it and had nothing. Could. It start a game at all. I took the ball out and it started going through the test audits. The drain switch was causing it to change what audit it was in. The right sling adds credits and the left inlane started a game. The center standup ends the game and the right flippers completely shut the game down. Not sure what's really going on with that. Might try try to replace the ic38 3081 chip to see if that solves anything

IMG_5489 (resized).JPG

#732 4 years ago

sounds to me like your switch matrix is all screwed up. You sure everything is plugged in correctly? You sure all the diodes on switches are on correctly? Banded side is where it's suppose to be? Including the coin door switches? Have you tried unplugging the coin door and see if you still have problems?

#733 4 years ago

Yes you blew that IC for sure. Replace
It and you should be good as new. When you blow the chip, the start. Tyron always seem to put it into test mode on the gen 2 stuff.

It's very common to blow the u38 because of the flipper end of strokes are in the same matrix as the standard switch array. The power that goes through can easily ground/arc and
Blow the matrix. If you were adjusting the flipper end of stroke with the game on, it would have caused this to happen. It's likely when you heck out that IC, it will be already socketed.

#734 4 years ago

just shopped out my Soccer kings. Bought this at expo. Was missing a soundboard (which I had in my parts stash). Rubber was crumbling off, but it was in nice physical shape. Everything is running and playing great. LED displays installed. Brinks chip to hold memory forever. Good to go. I've never played one before, but man this game is fun.

finished (1) (resized).JPG

finished (2) (resized).JPG

finished (4) (resized).JPG

finished (3) (resized).JPG

#735 4 years ago

Replaced the 3081 and now magic castle plays like a champ!! Thanks everyone for the help!!

So what are the options for the light tube around the back glass?

#736 4 years ago
Quoted from Its_me_aj:

options for the light tube around the back glass?

I had a new one made for mine. See if you can find a local neon place that will bend one for you.
They just need your old tube for a template.

#737 4 years ago

Just had this delievered today. Super rare Zaccaria/technoplay. Uses Zaccaria parts and boards, but technically a technoplay.

IMG_8164 (resized).JPG

IMG_8166 (resized).JPG

IMG_8167 (resized).JPG

IMG_8165 (resized).JPG

IMG_8168 (resized).JPG

IMG_8169 (resized).JPG

IMG_8170 (resized).JPG

#738 4 years ago
Quoted from brenna98:

I had a new one made for mine. See if you can find a local neon place that will bend one for you.
They just need your old tube for a template.

no where online that sells one already made for zacs?

#739 4 years ago

no. I have an extra one for farfalla. Which is the same one. Just more of a peachish pink color. Very close to magic castle, but I think magic castle is 2 colors. Not sure, i'd have to go look.

#740 4 years ago

I need to get one made for mc after we get it running again. There's a rip in the tube too

#741 4 years ago

I was going to try to do a led tube conversion thing but wasn't sure about the power supply

#742 4 years ago

We've put about 30 on MC tonight and so far it's played like a champ. Flippers are a tad bit weak but that's not a big deal I hope. The upper pf seems really dark but from what I can tell there isn't any lights out. Also I'm. It sure if the Orange special is working right. The other thing I'm not sure about was if there is a spot on the game to show wha player is up? From what I can tell it just shows how many players are in a game, not what one is currently playing

#743 4 years ago
Quoted from CaptainNeo:

but I think magic castle is 2 colors. Not sure, i'd have to go look.

It's one color. Pink

I have a local guy that can make any color.
I think time machine is the only 3 color tube.

If people need these, I suppose I can be the middle man and ship them out.

#744 4 years ago
Quoted from CaptainNeo:

Just had this delievered today. Super rare Zaccaria/technoplay. Uses Zaccaria parts and boards, but technically a technoplay.

That's pretty awesome, nice score Neo!

#745 4 years ago

wait till you see the gameplay video. When I powered up. I was really impressed.

#746 4 years ago
Quoted from brenna98:

It's one color. Pink
I have a local guy that can make any color.
I think time machine is the only 3 color tube.
If people need these, I suppose I can be the middle man and ship them out.

How much?

#747 4 years ago
Quoted from brenna98:

It's one color. Pink
I have a local guy that can make any color.
I think time machine is the only 3 color tube.
If people need these, I suppose I can be the middle man and ship them out.

devil riders is 2 color.

#748 4 years ago
Quoted from CaptainNeo:

devil riders is 2 color

I think you're wrong. My original was pink. Think I sold it to you.
It doesn't matter anyway. If you're gonna redo the neon tube, you can do any color you want.
I did Blue for Devil Riders, and it looked awesome.

I have the tri-color tube for Time Machine over at the neon guy now. He can reuse the template to make any color people may want.

I'll get them made and shipped to people that want them for $100

This pic shows magic castle and devil riders with a new neon. Time Machine isn't done yet. I'll show before/after pics when done.

zac (resized).jpeg

#749 4 years ago

one of them is half and half. Thought it was devil riders.

There are 2,479 posts in this topic. You are on page 15 of 50.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside