(Topic ID: 167974)

Power transformer problem

By jimy_speedt

5 years ago



Topic Stats

  • 4 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by rpk2012
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

image (resized).jpeg

#1 5 years ago

Hi,

Machine is a Zaccaria Pinball champ 82
On connector Cn1 of power driver, I do not get the 6.5 Vac on the 9/10 and 11/12 pairs. Continuity with the power transformer is ok, only I cannot measure on th transfo as pairs come i to a plastic plug as show on the pic. Other voltages are ok. Does it mean the transfo is out of order, or is any action possible ?

thanks

image (resized).jpeg

3 years later
#2 1 year ago

Holy resurrection, I am having the same issues with my Soccer Kings unit. Did you ever happen to get answers? It does not appear many know much about the Zaccaria machines. I know there are a few sites with info, but still so limited.

1 week later
#3 1 year ago

Hi,

Apologies, it finally worked properly, but I do not know what I found as a solution. And the machine is sold for a while now.

I suggest you open a new subject to hopefully get better answers

good luck

#4 1 year ago

Glad to hear! I have, seems people rarely respond with Zaccaria pins. Aside from a dedicated website, there is very little talk /support on them for items lacking info.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside