(Topic ID: 232289)

Xenon Tube Shot Issues

By Tez17

2 years ago



Topic Stats

  • 9 posts
  • 6 Pinsiders participating
  • Latest reply 2 years ago by Tez17
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Xenon left sauser (resized).jpg
1FDEE22C-3354-41F1-90B5-0CCDF79C2ACD (resized).jpeg
DBB0CE74-8965-4C67-AA15-3111372D1EB3 (resized).jpeg

You're currently viewing posts by Pinsider zablon.
Click here to go back to viewing the entire thread.

#3 2 years ago

Is yours missing the metal washer like thing at the bottom near the hole? From my tests this is what should slow the ball down.

For the ball getting stuck at the top - pics would help as mentioned - but do you have a wire there for the switch behind the ramp?

#5 2 years ago

I have mine set up with the clamp on the end as well and I do not have issues with the ball bouncing out. I was going to comment on the rubber, but apparently it was doing it without it. I don't really see any reason you are having this unless it is a pitch thing. Mine is pretty flat.

The wire on the ramp is cut short (probably broke at some point). It should curve back into the slot so the ball just pushes on it both directions. What I did was make my own to put in there (stole it from the coin door mech).

You're currently viewing posts by Pinsider zablon.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside