(Topic ID: 190151)

Xenon Glitch?


By chippe01

3 years ago



Topic Stats

  • 10 posts
  • 3 Pinsiders participating
  • Latest reply 3 years ago by chippe01
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 4 images uploaded to this topic. (View topic image gallery).

IMG_2529-2.jpg
IMG_2531-2.jpg
IMG_1312 (resized).JPG
IMG_1311 (resized).JPG

You're currently viewing posts by Pinsider mappy_mouse.
Click here to go back to viewing the entire thread.

#2 3 years ago

I have a similar problem with my Xenon, mine will also sometimes when the ball drains, kick out both balls into the shooter lane, I'm running the Alltek MPU and have wondered if that is the issue, but cant seem to find anything else wrong. (sorry not trying to hijack your post just thought I would let you know of another Xenon that is doing the same/similar thing.) I have just put up with it as it still plays well.

#9 3 years ago

my guess here is a mis-adjusted or sticky ball gate just inside the shooter lane is allowing both balls to slip though

this old post may shed some light on both issues as well:
https://pinside.com/pinball/forum/topic/80s-bally-ball-delivery-area-switch-xenon#post-1114514

Hi chas10e
Thanks for the advise/tips, I will try your suggestions and see what comes up, hopefully I can get her back to playing as she should.

Promoted items from the Pinside Marketplace
From: $ 155.00
$ 149.00
From: $ 18.00
Apparel - Men
Pinside Shop
$ 9.00
Electronics
Yorktown Arcade Supply
From: $ 140.00
$ 3.50
Various Other Swag
UpKick Pinball
$ 40.00
Lighting - Led
B & K Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball

You're currently viewing posts by Pinsider mappy_mouse.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside