(Topic ID: 186104)

Xenon, a couple of oddities


By chippe01

2 years ago



Topic Stats

  • 10 posts
  • 6 Pinsiders participating
  • Latest reply 2 years ago by TinyToo
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

pasted_image (resized).png
14918409391131446666491 (resized).jpg
IMG_24832 (resized).jpg
IMG_24812 (resized).jpg
IMG_24802 (resized).jpg

#1 2 years ago

I have a couple of issues with my Xenon and would like some advice.

1st issue, sometimes when shooting the ball through the tube, it will exit without falling into the saucer - just go straight out of the gate. How do I fix this?

2nd issue, the middle pop bumper worked sporadically, when I looked under the playfield, the switch underneath had only 1 screw, which was extremely loose. I tightened that 1 screw, making sure the switch was in the correct position. The bumper worked great after that.

Today I was changing a light socket, and the one screw thing was bugging me, so while I had the playfield up, I installed a second screw to ensure the switch wouldn't come loose again.

I fired the game up in lamp test to make sure all the lamps worked, which they did. I started a game, and the middle bumper did not work. When the ball hit the wafer, it would score (I think) and make the Ahhh sound, but the solenoid would not fire. I went into solenoid test and the same thing - all solenoids would fire except for this bumper (09 in the display).

I removed the screw I installed and turned off the power. Turned the game back on and the bumper worked again. Why doesn't it work with the second screw attached? Is the second screw somehow shorting the switch and the circuitry kicking in to turn off the coil so it's doesn't burn? If this is the case, what's the solution? I'd rather not change the switch if I didn't have to.

Lastly, I noticed something weird with the flippers. It seems when I activate either flipper and release, the coil seems to buzz for a few more seconds, then stops. I noticed this with my finger on the bats when releasing the flipper buttons. I have checked the EOS switches, and they open and close correctly with the flipper movement. Is this normal? I haven't noticed this on any of my other machines before.

OK, scratch this last one. I just tested with the PF up, and it's not the coils - it's the springs that pull the bats back. They vibrate for a few seconds when the flipper closes. I figured I'll leave this in, just for good measure.

#2 2 years ago

Can you provide a picture of this area where this 2nd screw is installed?

#3 2 years ago

I'll snap a picture, but I had already removed the 2nd screw. I noticed this had happened previously without the 2nd screw installed, but after a few hits it would work again. I was playing tonight and the same thing happened when I turned on the machine and played my first game. Usually, when the ball exits the saucer, it will hit that middle bumper. Tonight, it hit the bumper and made the ahhhh sound and scored, but did not pop. I kept trying to get the ball up there, and it wouldn't pop, but would score and sound. After a few hits, the bumper was popping again.

Could be a switch issue? But why would the sound and score register?

IMG_24802 (resized).jpg

IMG_24812 (resized).jpg

IMG_24832 (resized).jpg

#4 2 years ago

You have a bad switch. The 2nd screw is causing the switch to ground. Switches are cheap and simple to replace

#5 2 years ago

I used to have this problem, the ball was coming through with too much pace. I don't know what the original configuration was, but I fitted a rubber on the metal post closest to the side rail and this takes the pace off the ball. Solved the problem for me.

14918409391131446666491 (resized).jpg

#6 2 years ago

I may get 1 out of 20 or so roll through, but its usually a really fast tube shot.

My machine has a metal disk on the post you reference, is that what you replaced?

Also, the lower front post - the one on the left under the gate in your pic- has a weird spring thingy instead of a normal post and rubber. Is that normal? sorry no pic handy.

#7 2 years ago

You are missing the insulator tube for the switch stack. With out it the screw can touch ever blade and short them together.
http://www.marcospecialties.com/pinball-parts/3A-7007-114 I'm surprised this hasn't blown something up yet.

pasted_image (resized).png

#8 2 years ago

But if they were shorted, why would the sound and score work, but not the solenoid? Also, sometimes the solenoid wouldn't fire in the solenoid test. The switch test doesn't show any closed switches. I have ordered new spoon switches for all four bumpers, though.

I have also installed a new Alltek Solenoid Driver Board, new LED displays, new lamp driver, new Aux Lamp Driver and new rectifier board tonight. Everything is working as it should at the moment.

#9 2 years ago
Quoted from TinyToo:

I used to have this problem, the ball was coming through with too much pace. I don't know what the original configuration was, but I fitted a rubber on the metal post closest to the side rail and this takes the pace off the ball. Solved the problem for me.

I thought of doing that.

#10 2 years ago

My roll throughs are now very very rare. I just put the rubber on that metal post, the metal plate is still there. Mind you I am also happier now the ball is hitting rubber rather than metal. As you know sometimes the ball flies through that tube and I did wonder if that metal plate would damage the balls. As to the lower springy metal post, I had forgotten, I also replaced this with a standard post a few years ago. The rubber on the metal post was more important in stopping roll throughs though.

Promoted items from the Pinside Marketplace
2,300
Machine - For Sale
Rockford, IL
From: $ 140.00
$ 90.00
From: $ 159.95
From: $ 45.00
Displays
PinballSolutions.eu
$ 44.99
Electronics
PinballElectronics.com

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside