(Topic ID: 321893)

WPC95 MPU cause flipper stuck on

By Pesmerga

1 year ago


Topic Heartbeat

Topic Stats

  • 12 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by Pesmerga
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

u25 (resized).png
IMG-20220912-WA0004 (resized).jpg
Screenshot_20220912_195135 (resized).jpg
mm cpu (resized).jpg
IMG_20220908_215835 (resized).jpg
IMG_20220908_215831 (resized).jpg
IMG_20220908_215908 (resized).jpg
IMG_20220908_215854 (resized).jpg
scheme wpc95 (resized).png
#1 1 year ago

hello to everyone , I have this WPC95 MPU that as soon as the power goes through the machine, energizes the right lower flipper.
The coil remains stuck on until power is removed either by opening the coindoor or shutting down the pin. The solenoid goes stuck on even in test menu, it is not necessary to start a game.

I am pretty sure the problem is on the MPU and not elswhere (ex. a shorting transistor on PDB) because the problem moves through the machines swapping MPU boards..

I have consulted the schematics and think that the problem is in the yellow area(attached image), maybe some failed component let the MPU "think" that the related LR Flipper switch is pressed and activates the coil? Is it possible ? I'm not really sure how to narrow down to the culprit component, I have tested resistors with dmm and they are ok, note that all the lm339 and other ic on the board had been replaced and socketed except the U25 and U7 on this circuit!

Any advice on what to do now? I'd rather don't shotgun replace parts...
Please feel free to correct me if you think i'm on the wrong track!

thanks in advance for your precious help!

IMG_20220908_215831 (resized).jpgIMG_20220908_215831 (resized).jpgIMG_20220908_215835 (resized).jpgIMG_20220908_215835 (resized).jpgIMG_20220908_215854 (resized).jpgIMG_20220908_215854 (resized).jpgIMG_20220908_215908 (resized).jpgIMG_20220908_215908 (resized).jpgmm cpu (resized).jpgmm cpu (resized).jpgscheme wpc95 (resized).pngscheme wpc95 (resized).png
#2 1 year ago

“As soon as power goes through the machine”

Do you mean that as soon as the power switch is turned on, the flipper engages?

Isolate the issue. I know you said it follows the MPU but that seems odd to me.

…Remove the fuse to that flipper.
…power on
…use the diagnostic button to enter switch test.
…if the MPU thinks the switch is closed, it will show on the test display.


Chris Hibler - CARGPB #31
Http://chrishiblerpinball.com/contact
http://www.PinWiki.com/ - The new place for pinball repair info

#3 1 year ago

thank you for your reply Chris, this seems odd to me too! I'll try to do more tests about it and let you all know! which fuse you suggest to remove??

#4 1 year ago

Fuse F115 on the powerdriver

#5 1 year ago

Here I am! Finally I had time to do some tests! Here is a Pic of the switch matrix from switch edge test on the pinball (it's a MM) as you see the UR and LR Flipper switch both result open (they are optos). I tried to disconnect the right flipper opto board and j212 on the mpu but the situation doesn't change, the right flipper still stays stuck on (and the matrix remains as in the photo)

If I remove fuse 115, as suggested, the right flipper stays down but I think it is normal since it doesn't have the 50v through it...

what do you think I should do now? which component could cause this situation? should I replace U25 on the MPU?

thank you in advance!!

IMG-20220912-WA0004 (resized).jpgIMG-20220912-WA0004 (resized).jpgScreenshot_20220912_195135 (resized).jpgScreenshot_20220912_195135 (resized).jpg
#6 1 year ago

When switches F2 and F6 appear active even when J212 is disconnected, start with a check on U25.
If U25 pin 1 and pin 14 are LOW without J212, then something is wrong here.
Check 5V and pull-up resistors around U25
u25 (resized).pngu25 (resized).png

#7 1 year ago

Just had this same situation going on with my totan . J210 reflowed solder and this solved all my issues. My pin was also resetting in attract mode . I hope this helps.

#8 1 year ago
Quoted from zaza:

When switches F2 and F6 appear active even when J212 is disconnected, start with a check on U25.
If U25 pin 1 and pin 14 are LOW without J212, then something is wrong here.
Check 5V and pull-up resistors around U25
[quoted image]

Thanks for the reply, I have a logic probe but never used it before where should i hook the probe to take the necessary voltage while machine is powered on ?

#9 1 year ago
Quoted from Pesmerga:

where should i hook the probe

You can use C31 to hook up the probe. Left leg= (+5V), right = GND
Then with the probe on U25-1 and -14.

#10 1 year ago

Tested with logic probe, here the results:

IC U25-1 and U25-14 are both low
Resistors r111 and r113 are both low

IC U25-9 and U25-7 are both high
Resistors r99 and r103 are both high

What do you think? We have a culprit?

#11 1 year ago
Quoted from Pesmerga:

Resistors r111 and r113 are both low

When resistors R111 & R113 are LOW on both sides, they are not connected to the 5V. (damaged trace ?)
When they are LOW on one side and HIGH on other, U25 is most likely the culprit. Note that U25 pin 6 and 8 must be HIGH (5v) at all times.

4 weeks later
#12 1 year ago

Update! replaced U25 and the problem is solved! I have another issue with crackling speakers on this pin, but I'll do a separate post later! Meanwhile, thank you for your help!!

Promoted items from Pinside Marketplace and Pinside Shops!
$ 35.00
Cabinet - Other
Rocket City Pinball
 
11,000
Machine - For Sale
Livermore, CA
$ 449.00
Cabinet - Decals
Mircoplayfields
 
8,500
Machine - For Sale
Mt Zion, IL
$ 24.99
Cabinet - Decals
Bent Mods
 
From: $ 20.00
Various Novelties
Pinball Photos LLC
 
$ 119.99
Cabinet - (Alt) Translites
FlyLand Designs
 
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
 
$ 9.95
Eproms
Pinballrom
 
8,900
Machine - For Sale
Ontario, CA
$ 27.99
Lighting - Interactive
Lee's Parts
 
$ 89.99
Lighting - Led
Lighted Pinball Mods
 
14,500
Machine - For Sale
Bristow, VA
$ 12.95
$ 89.99
Lighting - Led
Lighted Pinball Mods
 
$ 449.00
Cabinet - Decals
Mircoplayfields
 
$ 399.00
Cabinet - Decals
Mircoplayfields
 
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
 
$ 9.99
Eproms
Matt's Basement Arcade
 
$ 45.95
Eproms
Pinballrom
 
$ 24.50
Playfield - Plastics
Pinball Haus
 
$ 37.99
Lighting - Interactive
Lee's Parts
 
$ 9.95
Eproms
Pinballrom
 
$ 399.00
Cabinet - Decals
Mircoplayfields
 
$ 30.00
Playfield - Other
YouBentMyWookie
 
$ 399.00
Cabinet - Decals
Mircoplayfields
 
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/wpc95-mpu-cause-flipper-stuck-on and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.