(Topic ID: 327306)

Replaced transistor but shaker still doesn’t work

By Mando

3 months ago

Topic Heartbeat

Topic Stats

  • 16 posts
  • 4 Pinsiders participating
  • Latest reply 3 months ago by Mando
  • No one calls this topic a favorite


Linked Games

Topic Gallery

View topic image gallery

2A7DDB85-8739-411C-9DBF-F564844E0746 (resized).jpeg
image (resized).jpg

#1 3 months ago

Was playing my newly acquired Road Show and the shaker was going off when multiball starts(which is normal). At some point it really started to shake!! Shaker stopped game continued to play fine. Opened coin door and there was a burning small. Long story short Q20 appears to be shorted and F111 blown. As expected these both go to shaker, and F111 also does flashers. Needless to say flashers and shaker dont work now.

I have a TIP 102 and can replace as well as a new fuse. My question is what else should I be worried about, are these motors known to go bad and it will just blow it again? I will obviously look for a short and look over the board better when its out. What about the little shaker board?

Also, its hard to read, but pretty sure there was an 8amp fuse and not a 5amp in there...grrr.

I did recently put in LED and GI OCD boards, should not be related but its the one thing that changed.

Not that it matters but this is a supposedly HUO game, and looks to be not played ton super clean, boards clean not hacks(well wrong fuse maybe) etc..

So... again just want to know other than replacing the transistor and fuse what else should I test do before firing it back up.


#2 3 months ago

Disregard this boar its fine

image (resized).jpg

#4 3 months ago

Ok I got to the bottom of the cause .. when I installed my LED OCD I accidentally put the J105 cable in the wrong place which I turn locked all the flashers on . Since they are on the same circuit as the shaker , and also because the wrong fuse was in there it shorted q20.

At this point I replaced q20 but I suspect either I did a poor job or something else is wrong as the shaker will not turn on .

Assuming my solder Job is ok(I think it is but I didn’t love the look of one pad) what else should I test ? I did test the wire at the motor if I touch my probes to the red and black wires on the connector I get just over 20V .. there is also a blue wire not sure if that’s what tells it to turn on and how to test it ?

Assuming it’s not “turning” on what’s best way to test the transistor on the board(not for short but that it works)

Also could it be the pre-driver or a resistor ? They look ok but who knows.

#5 3 months ago

Ok I actually if I put my black lead on ground and my red lead on the hot shaker wire I get 20v when running shaker test and turning off interlock . Thinking motor just got toasted no idea how to test

#6 3 months ago

Quick Monday bump, do shakers motors fry if locked on ? Hoping I just need a new motor and I have fixed the rest.

#7 3 months ago

Motors can fail. There are copper windings that can short out against each other, the motor can run hot and bake the oil/grease until the shaft can't turn, the copper fingers, plates or the brushes inside can burn out, wear out, etc...

Also, the shaker motor and it's power circuitry was designed for very intermittent operation. If it was locked on for quite a while it could have damaged quite a few things.

The easy test is first to fix the burned transistor, replace the fuse, fix any browned/blackened circuit boards and connectors. Open the plastic case, make sure the motor turns by hand and isn't bound up. Close up the case before you apply power, the weight that spins on these motors is dangerous!

Then apply power to the game (with the safety interlock allowing power!) briefly. This tests to make sure there isn't a problem with the pre-driver circuits to the transistor you replaced. If the motor moves when power is applied you still have some work to do on it's control circuits (usually a pre-driver transistor, though it could be blowing the transistor you just replaced instantly(!) or the other components).

When you've got the game up, the shaker motor plugged in and not always on, I'd go into coil test and very briefly pulse the shaker motor through the test menu. If it doesn't move, or immediately blows the associated fuse, yes, you'll need to fix the motor (probably beyond most people's skills...) or replace the shaker motor assembly.

Let us know what you find!

(Ask if you want to know more generally how to test a replacement transistor on a WPC driver board... this involves some alligator clips, a lightbulb socket, etc... Mostly I replace the burnt transistor, plug everything back in and do what I suggest above (a quick power-up-the-game test to find if something's locked on, followed by a test-menu test to check for proper operation.))

#8 3 months ago

Yeah long story short I got Q20 replaced, its no longer shorted. When in test mode the motor does not wizz...but....I seem to get 20V to it when I close the coin door and its on repeat for that coil which goes away when I open the door(well technically press the buttons) so to me that means all is good up to the motor?

There was definitely a significant burning smell and the board looks ok, all coils look ok. for sure the shaker motor was locked on ..until it wasnt

#9 3 months ago

and yes I am sorta curious how to test a transistor on the board! Just to know, also the pre-driver? Is that possible?

#10 3 months ago

Quick transistor operation test for WPC:

I like this:


The basic theory of how pinballs run coils is that the coil always has power to it (when the interlock (if there is one) on the front door is activated). Thus if you take your meter lead, and both sides of the coil read, say, 70v (the 50v circuit reads 70v without a load on it), you know the coil is getting power. (And because the voltage is on the other side of the coil, you know that the coil windings are intact, that the coil or the coil's connections aren't broken, voltage is getting to one side of the coil, and going through the coil to get to the other side.)

The control circuitry fails with the big transistor first (sometimes this is a TIP 36, for most coils it's a TIP 102 replaceable part, whether the number is TIP 102, TIP 120, TIP 122, etc.). First transistor in line with the coil is the usual point of failure.

Sometimes the pre driver to this transistor fails. This is a small transistor like a 2n5401, that drives the TIP 102, and sometimes the resistors and suchlike can be compromised and need repair. Very rarely, the chip that drives the pre-driver transistor that drives the output transistor can fail.

Still, for about 49 of 50 'problem on the board' coil failures, it's the output transistor itself, the transistor first in line with the coil, and nothing else.

So, these transistors can fail, and when they do, they mostly 'lock on' and stay on until they incinerate, where they don't connect any more.

The coil has voltage on it. All the time. Most of the time it has voltage on both wires. It needs a path to 'ground' to complete the circuit. The transistor is what connects ground to the coil.

That's why you can take an alligator clip and put one side of the alligator clip to ground (whether that is the ground terminal in the middle of the WPC Power Driver Board, or a grounded screw holding the board in, or the ground strap at the bottom of the backbox), and briefly touch the other end of the grounded alligator clip to the tab of the coil transistors and activate the coils. Touch it to Q30 (Right Sling), and there will be a spark, and the Right Slingshot coil will pull in. This kind of test should be done very briefly, don't hold the coil in until it incinerates.

You could touch your grounded alligator clip to the tab of Q20, and the shaker motor should activate.

Touching your grounded alligator clip to random things can be risky, so let's look at a test that is unlikely to burn up anything and require further repairs if you do something wrong.

Get a lamp socket (I like the one from Marco above, but as long as you have access to two lamp terminals you can do this). Put a bulb in the socket. Because of the way I hook it to 12V power, it would be best if you have a 161 (12V) bulb, but I always use a 555 and just burn it bright.

Connect an alligator clip to one side of the lamp socket, and the other end of that alligator clip to either TP1 (about 14-16V!, TP2 5V, or TP3 12V, I use TP3 for this). The proper voltage for the 555 bulb is 5 or 6 volts, but if you connect 12V or more to it briefly it won't burn out.

Now we have this lamp in about the same condition as the usual state of a coil. It has power to it, and no connection to ground to allow it to complete the circuit to activate it.

Get another alligator clip, connect it to the other (unconnected) lamp terminal.

Disconnect the plug from J126. Find pin 6, and connect the alligator clip to pin 6.

Go into coil test, get to 22 RIGHT SLING, and the bulb should be blinking.

In a similar way, disconnect J122, find pin 4, connect the alligator clip to pin 4.

Go to the coil test, get to 28 SHAKER MOTER, and the bulb should be blinking.

This verifies the control circuit, that supplies ground to the coil or other device, is capable of turning on, and turning off it's connection to ground. You might want to do this when you have replaced a TIP 102 transistor to verify that the board is now properly repaired.

Fun fact: In coil test, when it is on REPEAT, on a coil, you can press the START button on the front of the game and it will cycle through the wires, connectors, fuses, and eventually the transistors that are associated with the coil under test. Very handy!

#12 3 months ago

Ok it’s the board / transistor. Decided to swap it with a Rottendog I had and it works . The traces didn’t look great when I desolderd it. I use a hakko desoldering gun and it’s usually quite good at the job . There seemed to be some flux residue as well and the transistor was a different brand .

So needless to say while it could be another component I suspect the bad trade . Not sure how to fox that perhaps a professional can do it

2A7DDB85-8739-411C-9DBF-F564844E0746 (resized).jpeg
#13 3 months ago
Quoted from Mando:

Ok it’s the board / transistor. Decided to swap it with a Rottendog I had and it works . The traces didn’t look great when I desolderd it. I use a hakko desoldering gun and it’s usually quite good at the job . There seemed to be some flux residue as well and the transistor was a different brand .
So needless to say while it could be another component I suspect the bad trade . Not sure how to fox that perhaps a professional can do it [quoted image]

ChrisHibler can fix it. I’m not an expert on board repair, but it looks like the broken trace is on the right hole. I’d think you could make a stitch for that.

#14 3 months ago
Quoted from Lermods:

ChrisHibler can fix it. I’m not an expert on board repair, but it looks like the broken trace is on the right hole. I’d think you could make a stitch for that.

Yeah I emailed ChrisHibler its such a pristine board otherwise I’d hate to make it worse . May just grab a spare rotten dog to keep around cause I don’t want to wait 90 days . I’ll have 5 games it would work on if needed in the future

#15 3 months ago

I’ll take care of that.
You won’t need a stopgap board.

Chris Hibler - CARGPB #31
http://www.PinWiki.com/ - The new place for pinball repair info

Promoted items from the Pinside Marketplace
Machine - Wanted
Gainesville, VA
From: $ 15.00
Playfield - Decals
$ 109.95
$ 11.95
Playfield - Toys/Add-ons
$ 399.95
Lighting - Led
Pin Stadium Pinball Mods


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/wpc89-shaker-shorted-transistor-blown-fuse-f11-roadshow and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.