(Topic ID: 213443)

WPC-S coil issue


By kse001

1 year ago



Topic Stats

  • 17 posts
  • 6 Pinsiders participating
  • Latest reply 6 months ago by jay
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

I am in the process of putting a game back together and I have a problem with one coil. It is one of the high powered solenoids. When the game is first turned on, it behaves normally (i.e. the coil does not activate immediately). When I activate it in the test menu, the coil fires and then stays locked on until the game is powered off. Even releasing the interlock switch does not cause the coil to release - once it fires the only way to get it to stop is to flip the power switch.

I've been poking at this for the past day or so, and out of frustration I just replaced the TIP36c, TIP102, 2N5401, and corresponding LS374, but this had no effect - the coil is still behaving just as it did before I replaced them.

Any suggestions on what to look at next?

Thanks,

Kyle

#2 1 year ago

Hi Kyle,What game is it?Did you try another coil?Are the wires in the correct order soldered on that coil?Did you test the transistor after installing another one?

#3 1 year ago

Are you sure it's locked on, or is it just sticking?
The power interlock cuts coil power.
Something is odd here.
--
Chris Hibler - CARGPB #31
http://www.ChrisHiblerPinball.com/Contact
http://www.PinWiki.com - The Place to go for Pinball Repair Info

#4 1 year ago

Thanks for the replies. It is a Roadshow, and specifically it's the upper right diverter. I can tell by the sound that the coil is locked on rather than just stuck - that kind of "buzz" when the coil is being held.

Fair point on testing the new transistors. I admit I just assumed they were good, so I will need to double check them. I'll also double check the wiring again, too.

#5 1 year ago

Not real sure what happened, but when I went to work on this today it was working exactly as it should. Not a big fan of problems like this that just magically disappear, but we'll see if it comes back. I did not even touch the game since making my initial post, and prior to that the behavior was very consistent as described. In any case, thanks again for the responses.

#6 1 year ago

This is very odd...Lol! Post back if the problem returns

#7 1 year ago

As I had expected, the problem did return. I finished removing enough parts to get the dozer blade working as it should, and after re-assembling everything figured I should run through the coil tests again to see if had come back. Apologies, my initial description was not complete and had one part that was flat out wrong (which I should have realized in retrospect):

When I activate that coil in test, it locks on. The interlock switch DOES kill it, but as soon as I close the switch again the coil locks on again. In addition, testing other coils after it's locked causes the problem coil to fire and lock on again.

#8 1 year ago
Quoted from kse001:

The interlock switch DOES kill it,

Yes that is correct the interlock switch kills all Hi-power to all the coils,The next thing to do is locate the transistor that runs that coil.The location of the transistor would be on the driver board in the backbox,The manual will tell you the location.That transistor will need to test with multimeter,Post back if you need more help.

#9 1 year ago

Thanks. Sorry for the delayed response, but I've been using this post as a guide to go through things a bit more: https://pinside.com/pinball/forum/topic/sttng-f104-fuse-keeps-blowing/page/2#post-2268964. This has been pretty strange; I've fixed things like this before, but this one is not quite like the others.

A quick recap: the coil was locking on in test. Note: it only locked on after being activated - it did not lock on as soon as the game was powered on. I did some basic testing, pulled the PDB and replaced all 3 transistors for the coil, along with the 74LS374. Put the board back in, reconnected everything, and the coil still was locking on. Then, without me even touching the game, the problem mysteriously disappeared the following day and the coil worked normally. And then, about a day later, the problem came back, again without me doing anything (I'm working on other things).

I visually inspected the wiring on the coil and tested other coils to see if there were any other new issues. At that point I found that none of the high powered coils worked: sure enough, fuse had blown. I replaced the fuse and booted the game again. As soon as I closed the coin door, the fuse blew again. That is what led me to the post I mentioned above.

I ran through the various suggestions in that post, pulling the appropriate connectors, checking for grounding at the pins, etc. and didn't find any issues. I pulled the PDB again and re-tested ALL transistors for ALL the high powered coils, including the associated diodes this time, and everything was good. Put the board back in, powered the game up, and surprise: the coil was working as it should.

One thing I realized I did wrong during the above is that after pulling the board the first time, when I put it back in I wired it up, but I did not screw it in, so it was just "hanging" on the mounting screws. Since those screws provide grounding, is it possible that the original problem actually was the transistor/74ls374, but then everything that happened after that was due to the board not being secured? Or that the coil itself is going bad? I feel like I'm grasping at straws, but considering all the other tests made things appear to be OK. I bought this game as a project, and I really want to get it out of the house now but I don't want to list it for sale without being reasonably sure this issue has really been fixed. Any insights from someone more experienced with diagnosing these kind of problems would be greatly appreciated.

#10 1 year ago
Quoted from kse001:

Or that the coil itself is going bad?

Coils very very seldom go bad unless that coil is fried,Did you test the pre drive transistor?This transistor is the smaller one and the manual will tell you the location.
3 things to look into and test them again
1.The main Transistor
2.The Pre-drive transistor-smaller one
3.The Coil and diodes on that coil(If there are any)

#11 1 year ago

Thanks for the response. Yep, I tested all transistors, not just for the coil exhibiting the problem, but for all high powered coils (1-8). To be clear, when I say "all" transistors, I mean the 2N5401, the TIP102, and the TIP36c for every one of those coils. All 24 transistors have been tested twice now since replacing the 3 associated with the problem coil, and they all test good. As I mentioned, I also checked all the diodes (on the PDB, not the coil, as there are no diodes on these 8 coils).

I know it's unusual for coils to go bad, but I was at a loss for explaining the behavior I was seeing and wasn't sure if a bad coil could lock on, or if it would just not work. When you suggest testing the coil (#3 in your list), what is the best way to do that? Do you mean the following procedure? It seems like this would be appropriate for a coil that doesn't fire at all, but not sure about the problems I've been seeing. Or is there some other process you'd recommend:

Testing for Power at the Coil.
Most pinball games (including WPC) have power at each and every coil at all times. To activate a coil, GROUND is turned on momentarily by the driving transistor to complete the power path. Since only ground (and not power) is turned on and off, the driving transistors have less stress on them. With this in mind, if we artificially attach a coil to ground, it will fire (assuming the game is turned on).

Turn the game on and leave it in "attract" mode.
Lift the playfield.
Put the DMM on DC voltage (100 volts).
Attach the black lead of the DMM to the metal side rail.
Touch the red lead of the DMM on either lug of the coil in question.
A reading of 20 to 80 volts DC should be indicated. Switch the red test lead to the other lug of the coil, and the same voltage should be seen again. On flipper coils, test the two outside lugs of the coil. If no voltage reading is shown, no power is getting to the coil. On a two lug coil, if there is only voltage at one lug, the coil winding is broken. On 1993 and newer WPC games, make sure the coin door is closed!
If no power is getting to the coil, a wire is probably broken somewhere. Trace the power wire.

#12 1 year ago

Testing a coil,Power off the game.Set meter to ohms place one probe on the outer left tab hole of the coil and the other probe on the outer right tab hole of the coil.The meter should read 2 ohms or higher anything less would indicate the coil has/is shorted.

#13 1 year ago

Just replace the coil. They're $10.

#14 1 year ago
Quoted from pinmike:

Testing a coil,Power off the game.Set meter to ohms place one probe on the outer left tab hole of the coil and the other probe on the outer right tab hole of the coil.The meter should read 2 ohms or higher anything less would indicate the coil has/is shorted.

Thanks, I will try that tonight or tomorrow.

#15 1 year ago
Quoted from RonaldRayGun:

Just replace the coil. They're $10.

Cost is not the issue. I have had enough experience to know that the coil itself is seldom the problem as Mike said earlier. When I've dealt with problems like this before, it has always been a transistor or 74ls374 which is why I am seeking advice from those with more knowledge in this case. To me it makes little sense to pay the $10 (plus shipping), wait 3-5 business days for it to arrive, remove the inconveniently located assembly to replace the coil, replace said assembly, only to find that it was not the issue in the first place. A systematic approach to identify the real problem is a better method than guessing, IMO. Even more so when I plan to list the game for sale as soon as it's done - I don't want to sell it knowing that the buyer may encounter a problem I should have fixed.

#16 1 year ago

Would be great if you could swap the pdb with a known working board and see if the problem goes away.

1 year later
#17 6 months ago

Did this ever get sorted? I have the identical issue (though mine seems to never go away) on an NBA Fastbreak. I have not fully rebuilt the driver section for the particular coil outside of replacing a few TIP102s that keep failing as none of the other parts appear bad. What I did do was swap parts around on the driver board to see if the problem followed and it did not. The LS374 seems fine as well since no problems show up in diode test or with a logic probe. The fuse associated with this coil (in NBA's case, the shoot coils are driven by the unused flipper transistors and it's one of these that's failing) will blow sometimes and not other times. The TIP102 will blow almost immediately during a game but will not fry if I don't allow the coil to stay held during switch test. Coil was also replaced/tested just to make sure but it's fine as well. So I'm stumped.

Promoted items from the Pinside Marketplace
$ 27.99
Lighting - Interactive
Lee's Parts
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 75.00
Playfield - Other
Great American Pinball
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 19.95
Playfield - Toys/Add-ons
ULEKstore
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 233.10
4,600 (OBO)
Machine - For Sale
Colorado Springs, CO
$ 115.00
Playfield - Other
Great American Pinball
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 99.00
Gameroom - Decorations
Pinball Sales
Wanted
Machine - Wanted
Oakville, MO
From: $ 22.00
$ 29.99
Lighting - Interactive
Lee's Parts
4,000
Machine - For Sale
Phoenix, AZ
$ 9.90
Playfield - Toys/Add-ons
pinballmod
$ 47.00
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 34.95
Playfield - Toys/Add-ons
pinballmod
3,010 (OBO)
Machine - For Sale
Pittsburgh, PA
€ 3.70
$ 89.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 130.20
Cabinet - Sound/Speakers
PinWoofer

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside