(Topic ID: 182965)

WOZ power supply board problems


By Nugget88

2 years ago



Topic Stats

  • 11 posts
  • 8 Pinsiders participating
  • Latest reply 2 years ago by DutchTommy
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

pp000023_LI (resized).jpg
image1 (resized).PNG
image (resized).jpeg

#1 2 years ago

i have a WOZ standard edition and when i was playing i noticed an electrical burning smell coming from the cabinet. After turning off immediately and opening her up. This is what i seen

#2 2 years ago

image (resized).jpeg

#3 2 years ago

That's a known problem part to JJP. Call them tomorrow and they'll probably warranty it with an updated PS. I actually added a 12v cooling fan mounted to the perforated metal casing to keep the new PS from ever overheating again.

#4 2 years ago
Quoted from Nugget88:

i have a WOZ standard edition and when i was playing i noticed an electrical burning smell coming from the cabinet. After turning off immediately and opening her up. This is what i seen

https://pinside.com/pinball/forum/topic/yikes-woz-fried-lots-of-smoke-where-do-i-start

#5 2 years ago
Quoted from Nugget88:

This is what i seen

The manufacturer substituted that part with an inferior one and we didn't know until they started to burn.

JJP tried to locate the games that had them to replace them. Sorry they missed you.

During business hours please call JJP 732-364-9900 ext 1. Have your game serial number ready. Frank or Victor will fix you up.

LTG : )

#6 2 years ago
Quoted from LTG:

The manufacturer substituted that part with an inferior one and we didn't know until they started to burn.
JJP tried to locate the games that had them to replace them. Sorry they missed you.
During business hours please call JJP 732-364-9900 ext 1. Have your game serial number ready. Frank or Victor will fix you up.
LTG : )

Yet another example of why I will be a repeat customer at JJP

#7 2 years ago
Quoted from LTG:

The manufacturer substituted that part with an inferior one and we didn't know until they started to burn.
JJP tried to locate the games that had them to replace them. Sorry they missed you.
During business hours please call JJP 732-364-9900 ext 1. Have your game serial number ready. Frank or Victor will fix you up.
LTG : )

LTG - Any way to identify the inferior part? I have WOZ built in August of 2014...

#8 2 years ago
Quoted from 27dnast:

LTG - Any way to identify the inferior part? I have WOZ built in August of 2014...

Best call JJP ext. 1 and Victor or Frank can look up your serial number and see what is in your game.

LTG : )

#9 2 years ago

Good night, I've been looking for help and I can not. Friend, could you help me? I have a WOZ machine and she burned the source board. The staff of the JJP sent a new plate, only that it had also burned the mother board. I bought another one and changed it. Only after the change of the motherboard, the machine initializes only the pc. The rest of the machine does not light anything! Did it burn another plate? Sorry for my bad English. Because I'm from Brazil. I ask for your help, because no one has answered me so far from JJP support. thank you

image1 (resized).PNG

#10 2 years ago
Quoted from RicardoMenezes:

because no one has answered me so far from JJP support.

Best contact Frank or Victor for what next. I pm'd you their email addresses.

LTG : )

#11 2 years ago
Quoted from RicardoMenezes:

Good night, I've been looking for help and I can not. Friend, could you help me? I have a WOZ machine and she burned the source board. The staff of the JJP sent a new plate, only that it had also burned the mother board. I bought another one and changed it. Only after the change of the motherboard, the machine initializes only the pc. The rest of the machine does not light anything! Did it burn another plate? Sorry for my bad English. Because I'm from Brazil. I ask for your help, because no one has answered me so far from JJP support. thank you

i had the same problem not so long ago with WoZ.. after searching i found out that the USB cables located on the lower right side of the Big IO Board inside the metal Box.. they were plugged in but didnt make good contact for some reason anymore.. i tried to reseat both usb connectors.. and the game came alive like magic.. try that.

pp000023_LI (resized).jpg

Promoted items from the Pinside Marketplace
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 11,500.00
$ 15.00
Playfield - Protection
Pin Mods
$ 156.00
Playfield - Toys/Add-ons
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside