(Topic ID: 191771)

WOZ code update 6.5


By FalconPunch

2 years ago



Topic Stats

  • 294 posts
  • 86 Pinsiders participating
  • Latest reply 1 year ago by Nokoro
  • Topic is favorited by 20 Pinsiders

You

Linked Games

Topic Gallery

There have been 9 images uploaded to this topic. (View topic image gallery).

IMG_1551 (resized).JPG
reefer_madness (resized).jpg
images (resized).jpeg
Screen Shot 2017-06-26 at 9.26.41 AM (resized).png
IMG_0059.JPG (resized).jpeg
Screen Shot 2017-06-23 at 3.21.33 PM (resized).png
20170623_085618 (resized).jpg
IMG_4760 (resized).JPG
IMG_1266 (resized).JPG

You're currently viewing posts by Pinsider nokoro.
Click here to go back to viewing the entire thread.

#12 2 years ago

This is amazing! The code was already great. It is nice to see this extra polish added to it. I can't wait to install. Other companies should take note of how to do great code support. Thanks JJP!

#97 2 years ago

Just came home after a long business trip and did the update. I love the floating scores and balls in reserve. I'm a bit disappointed in the fact that they took some of the light show away after making the save Toto shot. The lights used to flash white in a pattern to mimic Toto running. I always thought that was such a cool touch. Maybe they took it away by mistake and will add it back . . . . (I hope!)

#104 2 years ago
Quoted from Vyzer2:

Also, don't see the twinkling white lights when you make a skill shot. Is that now gone?

You're right. That's gone too. I hope that and the lack of a TOTO finish are just things that were overlooked and will be put back in rather than intentional omissions.

#113 2 years ago
Quoted from MK6PIN:

Hmm...think the twinkle lighting effect and toto are still intact....maybe I'm missing something....

Really? That's weird. Can you try it again? If you save Toto, in the old version, the inserts would flash white one at a time as if Toto were running across the playfield. With the update, this doesn't happen. If it happens for you but not me and apparently some others, something must be wrong. I would love it if you could confirm.

#117 2 years ago
Quoted from beelzeboob:

Well...I have the new code on my USB, but no way in hell is this going into my machine until they fix the twinkly lights and the Toto lights. The extra balls, I'll take.

Agreed. I'm thinking about reverting I miss those lights so much! But I'm also pretty darn lazy . . . .

#123 2 years ago
Quoted from MK6PIN:

Will try again....I know I saved TOTO, and saw the typical white light insert trace...( disclaimer..it was bourbon night, but no alcohol tonight so will report shortly)

I think we've all seen the Toto lights after too much bourbon.

#129 2 years ago
Quoted from DeathHimself:

I think TNPLH sequence and lighting is different too now, to me it looks like it lost its sepia appearance. Really considering dropping back to 6.11, now can I roll it back or do I have to do a fresh install of 6.06 and delta upwards.

It did lose the sepia tone and is brighter now. I too like the old version. Supposedly, there is more fanfare at the ending now, at least according to the change log, but I haven't completed it yet to see.

#135 2 years ago
Quoted from lyonsden:

I don't get it -- the code gets updated with new features being added years after the game is released (and the code was already in great shape). Some very minor light effects get lost or the color changes slightly in a 5 second mode and people go nuts. I will happily take the code with new features at the loss of a couple of twinkles. The lighting effects are outstanding, the code is superb, and Keith and JPP's commitment to WOZ should be applauded.

I wouldn't say we are going nuts. We all applaud JJP and what they have done and continue to do with the code. We're just pointing out that there are a couple of bugs that still need to be corrected. I personally thought those Toto lights were an amazing touch. I didn't realize how much I really liked them until they were gone. It was touches like that that showed just how polished the code was and how committed Keith was to making it everything it could be. It would just be a shame if the added features were at the expense of other features. Personally, I think they'll make it right in the final 5.51 update.

#164 2 years ago
Quoted from pinball_keefer:

I hesitate to even say this, but the missing lightshows are due to a bug due to a change in a very low level system that caused conflicts with how Oz did some lightshows. We didn't notice it because tbh we haven't been playing Oz daily for quite a few months now.
So, it'll get fixed, I'm sorry, didn't mean to take them out, and the cause was something completely unrelated to the lightshows themselves.

Awesome! Thank you!

And, to make this thread more positive, in celebration, I personally agree to put in beelzeboob's mulch. Just tell me where I find the rake.

#201 2 years ago
Quoted from delt31:

Ok thanks. Would full updates also change lifetime play stats too? If so seems like you can never get a true read on how many plays the machine has

You can save your settings which I believe saves the lifetime plays as well before you back up, but if you are looking for a used pin, you should never go by the stated number of plays, as people might not have saved properly.

#209 2 years ago

I like the concept of daily high scores but frankly was getting tired of constantly entering my initials even for mediocre games. I only play a couple times a day. I wasn't sure if I wanted to turn them off though. So, I upped the minimum score requirement for a daily high score to 100,000 and problem solved.

I do really like the concept and will probably lower it when friends are over. I think it will be really cool on location as well.

#217 2 years ago
Quoted from Rdoyle1978:

This particular issue is a low-level OS implementation of the audio system though; Ubuntu now uses that new audio engine, which just has problems that haven't been fixed

Quoted from vireland:

The Ubuntu problem with the audio has been an issue with the kernel used since about April 2016 or so. There are workarounds on the web for PC users.

Quoted from Rdoyle1978:

Yes but since ubuntu 16.04 uses pulseaudio 8, it's a huge deal to try to backport (frontport?) to pulseaudio 9, and the workarounds don't seem to be reliable enough to put into a machine that has to work "all the time". Anyway it's annoying, I dont disagree

Quoted from vireland:

From what I read, it seems that the problems are related to the intel power save/sleep system for audio. Disabling that solved the issue for many of the people on PCs.

Sometimes I don't feel like I belong on these forums.

#224 2 years ago
Quoted from MK6PIN:

Yep...scared the crap out of me the first time it happened.....

It still scares the crap out of me.

3 weeks later
#237 1 year ago
Quoted from Farmboss:

I am not sure what the general consensus is on this update is. Worth it or not? Can a poll be added?

It's definitely worth it, but I do miss the twinkly lights that we have already complained about and which are going to be fixed. Whether you update now or wait for the fix, ultimately you should update.

#244 1 year ago

It used to be that if Extra Ball was lit and you were in save Toto mode, you could still hit the throne room to get an extra ball. I just tried that with the new code and couldn't do it. I wonder if that was a purposeful change. I wouldn't be surprised if so. I always thought it was a bit weird that you could still collect extra ball while in Toto or TNPLH.

3 months later
#263 1 year ago

I believe I've discovered another bug, and it is potentially game ruining. I tested it with the glass off, and got it to repeat itself. I was hoping someone could try it on their machine and verify.

Here's the general situation: Sometimes when you have two balls locked and hit another ball up the ramp, the timing of the arm is a bit off and releases two balls. (This is adjustable, but even adjusting it, it can still happen from time to time.) When this happens, I don't want an unearned multiball, so I let one ball drain and play with the other ball. However, if I then hit the other ball up the ramp, it treats that as a drain, and I lose the ball. I do not believe this happened at all with the old code.

So, to test, please take the glass off and lock two balls. Then, without lighting "lock" push another ball up the ramp. The pin will release one ball, but you can release a second on purpose just by raising the arm with your hand. Let the first ball drain and keep the second ball. Wait a few seconds, hit some switches to prevent the game from going into search mode. Then, without lighting "lock" again, push the ball up the ramp. In my case, that always results in the machine thinking the ball has drained.

This sucks as it can ruin your game if the machine accidentally releases two balls. Again, the accidental release happens from time to time, and I don't believe the old code ever did this.

Can someone try to verify?

#266 1 year ago

Thanks guys for the feedback. It would be great if you could verify with the glass off. I would like to email JJP, and it would be better if I can say that others have verified this.

#269 1 year ago
Quoted from merccat:

I tried a few times to replicate with the glass off but couldn’t. There may be another unknown in play.
Any chance any of your balls are magnetized? Sometimes that can cause balls to be in unexpected postions in the lock and/or trough. I know when I had some of those super shiney balls lots of wierd things would happen.

Weird. No, I use the carbon steel ones. When you tried it, did you hit the last ball up without the lock light on? If lock is lit, I don’t believe it registers a drain.

Quoted from pinball_keefer:

Hm, this definitely shouldn't happen, I'll have to check it out. Is it safe to assume you're shooting the ball up the ramp a fair amount of time after the ball drains?
A ball drain is supposed to "eat" a lost ball, so this should never happen. A lot of code did change in that area recently, though, so it's possible something was introduced. Will look into it.

Thanks for the quick response. I’m not sure if I hit the ball up there a lot, but it is a common shot as you know. I’m pretty sure it won’t happen if lock is lit. I’ll have to play with it more to see.

#270 1 year ago

I just tried this several more times, and it happens each time. It can happen after one ball is locked or two. It can even happen when lock is lit, so I was wrong about that. The last time I tried it, I waited a long time between draining the extra released ball and hitting the ramp again. Despite waiting a long time, hitting the ramp registered a drain.

I checked all switches on the Munchkin lock and in the trough and they registered ok.

Would love to hear back from others who try this.

#272 1 year ago
Quoted from DeathHimself:

Happens in my 6.50 code RR as well. Just glass tested it and sure enough the same results as you. Hopefully Keith will look into this as well as replace the lost lighting effects that happen in the update.

Thanks! I’m always glad to find out that I’m not crazy.

#276 1 year ago
Quoted from merccat:

So wierd as it never happens to me following your steps.
Maybe it’s being triggered by a setting? I’m using ball in reserve mode, maybe the issues doesn’t manifest in that mode... will try switching back.

I’m using balls in reserve. That is weird. You are on the latest release, right? Not a beta version? Since it’s happening to at least one other person, it must be a code issue.

It could be there is some other setting, but I’m not sure what that would be. I’ve given myself a 10 second ball save, but I let that expire before I try. Do you have a ball save, and if so, do you let it expire before trying?

#279 1 year ago
Quoted from merccat:

Well I’m on 6.5 and tried both ball in reserve and ball in play plus tried adding a ball save.
To confirm, without looking back up at your directions, here is what I’m trying:
- Start a new game, no balls held in locks.
- Lock Lion, then lock Scarecrow, tin man not yet enabled.
- push ball up ramp, letting two release from lock so that one ball is left in lock
- let one ball drain and shoot the ramp (tin man still not enabled).
Not sure what to try now, sorry I wasn’t much help here, still pretty sure this has happened to me before though.

That sounds right. For kicks, you could try it with just one ball initially locked. Not sure why it is not happening for you, but happening for others.

One last thing to try. I’m pretty sure all of the times I tried it, Scarecrow was left unlocked. When I get home, I can try by locking scarecrow to see if that makes a difference.

#281 1 year ago

I just tried by locking scarecrow first, and it still happened.

However, I noticed something. When it releases two balls, it seems to know and puts a ball save on for a few seconds. So, if you let both released balls drain the normal way, it will kick one back into play. I assume others have this feature. merccat , please try sending the ball up the ramp once that ball save turns off (if you haven't already). Anyway, for those who have the problem, until the code gets fixed, the solution seems to be to just let both balls drain and have one kicked back into play.

#283 1 year ago

Here's a video:

One thing I do is I roll the ball up the ramp when the shoot again light is off. If you roll the ball up the ramp right away with the shoot again light on, it kicks a ball into the shooter lane and things seem to work from there.

One other thing: I have the pindemption dongle. I doubt that matters, but I thought I would mention it as it might be a difference between my machine and others.

#287 1 year ago
Quoted from pinball_keefer:

Thanks, ballsaver is the missing part here.

Oh good. I'm glad that helped. Does that mean you were able to replicate it, and it is a software issue?

1 week later
#288 1 year ago

I just had another weird one where two balls were released from the arm, I got one immediately captured by the monkey and kept playing with the other one. Then I hit the ramp, and it didn’t notice the ball was held by the arm. Eventually, it went into ball search mode and released both balls. I do think there is something messed up when it accidentally releases two balls.

#290 1 year ago
Quoted from RobKnapp:

Do you think I should hold off on a WOZ 75th 2.0 RR purchase . I absolutely would like to see what is going on by JJP tech from the video you sent .

No. Don’t worry about those slight bugs. They are rare occurrences happening somewhat more frequently for me because I recently waxed so a fast ball up the ramp sometimes releases two balls. I haven’t found the sweet spot yet for adjusting the timing of the arm.

Besides, it sounds like they are going to get fixed. JJP code support is great. The game’s code is fantastic. One of the best coded games out there.

#293 1 year ago
Quoted from check_switch_26:

Yes, it's a software issue. You can avoid the problem (for now) by turning off the ball saver.

Ah, thanks. Unfortunately, without the ball saver, I have other problems purely relating to my own abilities.

2 weeks later
#294 1 year ago

Just saw that 6.6 is out which, from the release notes, seems to fix the bugs and add a few things as well. Sweet! Thanks JJP!

Promoted items from the Pinside Marketplace
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
8,200 (Firm)
Machine - For Sale
Victoria, BC
$ 114.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 54.00
10,500
Machine - For Sale
Gainesville, TX
$ 279.95
$ 16.95

You're currently viewing posts by Pinsider nokoro.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside