(Topic ID: 141945)

WoZ 5.05 bugs - post them here


By zsciaeount

3 years ago



Topic Stats

  • 139 posts
  • 47 Pinsiders participating
  • Latest reply 3 years ago by vireland
  • Topic is favorited by 11 Pinsiders

You

Linked Games

Topic Gallery

There have been 4 images uploaded to this topic. (View topic image gallery).

image_(resized).jpeg
image_(resized).jpeg
image_(resized).jpeg
capturedorothylight.jpg

There are 139 posts in this topic. You are on page 3 of 3.
#101 3 years ago
Quoted from DCFAN:

Perhaps your switch behind the flipper did not activate?

Okay, got it to repeat by setting it up with the glass off. It does not seem to happen with 4 horses - ever. However, with 5 horses (or maybe all quantities over 4, I only tested 5), if you shoot into the shooter lane to collect your 5 horse stable right after the ball auto launches for the witch's lights on mode, it will not collect the horses. The game has to be in multiball or you have to cancel the witch lights on start video to get the ball fast enough to make this happen.

#102 3 years ago
Quoted from DCFAN:

Perhaps your switch behind the flipper did not activate?

I've had the collect horses not activate quite a bit... and am thinking switch as well (but haven't examined it yet)... that said, it seems like the software should notice the switch by the plunger is pressed and still award the horses (kind of like a back up)... or at least that would be nice as there should be no other way to get a ball back there...

#103 3 years ago
Quoted from vireland:

Okay, got it to repeat by setting it up with the glass off. It does not seem to happen with 4 horses - ever. However, with 5 horses (or maybe all quantities over 4, I only tested 5), if you shoot into the shooter lane to collect your 5 horse stable right after the ball auto launches for the witch's lights on mode, it will not collect the horses.

Hmm... maybe it isn't the switch b/c that is usually how I hit it...

#104 3 years ago

Just did the upgrade. Went fine. Very easy to do. Btw, I did this with a MAC and it worked fine.

#105 3 years ago

Had the locked on insert lights again. Third time. It *seems* like all of them are tied to a multiball and crystal ball mode stack. Somewhere during or after it messes up the status of the insert lights, locking some of them on. In this recent one, everything from about the 9 in YBR down was locked on. Later in the game, the inserts over by Toto rollovers (maybe 9 of them) got SUPER BRIGHT, but other than that, all the insert lights in the affected area were locked on.

#106 3 years ago

Another weird bug. Started a new game. Screen glitched out and it jumped into a witch hurryup with 2500 point (not moving) and gave me 5,075 points. All of this with the initial ball still in the shooter lane.

#107 3 years ago
Quoted from vireland:

Another weird bug. Started a new game. Screen glitched out and it jumped into a witch hurryup with 2500 point (not moving) and gave me 5,075 points. All of this with the initial ball still in the shooter lane.

That's the witch's gift surprise mode.

#108 3 years ago
Quoted from vireland:

Another weird bug. Started a new game. Screen glitched out and it jumped into a witch hurryup with 2500 point (not moving) and gave me 5,075 points. All of this with the initial ball still in the shooter lane.

Likely your witch switches are too sensitive.

#109 3 years ago
Quoted from DCFAN:

Likely your witch switches are too sensitive.

I might think that, except for the random 5075 points that don't line up with any skill shots I know, including the witch.

But it would be a good failsafe to put in the code. If there's only one ball and that ball is in the shooter lane waiting to be plunged, all scoring is disabled.

#110 3 years ago
Quoted from underlord:

That's the witch's gift surprise mode.

Put the WOZ in switch test mode and then nudge the machine. You'll probably see which switch is too sensitive.
(wrong quote but you get the idea)

#111 3 years ago
Quoted from wtatumjr:

Put the WOZ in switch test mode and then nudge the machine. You'll probably see which switch is too sensitive.
(wrong quote but you get the idea)

This doesn't trigger the witch switch on mine. Also, pretty sure the 5,075 points and hurryup on game start was an actual bug/glitch because the video on the screen glitched out completely momentarily.

I didn't mention it before, but this happened on the first game after turning it on. It was turned on, in attract mode for a while, then started and that happened.

#112 3 years ago

Got the no insert lights at all (just spotlights) on powerup bug today.

#113 3 years ago

I had something weird happen today, first time I'd seen it. I was down to making the last 2 shots to kill the witch, and in the past at least, I think I had to hit past the drop target (on the way up to the castle), and then the house, and then maybe hit the witch on the loop around? Either way I know I did this like 2 or 3 times and it never trigged the kill until maybe the 4th time. Just yesterday I got to this mode and it worked the very first time, so just seemed a lot harder if not something not working correctly.

Love this game by the way. I've broken a million 3 times now over the last few days. Woot!

#114 3 years ago
Quoted from cscmtp:

I had something weird happen today, first time I'd seen it. I was down to making the last 2 shots to kill the witch, and in the past at least, I think I had to hit past the drop target (on the way up to the castle), and then the house, and then maybe hit the witch on the loop around? Either way I know I did this like 2 or 3 times and it never trigged the kill until maybe the 4th time. Just yesterday I got to this mode and it worked the very first time, so just seemed a lot harder if not something not working correctly.
Love this game by the way. I've broken a million 3 times now over the last few days. Woot!

To Melt the Witch, after making four shots, I believe the drop target goes down on its own. You shoot one ball into the VUK behind the drop target and it holds the ball there. Then you shoot the ramp with the other ball and one-time the witch after the ball falls out of the Munchkin playfield.

3 weeks later
#115 3 years ago

Just had a bad one. First ball, about 15k score, just got the "Looks like there's a twister coming, better shoot the ramps" callout as the ball drained. I held both flippers to speed through the end ball score screen and then held the start button to start a new game. The screen went black and all the inserts went to about 1/10th brightness, flickering, then the whole machine rebooted.

Is the Linux core they're using in this keeping a system log? Maybe that would be helpful when things like this happen.

#116 3 years ago

UPDATE to the Weird Witch Skill Shot/Hurryup bug that can happen at game start in 5.05!

Okay, had this happen again today and was able to pay closer attention. Turned the machine on. As SOON as the screen came up with the scarecrow I started pressing “START” to begin a game. It took three presses before it registered (three slow press and holds). When it finally DID register, instead of the witch animation that normally starts a game, I got the orange “Skill shot” animation and 5,075 points, THEN the ball launched up from the trough to be launched. This clearly shows it’s a program bug and not a loose witch switch because there was NO mechanical action before Skill Shot was displayed, and the witch start game animation never played.

This event also locked most of the playfield lights on the right to green, as well as the lights in the state fair area. The rest of the lights were all locked to various colors.

EDIT: I can reproduce it! From power on, start pressing and holding then releasing Start slowly in succession as soon as Scarecrow shows up. this time it took 4 presses before the game started, and I got the glitch to happen instead of the witch animation to start the game! It also messes up the lighting in different ways most times.

EDIT2: 100% reproduction rate with the above method. Try it on yours!

1 week later
#117 3 years ago

After power up (first game) when I hit the monkey targets the back panel capture arrow flashes blue. When I hit the shot, the monkey descends, picks up the ball, and then arrow goes dark. It never lights again. It won't even go through the described sequence in a second or third game. The arrow does activate during LED light show/sequences...but as for it's intended game function, it's malfunctioning!

#118 3 years ago
Quoted from vireland:

UPDATE to the Weird Witch Skill Shot/Hurryup bug that can happen at game start in 5.05!
Okay, had this happen again today and was able to pay closer attention. Turned the machine on. As SOON as the screen came up with the scarecrow I started pressing “START” to begin a game. It took three presses before it registered (three slow press and holds). When it finally DID register, instead of the witch animation that normally starts a game, I got the orange “Skill shot” animation and 5,075 points, THEN the ball launched up from the trough to be launched. This clearly shows it’s a program bug and not a loose witch switch because there was NO mechanical action before Skill Shot was displayed, and the witch start game animation never played.
This event also locked most of the playfield lights on the right to green, as well as the lights in the state fair area. The rest of the lights were all locked to various colors.
EDIT: I can reproduce it! From power on, start pressing and holding then releasing Start slowly in succession as soon as Scarecrow shows up. this time it took 4 presses before the game started, and I got the glitch to happen instead of the witch animation to start the game! It also messes up the lighting in different ways most times.
EDIT2: 100% reproduction rate with the above method. Try it on yours!

I tried what you said. After power up the scarecrow starts dancing. I pressed the Start button three times and it started a game on the third press. It did not give the skill shot with points. That is your witch switch being too sensitive. It needs to be adjusted. I had that problem about a month after getting the game. After adjusting the switch it does not do that anymore.

The reason for the third press starting the game is likely because the computer is still doing part of the boot-up routine.

#119 3 years ago
Quoted from DCFAN:

I tried what you said. After power up the scarecrow starts dancing. I pressed the Start button three times and it started a game on the third press. It did not give the skill shot with points. That is your witch switch being too sensitive. It needs to be adjusted. I had that problem about a month after getting the game. After adjusting the switch it does not do that anymore.
The reason for the third press starting the game is likely because the computer is still doing part of the boot-up routine.

I could buy that if the video on the screen didn't glitch out for like a quarter second sometimes (with graphics and garbage) when this happens and if Keith hadn't admitted there's legacy code in the source to work around this issue so it doesn't happen. It just may not be effective due to something changing in 5.05.

Also, I've shaken the machine and hit the playfield at varying distances with the palm of my hand while in switch test mode to try to trigger the witch switch and it's rock solid. No change, not even a blip unless I hit the actual switch.

#120 3 years ago

Hi guys, this may have been in the 4.0 software too but sometimes my crystal ball looks like this:

It's like static on an old tv, but color

image_(resized).jpeg

image_(resized).jpeg

#121 3 years ago
Quoted from paynemic:

Hi guys, this may have been in the 4.0 software too but sometimes my crystal ball looks like this:
It's like static on an old tv, but color

image_(resized).jpegimage_(resized).jpeg

I am guessing that is a loose connector at the ball. The new code seems to have fixed most of the crystal ball image glitches.

#122 3 years ago
Quoted from vireland:

I could buy that if the video on the screen didn't glitch out for like a quarter second sometimes (with graphics and garbage) when this happens and Keith didn't admit there's legacy code in the source to work around this issue so it doesn't happen. It just may not be effective due to something changing in 5.05.
Also, I've shaken the machine and hit the playfield at varying distances with the palm of my hand while in switch test mode to try to trigger the witch switch and it's rock solid. No change, not even a blip unless I hit the actual switch.

Do you still get the witch skill shot occasionally when you start a game that is not the first game after turning on the machine?

#123 3 years ago

I have a new to me WOZ LE with 4.11 code.

Despite the issues brought up to in this thread, are there more? I am considering keeping my code at 4.11 until these get fixed.

Thoughts?

Marcus

#124 3 years ago
Quoted from Xerico:

I have a new to me WOZ LE with 4.11 code.
Despite the issues brought up to in this thread, are there more? I am considering keeping my code at 4.11 until these get fixed.
Thoughts?
Marcus

best part about the new code is the Add a ball and MB resurrection changes. The Dorothy lock lamp bug is annoying in multiplayer game. New code should drop ANYDAY NOW FOR THE LOVE OF ALL THINGS WOZ so I would just keep 4.11.

#125 3 years ago
Quoted from DCFAN:

Do you still get the witch skill shot occasionally when you start a game that is not the first game after turning on the machine?

Yes, but it is far more rare than the chances of it happening after it's first turned on. Like 50-100x more rare.

#126 3 years ago

Has anyone experienced this since installing 5.05? It doesn't happen very often, but sometimes I'm playing a game, and all the sudden the screen goes out (like tonight I think I hit the witch with the upper flipper and poof, looks dead) I reboot and so far it comes back fine, I can play, and I might not see this again for weeks. But it has happened now probably 5-6 times over the last 2 months. Any ideas? Think its code related?

#127 3 years ago

Yes, its a bug in 5.05. Happened to me many times.

#128 3 years ago
Quoted from cscmtp:

Has anyone experienced this since installing 5.05? It doesn't happen very often, but sometimes I'm playing a game, and all the sudden the screen goes out (like tonight I think I hit the witch with the upper flipper and poof, looks dead) I reboot and so far it comes back fine, I can play, and I might not see this again for weeks. But it has happened now probably 5-6 times over the last 2 months. Any ideas? Think its code related?

It's definitely a bug in 5.05. You don't have to reboot, though. When this happens to me, I just open and close the coin door and the video comes back as soon as I open the door.

#129 3 years ago

Today I turned WOZ on and it started but no lights. Clearly playable. Everything else going on but no playfield and no lcd.

Separately, should the crystal ball be on most of the time? Mine is blank most of the time but occasionally has a winged monkey, etc., mostly blank. Sometimes the color static from my previous post.

image_(resized).jpeg

#130 3 years ago
Quoted from paynemic:

Today I turned WOZ on and it started but no lights. Clearly playable. Everything else going on but no playfield and no lcd.
Separately, should the crystal ball be on most of the time? Mine is blank most of the time but occasionally has a winged monkey, etc., mostly blank. Sometimes the color static from my previous post.

image_(resized).jpeg

The ball does go blank some but not the majority of the time, and the static is a problem in your game.

#131 3 years ago
Quoted from Xerico:

I have a new to me WOZ LE with 4.11 code.
Despite the issues brought up to in this thread, are there more? I am considering keeping my code at 4.11 until these get fixed.
Thoughts?
Marcus

You picked up a WOZ?

#132 3 years ago
Quoted from Snailman:

You picked up a WOZ?

Yep. Same one from the Houston Show.

Marcus

#133 3 years ago
Quoted from Xerico:

Yep. Same one from the Houston Show.
Marcus

Nice! Hopefully the castle doors problem was an easy fix

#134 3 years ago
Quoted from cscmtp:

GREAT notes and it worked on the first try. Have to wait until the morning to play as to not wake up the kids but can't wait! So far REALLY loving this pin!

Because it's AWESOME?????

#135 3 years ago

I was told by support that 5.05 was viewed as very buggy. Hopefully 6 will be here soon.

#136 3 years ago

I'm fine with waiting for 6.0 so they can comb it carefully for any bugs. It is better than getting it early and living with the bugs. Take your time Keith.

#137 3 years ago

3days to 3 weeks as 6.03 is in final beta testing (from the jjp support guy I called about my crystal ball).

I got the ball stuck behind the closed castle door once and found that there were no rubbers on the posts in there. Is that normal or an assembly flaw? I put them on and it appears to help. Has anyone else had problems with this?

#138 3 years ago
Quoted from paynemic:

3days to 3 weeks as 6.03 is in final beta testing (from the jjp support guy I called about my crystal ball).
I got the ball stuck behind the closed castle door once and found that there were no rubbers on the posts in there. Is that normal or an assembly flaw? I put them on and it appears to help. Has anyone else had problems with this?

Yes. The rubbers will help.

#139 3 years ago
Quoted from paynemic:

3days to 3 weeks as 6.03 is in final beta testing (from the jjp support guy I called about my crystal ball).

Wonder what the changelog differences are between the posted 6.00 one and 6.03.

Promoted items from the Pinside Marketplace
$ 165.00
Playfield - Toys/Add-ons
Pixels Arcade Games
$ 279.95
$ 189.00
Gameroom - Decorations
Lit Frames
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 399.95
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
From: $ 40.00
Cabinet - Other
ModFather Pinball Mods
Wanted
Machine - Wanted
Benicia, CA
$ 50.00
$ 42.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
9,000
Machine - For Sale
Fullerton, CA
$ 12.99
8,200 (Firm)
Machine - For Sale
Victoria, BC
$ 8,500.00
Pinball Machine
PinballSTAR Amusements
$ 11,500.00
$ 156.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 40.00
Cabinet - Other
ModFather Pinball Mods
There are 139 posts in this topic. You are on page 3 of 3.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside