(Topic ID: 50131)

World Cup Soccer 94 owners. Everyone welcome.


By DEWSHO

7 years ago



Topic Stats

  • 5,824 posts
  • 532 Pinsiders participating
  • Latest reply 2 days ago by jorro
  • Topic is favorited by 189 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,425 images uploaded to this topic. (View topic image gallery).

IMG_20200516_113426 (resized).jpg
2290B6B8-C308-4BAB-9A12-0FAE26F1348B (resized).jpeg
FC74C75D-485D-40CA-A9FE-870EFC7BBC56 (resized).jpeg
60D1249C-DF26-4692-820F-C47A6D428D0E (resized).jpeg
5DE8FEED-19E2-4246-869E-6CDAD47C12DE (resized).jpeg
46158500-3802-4408-AE01-5862310E64BC (resized).jpeg
IMG_0340 (resized).jpg
IMG_0338 (resized).jpg
IMG_8231 (resized).JPG
IMG_8232 (resized).JPG
DSC_1980 (resized).JPG
pasted_image (resized).png
WhatsApp Image 2020-05-04 at 10.39.30 (resized).jpeg
IMG_20200502_073154 (2).jpg
Attach52165_20200501_233838 (resized).jpg
Attach52159_20200501_233614 (resized).jpg

There are 5824 posts in this topic. You are on page 68 of 117.
#3351 2 years ago
Quoted from alistaircg:

I have a problem that I can not figure out, please could somebody help ?
WCS94 has 4 balls. When locking balls , 1st ball locka successful 2nd balls does not lock. When the player looses the 2nd ball, the machine searches for a ball (know that there is a ball missing, this ball is in lock mode) . After searching for the ball for a couple of seconds, it then decides to release the ball (1st ball) that was locked
When going through test mode in the program, all switches and sensors indicate as working. The machine does not display any faulty switches

Hmmm... that kinda screams bad trough opto to me.

#3352 2 years ago

Not sure if anyone has need, but I have a couple spare WCS trans. One is an original with Slight yellowing, the other is a high quality, super nice repro. Looking for $125 obo shipped for either of them in the USA.

PM me if interested.

IMG_0451 (resized).JPG

IMG_0452 (resized).JPG

#3353 2 years ago
Quoted from RDReynolds:

Not sure if anyone has need, but I have a couple spare WCS trans. One is an original with Slight yellowing, the other is a high quality, super nice repro. Looking for $125 obo shipped for either of them in the USA.
PM me if interested.

Repro gone, still have the original.

#3354 2 years ago

Hi all, I bought a World Cup Soccer on Saturday. It is my first pin, and we got everything set up yesterday and all seemed great. We played for a couple hours and took a break. When I hit the start button again, the sound wasn't working. I ran the sound test, and eventually all the sounds kicked in. We kept playing and all was fine.

However, this morning, I fired it up and again, the sounds weren't working. I ran the sound test and they all say "running" but no sound is coming out. Does anyone have any suggestions? Keep in mind, it is my first pin. Speak slowly and use small words, haha.

#3355 2 years ago

i'd guess loose connection somewhere. check/reseat connectors. could be cracked solder around male connectors, too.

#3356 2 years ago

The long wide ribbon cable running from CPU board (with all the chips) clockwise to the other three smaller boards is usually the culprit. The top center board is the sound board.

Carefully remove the cable, spray with contact/electronics cleaner, let it dry and reattach it. Press firmly.

Be sure to take pictures before if you don't know which way it's seated. There's a red edge on it to see alignment. Make sure the ribbon cable sits properly and doesn't "miss" any pins.

If you are uncertain, just try to press firmly on the cables four connections.

#3357 2 years ago

Hey guys – need some tech help on this game.

Rollover switches 1-4 (red circles leading to the goal) and two switches on each side of the left ramp don’t work. I suspect they’re all on the same line and one is out? I haven’t had a chance to look into it further but any advice and what to focus on? I believe the wire that connects them all is green and blue.

#3358 2 years ago

More than any other game my WCS has flaky switches that just end up being the switches. Trace the wires back, make sure no breaks or broken diodes, and maybe swap in a good switch and test it before monkeying around with the switch matrix.

#3359 2 years ago
Quoted from gunstarhero:

More than any other game my WCS has flaky switches that just end up being the switches. Trace the wires back, make sure no breaks or broken diodes, and maybe swap in a good switch and test it before monkeying around with the switch matrix.

Thanks. Will def double check when I get home. Any chance it could be a blown fuse or is it def wire/switches?

#3360 2 years ago
Quoted from delt31:

Thanks. Will def double check when I get home. Any chance it could be a blown fuse or is it def wire/switches?

More Likely A Broken Wire In That chain.

#3361 2 years ago

Thanks for the quick responses. If you happen to have a chance to take a pic of this area, please post so I can compare. I've been trying to get as many as possible to see where mine is different (assuming it's not an obvious break).

#3362 2 years ago

Has anyone installed an NVRAM on their board? On the following page it says if you have an existing 62256 chip (which I do) that no change is needed. But soon thereafter it says to remove R93 and install jumper W3, which would mean you have to make a change. Kind of confusing to me.

So has anyone installed an NVRAM chip in their game yet? If so, what all did you have to do to install it, other than desolder the exiting RAM, solder on the new socket, and put in the chip itself?

Forgot to link the page I was referring to: http://www.pinitech.com/products/62256_nvram.php

#3363 2 years ago
Quoted from Bugsy:

Has anyone installed an NVRAM on their board? On the following page it says if you have an existing 62256 chip (which I do) that no change is needed. But soon thereafter it says to remove R93 and install jumper W3, which would mean you have to make a change. Kind of confusing to me.
So has anyone installed an NVRAM chip in their game yet? If so, what all did you have to do to install it, other than desolder the exiting RAM, solder on the new socket, and put in the chip itself?

Yes, I've done it. Basically WPC boards can have two different setups for RAM chips:

1. 6264 chips
2. 62256 chips

The difference between the chips (from what I remember) is just the overall storage size of the chips (64Kbit vs 256Kbit).

My board had a 6264, which I replaced with the Pinitech 6264. No jumper change needed.

If you have confirmed that your board has the 62256, then I would buy that module and not mess with the change. Removing the resistor and adding a jumper is pretty easy, but if you can workaround it then great.

Just a warning though, removing the RAM chip on a WPC board is not easy. Traces are small, tightly packed, and fragile. Definitely take your time and NO PRYING as there are many traces under the RAM chip.

#3364 2 years ago
Quoted from delt31:

Thanks for the quick responses. If you happen to have a chance to take a pic of this area, please post so I can compare. I've been trying to get as many as possible to see where mine is different (assuming it's not an obvious break).

So checked wires and everything looks fine. I checked with meter and there seems to be some current. I'm not an electric guy but a signal is present in all. This might be the U20 chip. I'm going to replace and see as I have an extra.

EDIT - It was the U20 chip. Tricky SOB but all good with rollovers.

#3365 2 years ago

Does anyone have the part number or know the spring for the Diverter plunger? I need to replace mine. Not the small one that is below but the spring that should be on the rod that actually goes into the coil. It's not in the manual. Thanks!

#3366 2 years ago
Quoted from comment23:

Just a warning though, removing the RAM chip on a WPC board is not easy. Traces are small, tightly packed, and fragile. Definitely take your time and NO PRYING as there are many traces under the RAM chip.

Thanks, I have read about the thin and fragile traces on WPC and will be sure to be careful. I have done a good amount of board work before with the soldering iron, so I have some good experience. But it's never a bad idea to always be extra cautious.

#3367 2 years ago
Quoted from Bugsy:

Thanks, I have read about the thin and fragile traces on WPC and will be sure to be careful. I have done a good amount of board work before with the soldering iron, so I have some good experience. But it's never a bad idea to always be extra cautious.

Awesome, you should be fine then!

#3368 2 years ago

Hoping to be part of this club by this weekend. Can't wait! This is my favorite pin!

#3369 2 years ago

I'm in!

443ce6c279ccbd874fd093a4237705bf5e0e50c5 (resized).jpg

f9def155b6d6742176d3961137707649d8c8190a (resized).jpg

#3370 2 years ago

I joined as well. This is prob the best pin for your money out there. 3k and you get so much. Spinners modes physical locks toys it's all there

#3371 2 years ago

'Atta boy!
Looks like a nice one.

Quoted from delt31:

I joined as well. This is prob the best pin for your money out there. 3k and you get so much. Spinners modes physical locks toys it's all there

Best pin for the money indeed!
Great playability and fast too. Love me some WCS!
And, oh yeah... you get an 'Atta boy also.

Two more in the club.

#3372 2 years ago

yeah, i've been saying that, too. under $3k, BSD or WCS. the latter is definitely more family friendly, which can matter a lot.

#3373 2 years ago

Just an update to the major shop job I've been doing, ended up pretty much restoring the cab inside and out and stripping off 95% of the top side.

IMG_2375 (resized).JPG

IMG_2377 (resized).JPG

IMG_2380 (resized).JPG

IMG_2480 (resized).JPG

IMG_2520 (resized).JPG

IMG_2524 (resized).JPG

#3374 2 years ago

Forgot to show what it looked like before I stripped and buffed it.

IMG_2164 (resized).JPG

IMG_2165 (resized).JPG

#3375 2 years ago
Quoted from Bud:

Forgot to show what it looked like before I stripped and buffed it.

Aww man, you took off all the patina!

j/k dude, looks great!

#3376 2 years ago
Quoted from Bud:

Just an update to the major shop job I've been doing, ended up pretty much restoring the cab inside and out and stripping off 95% of the top side.

Looks great. What's your plan for cleaning the wireform?

#3377 2 years ago
Quoted from RonaldRayGun:

Looks great. What's your plan for cleaning the wireform?

I sent off the coin toss and wire forms and had them plated. Just have to finish putting it all back together

#3378 2 years ago

What was your specific technique for the buffing?

#3379 2 years ago

Looks great. Congrats!

#3380 2 years ago
Quoted from comment23:

What was your specific technique for the buffing?

Clean with naphtha, then I use a series of 3M automotive products on a 3 inch foam pad on a drill. Then I wipe it all down with wizards shine master wax.

3 weeks later
#3381 2 years ago

Got a WCS a bit ago and have a few minor problems.
Skill shot phantoms every so often (I'm guessing I need to clean and adjust the optos).
On multiplayer games, the lock will often kick out two balls if a ball is already locked on the right (on the trophy playfield).
The game also doesn't want to give me a ball in the shooter lane during multiball start. Could this be related to the coin flip issue?
Thanks. I searched around a bit and didn't have any luck.

#3382 2 years ago

Hi all, I've had my World Cup Soccer for about two months now, and more or less, it's been working perfectly. But last night the goalie stopped moving.

I opened it up and ran the goalie test. I can hear the motor running, but the goalie is not moving. Does anyone have any suggestions on what my next move should be? It's my first pin, so I'm nervous to just start messing around with things. Thanks in advance for any help you can offer!

#3383 2 years ago
Quoted from weasley:

Hi all, I've had my World Cup Soccer for about two months now, and more or less, it's been working perfectly. But last night the goalie stopped moving.
I opened it up and ran the goalie test. I can hear the motor running, but the goalie is not moving. Does anyone have any suggestions on what my next move should be? It's my first pin, so I'm nervous to just start messing around with things. Thanks in advance for any help you can offer!

Make sure it's still attached to the assembly would be my first troubleshooting attempt. If it is, you may need to dig a little deeper -- but for sure check the wiring and diodes and such.

#3384 2 years ago

There is a big difference between opening up a machine and observing things and
"messing around" with things as you say.
Many problems can be remedied quickly with a basic knowledge of things. That said there is no need to be intimidated.
As suggested, goalie attached? Loose wire perhaps?
As you rule out the quick fixes you will come to know when you are in over your head and require help.

#3385 2 years ago

Thanks for the feedback guys! I pulled the playfield out and was checking wires when I noticed there was a wire jammed under the goalie. I pulled it out, straightened it out and it solved the problem! I'm glad it was a minor thing, but it's also given me the confidence to not be so scared about opening up the game. Thanks again everyone.

#3386 2 years ago
Quoted from weasley:

Thanks for the feedback guys! I pulled the playfield out and was checking wires when I noticed there was a wire jammed under the goalie. I pulled it out, straightened it out and it solved the problem! I'm glad it was a minor thing, but it's also given me the confidence to not be so scared about opening up the game. Thanks again everyone.

You, my friend, get an
"atta boy!"

#3387 2 years ago

Anyone have a spare big ramp?

The entrance is on the right side of PF and wraps around to mini pf.

A-18009 is the part number

#3388 2 years ago

Does anyone still have a set of those soccer ball stencils for the speakers? I'd love to paint mine, but didn't have access to the machine back when they were being made. If so, please PM me. Thanks.

#3389 2 years ago
Quoted from Pdxmonkey:

Anyone have a spare big ramp?
The entrance is on the right side of PF and wraps around to mini pf.
A-18009 is the part number

These seem like unobtanium. I know Larry at Starship has been saying WCS94 ramps are next. But it's been "next" for quite some time. Here's hoping they show up soon.

#3390 2 years ago
Quoted from cocomonkeh:

The game also doesn't want to give me a ball in the shooter lane during multiball start

Had this issue too. Balls were magnetized and getting hung up in the through and then obviously not getting registered by the optos.

Picked up one of these and it fixed the problem:

http://www.marcospecialties.com/pinball-parts/03-16809

#3391 2 years ago

Said it before and I'll say it again:
Why doesn't this game have a color DMD?!
They do Popeye but not WCS?
What's up with that?

#3392 2 years ago
Quoted from rollitover:

Said it before and I'll say it again:
Why doesn't this game have a color DMD?!
They do Popeye but not WCS?
What's up with that?

Problem is the people that can colorize the game need to own the game so hey can work on it. That's why you see the oddball releases.

I'm sure they are working on it, it may just have some complications that are taking longer for this one. Not sure.

Eagerly awaiting color DMD for this game.

#3393 2 years ago

would really dress the game up.

#3394 2 years ago
Quoted from rollitover:

Said it before and I'll say it again:
Why doesn't this game have a color DMD?!
They do Popeye but not WCS?
What's up with that?

Can't wait. ColorDMD will be perfect in WCS.

#3395 2 years ago

I talked to the owner of color dmd months ago. He confirmed that someone IS working on WCS.

#3396 2 years ago
Quoted from Pdxmonkey:

Anyone have a spare big ramp?
The entrance is on the right side of PF and wraps around to mini pf.
A-18009 is the part number

pm sent

#3397 2 years ago

Does anyone know where this small piece goes. It's probably obvious but I've never found a place to put it. It was powder coated at one time and so it must be fairly important. Thanks!

IMG_1757[1] (resized).JPG
IMG_1758[1] (resized).JPG
IMG_1759[1] (resized).JPG

#3398 2 years ago
Quoted from toberlindacher:

Does anyone know where this small piece goes. It's probably obvious but I've never found a place to put it. It was powder coated at one time and so it must be fairly important. Thanks!

Pretty sure it holds the wireform up in the middle. The one that runs from the striker hole to the right flipper.

#3399 2 years ago
Quoted from chuckwurt:

Pretty sure it holds the wireform up in the middle. The one that runs from the striker hole to the right flipper.

You sir are correct

#3400 2 years ago
Quoted from chuckwurt:

Pretty sure it holds the wireform up in the middle. The one that runs from the striker hole to the right flipper.

Great, thanks for the help!

Promoted items from the Pinside Marketplace
Trade
Machine - For Trade
Garden City, NY
$ 8.50
Lighting - Led
Pinball Haus
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 40.99
Lighting - Interactive
Lee's Parts
$ 99.00
Playfield - Other
Arcade Upkeep
From: $ 233.10
There are 5824 posts in this topic. You are on page 68 of 117.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside