New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 50131)

World Cup Soccer 94 owners. Everyone welcome.


By DEWSHO

7 years ago



Topic Stats

  • 6,033 posts
  • 545 Pinsiders participating
  • Latest reply 1 minute ago by KSUWildcatFan
  • Topic is favorited by 190 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,502 images uploaded to this topic. (View topic image gallery).

IMG_20200718_131646 (resized).jpg
IMG_20200901_203439 (resized).jpg
IMG_20200813_183253 (resized).jpg
IMG_20200803_140023 (resized).jpg
IMG_20200915_190154 (resized).jpg
IMG_20200915_144540_1 (resized).jpg
IMG_20200723_021413 (resized).jpg
45A49534-AD4A-45DA-A7B0-F8288E87DC95 (resized).jpeg
IMG_20200928_202603 (resized).jpg
IMG_20200928_171048095 (resized).jpg
IMG_20200928_171035652 (resized).jpg
IMG_20200928_171030893 (resized).jpg
IMG_20200928_171027123 (resized).jpg
IMG_20200928_171022807 (resized).jpg
IMG_20200928_171018490 (resized).jpg
IMG_20200928_170923079 (resized).jpg

There are 6033 posts in this topic. You are on page 39 of 121.
#1901 5 years ago

Well, I did my best to solder in that new emitter. It looked okay (not great) and I tried it out. That LED appears to be totally dead now, not lighting up at all and not showing up in the switch edge test. Not sure if it was my crappy soldering job or if the board was messed up. I guess it looks like I'll be ordering another opto board. Thanks for trying! I hope my new board fixes the issue. In the mean time, I'm going to put on some new rubbers and see what other parts I need.

#1902 5 years ago
Quoted from n1teowl:

Well, I did my best to solder in that new emitter. It looked okay (not great) and I tried it out. That LED appears to be totally dead now, not lighting up at all and not showing up in the switch edge test. Not sure if it was my crappy soldering job or if the board was messed up. I guess it looks like I'll be ordering another opto board. Thanks for trying! I hope my new board fixes the issue. In the mean time, I'm going to put on some new rubbers and see what other parts I need.

Can u take a pic of your work so I can see if something got messed up? If u don't want to no prob. It's a pain to keep taking parts on and off.
You used the dark one out of the pair right?

#1903 5 years ago
Quoted from RampShot11:

Can u take a pic of your work so I can see if something got messed up? If u don't want to no prob. It's a pain to keep taking parts on and off.
You used the dark one out of the pair right?

Here it is...

Yep, I used the dark one.

20150904_170415.jpg

#1904 5 years ago

Did u put the notch the right way?

#1905 5 years ago

And double check the back of the bag and make sure the dark one is the emitter. You never know if they changed it.

#1906 5 years ago

The notch. Sorry about the grainy pic. iPads take horrible pictures.

image.jpg

#1907 5 years ago

For teamawesome,

Looks like your cabinet harness is wrapped around an old soccer ball and maybe bottom of playfield, also can't see from your pic but is the sliding rail attached to the bottom of the playfield possibly all the way off the pivot and blocked by the catch on the front of the rail itself?

#1908 5 years ago

Well, it's dead Jim. I tried to desolder and resolder and ended up messing up the board. My skills are sadly lacking. It was a last ditch attempt though, so it was worth a try. I'll have to get the new board.

#1909 5 years ago
Quoted from n1teowl:

Well, it's dead Jim. I tried to desolder and resolder and ended up messing up the board. My skills are sadly lacking. It was a last ditch attempt though, so it was worth a try. I'll have to get the new board.

Keep the bad board - use it for practice.

#1910 5 years ago
Quoted from n1teowl:

Well, it's dead Jim. I tried to desolder and resolder and ended up messing up the board. My skills are sadly lacking. It was a last ditch attempt though, so it was worth a try. I'll have to get the new board.

Star Trek reference... Nice!!

Well at least you tried ,right?!?!
Hope the new board arrives quickly.

#1911 5 years ago
Quoted from RampShot11:

Standby for pics.

Thanks for those pictures. Anything I should be aware of on the way there?

Quoted from Venom_249:

Looks like your cabinet harness is wrapped around an old soccer ball and maybe bottom of playfield

Sure enough... That was an old, crummy half soccer ball that looks way more busted than the one installed. I also found a huge screwdriver, a screw, and a couple washers floating around! Who knows what remains...

Quoted from Venom_249:

is the sliding rail attached to the bottom of the playfield possibly all the way off the pivot and blocked by the catch on the front of the rail itself?

Something must be blocking it at the pivot point, but it's hard to take good pictures there with the things hanging down in that area. The one on the right side wants to move forward, but the one on the left is completely stuck. Here are a couple views that might help you diagnose it.

IMG_20150906_180007.jpg

IMG_20150906_180051.jpg

Doesn't seem like it should be stuck... but it is!

#1912 5 years ago
Quoted from t3amaw3s0m3:

Doesn't seem like it should be stuck... but it is!

As a guess, since I can't fully see in the pics....

Maybe the round "pivot" bolt has partially unscrewed -> this causes things to get stuck.
You need to apply enough pressure to pull it loose, and then re-tighten the pivot head.

Good Luck!

EDIT - I just can't tell from the pics - sorry

#1913 5 years ago

Hey guys! Just joined the club! I may have paid on the high end at $2500 but it was only a 20min drive and that beats shipping in my opinion.

My machine:
Cabinet: 7/10 nicks and dings with a little fade
Back Box 7/10 usual nicks and dings
Playfield 8.75/10 prime candidate for cliffys but all else looks good
Display is solid *see below

It came with:
Full LED's
New plastic kit
New Ball
New Rubbers
New Legs
New lock down bar

My issue is since I moved from seller to my house I have been getting intermittent credit dot errors resulting in the diagnostics reporting a sound board interface error. I am also experiencing intermittent frozen /distorted display. This doesn't happen all the time but I would prefer it not happen at all. Reseating the cables and cycling power has cleared the issues...but doesn't give the warm fuzzy feeling or telling why it's happening.

Myself and my 4 boys enjoyed several games last night but it's frustrating when the errors creep up....

Any thoughts or suggestions would be greatly appreciated. Are there many MOD's available like some of the other games? Striker toys seem to be out there....has anyone done any?

Thanks!

#1914 5 years ago
Quoted from thall17:

My issue is since I moved from seller to my house I have been getting intermittent credit dot errors resulting in the diagnostics reporting a sound board interface error. I am also experiencing intermittent frozen /distorted display. This doesn't happen all the time but I would prefer it not happen at all. Reseating the cables and cycling power has cleared the issues...but doesn't give the warm fuzzy feeling or telling why it's happening.

Thanks!

Sounds like you need new ribbon cables. Are the current ribbon cables old looking or original?
I see you have a Scared Stiff, I would try the ribbon cables from the SS and put them in the WCS and see if the issue still pops up. I have a feeling it won't.

#1915 5 years ago

Would anyone with a great cabinet be willing to take some High Res photos for me? I would greatly appreciate it

Thanks

#1916 5 years ago
Quoted from T7:

You need to apply enough pressure to pull it loose, and then re-tighten the pivot head.

This is intriguing advice... Of course, I tried using the rod of a Harbor Freight screwdriver to loosen the nut, and I thought the screwdriver would break before the nut would actually turn. In researching the terms further, I discovered the related parts (in Sec. 2-3 of the manual) are:
the Plate Spacer (http://www.marcospecialties.com/pinball-parts/01-11408),
the Pivot Nut (http://www.marcospecialties.com/pinball-parts/02-4329-1), and
the Pivot Bushing (http://www.pinballlife.com/index.php?p=product&id=2204).

So I should try to hold the bushing steady while trying to turn the nut loose, and then once it's loose, I'll re-tighten it? (Sorry if this is an idiotic question; I'm way more of a software guy than a hardware guy.)

Anyway, my WCS game will be brought to the Dallas Makerspace in Carrollton for our Open House this Saturday 9/12, and there will be about a dozen other pins available to play! If you mention this thread, I'll let you have a crack at lifting the playfield. (And if you ask nicely, maybe we'll show you all the other projects we're working on in the back room. )

#1917 5 years ago
Quoted from t3amaw3s0m3:

This is intriguing advice... Of course, I tried using the rod of a Harbor Freight screwdriver to loosen the nut, and I thought the screwdriver would break before the nut would actually turn. In researching the terms further, I discovered the related parts (in Sec. 2-3 of the manual) are:
the Plate Spacer (http://www.marcospecialties.com/pinball-parts/01-11408),
the Pivot Nut (http://www.marcospecialties.com/pinball-parts/02-4329-1), and
the Pivot Bushing (http://www.pinballlife.com/index.php?p=product&id=2204).
So I should try to hold the bushing steady while trying to turn the nut loose, and then once it's loose, I'll re-tighten it? (Sorry if this is an idiotic question; I'm way more of a software guy than a hardware guy.)
Anyway, my WCS game will be brought to the Dallas Makerspace in Carrollton for our Open House this Saturday 9/12, and there will be about a dozen other pins available to play! If you mention this thread, I'll let you have a crack at lifting the playfield. (And if you ask nicely, maybe we'll show you all the other projects we're working on in the back room. )

If someone gets it lifted let us know. I am very curious as to why it is sticking so badly.

#1918 5 years ago
Quoted from thall17:

Would anyone with a great cabinet be willing to take some High Res photos for me? I would greatly appreciate it
Thanks

Are you making new decals for cab? I'm curious about this process- I have a sopranos but at some point some kids scratched the hell out of one side with a razor. I'd love to print new decals and apply them if possible

#1919 5 years ago
Quoted from thall17:

Would anyone with a great cabinet be willing to take some High Res photos for me? I would greatly appreciate it
Thanks

How did you make out with the ribbon cables?
Also, I will post some pics of the cab of the one I have at my house later tonight. Any special angles you would like? Or just front , sides and sides of back box?

#1920 5 years ago

I finally got my opto board from Great Lakes Modular and put it in. Everything seems to be working fine now! Thanks for your help in diagnosing this. While I was waiting for my board I took the opportunity to shop it out. New rubbers, polished everything, 2 coats of wax. Working and looking great.

#1921 5 years ago
Quoted from n1teowl:

I finally got my opto board from Great Lakes Modular and put it in. Everything seems to be working fine now! Thanks for your help in diagnosing this. While I was waiting for my board I took the opportunity to shop it out. New rubbers, polished everything, 2 coats of wax. Working and looking great.

Glad to hear that. GOAL!!!!!!!!!!!!!!!!!!!!!!!!!!

#1922 5 years ago

I'm shopping out a WCS for a friend/fellow Pinsider and decided since he needed a new goal bracket to paint it gold, I'm also painting the goal posts and all the metal spacers gold also. More pics to come.

image.jpg

image_1.jpg

#1923 5 years ago

Nice! Will match the metal ramp very well.

#1924 5 years ago
Quoted from rollitover:

Nice! Will match the metal ramp very well.

Yes. I was thinking of doing the metal ramp too. I found a chip resistant clear so it might work. His ramp is very dull and starting to lose the gold color it had on it from the factory.

#1925 5 years ago

Would love to restore the gold on mine as well. Got a quote of $40. Just don't have the extra coin to do it though.

#1926 5 years ago
Quoted from rollitover:

Would love to restore the gold on mine as well. Got a quote of $40. Just don't have the extra coin to do it though.

$40!! That's a great price. Does that include re Golding the legs also?

#1927 5 years ago
Quoted from RampShot11:

$40!! That's a great price. Does that include re Golding the legs also?

No, I was told that price was for the ramp only. Now that you mention it, I should inquire about the legs as well.

#1928 5 years ago

Don't forget the cointoss assembly too

#1929 5 years ago
Quoted from Blitzburgh99:

Need advice on the 'Assist' kick out....when I first got the game about 2 months ago, it worked great. But the distance the ball come out has slowly decreased, where now, it just goes a ove the edge and rolls back in....over and over and over.
After closer look, it seems that the spring is tight or doesn't move full range. I push it manually back and forth to loosen it up, and I got the distance almost back. It wouldn't score goals, but at least it kick the ball out far enough to not stop the game with tilts trying to jar it loose. After a few games, it went back to getting stuck.
Is there a way to lubricate the spring mechanism?
Any other ways to fix?

Bump for any thoughts on servicing the assist kick out?

#1930 5 years ago

I had the same problem and found the end of the eject cam was all beat up .I replaced the the eject cam , mounting bracket, plunger and link and coil sleeve and cleaned everything up and lubricated pivot points

#1931 5 years ago

Just picked up my first WCS and am having a ton of fun on it so far! Thought I'd post to see if anybody has had any issue with the three yellow illumination bulbs at the top of the playfield. When I got the game they were working fine, and now a day later they're out entirely. I've checked the connection on the board and all appears to be fine. My game didn't come with a manual, so I'm downloading a copy now -- but thought I'd post in the meantime in case anybody has experienced this before. It's a REALLY dark game without those lights up there, so would love to get them back up and running!

Edit to update ... Okay, so now that I've got the manual I have checked the proper connection as well as fuse F106. Both are fine as far as I can see, but the lights are still out. For good measure I've swapped in a new bulb in the line. Anybody have any ideas on what could have suddenly gone out on this?

#1932 5 years ago

Just picked up my first WCS and am having a ton of fun on it so far! Thought I'd post to see if anybody has had any issue with the three yellow illumination bulbs at the top of the playfield. When I got the game they were working fine, and now a day later they're out entirely. I've checked the connection on the board and all appears to be fine. My game didn't come with a manual, so I'm downloading a copy now -- but thought I'd post in the meantime in case anybody has experienced this before. It's a really dark game without those lights up there, so would love to get them back up and running!

Edit to update ... Okay, so now that I've got the manual I have checked the proper connection as well as fuse F106. Both are fine as far as I can see, but the lights are still out. While tinkering with the playfield I briefly brought them back, and then after another lift of the pf it went out again. Surely a loose connection somewhere, but I've followed the entire wire with no success. Arg.

#1933 5 years ago

[duplicate post, sorry]

#1934 5 years ago
Quoted from DParcade:

Just picked up my first WCS and am having a ton of fun on it so far! Thought I'd post to see if anybody has had any issue with the three yellow illumination bulbs at the top of the playfield. When I got the game they were working fine, and now a day later they're out entirely. I've checked the connection on the board and all appears to be fine. My game didn't come with a manual, so I'm downloading a copy now -- but thought I'd post in the meantime in case anybody has experienced this before. It's a really dark game without those lights up there, so would love to get them back up and running!
Edit to update ... Okay, so now that I've got the manual I have checked the proper connection as well as fuse F106. Both are fine as far as I can see, but the lights are still out. While tinkering with the playfield I briefly brought them back, and then after another lift of the pf it went out again. Surely a loose connection somewhere, but I've followed the entire wire with no success. Arg.

HSD check the connector under the playfield and see if the wires are loose.

#1935 5 years ago

Having a small issue where the game is giving me a credit for hitting a shot that earns you one of the S's in the soccer ball that builds towards ball lock.

I believe it has something to do with the left ramp switch because the diverter is changing positions without hitting the ramp and it corresponds with one of the S's it's erroneously giving me credit for.

It seems to happen quickly at the beginning of a game and that's it. Switch Test did not show anything obvious when testing several different switches. Anyone ever encounter something like this?

#1936 5 years ago

My friend is working on restoring a WCS 94, Quick question on the soccer ball spin direction.
In the test menu you can test having the ball spin in one direction, then test it spinning in the other direction. During gameplay does the ball ever change the direction it is spinning? If it only ever spins in one direction, which is the correct direction, CW or CCW?

#1937 5 years ago
Quoted from Lockenick:

My friend is working on restoring a WCS 94, Quick question on the soccer ball spin direction.
In the test menu you can test having the ball spin in one direction, then test it spinning in the other direction. During gameplay does the ball ever change the direction it is spinning? If it only ever spins in one direction, which is the correct direction, CW or CCW?

No, unfortunately. It does technically use the reverse signal, but only to stop the ball faster (instead of letting it spin down).

If my memory's correct, they originally were going to have it spin the other direction, but was worried that it would send balls STDM.

#1938 5 years ago
Quoted from Coyote:

No, unfortunately. It does technically use the reverse signal, but only to stop the ball faster (instead of letting it spin down).
If my memory's correct, they originally were going to have it spin the other direction, but was worried that it would send balls STDM.

Thank you sir! I spent a day inter-tubing in Harpers Ferry earlier this summer, beautiful place.

#1939 5 years ago
Quoted from Lockenick:

Thank you sir! I spent a day inter-tubing in Harpers Ferry earlier this summer, beautiful place.

Not a problem! And yes, we have LOTS of tourists here in the spring/summer. Clogs up our roads like h3ll.

#1940 5 years ago
Quoted from Lockenick:

During gameplay does the ball ever change the direction it is spinning? If it only ever spins in one direction, which is the correct direction, CW or CCW?

Actually, it should spin clockwise (helping balls into the goal, especially from the left drain 'corner kick' shooter to create "header" goals) during regular play and counter-clockwise during World Cup Final play. This was mentioned quite a way back in the thread (post #599 or so), but I verified it on my (then) pin.

#1941 5 years ago

This is correct. It will spin both ways. Has anyone figured out how to get the ball to grip the pinballs a bit more? On mine they just kinda slowly roll off no matter how fast the soccer ball is spinning...

#1942 5 years ago
Quoted from ellray:

Actually, it should spin clockwise (helping balls into the goal, especially from the left drain 'corner kick' shooter to create "header" goals) during regular play and counter-clockwise during World Cup Final play. This was mentioned quite a way back in the thread (post #599 or so), but I verified it on my (then) pin.

Quoted from RDReynolds:

This is correct. It will spin both ways. Has anyone figured out how to get the ball to grip the pinballs a bit more? On mine they just kinda slowly roll off no matter how fast the soccer ball is spinning...

Interesting. This must be a change in the newer ROM levels, then. My old game (on L-1, I believe, way back when) only spun one direction. I remember asking the WMS tech about it when they came to take readings on it. Good to know, then!

#1943 5 years ago
Quoted from RDReynolds:

This is correct. It will spin both ways. Has anyone figured out how to get the ball to grip the pinballs a bit more? On mine they just kinda slowly roll off no matter how fast the soccer ball is spinning...

Only thing you can do is clean the ball from time to time in an effort to keep the rubber supple. The ball hardens over time and there is (much) less reaction when the pinball comes in contact. Softer, more supple soccer ball will perform better.

#1944 5 years ago
Quoted from rollitover:

Softer, more supple soccer ball will perform better.

Can't resist . . . how do you keep your soccer ball more supple?

#1945 5 years ago
Quoted from Hammerhead:

Can't resist . . . how do you keep your soccer ball more supple?

A good hands-on massage, using both hands. The more you do it, the better you become with it, until jsut a few fingerstrokes and it'd be as supple as a new plunger rubber.

..Goodnight everybody!

#1946 5 years ago

Looking to join the club...
WTB Mint/CQ
https://pinside.com/pinball/market/ad/25411

#1947 5 years ago
Quoted from ellray:

Actually, it should spin clockwise (helping balls into the goal, especially from the left drain 'corner kick' shooter to create "header" goals) during regular play and counter-clockwise during World Cup Final play. This was mentioned quite a way back in the thread (post #599 or so), but I verified it on my (then) pin.

Thanks! I'm crossing my fingers that once we get it up and running that it will spin as you describe. The soccer ball is brand new so should have some grip on the ball.

#1948 5 years ago

Just curious how strong the stock flippers are supposed to be on these, mine seem a little weak even after working on them replacing worn parts...

#1949 5 years ago

Mine are pretty strong. I have zero issue hitting any ramps and can really make things scream on a trip around the back of the machine...

#1950 5 years ago

It's my only old game with those bally flipper opto boards, maybe I just am not cleaning those properly, have to check that out...

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
Wanted
Machine - Wanted
Ashland, OH
$ 65.00
Boards
Pinball Haus
$ 350.00
Boards
Pinball Basement
There are 6033 posts in this topic. You are on page 39 of 121.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside