(Topic ID: 292880)

Willy Wonka v1.34-v1.38 updates include choppy/stuttering animations

By jimbodeanny

43 days ago


Topic Heartbeat

Topic Stats

  • 39 posts
  • 9 Pinsiders participating
  • Latest reply 5 days ago by BC_Gambit
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

Capture (resized).PNG
1621675477401 (resized).png

#1 43 days ago

Anyone else getting dropped frames in the animations (i.e. they're choppy/sluggish) after updating to v1.37? I did the full install from v1.33 and I'm noticing the bulk of animations are choppy, almost like dropped frames or a lower framerate.

Some of the more noticeably affected animations...
- the match "game over" screen
- the bubbles during the high score screens in the attract mode
- the extra ball oompa loompa animation

I've done the full install twice now but it acts the same. Game plays fine. It's only the animations that appear affected as the video clips are fine.

I was going to try going back to v1.33 but none of the older versions appear to be available.

It's almost as if the update affected the gpu performance and/or framerate. Very strange.

Edit: I've spoken to the KingPin games (where I bought my LE) and they're contacting JJP. Hopefully it's nothing major and is simple to resolve. I'll post in here when I have an update.

#2 43 days ago

Same here on 1.37

#3 42 days ago
Quoted from AMSNL:

Same here on 1.37

Glad I'm not the only one. I've heard they had similar issues with an update for Guns n Roses that was resolved with a "fix" update a week or two later.

#4 42 days ago

Unrivaled quality!

#5 42 days ago

Put your game on beta download and take the 1.37 vers 1 I think that should do the trick

Does it over WiFi

#6 42 days ago
Quoted from AMSNL:

Put your game on beta download and take the 1.37 vers 1 I think that should do the trick
Does it over WiFi

I don't have a WIFI adapter installed (yet). I ordered one and am planning to install it on Friday. How do I enable beta download?

#7 42 days ago
Quoted from jimbodeanny:

How do I enable beta download?

Full Menu - Utilities - Network Connections - link your WiFi in your router to your game. You'll need a WiFi dongle too.

LTG : )

#8 42 days ago
Quoted from LTG:

Full Menu - Utilities - Network Connections - link your WiFi in your router to your game. You'll need a WiFi dongle too.
LTG : )

Thanks! I'll have to try that on Friday when my dongle arrives. Hopefully that does the trick.

#9 42 days ago
Quoted from LTG:

You'll need a WiFi dongle too.

WiFi :
https://www.microcenter.com/product/604932/tp-link-archer-t2u-nano-ac600-nano-wireless-usb-adapter

Bluetooth :
https://www.microcenter.com/product/426849/asus-usb-bt400-usb-20-bluetooth-40-adapter

USB Hub :
https://www.microcenter.com/product/485912/inland-4-port-usb-31-(gen-1-type-a)-hub---black

Here is what I used in my game. Your game may already have the bluetooth dongle. I got the USB hub, plugged it into the cable by the cashbox. Then plugged the bluetooth dongle and wifi dongle into it.

LTG : )

#10 42 days ago
Quoted from LTG:

WiFi :
https://www.microcenter.com/product/604932/tp-link-archer-t2u-nano-ac600-nano-wireless-usb-adapter
Bluetooth :
https://www.microcenter.com/product/426849/asus-usb-bt400-usb-20-bluetooth-40-adapter
USB Hub :
https://www.microcenter.com/product/485912/inland-4-port-usb-31-(gen-1-type-a)-hub---black
Here is what I used in my game. Your game may already have the bluetooth dongle. I got the USB hub, plugged it into the cable by the cashbox. Then plugged the bluetooth dongle and wifi dongle into it.
LTG : )

Thanks for the links. I ordered the dongle(s) from Amazon that were listed on JJP's site, but I have a Microcenter very close to me, so I may just grab that WiFi dongle now so I don't have to wait

Once I setup the WiFi and connect to my router, how do I do the beta download?

#11 42 days ago
Quoted from jimbodeanny:

how do I do the beta download?

Same area. Utilities - Network Settings - there is a part labeled update. If you do the beta one, it's more like a full install. It will take awhile.

LTG : )

#12 42 days ago

Quick update: Just got back from Microcenter and installed the hub & WiFi dongle. I successfully connected to my WiFi/router and enabled beta updates. The only update it detected was beta v2. In the notes, it said it was the same as the official 1.37 update, but since that was the only update it found, I went with it. It completed the update successfully, but the game still has the choppy animations. *Sigh*

#13 42 days ago
Quoted from jimbodeanny:

The only update it detected was beta v2.

Beta Build 2 is the only out there right now.

LTG : )

#14 42 days ago
Quoted from LTG:

Beta Build 2 is the only out there right now.
LTG : )

Okay, thanks. Guess I'll wait until I hear back from JJP.

#15 42 days ago
Quoted from TheLaw:

Unrivaled quality!

Better then some of that shitty Stern quality!

#16 41 days ago

Quick update: Tried a few things while I wait for a response from JJP.

1) Tried a different SSD and did a fresh install. No improvement.

2) Tried a different SATA cable, and all three unoccupied SATA ports on the motherboard. No improvement.

3) Tried a brand new 850w power supply. No improvement.

4) Cleaned off the CPU/cooler thermal paste, and replaced with new TP-1 Bitspower thermal paste. No improvement.

At this point, my guess is that if it's not a software issue, then it's probably either the CPU or motherboard. That's my theory anyway.

#17 40 days ago

Decided to try to make a better quality video, highlighting some of the animations that are noticeably choppy. I used a direct HDMI capture so the clips in the video are taken straight from the game and unaltered. Hopefully, it illustrates what I'm seeing and people are able to notice it more. Then again, maybe it's just normal and something only my OCD is noticing.

Best to watch fullscreen at 1080p.

#18 37 days ago

Does anyone have v1.33 or v1.35 full install ISOs that they could share? JJP pretty much said there's nothing wrong (which is very disappointing) and so I want to go back to an older version of the software when this issue didn't exist.

Thanks!

#19 37 days ago

Man I tell ya, between JJP telling all those folks with bad playfields to go pound sand, refusing warranty and only offering buybacks, then later reneging on that offer... and now they're pretending this code issue doesn't even exist? It's plain as day in a video for chrissakes, it's gonna be even more obvious on a game. 12.5K for an LE that can't even stream a fucking MP4 cleanly??

I've about lost all respect I had for JJP as a company. Fix your shit.

#20 37 days ago
Quoted from metallik:

Man I tell ya, between JJP telling all those folks with bad playfields to go pound sand, refusing warranty and only offering buybacks, then later reneging on that offer... and now they're pretending this code issue doesn't even exist? It's plain as day in a video for chrissakes, it's gonna be even more obvious on a game. 12.5K for an LE that can't even stream a fucking MP4 cleanly??
I've about lost all respect I had for JJP as a company. Fix your shit.

Yeah, I'm very frustrated. I went above and beyond, trying a different SSD, different cables, different SATA ports, new thermal paste, and even a new power supply to see if it was something I could fix. And then to just have them throw their hands in the air. But the single thing that irritates me more than anything, is there's no simple way for me to revert back to an earlier version of software. They don't have ANY pre-1.37 updates available on their site. Had I known the new version would be like this, I NEVER would have updated my software. Period.

#21 37 days ago

That's kinda crazy they don't offer the prior version as a fallback. With wifi updates, are they going to imitate the trend with phones where you can only update and never revert?

You (and anyone else with WWLE) can check your downloads folder on your computer, if you downloaded older versions in the past they may be still sitting in there.

#22 37 days ago
Quoted from metallik:

That's kinda crazy they don't offer the prior version as a fallback. With wifi updates, are they going to imitate the trend with phones where you can only update and never revert?
You (and anyone else with WWLE) can check your downloads folder on your computer, if you downloaded older versions in the past they may be still sitting in there.

Yeah, I don't have them. Mine was updated on site to v1.33 and then I updated to 1.37 so I don't have any versions downloaded on my PC.

#23 37 days ago

UPDATE:

Well, I was able to find the old v1.31 as well as two versions of v1.34. After a bunch of testing, here are my findings.

- v1.31 works flawlessly and all animations are buttery smooth (as expected)

- v1.34RC/v1.34 both have stuttering/jittery/choppy animations (much like 1.37)

- doing a delta upgrade from v1.34 to v1.37 proved no different than the full install, with choppy animations (as expected)

As I mentioned before, I've tried many things to improve the choppy animations.

- tried a new SSD
- tried different SATA cables and different ports on the motherboard
- tried a brand new 850w power supply
- replaced the old thermal paste on the cpu/cooler with new paste

I may try throwing in another 4GB stick of RAM to see if that helps improve things since the gpu is integrated on the motherboard and shares memory. Short of that, and/or maybe a faster cpu, I'm out of ideas. I have plenty of spare graphics cards, but since there's no real way to load drivers, things are limited to the onboard graphics. But in the end, this is clearly a software issue.

At this point, I'm hunting for the v1.33 install file as that was the version I had on prior to updating to v1.37 and things ran perfect. If anyone has or knows where I can get that update, please message me. Thank you! I'd also be curious to try v1.35 and v1.36 to see if those are any better. But for the time being, I will happily play with an older version of software until JJP gets it right.

#24 37 days ago
Quoted from jimbodeanny:

UPDATE:
Well, I was able to find the old v1.31 as well as two versions of v1.34. After a bunch of testing, here are my findings.
- v1.31 works flawlessly and all animations are buttery smooth (as expected)
- v1.34RC/v1.34 both have stuttering/jittery/choppy animations (much like 1.37)
- doing a delta upgrade from v1.34 to v1.37 proved no different than the full install, with choppy animations (as expected)
As I mentioned before, I've tried many things to improve the choppy animations.
- tried a new SSD
- tried different SATA cables and different ports on the motherboard
- tried a brand new 850w power supply
- replaced the old thermal paste on the cpu/cooler with new paste
I may try throwing in another 4GB stick of RAM to see if that helps improve things since the gpu is integrated on the motherboard and shares memory. Short of that, and/or maybe a faster cpu, I'm out of ideas. I have plenty of spare graphics cards, but since there's no real way to load drivers, things are limited to the onboard graphics. But in the end, this is clearly a software issue.
At this point, I'm hunting for the v1.33 install file as that was the version I had on prior to updating to v1.37 and things ran perfect. If anyone has or knows where I can get that update, please message me. Thank you! I'd also be curious to try v1.35 and v1.36 to see if those are any better. But for the time being, I will happily play with an older version of software until JJP gets it right.

Quick update:

Someone shared the Delta v1.33 update with me so I was able to test it (and go back to v1.33, which is what I wanted.)

As I expected v1.33 also works perfectly with buttery smooth animations. I'll be sticking to this version until JJP fixes the animations in a future update - hopefully.

#25 36 days ago

Quick update:

Just tested out v1.35 and the choppy/laggy animations are there as well.

1.31 - runs perfect (as expected)
1.33 - runs perfect (as expected)
1.34 - choppy/stuttering animations
1.34RC - choppy/stuttering animations
1.35 - choppy/stuttering animations
1.37 - choppy/stuttering animations

So in other words, pretty much everything after v1.33 has animation issues.

#26 36 days ago

Here's a side-by-side comparison video I just made, showing in detail the difference between the normal smooth animations of v1.33 (and before) versus the choppy/stuttering/laggy animations of v1.37. Although this issue is noticeable in many (if not all) of the animations, I decided to just focus on the "game over" animation to make things simple and hopefully easier for people to see.

I highly recommend watching it full screen at full quality (1080p60fps). Also, be sure to watch the end where you can see the lag v1.37 has between screens.

#27 30 days ago

I just noticed v1.38 is available now. Going to test it out and see if the animation issue(s) were fixed. Fingers crossed.

#28 30 days ago

v1.38 still has the animation issues. Back to v1.33 it is.

#29 30 days ago

I will have to check this out on a better screen. My cell phone makes it hard for me to see a difference.

#30 30 days ago
Quoted from BC_Gambit:

I will have to check this out on a better screen. My cell phone makes it hard for me to see a difference.

Yeah, you'll want to watch it on a larger monitor, full screen, at 1080p60fps.

Just sent JJP Software a tweet asking about the animation issues.

#31 28 days ago

I admit even seeing it on my large monitor this seems tolerable to me, but I am more picky about audio (e.g. some repetative sounds would likely drive me up the wall faster than the screen...).

#32 28 days ago
Quoted from BC_Gambit:

I admit even seeing it on my large monitor this seems tolerable to me, but I am more picky about audio (e.g. some repetative sounds would likely drive me up the wall faster than the screen...).

I hear ya and to each their own. For me, the mere fact of knowing that it's not performing 100% as it was on earlier versions is irritating. Audio issues would be more noticeable during gameplay, but the stuttering animations are a complete eyesore to me now.

What's disappointing is that I haven't had a single response from JJP on Twitter. Yet, in the update logs, it specifically states that JJPSoftware on Twitter is the best place to have "real humans" respond. LOL.

#33 27 days ago

Confess to feeling a bit lucky that I didn't update from 1.33 due to work pressures. I agree with the OP. The stuttering would drive me crackers. Even when not being played, Wonka is a thing of beauty in any gameroom - a work of art in attract mode! The stuttering detracts from that. All MHO, of course, but I will wait to update.

#34 27 days ago

I'm still using 1.33
happy with this version.

#35 27 days ago
Quoted from FlippinJB:

Confess to feeling a bit lucky that I didn't update from 1.33 due to work pressures. I agree with the OP. The stuttering would drive me crackers. Even when not being played, Wonka is a thing of beauty in any gameroom - a work of art in attract mode! The stuttering detracts from that. All MHO, of course, but I will wait to update.

Quoted from pascal-pinball:

I'm still using 1.33
happy with this version.

Agreed. I'm happy with v1.33 for now and I won't be updating until they fix their sh*t. After spending over $10k on this machine, I expect it to work 100%.

I'm happy I have the software installation files from the older versions (and thank you to those folks that shared various versions with me), which is something JJP should have made easily accessible in the first place. That's software 101. Especially when there are complaints about bugs/issues with the current release. The fact that they won't even respond on Twitter and even acknowledge the problem translates (to me) that they're just hoping nobody else will complain because they don't want to do the necessary to fix it. What a joke.

#36 26 days ago
Quoted from jimbodeanny:

Just tested it out. That's a big no-go on the animation fix. Still as choppy as ever. Time to go back to v1.33. *sigh*
EDIT: Just Tweeted about this to JJPSoftware. Here's the Tweet. https://twitter.com/jamesdeanny/status/1394399676321853440?s=20

Quoted from naf_llabnip:

I added a comment to your tweet, you made a fair case with the video, I doubt they would have had time to figure it out in time for this release, but perhaps the next one.

I sent my first Tweet to them on the 17th, right after the v1.38 update, asking if they were planning to fix the animations.

1621675477401 (resized).png
#37 26 days ago

Four days go by...not one word.

Then today, this is the response I get. Great attitude and customer service from JJP. I love that I've been "dealt with."
Capture (resized).PNG

2 weeks later
#38 6 days ago

Quick update. Tested out the new beta v4 release.

The attract mode animations (i.e. the bubbles) appear to be fixed and much better now.

The "Match" (Oompa Loompa/curtains) animation and the "Game Over" clip are still very choppy/stuttery.

It's good to see some improvement though! Hopefully, it will all be ironed out before the official release!

#39 5 days ago

Well some good news is welcome!

Thank you for following up.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside