New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 123789)

WMS Road Kings Problems


By troxel

5 years ago



Topic Stats

  • 21 posts
  • 6 Pinsiders participating
  • Latest reply 5 years ago by Breaking_Dad
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 18 images uploaded to this topic. (View topic image gallery).

DSCN0044.JPG
DSCN0043.JPG
P1090853.JPG
P1090854.JPG
P1090847.JPG
P1090849.JPG
P1090848.JPG
untitled.JPG
Special solenoid 2 system11.JPG
Special solenoid system11.JPG
P1090628.JPG
P1090623.JPG
P1090624.JPG
P1090621.JPG
P1090622.JPG
P1090620.JPG

You're currently viewing posts by Pinsider troxel.
Click here to go back to viewing the entire thread.

#1 5 years ago

I am more of an arcade guy, but picked up a Road King the other day that is having a few problems. Just looked at it quickly and found the following problems.

1. Start a game, and 2 balls will shoot out. I imagine this is a switch adjustment in the trough?
2. Right flipper (FL-17636) does not work at all. It's completely dead. This is different than the other one and took some photos of both. Any suggestions on where to start?
3. Top and right pop bumper not working during game play, but will fire in test mode.

Any suggestions/help would be greatly appreciated!

P1090616.JPG P1090619.JPG P1090620.JPG P1090621.JPG P1090622.JPG P1090623.JPG P1090624.JPG
#4 5 years ago

Thanks for all the help so far. I had a chance to look at this a little bit more today and still had a few questions.

#1. The two trough switches should be closed when the balls are in the trough and open when not in the trough? If that's true, then they show up in the switch test as closed.

#2. Noticed that the coil only had one diode connecting the outside lugs. I installed 2 new diodes and went through the guide. Is there only one fuse for both flippers and that's on the flipper power supply board? If so, it checked good. I cleaned the EOS switch and the button switch. Tested for 50 volts and got 71 Vdc. Coil did fire when grounded to the middle lug. Tested ohms and got 4.1 on one side and 360 on the other. This seems out of spec from the guide, but not sure what it should be since it's a FL-17636. Any other suggestions?

#6 5 years ago

I have 71 Vdc on one side of the flipper switch. Tried grounding the switch to see if the coil would fire, and it did NOT fire. There was a little spark, but the coil didn't fire. I did have continuity from the flipper switch (ground) back to ground.

I appreciate the help on this. What's the next step?

#8 5 years ago

I think you are right. It looks like the contact is missing on the right switch. I did test for continuity when the switched closed, and it does beep.

P1090628.JPG
#10 5 years ago

Thanks for the help on this. I will order the switch and see if I can get these other problems figured out as I wait for the part to come in.

2 weeks later
#11 5 years ago

Finally had a chance to install the flipper switch and the flipper still doesn't work. I did noticed that if I pull the flipper up, it will stay up until I release the button. Any other thoughts or items to check?

#15 5 years ago

The EOS is pretty pitted and beat up. I will order a new one and replace. The flipper looks like it was hacked in and wondering if someone can take a look at the photos and see if anything looks out of the ordinary.

Does the diode need to go from wire to switch. Looks horrible the way it's mounted.

Thanks again.

(I will tackle the other problems once I get the flipper working)

P1090847.JPG P1090848.JPG P1090849.JPG P1090853.JPG P1090854.JPG
2 weeks later
#17 5 years ago

Thanks, Andy_B. The photos really helped. I replaced the EOS and lane change switch and cleaned up some of the wiring, and the flipper is now working. Do I need to install a 2.2 uf cap on the EOS?

I also got the pop bumpers working. They just needed cleaned and adjusted. The two ball kickout was an easy fix, because I had 3 balls installed instead of two.

I have a couple more problems now. The left and bottom pop bumpers won't light. I replaced a new bulb and still no light. What's the best way to check if it's the socket, wiring, or something else?

I am missing the top-left segment on the credit display. Is this bad resistor? What's the best way to trouble shoot this, too?

Thanks again. Excited to finally play a few games on this.

#18 5 years ago

I got the lights working on the pop bumper tonight. The connector to the PS is flaky. I will need to replace it when I have time.

The same segment is missing on the first two numbers on the credit/match display. It's the top left (vertical) segment. Is there a resistor that I can check or something else?

2 weeks later
#19 5 years ago

Still no luck with the missing segments. Any advice?

Also, what is the detour R exit switch? Can't find it in the manual. This flashes when the game starts.

#20 5 years ago

Figured out why I couldn't spot the detour R Exit...my game is missing it. Can someone take a top and bottom photo of the switch?

Promoted items from the Pinside Marketplace
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
Wanted
Machine - Wanted
Fredonia, NY
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 22.50
$ 17.00
1,500
Machine - For Sale
Chester, VA
$ 19.99
Eproms
Matt's Basement Arcade
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
$ 9.00
Electronics
Yorktown Arcade Supply
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 27.99
Eproms
Matt's Basement Arcade
From: $ 18.00
Apparel - Men
Pinside Shop
$ 62.95
Cabinet - Shooter Rods
Super Skill Shot Shop
£ 31.00
Lighting - Led
PinballToys
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
$ 20.00
Playfield - Decals
Flashinstinct
$ 19.00
Playfield - Toys/Add-ons
The MOD Couple

You're currently viewing posts by Pinsider troxel.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside