(Topic ID: 280402)

Williams Tri Zone not booting.

By JT-Pinball

12 months ago


Topic Heartbeat

Topic Stats

  • 11 posts
  • 3 Pinsiders participating
  • Latest reply 12 months ago by JT-Pinball
  • No one calls this topic a favorite

You

Linked Games

#1 12 months ago

Hello All,

I am working on a Williams Tri Zone. I have recapped the powers supply and seem to be getting correct power. I added a nvram and changed the badly corroded 40 pin. Display glow but do not work. When i push the diagnostic i get 2 solid lights that dont go out. This seems to indicate a bad 5101 but its not booting to audit and the nvram is new. These games do not have the onboard diagnostic of the bally stern stuff im use to. Thanks for any help.

#2 12 months ago

Hi,

I've done a number of old williams repairs in the past but it's been a while. For me, Mark's guide was by far the best resource. Here's the MPU section, it may also be worth looking at his power supply section to make sure your work didn't cause any errors. Hope this helps!

http://pinball.flippers.info/system6repairpart4.asp

#3 12 months ago

Thanks @mac244 i read thru it. Says to start testing with a test rom. I dont have a test rom for this board. I was hoping it would be simplier than that. just my luck

#4 12 months ago

Ok so I checked the with my logic probe cpu to see if it appears to be running and it does as i am getting pulsing on some of the pins at 9 to 20. I disconnected the driver board and put the mpu on my bench. Now when i press the diagnostic button only the top light stays lit. Maybe i am chsing my tail with out a test rom?

#5 12 months ago

You can't run stock software on a system 3-7 mpu board without the driver board connected.

Get pincoder.ca test roms burned to do that.

#6 12 months ago

Was this machine working before you pulled it apart? Go to the power supply page in that guide and go over everything just to make sure there is no issue there, a very small change in voltage to the MPU will keep it from booting up. I'd pull the connectors off the driver board and see if that has any effect as well. If there is no change and you can't make any headway with Mark's guide, PinWiki also has a bunch of information on them and you'll probably get a lot more help here:

https://pinside.com/pinball/forum/topic/system-3-9-club/page/2#post-5931125

I haven't worked on an older Williams in years so I'm afraid I've forgotten most of what I used to know! Good luck!

#7 12 months ago

Thanks @ mac2444 i have looked at the information on pinwiki too. The power output from the power supply should be ok. I have 11.8 and 5.1 coming into the mpu. When i just disconnected the conectors to the driver board but left it conected to the mpu there was no change. Turn game on lights flash and go out no displays no attract. Push diag button flash both stay on.

As far as the game working before i took it apart, no. It was missing display voltage ao i fixed that made display voltage 91. Recaped the board and changed some stressed diodes. Master display has bad high volt driver so picked up a good master display. Pulled off the old battery holder afdressed some corosion on the mpu and added a nvram changed the 40 pin interconect on mpu and driver. Board has RN sockets so didnt plan to change those.
The system 6 club is a good idea.

#8 12 months ago

If they are flashing and then going out when you start it up, that's good. The 5101 chip is often the issue here. You said you replaced it with a nvram, do you have a 5101 you can put in the socket to test? I'd take a good look at your nvram socket and make sure no leads were damaged when desoldered. I'm sure you haven't done this but just in case....make sure the chip in in the right way....someone I know may have put a socket in backwards and then oriented the chip wrong because of it in the past

Have you tried the quick "off and on" that's listed in the guide? Basically once the game is on, (the led's have flashed and gone out) turn it off and back on quickly. If the game's attract lighting now comes on but not the displays, the issue is probably with the display driver. If not, I'd be back looking at the 5101/mvram chip.

#9 12 months ago

Thanks @ mac2444 i have worked on a few of these games were stuck in audit mode. If the batteries have been removed or 5101 chnaged it would boot to audit then if i power cycled it it would go into attract. This game is not making it to audit. It must be just short of fully booting. I do have a 5101 chip. Ill swap out the nvram and try again. I am going to have to put the driver board back on. I was just trying to eliminate it as an issue but guess the mpu cant be tested without the driver attached unless you have test roms. Which i may have to order from pincoder.

#10 12 months ago

Swapped the nvram for the 5101 mo change. Chip is oriented corectly. I looked at board again i don't see any solder splashes. I will tone out between the pins whem i put the nvram back

#11 12 months ago

Ok so I am working to take a deeper diver here with what I have. Guess if I cant get it Ill order test rom. I took a look at the board schematics it has test points and values it also shows if it should be pulsing or not and what the wave would look like if scoped. So when i test my test points i get the following
Tp1 11.1
Tp2 3.7 to 0 when i press the switch
Tp3 0 and shows low on probe. This should be 5v and high if game were booted?
Tp4 0 and low. This should be high?
Tp5 4.7 high pulsing
Tp6 2.3 high pulsing
Tp7 4.9 high
Tp8 4.9 high
Tp9 4.9.
Look at ic15? Anyone know what the pin out should look like.?

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside