Williams sys11 no background music

(Topic ID: 233471)

Williams sys11 no background music


By kevin76

13 days ago



Topic Stats

  • 23 posts
  • 3 Pinsiders participating
  • Latest reply 11 days ago by mjalexan
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 10 images uploaded to this topic. (View topic image gallery).

15472189081981264318193 (resized).jpg
20190110_123453 (resized).jpg
1547115773086587694873 (resized).jpg
15471157361842137656902 (resized).jpg
1547070922055619494214 (resized).jpg
1547070850698119055688 (resized).jpg
20190109_201106 (resized).jpg
pasted_image (resized).png
20190106_111901 (resized).jpg
20181202_112338 (resized).jpg

#1 13 days ago

Hello Pinsiders,

Hoping on some help because im stuck. Working on a Williams Millionaire and got speech an sounds but no backgroundmusic.

Soundboard D-11298-555
CPU D-11883-567 (U1 not populated)
Whats done:
Checked voltages OK
Soundboard swap to my earthshaker and got sound and speech. So problem must be on the CPU board.
Soundtest (SW1) on the CPU gives me speech (millionaire) and one sound, after reading a lot this should also be oke.
Ribboncable between soundboard and CPU, checked oke.
Game boots up and in to attract mode, everything is functional.

The only thing i can think of is that the CPU should be populated at U1 or am i wrong here?
Any help where to look would greatly be appreciated.

Thank you all for your answers.

Kind regards kevin.
20181202_112338 (resized).jpg20190106_111901 (resized).jpg

#2 13 days ago

U1 should be empty. How many beeps at startup?

#3 13 days ago

Coils activate and then one deep going into atract mode.
One more thing i found out is dat Millionaire is a sys11A game, soundboard and powersupply are sys11A but the CPU board is a sys11B board.
Perhaps that helps?

#4 13 days ago

If you are getting a single tone on boot, your sound board is at least initizating. I think your missing sounds may be more related to having the wrong MPU board. The 11b board is missing part of the sound system the 11a has.

#5 13 days ago

According to the manual, U19 is the background rom. So when you put the sound board in earthshaker you got sounds and speech, but no background music?
How do you know the ribbon cable is good?

@uncivil_engineer If you're referring to the audio amp in the upper left corner, i think that's only for system 11, not 11A-C

This was a good Sys 11 BG music thread: https://pinside.com/pinball/forum/topic/williams-system-11-missing-background-music-investigation/page/2

Manual link: https://www.ipdb.org/files/1597/Williams_1987_Millionaire_Manual.pdf

#6 13 days ago

Everybody thank you,

I put the soundboard in my earthshaker and got speech/sound and backgroundmusic, the ribboncable was tested in the same manor.
I got the manual for millionaire and in the schematics for the MPU U1 (sound section) is populated.
But when i look at some youtube movies (for example on by TNT #215) the board that they use is populated and when looking at another video (TNT #264) the board isn't populated?
This is the reason for my question, does the board that im using need to be populated or not to produce backgroundmusic?

#7 13 days ago

whats the story on this resistor network? looks like it was replaced maybe? Are there any shorts between the legs?
How about under the battery holder, any corrosion?
any bad joints on the ribbon cable pins?

you don't need U1, it is the amplifier for 1J15, which you don't have. All your sound is amplified on the sound board. there are pictures on pinwiki of an 11a (not 11A) showing the populated U1 area, 3 LED rather than 7 segment LED diagnositc, all the same as TNT 215. You'll also see that the speakers are getting amplified by the soundboard on both 215 and 264.

http://pinwiki.com/wiki/index.php?title=Williams_System_9_-_11#MPU_Driver_Boards

pasted_image (resized).png
#8 13 days ago

Good call, i didn't think that resistor had any thing to do with the sound. Will report back after checking!

#9 13 days ago

Dmm testresults are:
Pin 2 - 7 are 4.7 ohms
Pin 8 is 1.63 ohms
Pin 9 is 4.7 ohms
Pin 10 is 0.18

Did the test in circuit. Does this effect the sound and do i have to replace this resistor network? Not my handywork by the way must have been done by previous owner.

#10 13 days ago

Can you see if any of those legs on the resistor network are touching? From the picture, seems like there is a bridge between 9-10 and 7-8 but hard to tell in that picture. Measure resistance between pins 2-9, ex 2-3, 3-4, etc and see if they’re all the same.

Src1 is the pull up resistor for the bus line going to the sound board.

#11 12 days ago

Pin 1-2 4.7
Pin 2-3 9.3
Pin 3-4 9.3
Pin 4-5 9.3
Pin 5-6 9.3
Pin 6-7 9.3
Pin 7-8 6.3
Pin 8-9 6.3
Pin 9-10 4.8

#12 12 days ago

No connection between the pins with dmm on diode test only conductivity is between pin 1 and 2

#13 12 days ago

20190109_201106 (resized).jpg
#14 12 days ago

If it needs replacing which one do i need to get bussed or isolated 4.7 k ohm 10pin?

#15 12 days ago

Reading between pins:
2-3: 9.3
3-4: 9.3
4-5: 9.3
5-6: 9.3
6-7: 9.3
7-8: 6.3
8-9: 6.3
9-10: 4.8

#16 12 days ago

Wow that picture looks a lot different than the first!

How about src3, that’s the other pull up for 1j21. Looks like pin 10 is broke on src2?

I think you would want to get the scope out next and see if you’re getting hi and low on 1j21 3-10, 11-13, 15, 16, and 18. Those are all the pins that get pulled up unless ground is sent from u41 and u42.

You could also check connection between those 1j21 pins and the corresponding legs on u41 and u42, see if the repair or corrosion caused something.

Bussed would be the replacement style if f needed.

#17 12 days ago

Will do some more checking in the morning! Looks like some battety damage there but no broken pin! Thanks so far for all your help so far.!

1547070850698119055688 (resized).jpg1547070922055619494214 (resized).jpg
#18 12 days ago

After cleaning and nutralizing the acid! Going to try nd reflow the pins first!

15471157361842137656902 (resized).jpg1547115773086587694873 (resized).jpg
#19 11 days ago

Found 4 cut traces by battery acid between the pins! Going to fix it and report back!

20190110_123453 (resized).jpg
#20 11 days ago
Quoted from kevin76:

Found 4 cut traces by battery acid between the pins! Going to fix it and report back!
[quoted image]

That would probably do it!

#21 11 days ago

Great music works again but the now all three popbumpers aren't working anymore??? Any tips are welkom!

15472189081981264318193 (resized).jpg
#22 11 days ago

Problem solved it was the fuse that had blown previeus! Thanks alot for all the help!

#23 11 days ago
Quoted from kevin76:

Problem solved it was the fuse that had blown previeus! Thanks alot for all the help!

Awesome! Glad you were able to get it fixed.

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 14.00
Electronics
Yorktown Parts and Equip
From: $ 16.95
$ 18.99
Eproms
Matt's Basement Arcade
$ 22.00
850
Machine - For Sale
Nyack, NY
$ 36.99
Eproms
Matt's Basement Arcade
$ 175.00
Lighting - Interactive
Professor Pinball
$ 6,995.00
Pinball Machine
Flip N Out Pinball
$ 89.99
$ 79.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 99.99
Lighting - Other
Lighted Pinball Mods
$ 26.50
Playfield - Toys/Add-ons
The MOD Couple
$ 229.99
$ 18.99
Eproms
Matt's Basement Arcade
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
€ 222.00
Cabinet - Decals
Buthamburg

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside