(Topic ID: 83096)

Williams Space Shuttle Sound Problem


By RetiredPinman

5 years ago



Topic Stats

  • 12 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by ccbiggsoo7
  • Topic is favorited by 2 Pinsiders

You

Linked Games

#1 5 years ago

When the game is powered up there is constant noise coming from the speakers that varies with the attract mode flashing lights.

Pushing diagnostic S/W 2 on the large CPU board does nothing. It is supposed to cause sounds to be produced that continue till the game is power cycled.

The noise mentioned above ceases when in the book keeping or diagnostic modes. The diagnostic sound test produces no sound for sequence 00-05. There is a sharp clear sound for sequence 06. Then there is noise for sequence 07. It then repeats starting with sequence 00. The instruction manual says there are only 7 sequences; 00 - 06.

When the game is played the noise mentioned above is continuous, but you can hear just over the noise some non-speech sounds made when targets and switches are made. At I assume appropriate points in the play you can clearly heard astronaut speech words over the noise.

Several times when I was cycling through the diagnostic tests for some unknown reason during the lamp test the sound system spoke, in order, the game's speech words. It did it clearly without any noise.

Is it possible that the 6808 sound MPU is not running, since the diagnostic switch (S/W 2) has no effect? Yet even without it running the game does sound the speech words appropriately as the game is played. Possibly the speech MPU, prom or ram is messed up causing the noise.

#2 5 years ago

You have checked the speech/sound mixer switch? If you are only getting speech then that would be a good place to check. Have you pressed the speech test button on the MPU? It is a white switch near the lower right hand corner of the MPU.

Do you have an oscilloscope or logic probe? Those would be handy to test chips rather than just replacing them all like I did. Here is my thread from solving the sound on my comet, which has the same MPU as Space Shuttle. If you are getting some speech I think your problem is different than mine.

http://pinside.com/pinball/forum/topic/no-sound-on-williams-system-9-comet

Another thing to check is the screws holding the MPU board to the head, make sure they are all tight and not missing. People on this site are great and very helpful, I'm sure someone will chime in. Good luck!

#3 5 years ago

I read your comet adventure. I agree that my problem is not the same as yours. I hope that I end up with the same successful result.

I did test the central processor diagnostic S/W 1 and it worked as expected. But I get no action when I press the speech/sound test button, S/W 2 located down near the batteries. I think that either the sound processor is not running or its software is hosed such that when S/W 2 is pressed, which generates a processor interrupt, it does not execute the code that its supposed to.

Where is the speech/sound mixer switch?

I do not have an oscilloscope or logic probe, though I might need to get one if I am going to get very far fixing solid state machines.

#4 5 years ago

The speech/sound mixer is on the speech board, protruding white knob. Check that it isn't turned all the way to one side or the other.

I think I still have the test chip that makes testing these boards really simple. A logic probe is also cheap and would definately help narrow it down in combination with the test chip. You also need a power supply and a few jumpers. I picked up a cheap pinball power supply on ebay. Let me know if you want to throw me a few bucks and have it.

http://home.scarlet.be/~fb054529/will9/ewill9.htm

#5 5 years ago

PinballTilt; So far you are the only person that has posted anything about my sound problems- Thanks!

Yesterday I think I discovered the root cause of the noise in the sound system. The braid of the two conductor braided cable attached to J16 on the CPU card was not fully grounded. I temporarily addressed the problem by wrapping a piece of braided wire around the wire bundle between the connector and where the wires go into the cable jacket and then attaching the braid to a hard ground. Doing this eliminated at least 95% of the noise that was driving me crazy when the machine was powered on. I will investigate the problem further when I get around to tasking out the CPU card. My suspicion is that the connectors used are not really suited for braided cable. The braid is not making a good zero impedance connection to the CPU card ground.

I am still struggling with the other sound problem. The mixer pot had no effect.

Meanwhile I have some lamp, switch, and solenoid problems to address. I think that I will work on them and then get back to the sound problem. Meanwhile without the noise the game plays reasonably well, but with out a switch matrix columns worth of switches starting with the Rt Flipper lane change switch.

I get sounds and speech, but some are missing and not appropriate. For example at the start of most, but not all, balls it will say Ready Pilot Abort vs Ready Pilot One. It never says One. Its either Ready Pilot Abort or Ready Pilot.

Unless someone can help me further I think that I will be shotgunning a fix such as changing the U12 RAM or the U49 Prom. I assume that U49 contains the processor code as well as the sound codes. It also contains four words: airlock, open, close, and scream. Occasionally when the game is being played it will say all four of those words in that order which I don't think is correct.

2 weeks later
#6 5 years ago

I fixed the noise problem so now I am trying to get my arms around the sound problem. It would really help if someone that has a working Williams Space Shuttle game would tell me exactly what sounds or speech they get as a result of the two sound tests. The first test is initiated by pressing SW2 located at the bottom of the large processor card and a little to the right of the batteries. The manual says that when the switch is pressed that several electronic sounds are produced repetitively until the game is power cycled. When I press SW2 nothing happens.

The second test is the Diagnostic Sound Test. It is the second test in the diagnostic test sequence occurring after the Display Test. During this test the Credits display should display 00 and the Match Display will slowly cycle from 00-06. According to the manual a different sound should be produced for Match Display 01-06. For me I get no sound for Match Display 00-05. Match 06 is a sharp sound byte and Match 07 sounds like the Shuttle blasting off. Then it reverts to 00 with no sound till it cycles back to 06. What sounds do you get? Are all of the sounds electronic sound bytes or are some of them speech and if so which words?

#7 5 years ago

Short video of the test sounds playing for you.

3 weeks later
#8 5 years ago

Thanks very much for the video Grauwulf. I see that your machine in the sound diagnostic test cycles from 00 to 07 as does mine. The manual says that it should only cycle from 00 to 06. At least I probably don't have a problem there. The other interesting thing is that there are 6 sound bites, 01 to 06, and then one speech bite for the mythical 07. When I perform the sound diagnostic test I get no sound for 01 to 05, a sound bite that I think is not the same as yours for 06 (but I will check), and another sound bite for 07 that could be noise.

As I mentioned earlier in this tech blog above I do get sounds when I play the game, both sound bites and speech. I think some are correct and some not. For example for player one it says Ready Pilot Abort. For players two and three it says Ready Pilot followed by something un-distinguishable. But for player four it clearly says Ready Pilot Four. Also after locking a ball it serves up another ball and correctly says Ready Four Liftoff.

I think that I have an addressing problem that causes the speech and sound to be correct some of the time and not correct other times. Plus its consistent meaning a hard failure. My guess is that its one of the PIA chips. I bought a logic probe that I am going to use to look for address bits to the speech proms that don't jump around. In particular I am going after the address bit for the prom that contains the the words One, Two, and Three. During play all of the other words come up, but I never hear those three words.

I don't think that my problem is the prom containing the One, Two, and Three words. On several occasions for reasons I don't understand the game will clearly sound out its entire 12 word vocabulary including One, Two, and Three. It did it a couple of nights ago while I was playing it. It did it several times in the past while I was performing the controlled lamp test.

Likewise I think that the addressing problem is affecting the sound bites as evidenced by the fact that I don't get the same ones that you get when performing the sound diagnostic. I am thinking that if the wrong address gets on the address bus that either an incorrect sound will occur or no sound at all. When I play the game there are many periods of time when there is no sound at all. I think that there should always be sound present when the game is being played. No sound is the same thing that is happening during the sound diagnostic test.

Again, thanks.

3 weeks later
#9 5 years ago

No problem. It could also be the ribbon cable going to the speech board, I've seen bad connections there cause some weirdness as well. There is a way you can run the game with the speech board disconnected and still get sound to see if your MPU based sounds are working correctly, but I'd have to look it up. It just involves jumpering two pins in the cable header with a jumper cap. My money is on the PIA or the ram in the sound section, using Leon's test rom for the sound section could certainly help eliminate those quickly.

#10 5 years ago

Grauwulf I think I have eliminated the ribbon cable and the speech sub-board. I ohmed each pin in the ribbon cable and found no open, short, or out of family resistance. I also operated the machine with the ribbon cable disconnected and W10 jumpered on the processor board. As I expected the game played with electronic sounds, but no speech. The sounds were the same as when the ribbon cable was connected. With it disconnected I ran the sound diagnostic test and got the same result as before, except no sound at all for step 07 which is the only speech sound per your test.

BTW with the logic probe and the ribbon cable again connected I confirmed in the logic flow that step 7 in the sound diagnostic test is the only speech sound. The other 6 are electronic sound bytes.

My money is on the 3 bit decoder U50. It decodes the upper 4 bits of the 16 bit address buss that selects the eproms, the ram, and the speech PIA. It could easily be selecting the wrong device and cause the problem. If not that then my second guess is the U49 eprom. But you might have a point that the U12 speech processor ram could also be the problem.

I have a friend looking at the schematics. He owns a Gougar game, a 1979 Williams machine. I looked at the schematics of that game and the sound design and components are virtually the same as in Space Shuttle. They are just divided up on interconnected circuit boards versus one large processor board. It even appears to have the identical small speech board with a 40 pin ribbon cable. I am waiting for his assessment before changing out parts. I want to minimize the number of parts, ICs, that I change to minimize the possibility of damaging the processor board.

What does your game do when you depress test button 2? Mine does nothing. Turns out my test button 2 does not work. It should ground a pin on the processor chip. I grounded the processor pin with an external jumper and still got nothing most of the time. A couple of times I got the processor to lock up requiring a power cycle of the machine to get things going again. While the processor was locked up I got no sound. According to the processor spec sheet the pin that is grounded fires an interrupt causing the processor to drop what its doing and go to a piece of code stored in an upper portion of the 16 bit address space. If the address bus is messed up as I think it is the processor is probably not getting vectored to the correct piece of code.

1 year later
#11 3 years ago

I am finally back at it again. I have changed out a ton of IC's to no avail. I procured an oscilloscope to help me go after the problem. I am focusing on the sound processor's PIA, U13. Did some scoping last night. Using the sound diagnostic I get no sounds at all when the test number reads 0-5. I re-played the You Tube video that Grauwulf kindly provided and realize that there is no sound produced for test number 0. So I will scope again to see if the 8 bits of the digital to analog converter, U48, flip for test numbers 1-5. If they don't there there is a control issue re the PIA that it is not passing the 8 data bits from the U49 Prom to the DTA.

If anyone has a good description of how the 6821 PIA works I could sure use it. I have something that I dug up in the past that I will re-study to learn about how it works and most importantly the control signals that control it.

1 year later
#12 2 years ago

ever come up with a solution? having same probs.

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
1,650
Sale Pending!
Fort Wayne, IN
$ 20.00
Electronics
Yorktown Parts and Equip
From: $ 16.95
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
2,200 (Firm)
Sale Pending!
Ham Lake, MN
From: $ 18.00
Apparel - Men
Pinside Shop
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 14.99
Electronics
PinballElectronics.com
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 62.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 219.99
Lighting - Led
PinballBulbs
$ 42.00
Playfield - Toys/Add-ons
The MOD Couple

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside