(Topic ID: 239574)

Williams Skylab when scoring 50 point targets sometimes won't stop

By StotzBotz

2 years ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by currieddog
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Pinball (resized).png
Pinball (resized).png

#1 2 years ago

Hope I'm not too annoying here starting a new topic as I didn't want to go un noticed adding this to an older post. When I'm playing my Williams Skylab something sporadically keeps sticking. There are the targets along the left and right side that have the long rubber bands and the switches behind them. When they are hit, 50 points are racked up. Sometimes when to hit one of the targets the scoring reels just keep going scoring hundreds of points before stopping. I checked the switches and all are adjusted properly. Is there anything else that I can adjust, clean or repair that will stop this from happening. You can play an entire game sometimes with 5 balls and it won't do it. Other times it will do it soon after starting to play. Any help with this would be greatly appreciated but if you could please tell me the location of what device I might be working with it would be so helpful. Many thanks in advance.

#2 2 years ago

This switch on the motor could be adjusted too close.

For a switch to work 3 things are necessary
1) When open, there should be a small space between the contact points (duh)
2) When closing, the long blade's contact point should push the short blade's contact point enough to move the short blade
3) The contact points should be clean, which they usually will be if #2 is happening

Pinball (resized).pngPinball (resized).png
#3 2 years ago

Also the lock-in switch on the 50 relay itself could be gapped too close.

#4 2 years ago

Would anyone know where this mechanism is located?

#5 2 years ago

The sw. HowardR noted is part of the score motor and that stack is next to two shorter ones at the end. The 50 pt relay is likely on the bottom of the cabinet, hopefully labeled.

#6 2 years ago

Well as usual I greatly appreciate you guys guiding me through this issue with my machine. I found the 50 point relay switch assembly by starting a game, lifting the play field then hitting a target by hand and watching for the flash from the relay. It was located on the bottom of the play field and clearly marked so I knew I found the right one. I gently took some emery sand paper and ran it between the different contacts briefly. I then sprayed just a little chem spray contact cleaner on the points and waited a little for it to dry. I've played this machine all day off and on and the problem has not returned. Thanks again.

#7 2 years ago
Quoted from StotzBotz:

I then sprayed just a little chem spray contact cleaner on the points

This is never needed

#8 2 years ago

Great that's it's going! Please check as 'resolved.'

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside