(Topic ID: 154937)

Williams Pharaoh Dare you enter to tomb of the mighty Pharaoh!

By dementedwarlok

8 years ago


Topic Heartbeat

Topic Stats

  • 183 posts
  • 49 Pinsiders participating
  • Latest reply 4 months ago by Pauz21
  • Topic is favorited by 27 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

image (resized).jpg
image (resized).jpg
markup_1000008130 (3).png
20230803_143208 (resized).jpg
20220720_185038 (resized).jpg
20220628_125204 (resized).jpg
20220627_231806 (resized).jpg
20220629_002127 (resized).jpg
s-l1600 (1) (resized).jpg
s-l1600 (resized).jpg
IMG-20220317-WA0010 (resized).jpg
IMG-20220317-WA0000 (resized).jpg
IMG-20220317-WA0001 (resized).jpg
IMG-20220317-WA0012 (resized).jpg
IMG-20220317-WA0003 (resized).jpg
IMG-20220317-WA0002 (resized).jpg
There are 183 posts in this topic. You are on page 4 of 4.
#151 1 year ago
Quoted from ROMM:

Did she find out about the magna save? No one that ever plays mine notices it or realizes what it does. Magna save is awesome and is the reason I bought mine. Hope to pick up a Grand Lizard and Black Knight eventually.

Yes, I told her about it and showed her how it works (successfully I might add). When she saw that her mind was blown and that’s when she was totally sold on it. It’s the only game we have with a magna save.

2 months later
#152 11 months ago

Does anyone know what this part it and where it goes? It was in the bottom of the cabinet of my Pharaoh and I can't find an obvious location for it to go.

20230803_143208 (resized).jpg20230803_143208 (resized).jpg
#153 11 months ago

Does anyone have the files or know where I can get some nice color apron cards for this game?

#154 11 months ago
Quoted from Cudaman:

Does anyone know what this part it and where it goes? It was in the bottom of the cabinet of my Pharaoh and I can't find an obvious location for it to go.
[quoted image]

Possibly coin box divider

2 weeks later
#155 11 months ago
Quoted from BobLangelius:

Possibly coin box divider

Bingo...that was it! Never thought of that.

So who needs a Pharaoh? I guess we can't embed a for sale ad here for some reason? PM me if interested or check the market ads.

1 month later
#156 9 months ago

Having a problem with our Pharaoh. Ball goes into the Slaves Tomb and then just sits there, nothing seems to register that it is there, eventually I have to turn the game off, take the glass off, and manually get the ball out.

Please excuse the fact that I am not too familiar with working on these older machines. Probably shouldn't have bitten off more than I'm capable of chewing right now, but hoping to learn stuff along the way. Reason for mentioning this, if you care to help me with ideas on how to fix please give instructions to someone who is far, far from an expert on these things.

#157 9 months ago

Check the switch in the tomb. If the game did something, like played a sound I’d think coil. But since it doesn’t do anything I’d think switch.

#158 9 months ago
Quoted from BobLangelius:

Check the switch in the tomb. If the game did something, like played a sound I’d think coil. But since it doesn’t do anything I’d think switch.

Thank you for the quick answer, I appreciate it.

Am I able to run a switch test through the menus, and will that tell me if it's working or not? Or am I physically inspecting the switch to see if there's something telling me that it's not working properly and needs to be replaced?

#159 9 months ago

Open the coin door and you will see 2 buttons and a switch or three buttons but the middle one locks down down. From my memory you need to set the middle one ‘down’ and push the right most one down to enter tests. Then set the middle back up and use the right one again to go through all the tests. Display/solenoid/sound/switches. When at the switch test all stuck or depressed switches (down drops, ball trough will rotate in the display showing there internal id. I would get all the drop up and remove balls and then test the problem switch. If you get nothing .. dirty/bad switch or broken wire .. possibly a computer board issue if more than one switch is bad

#160 9 months ago
Quoted from LeMansFan:

Thank you for the quick answer, I appreciate it.
Am I able to run a switch test through the menus, and will that tell me if it's working or not? Or am I physically inspecting the switch to see if there's something telling me that it's not working properly and needs to be replaced?

Go into switch test.("Switch edges" if it has it.). Test the slaves tomb switch with a ball. See if it registers. it probably will not.

If it does not register, you need to (turn machine off) look at the switch physically and see what is going on:

It could be just dirty. Has it been un-played for a while? Clean the contacts by running a business card between the contacts while you hold them together.

It could have a broken wire. ( there should be two different color wires[ possibly multiples of each] going to it and a diode) All connected?

It could be a bent wire actuator, Again use the ball and check that it causes the contacts to close. ( and wipe against each other slightly)

If it does register in switch test, then move on from the switch. it is coil related.

But since you say it does nothing, it makes me think you have a switch problem.

Report back please.

4 weeks later
#161 8 months ago

Can anyone take a couple measurements for me from the inside of the cabinet? I need to know the lengths of the wooden support rails attached to the inner side of the cabinet, the wood that the playfield rests on top of. In particular, it seems the left side is probably going to be broken into 3 lengths--I'd like to know what they measure. Thanks!!!

Here's a pic from my Jungle Lord that shows what I'm referring to:

markup_1000008130 (3).pngmarkup_1000008130 (3).png
#162 8 months ago
Quoted from frunch:

Can anyone take a couple measurements for me from the inside of the cabinet? I need to know the lengths of the wooden support rails attached to the inner side of the cabinet, the wood that the playfield rests on top of. In particular, it seems the left side is probably going to be broken into 3 lengths--I'd like to know what they measure. Thanks!!!
Here's a pic from my Jungle Lord that shows what I'm referring to:
[quoted image]

Im probably gonna visit our location on sunday, will take measurements then if I remember.

#163 8 months ago
Quoted from mtn-:

Im probably gonna visit our location on sunday, will take measurements then if I remember.

Thank you!! I appreciate it

#164 8 months ago
Quoted from frunch:

Thank you!! I appreciate it

Im a drunken bastard, so Ill try to set a reminder on my stupid phone.

#165 8 months ago
Quoted from mtn-:

Im a drunken bastard, so Ill try to set a reminder on my stupid phone.

Hahaha well i really do appreciate your willingness to help! It turns out another pinsider had the measurements available, so it looks like I won't need them anymore. Thank you again for your offer, though!

#166 8 months ago
Quoted from frunch:

Hahaha well i really do appreciate your willingness to help! It turns out another pinsider had the measurements available, so it looks like I won't need them anymore. Thank you again for your offer, though!

Happy you got it sorted! You should post those measurements with or without pictures here, maybe someone else will look for them one day?

#167 8 months ago
Quoted from mtn-:

Happy you got it sorted! You should post those measurements with or without pictures here, maybe someone else will look for them one day?

You raise a good point -- once i install the corrected support rails (and confirm they work properly), I'll post a pic with measurements in case anyone else needs them.

#168 8 months ago
Quoted from frunch:

I'll post a pic with measurements in case anyone else needs them.

Side note, PinballMakers made their system 7 cabinet design based on a Pharoah - unfortunately they didn't include the playfield support rail dimensions but anyway there might be other info there of use: Your measurements will fill some gaps.

https://pinballmakers.com/wiki/index.php?title=Files_Section

#169 8 months ago

Yes. That’s the same model, I need to update the pdf

Sadly the model is too big to post. If you want a copy of the model I can email

2 months later
#170 6 months ago

Hey guys. New to the club. And doing some trouble shooting. Can anyone direct me to a part number for those little relays mounted under the playfield? I’m having issues with GI lights in the head and in my lower playfield.

Thought I had it traced to loose connectors on those relays. That fixed the head but not the lower play field. For that issue it appears to be the relay itself. Changed the connectors. They’re solid but need to tap on the relay each time I turn the machine on to get it to turn the lower GI on. And if they go off during the game for some reason they don’t want to come back on so it appears it’s a sticky relay issue.

Also. I saw a while ago someone had posted some random plastics they had as extras.

I have lots that are warped or minor cracks but I really need the two big ones in the upper right and left corners. Or that tiny rectangle piece that’s on the facade of the upper playfield right in front of the shooter lane. Those three are missing chunks.

Outside of that. I have some questions on whether my sound boards are working right. Some of the sounds are pretty random and seem like my sound board has turrets to me.

I also have a lot of static in my speakers when it’s in attract mode. Not sure if that’s a ground problem or just bad connectors.

Once all that’s dealt with I just need to rebuild the cabinet. Haha. It’s in bad shape. play field

#171 6 months ago
Quoted from Pauz21:

Hey guys. New to the club. And doing some trouble shooting. Can anyone direct me to a part number for those little relays mounted under the playfield? I’m having issues with GI lights in the head and in my lower playfield.
Thought I had it traced to loose connectors on those relays. That fixed the head but not the lower play field. For that issue it appears to be the relay itself. Changed the connectors. They’re solid but need to tap on the relay each time I turn the machine on to get it to turn the lower GI on. And if they go off during the game for some reason they don’t want to come back on so it appears it’s a sticky relay issue.
Also. I saw a while ago someone had posted some random plastics they had as extras.
I have lots that are warped or minor cracks but I really need the two big ones in the upper right and left corners. Or that tiny rectangle piece that’s on the facade of the upper playfield right in front of the shooter lane. Those three are missing chunks.
Outside of that. I have some questions on whether my sound boards are working right. Some of the sounds are pretty random and seem like my sound board has turrets to me.
I also have a lot of static in my speakers when it’s in attract mode. Not sure if that’s a ground problem or just bad connectors.
Once all that’s dealt with I just need to rebuild the cabinet. Haha. It’s in bad shape. play field

image (resized).jpgimage (resized).jpg

#172 6 months ago

awesome thank you!!

1 week later
#173 6 months ago
Quoted from Pauz21:

awesome thank you!!

Found the relay locally and it did the trick! Thanks very much.

Only issue left that I can find is the right ? Mark light appears on all the time.

And the voice sound is sometimes very “dirty” and static. Wondering if changing the caps might fix that.

#174 5 months ago
Quoted from Pauz21:

Found the relay locally and it did the trick! Thanks very much.
Only issue left that I can find is the right ? Mark light appears on all the time.
And the voice sound is sometimes very “dirty” and static. Wondering if changing the caps might fix that.

Bump on this question. Question mark on the right appears to be lit all the time.

And to further update. Since my first post I’ve put Leds in the machine. That lamp is still in solid. But so are several others now too.

Also. There are several lights that appear to be slightly ghosting in the same flash pattern as the back box lights in the name PHaraoh.

One last dumb question. All these sockets have a third lug and the diode is running to the lug with no wire on it. What is the purpose of the 3rd lug and what exactly is this diode doing if it has no wire running to one end?

Thx

#175 5 months ago
Quoted from Pauz21:

Bump on this question. Question mark on the right appears to be lit all the time.
And to further update. Since my first post I’ve put Leds in the machine. That lamp is still in solid. But so are several others now too.
Also. There are several lights that appear to be slightly ghosting in the same flash pattern as the back box lights in the name PHaraoh.
One last dumb question. All these sockets have a third lug and the diode is running to the lug with no wire on it. What is the purpose of the 3rd lug and what exactly is this diode doing if it has no wire running to one end?
Thx

One side goes to a wire and the other side goes to the lamp. This is required to form the lamp matrix. Multiple lamp locked on is usually the fault of one of the matrix ICs. Check the lamp matrix grid in the manual and then figure out which IC controls them

Mike V

#176 5 months ago
Quoted from RacingPin:

One side goes to a wire and the other side goes to the lamp. This is required to form the lamp matrix. Multiple lamp locked on is usually the fault of one of the matrix ICs. Check the lamp matrix grid in the manual and then figure out which IC controls them
Mike V

Quoted from RacingPin:

One side goes to a wire and the other side goes to the lamp. This is required to form the lamp matrix. Multiple lamp locked on is usually the fault of one of the matrix ICs. Check the lamp matrix grid in the manual and then figure out which IC controls them
Mike V

So quick update. After putting LEDs in to

Quoted from RacingPin:

One side goes to a wire and the other side goes to the lamp. This is required to form the lamp matrix. Multiple lamp locked on is usually the fault of one of the matrix ICs. Check the lamp matrix grid in the manual and then figure out which IC controls them
Mike V

So quick update. I decided for the heck of it… to replace that socket on the one that’s been locked on since I got it. Not only did it fix that issue. But all other locked on and ghosting lights corrected themselves. So not sure if it was the socket or the diode but that was successful.

Then all I had left was the left kicker not working. Traced it to a bad connector. Fixed that up and it works but the #7 bonus light went out. Haha. I’m certain it’s just janky connectors.

So other than a minor light out. Fully working. Playing well.

Anyone have a link to the drop target decals?

#177 5 months ago

Congrats on the fix! Here's the decals i went with. Admittedly, Marco has a bit of a hit-or-miss reputation for some of their decals but i was happy with the set i received.

https://www.marcospecialties.com/pinball-parts/31-1003

3 weeks later
#178 4 months ago

Having an issue with our Pharaoh.

Please allow me to preface that I should probably not own an older game such as this because my pinball maintenance skills are barely past the level of a total newbie. I've gotten better, but I still have much to learn. This game was one my wife liked, so she bought it, and I'm trying to keep it running for her.

Everything had been working very well and there were no problems with the game. However it's not working properly now.

What happens is immediately on power up I see that there are lights lit on the playfield that normally shouldn't be lit when starting a game, for example the 2x and shoot again lights (among others). When we did try to play a game like this everything seemed to work, but then once the ball was held in the main lock it just holds it there and doesn't release.

I bought a fuse tester and have tested all the fuses and they all check out. I reseated the connectors. Still have the issue. And now it seems as though the playfield inserts are flickering when the game is turned on.

Any specific things I haven't done that I can check on? Appreciate any advice, and if you're kind enough to give some please assume I will need very specific suggestions and speak to me as someone very green on maintenance. Thanks in advance.

#179 4 months ago
Quoted from LeMansFan:

Having an issue with our Pharaoh.
Please allow me to preface that I should probably not own an older game such as this because my pinball maintenance skills are barely past the level of a total newbie. I've gotten better, but I still have much to learn. This game was one my wife liked, so she bought it, and I'm trying to keep it running for her.
Everything had been working very well and there were no problems with the game. However it's not working properly now.
What happens is immediately on power up I see that there are lights lit on the playfield that normally shouldn't be lit when starting a game, for example the 2x and shoot again lights (among others). When we did try to play a game like this everything seemed to work, but then once the ball was held in the main lock it just holds it there and doesn't release.
I bought a fuse tester and have tested all the fuses and they all check out. I reseated the connectors. Still have the issue. And now it seems as though the playfield inserts are flickering when the game is turned on.
Any specific things I haven't done that I can check on? Appreciate any advice, and if you're kind enough to give some please assume I will need very specific suggestions and speak to me as someone very green on maintenance. Thanks in advance.

I’m guessing connectors or bad socket diodes are your light culprit.

I had a similar issue. One bad diode on a socket cause a handful to lock on. Changed the one fixed them all.

Make sure though, when you reseat the connectors… you also check the plugs that connect the head and the cabinet cables together. I had some of those where the pins were starting to push out. So I had to push them back in.

Regarding the lock not releasing. I’m guessing it’s a dirty or misaligned switch under the scoop.

#180 4 months ago

Can anyone post a high resolution picture of the right magna sav area on the playfield? Mine has magnet burn and would like to touch it up. Thank you.

#181 4 months ago
Quoted from Pinballflare:

Can anyone post a high resolution picture of the right magna sav area on the playfield? Mine has magnet burn and would like to touch it up. Thank you.

image (resized).jpgimage (resized).jpg
#182 4 months ago
Quoted from Pauz21:

[quoted image]

Thank you very much!

1 week later
#183 4 months ago

Anyone have the file for the drop targets? Want to get some printed on vinyl.

Also couple weird things left to figure out on mine.

The drops some times randomly rest. It will award the bonus at the bottom even though not all have been dropped and it resets.

On the top. When it does it it resets the bank but it’s still flashing based on what you had down. So it’s almost like the controlled light aren’t reset. Just the bank. Gotta be a board issue but I don’t know how to diagnose.

My left inlane and outlane and kicker also score higher points. And the two lanes award I believe too much bonus.

Any ideas.

Promoted items from Pinside Marketplace and Pinside Shops!
$ 52.95
Eproms
Pinballrom
 
$ 44.99
Cabinet - Shooter Rods
Pinball Shark
 
$ 36.95
Eproms
Pinballrom
 
$ 12.50
Lighting - Led
RoyGBev Pinball
 
$ 25.00
Electronics
Yorktown Arcade Supply
 
2,300
Machine - For Sale
South Kingstown, RI
From: $ 90.00
Tools
Pincoder Store
 
From: $ 9.00
$ 65.00
Boards
Pinball Haus
 
Hey modders!
Your shop name here
There are 183 posts in this topic. You are on page 4 of 4.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.