(Topic ID: 265113)

Williams Liberty Bell ball won't eject

By basset1

1 year ago

Topic Heartbeat

Topic Stats

  • 51 posts
  • 6 Pinsiders participating
  • Latest reply 1 year ago by SilverballSleuth
  • No one calls this topic a favorite


Linked Games

Topic Gallery

View topic image gallery

IMG_E5347 (resized).JPG
IMG_5337 (resized).JPG
IMG_5336 (resized).JPG
IMG_5329 (resized).JPG
IMG_5328 (resized).JPG
pasted_image (resized).png
pasted_image (resized).png
pasted_image (resized).png
Capture (resized).PNG
Capture (resized).PNG

There are 51 posts in this topic. You are on page 1 of 2.
#1 1 year ago

Williams Liberty Bell: Machine starts fine, plays great. However, about once every 20 games or so, the ball won’t eject from any of the three eject holes. I know it’s going to happen because I hear a hum. The Ball Index relay is the one humming. Checked the eject and top eject relays, even resoldered the switch connections. Found an open switch on the hundred’s score wheel but didn’t solve the problem. Cleaned all the jones plugs. Checked all the score wheel switches. Now, when I start a game, as soon as a ball falls into an eject hole, the ball index relay energizes and starts getting louder and louder. Ball drains, ball index releases. I’m pretty sure the ball index is supposed to stay energized for the entire ball, I think. Running out of things to look at. Delay relay is working, looked at motor 4-D. Appreciate any help. Reed

#2 1 year ago
Quoted from basset1:

I’m pretty sure the ball index is supposed to stay energized

That's right.

Quoted from basset1:

the ball won’t eject from any of the three eject holes

Does either the Eject relay or the Top Eject relay activate when one of the three eject hole switches is closed?

#3 1 year ago

Here's what happens: I hear a hum (ball index relay), then when the ball falls into an eject hole, it just stays there, does not eject, still humming. Turn off machine. After restart, sometimes it stays humming and ball doesn't eject if I put a ball in the hole, sometimes the hum goes away and it's working correctly. This first start several months ago. When it first happened, I could nudge the machine several times and it would be ok. Now, it's happening much more often and I can't nudge the machine to make it go away. Was not working late last night. Just went and checked the machine this morning and everything's working correctly. Pesky intermittent problem. Looking at the schematic, I thought it would be in the eject relay circuit so I checked all the gaps on the eject relay and the top eject relay. Even resoldered all of those switches on both relays. Thanks for any help. Reed

#4 1 year ago

The eject holes are energized through a normally closed switch on the Delay Relay. Clean and/or adjust that one.

#5 1 year ago

Wondering if you have a bit of a short between C and D on this score motor stack?
Capture (resized).PNG

#6 1 year ago

The Delay Relay is working. If I hit one of the spinners, the delay relay holds in for a few seconds. Gaps all look good. I looked at all the wires on 4 D & C Motor. Don’t see any wire touching. I could resolder all switches on D and C???

When I turned off the machine, it was humming and ball stuck in hole. With a multi meter, I got low .02 resistance between the G-B wire on 4C and the R-BR wire on 4D. I’m not the best in reading schematics but I couldn’t see where these two would connect anywhere on the schematic. Looking at schematic at D14 where Motor 4-C goes to ball index relay and outhole relay (G-B wire), I don’t see any path to get to motor 4D switches.

As usual, the machine again is working. I’ve been taking videos on each game (unfortunately my wife was playing it when it went bad again) to try and see where the ball is when the humming starts. Again, appreciate any help. Reed

#7 1 year ago
Quoted from basset1:

I looked at all the wires on 4 D & C Motor. Don’t see any wire touching. I could resolder all switches on D and C???

How about the blades? I wouldn't resolder.

Another possible because of the intermittent nature of this: 'floating contact,' ie-the contact is a bit loose on the blade and needs a good squeeze with needlenose pliers. Do all involved.

#8 1 year ago

Checked the blades and squeezed with needlenose pokers. Played a couple of games with a video and it did it again. It happened right after going through the left spinner. Reed

#9 1 year ago

Well, I was going to say that the spinners energize the Delay relay so check sw. D but I see in post 6, that you said that they do energize it. I think it's time to start thinking of checking for a broken wire by using jumper cables. If you're not sure about that process do a search here.

#10 1 year ago

ok, thanks. will post anything I find

#11 1 year ago

How about a bad solder joint? possibility?

#12 1 year ago

The Delay relay may be energizing correctly but did you clean the switch on the Delay Relay? I would jumper it closed, just to be sure it's making contact. If the switch is not positively closed the eject relays won't work.

#13 1 year ago

Ok, I looked at the delay relay. Pushed it in and out and it seemed a bit sticky. Took out the coil. I wasn't the metal part that was sticky, it was the contact between the plunger and metal. Cleaned it up,no longer sticky. Cleaned the switch which really wasn't dirty and tightened the contact slightly. Making good contact. Found something else. When the ball got stuck in hole (by the way, all three eject holes don't work), the delay relay is energized but if I spun the spinner real fast, the delay relay would pull back. Also, the two spinner switches were somewhat dirty so cleaned those. Still looking a loose wires, solder connections, etc. Reed

#14 1 year ago

Forgot one other thing. When things start to go wrong, the hum in the index relay starts then gradually gets louder and louder, then ball won't eject. Also, noticed that the ball index relay was getting hot. I checked the resistance on the ball index relay and it matches all the adjacent relays. Reed

#15 1 year ago

Have you checked Tilt relay sw. D and E yet? If not that, try jumpering from the Spinner relays to the Delay.

Capture (resized).PNG
#16 1 year ago

When you close a switch (or put a ball in) one of the left or right eject holes, observe the Eject Relay. Is it energergizing?
If it isn't energizing then I would check Cam Index B.

pasted_image (resized).png
#17 1 year ago

Checked tilt relay. Cleaned switches which were not that dirty. Looked closely at D & E on tilt relay, checked solder connections, loose wires switch gaps look ok. The eject relay energizes only when a ball goes in either the left or right eject hole. The top eject relay energizes only when ball goes in top hole. When the playfield is down and this happens, i.e., ball stuck in eject hole, I can take the ball out and it still hums loudly, but when I lift the playfield up, it usually stops. I think, but not sure, it's because of the very touchy spinner switch that kinda float when playfield is raised but not positive. Only once was I able to look around when it was still humming loudly. Therefore, when I'm testing things or trying to figure out what's going on, the machine is working perfectly. On the schematic, looking at the spinner and delay relay, not sure how to jumper this, especially if the machine is working correctly. At a bit of a loss on how to tackle intermittent problems. If it's loose wires, I can jiggle wires, if it's mis-adjusted switches, I can keep looking at all the switches mentioned above, but 95% of the time the machine is working correctly. On jumping spinner relays to the delay relay, should I do this with the machine running correctly? Will that tell me anything? I have a test light and am always checking resistance on connections. Thanks all for continuing to address this issue. Reed

#18 1 year ago

If the eject relay energizes but the eject coils don't fire then you need to look at the score motor switches that those coils have in common. They all run through Motor 4D and possibly 5B.

pasted_image (resized).png
#19 1 year ago

I don't think I explained that correctly. When the machine is working correctly, the eject and top eject relays will energize as they should and eject the ball. When the ball is stuck in the hole, nothing happens, the eject relays don't energize and the ball doesn't eject.

#20 1 year ago
Quoted from HowardR:

Does either the Eject relay or the Top Eject relay activate when one of the three eject hole switches is closed?

Quoted from basset1:

When the ball is stuck in the hole, nothing happens, the eject relays don't energize and

If the Eject relays don't energize, Inspect and diagnose this circuit with Alligator clip jumper wires
Starting with the circled switches that are common to both Eject relays

pasted_image (resized).png
#21 1 year ago

Alright, I think I've discovered something. I can make the "ball stuck" action by moving either one of the spinner 90 degrees. Move the spinner back 90 degrees, it stops. Will look at this closer tomorrow. Reed

#22 1 year ago

Reed-Looking at the pic of the Spinner assem. on p. 20 of the manual. Is there a sw. in between the boards? Can't quite figure the set up. Actually, can you post a pic?

Link to manual: https://www.ipdb.org/files/1436/Williams_1977_Liberty_Bell_Instruction_Manual.pdf

#23 1 year ago

Not really a switch. When the spinner moves, the plastic cog with notches moves and the copper blade just stops it from backing up. When the plastic cog moves, it pushes the plate up against the coil and energizes it. Hope I explained this correctly. First picture is look down at 45 degree angle, second picture looking up at 45 degree angle. Reed

IMG_5328 (resized).JPGIMG_5329 (resized).JPG
#24 1 year ago

Thanks. Now, one board is left and one right? And how are you moving it 90 degrees to recreate the problem?

#25 1 year ago

Ok. Playfield down (although this works whether it's up or down). Game started normally, ball ready to go. On either one of the spinners on the top of the playfield where the ball goes through, the spinner is in it normal position, vertical (first picture). Manually move it in either direction 90 degrees (now horizontal, second picture). Just a hair past 90 degrees the hum starts and all three eject holes do no eject. Move it back 90 degrees (vertical, i.e., normal position), hum goes away, eject holes work.

IMG_5336 (resized).JPGIMG_5337 (resized).JPG
#26 1 year ago

Oooooo, you move the spinners!! I thought you meant the relay. So, what's happening underneath when you do that, ie-where the wire goes thru the PF and connects?

#27 1 year ago

Turning your spinner like that, activates your spinner relay which activates your delay relay which opens the circuit to the eject relay. It's working correctly. Sounds like you need to adjust your spinner switch.

#28 1 year ago

Looking at C16 on the schematic, I'll trace what happens for the right spinner switch and right spinner relay. Start machine, all's well, move spinner 90 degrees, no eject holes work, right spinner relay energizes. Now looking at the right spinner relay and going physically thru "A" thru "D". I'm moving the spinner 90 degrees for each stack on right spinner relay. "D" - delay coil energizes; "C" - the spinner unit coil is pulsed; "B" - goes thru "C" switch on change relay. Change relay does not energize which I think is correct. This is a closed m/b switch. Good contact from right spinner relay to switch C on change relay; "A" - Advance relay is energized. That's all I've done so far, haven't looked at left spinner relay but I know that does energize when moving the spinner9 0 degrees. I'll start tracing thru the schematic on different relays but if you have a good idea where to look so I can zero in on a relay, etc., that would be great. Thanks so much.

#29 1 year ago
Quoted from basset1:

Start machine, all's well, move spinner 90 degrees, no eject holes work

No sign of something disengaging when you do that?

#30 1 year ago

Adjust the gap wider on both of your spinner switches. Not the spinner relay. The spinner switch that is physically attached to the spinner by the wire running through the hole in the playfield. If this switch is too close together, a slight movement may close the switch. resulting in exactly what you are experiencing. Including the hum mentioned earlier.

#31 1 year ago

Did not see anything disengaging but I'll look again. On the spinner switch, I put the playfield almost all the way down but could still look underneath and see both switches. They are a good distance away from each other. When I close the switch, it is still making good contact. If I increase the gap, it might not make good contact when ball goes thru. I'll wait for your reply before I adjust the switch. I took a picture of the switch in it's open state with playfield almost down. Hard to see but if you zoom in, you might be able to see how far away the switch is.

IMG_E5347 (resized).JPG
#32 1 year ago

Hard to see in the pic, but that looks like it has plenty of gap. I would put a piece of paper in each spinner switch (to block it from closing) and see if you still have a problem. If the ejects work o.k. with both spinner switches blocked then you know it must be the spinner switches.

It the ejects still don't work you may have a wire touching on a solder lug on those switches. Also make sure the wire that comes through the playfield isn't touching both blades.

It might be hard to get the paper to stay in those switches. You can might have to fold paper around and tape it.

#33 1 year ago

Put paper in both spinner switches, spun spinner, nothing since not making any contact. Eject holes all work. When the spinner spins fast when a ball hits it, I believe it's suppose to stop all the eject holes. I spun the spinner manually fast and while it was spinning, I tried the eject holes and they didn't work. Spinner stopped, eject holes work. This makes since because when you send a ball very fast thru either spinner and the ball lands in the top eject hole while the spinner is still spinning and adding up scores, the eject holes won't eject until the spinner stops. By moving the spinner 90 degrees slowly, it should be stopping the eject hole. So I now understand about adjusting those switches so I increased the gap just a hair, didn't work. Played a couple of game and it did it again. This time, however, I looked at the spinners and they were both vertical. If they was horizontal, I could see how the eject holes would not work. So, the switches were not making contact when this event occured because gravity keeps the switch wide open (spinners were vertical). So, I think something somewhere else is doing the same thing as closing the spinner switches. I'm now looking at both spinner relays. Reed

#34 1 year ago

On your spinner relays, check the gap on the switches with the Black/Orange wire on one side - Orange on the other. If that switch is closed on either relay, it will trigger the delay relay which will stop it from ejecting.

#35 1 year ago
Quoted from basset1:

Liberty Bell ball won't eject.

Maybe the problem is a crack somewhere. After all, it is the Liberty Bell.

(And maybe a dad joke like that should come with a warning?)

#36 1 year ago

I just played a whole bunch of games thinking it might be fixed - wrong! I tweaked the gaps on the left spinner relay before all those games so now I'll look at the right spinner relay. These spinner relays seem the obvious place to concentrate on right now. Cracking wise is a good thing. Thanks for your continued support. I'll keep working on this until it's fixed. Reed

#37 1 year ago

Minor adjustments on right spinner relay, still not working correctly. Seems to me like something is creating a connection that does the same thing as closing either of the spinner switches. Short? How to troubleshoot this? Unless I'm missing something....

#38 1 year ago
Quoted from basset1:

How to troubleshoot this?

At least three posts have recommended jumpers.

#39 1 year ago

ok, jumpers. I'm learning as I go here so please bear with me. If the machine is work correctly, where could I put jumpers if everything is working? What will it tell me? When the event occurs, as soon as I lift the playfield, the spinners move and the machine goes back to normal. Now, I secured the spinners so they won't move - spinner switches will always be open. I'll start playing games (without anything hitting the spinners) and hopefully when this happens again, I'll be able to do some trouble shooting. However, I think I have a limited amount of time because the ball index relay starts getting hot - it's humming loudly- and I don't want to burn it up. Appreciate help on exactly what circuit to trouble shoot. Reed

#40 1 year ago

If the delay relay is energized, the ball won't eject, because a switch on the delay relay will open, So put a jumper on this switch, this will keep the switch closed at all times. See if your ejects work while jumpered then you know that it is caused be the delay relay.

The only thing that will energize the delay relay are switches on the Spinner relays and the only thing that will energized the spinner relay are your spinner switches.

#41 1 year ago

Jumpered across the delay relay switch. Eject holes all work. Spun the spinner with the jumper on, delay relay energizes on and off as spinner spins.

#42 1 year ago

OK So now you know that the delay relay switch opening is what is causing your ball to not eject.

The orange/black to Orange switches on your left and right spinner relays close to energized that Delay relay.
Put paper between these orange/black to orange switches on both relays and see if the delay relay still fires. It shouldn't.

Then remove one paper at a time and try again.

#43 1 year ago

With jumper still on delay relay, put paper between both left & right switches. Spun the spinner, delay relay did not energize, all eject holes worked. Took out paper one at time, spun that spinner, delay relay energized. Same for other spinner.
What is interesting to me that hasn't happened before, with the jumper on the delay relay switch, if I move the spinner slowly past 90 degrees, which duplicates the humming and the eject hole not working, the eject holes now work when I move the spinner. Have to leave, back in 45 mintes. Reed

#44 1 year ago

Got it. Spinner switch onlu energizes the spinner relay and the spinner relay only energizes the delay relay. Based on that, when I'm playing a game and the hum starts and the eject holes won't eject, that means the spinner switches are making contact. With the playfield down and a large gap in the spinner swithes, and gravity holding the longer blade down, I don't think they are making contact. Then what's making the spinner relay energizing and the delay relay energizing if not the spinner switch?

#45 1 year ago

You'll need to look to see which spinner relay is staying on when this condition happens. That way you only have to deal with one spinner/spinner relay.

The only thing that can pulse the spinner relays are the Left and Right Spinner switches. If you are positive that none of you spinner switches are staying closed and this "no eject" only occurs after hitting a spinner, it's possible that the spinner switch is working alright but the Spinner Relay is not letting go when the Spinner switch reopens. If that's the case it could be a sticky or partially magnetized armature plate on one of your spinner relays.

#46 1 year ago

Right spinner relay is sticking closed when event occurs. Took right spinner relay coil out, cleaned some gunk off coil where it hits armature, took spring off and cleaned all around armature, buffed armature (no real indentation on armature). Put small piece of paper clip on armature and coil, didn’t seem magnetized. Put back together, played 20 games or so, right spinner relay stuck again. Turned off machine. Turned on machine, hit red button, right spinner coil energized and now the eject holes and the spinner relays and delay all on are going on and off continually. Turned off machine. Reed

#47 1 year ago

Still working on this. Event happened (eject hole not working, hum), turned off machine. Turned on machine, hit red button, started humming immediately, right spinner relay and delay relay energized. If the spinner switch was not closed, and the spinner switch is the only thing that can trigger the right spinner relay, how could the right spinner relay be energized before ball launched at the very beginning of a game? Happening more often. Reed

#48 1 year ago

It's still most likely a closed spinner switch. Didn't the problem go away when you put paper in the spinner switch?

Even with paper in it, the switch could still be shorted together somewhere. Only way to know for sure would be to remove the spinner switch from the circuit. Desolder one the the wires on your right spinner switch and put some tape over the exposed wire, this will positively open your circuit. Then see if the problem goes away.

#49 1 year ago

If was the right spinner switch. Unsoldered and played a whole bunch of games. No problems. Resoldered this afternoon and have play 20 games or so and no problems as of yet. Hopefully it was the solder joint - there was very little solder on the switch - and I won't have any more problems. Thanks for everyone's help. Really appreciate it. Reed

#50 1 year ago

Got stuck again. Tweaked the switch. Will look into getting a new switch.

There are 51 posts in this topic. You are on page 1 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside