(Topic ID: 265421)

Williams Gold Mine display problems

By Arud85

4 years ago



Topic Stats

  • 1 post
  • 1 Pinsider participating
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    #1 4 years ago

    Hi everyone I have a William's gold mine (shuffle) with a display problem. The game has been sitting in a garage for 20 years and I am fixing it up. It's a system 11b and the game seems to work in every mode but with none of the 7 displays working. I tested my voltages and had 100v dc -100v dc 5v going to the master display board. I rebuilt the high voltage side of the power supply just in case and lowered the voltage. Now I have -92v dc 95v dc 5v dc. I thought I had a bad master display board so I swapped that out with no luck. I looked at the main board and reflowed all the solder joints on the connectors. After doing that I did it on all the other boards just incase and still no display. I inspected for possible corrosion and found a very small spot on 1 diod and 2 resistors but they tested fine. There was no signs of heat damage or burns either. After searching the forum and seeing some trouble shooting ideas I tried them with no luck. I shut off all the lights and looked for a glow but none. The last thing I did was look for voltages on the displays themself and was able to get fluctuating voltages at the displays themselves. So I basically at the point I think the displays are bad but I'm not 100 percent. My question is is there anyone that has any ideas or if someone is in the Connecticut area that I can bring my displays to a working game to see if they work and see if I have a game board issue or a display issue. I'm already looking at getting a pin score setup if i cant figure anything else out. Sorry for the long post and thanks.

    Reply

    Wanna join the discussion? Please sign in to reply to this topic.

    Hey there! Welcome to Pinside!

    Donate to Pinside

    Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


    This page was printed from https://pinside.com/pinball/forum/topic/williams-gold-mine-display-problems and we tried optimising it for printing. Some page elements may have been deliberately hidden.

    Scan the QR code on the left to jump to the URL this document was printed from.