(Topic ID: 183293)

Williams Flash will not boot now...

By Ghostcri

3 years ago

Topic Stats

  • 10 posts
  • 7 Pinsiders participating
  • Latest reply 3 years ago by bdPinball
  • Topic is favorited by 3 Pinsiders


Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

20170309_130322 (resized).jpg
20170309_130306 (resized).jpg
20170309_130313 (resized).jpg

You're currently viewing posts by Pinsider ghostcri.
Click here to go back to viewing the entire thread.

#1 3 years ago

First time poster, but I have been lurking and unfortunately have not been able to find an answer to my problem with my Flash.

Last week it was working great until suddenly it would freeze up once in awhile but a quick power on/off usually fixed that. Then a couple of days later the machine would not cycle the ball for a new game and none of the solenoids would fire. Per advice from the previous owner, I checked fuse F2 on the power supply board and it was indeed blown. I replaced it with another 2.5 amp slow-blow fuse and when I plugged it in an turned it on, the GI worked but now none of the LCDs were coming on...The solenoids were still not working and somehow it seems like the problem had gotten worse. I pulled the new fuse again and checked it and it had not been blown. I'm at a loss as to where to start since I had done nothing to the machine since pulling the blown fuse...

Any help would be greatly appreciated!

#7 3 years ago

Thanks for the suggestions guys, I appreciate it.

The previous owner replaced the 40 pin and relocated the battery pack off-board. Here are some photos of it all as well as the power supply board. I had previously located a loose pin/connector on one of the slave lcd cables that I was going to replace but that shouldn't affect it from lighting up or starting...?

20170309_130313 (resized).jpg

20170309_130306 (resized).jpg

20170309_130322 (resized).jpg

#8 3 years ago

Well a little update on my issue with Flash.

I was advised to check the voltages on my power supply board and after I found a diagram and referenced the manual for the proper voltages this is what I got:

unregulated logic supply - 12.97v - typical reading per manual is +11v

logic b+ - fluctuated every time I measured it! from -7.7 to -20 to -15.6 - typical reading per manual is +5.1v...

logic supply - 18.54 - typical reading per manual is 18v

solenoid supply - 34.7 - typical reading is 40v

display voltage - -100.7v - typical reading is -100v

display voltage again - -100.2 - typical reading is -100v

general illumination - i was unsure of where the "fuse card fuse" was so I was unable to measure this

Crazy thing is, while I was measuring the voltages, the machine "sprung back to life" and started working properly again...
It's cool that it works but what worries me is why all of a sudden when I didn't do anything?

Any ideas?

Promoted items from the Pinside Marketplace
$ 50.00
$ 14.00
Yorktown Arcade Supply
From: $ 9.00
1,500 (OBO)
Machine - For Sale
Weedsport, NY
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 5.00
Cabinet - Other
UpKick Pinball
$ 12.00
Cabinet - Other
Siegecraft Electronics
$ 11.00
From: $ 5.00
Cabinet - Other
UpKick Pinball
$ 7,599.00
$ 33.50
Playfield - Toys/Add-ons
$ 10.00
Cabinet Parts

You're currently viewing posts by Pinsider ghostcri.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside