(Topic ID: 248215)

Williams Flash 3rd 4th digits in displays not working @ first then ok


By StotzBotz

6 months ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 6 months ago by StotzBotz
  • No one calls this topic a favorite

You

Linked Games

#1 6 months ago

Hello friends. I have a strange problem that just started with my Williams Flash machine. It's been working okay since I got a refurbished mpu and driver board installed about a week ago. Suddenly I would turn the machine on in the morning after it had been off all night and the 4th digit in all of the score displays was out. After a few minutes it would ever so gently light up then be completely fine til the game was turned off and sit for a few hours. This morning I turned it on and now the 3rd and 4th digit were out. Same thing as after a few minutes they would slowly light up to full capacity. I took the main display board out and cleaned all of the contacts and checked for bad solder joints. Put in back in but the problem is still there with no change. The person that I got the board from appears to be very experienced with Williams machines and thinks that I need to send the mpu back for diagnoses. Of course right about the time this problem started I sold the machine so I'm really trying to see if there is anything that I could possibly do or try. I'm about ready to purchase another mpu and try to get my money back on this one as I don't want the new owner to be stuck with any problems. Any advice or help would be greatly appreciated as I'm trying to get this resolved as soon as possible.

#2 6 months ago

You might have a connector pin problem in the display data harness. Check the connectors along the top of the CPU board and the input connectors on the display board...make sure the wires are securely punched down into the blades of the pins.

#3 6 months ago

Thanks for the help. I removed the mpu, soldered all of the top connector pins in case there was a cold solder joint, then re seated all of the ICs that were in sockets since I wasn't sure which ones were possibly associated with the displays. The problem seems to have been resolved. i'll know for sure in the morning when I turn the machine on after a night of it not being on.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
Wanted
Machine - Wanted
Newburyport, MA
From: $ 9.00
$ 14.00
Electronics
Yorktown Arcade Supply
$ 11.00
2,500
Machine - For Sale
Montreal, QC
$ 22.00
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 12.00
Cabinet - Other
Siegecraft Electronics
$ 50.00
$ 17.00
$ 60.00
Playfield - Toys/Add-ons
Docquest Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside