(Topic ID: 259848)

William's space odyssey problem


By BubbaPin

4 months ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 3 months ago by ArgosySK
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

extra ball 2 (resized).JPG
extra ball (resized).JPG

You're currently viewing posts by Pinsider BubbaPin.
Click here to go back to viewing the entire thread.

#1 4 months ago

Picked up a space odyssey couple days ago, got it for a good price game is in relatively great shape but had some game play problems. Going through it to try and get it operational. I know alittle electrical but not alot. When I picked it up. It would play if your pressed the play button and hand turned the motor one step. Would kick a ball out. No ball in play lights but would play the one ball until it drained, then you would have to keep doing g that.initial thought was the ball count unit. Cleaned up the contacts with alcohol and a q tip. Oiled the cog gear. Tried it then and it would play ball 1 through 5 then go to game over. Press the button again, scores reset but stuck on game over unless if I manually brought the ball count unit back and manually moved the score motor a step. So then I looked at the game over relay, cleaned the contacts on that. Then that's when more proble.s started. Game wouldn't start. Unless if I manually moved the plate on the game over relay back to the active position and press the button and manually real back the ball count unit and moved the score motor a step. WHAT IS GOING ON PLEASE HELP.

#2 4 months ago

Now its stuck on whenever a ball gets drained the bonus keeps spazzing and racking up

1 week later
#4 4 months ago

After a week of research and reading the manuel for space mission and the schematics for odyssey I have managed to fix all of the problems I once had. Except for one. I cant get the machine to grant A extra ball. Still trying to power through, on day three of trouble shooting as we speak. Can get the light to come on, same player shoots again, but when ball is drained it shuts the light off and moves on to the next ball. Will make another thread that is identifiable to help solve issue.

Promoted items from the Pinside Marketplace
$ 4.00
Playfield - Decals
UpKick Pinball
Trade
Machine - For Trade
Lewisville, TX
$ 5.00
Cabinet - Other
UpKick Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 5.00
Boards
Allteksystems
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 209.99
Lighting - Led
PinballBulbs
$ 25.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
From: $ 220.00
Playfield - Toys/Add-ons
CzTV Mods
$ 40.00
Playfield - Decals
Metal-Mods
$ 49.00
$ 89.95
Cabinet - Shooter Rods
Hookedonpinball.com
$ 20.00
Various Novelties
GC Pinball
$ 29.95
Playfield - Toys/Add-ons
ULEKstore
$ 70.00
Playfield - Plastics
Cobra Amusements
$ 5,899.00
Pinball Machine
Little Shop Of Games
£ 31.00
Lighting - Led
PinballToys
From: $ 119.99
Lighting - Backbox
Rock Custom Pinball
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 30.00
Playfield - Decals
Pinball Pimp

You're currently viewing posts by Pinsider BubbaPin.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside