(Topic ID: 210376)

Wild Fyre: No score displays, (almost) everything else working

By Necromancyr

3 years ago


Topic Heartbeat

Topic Stats

  • 57 posts
  • 6 Pinsiders participating
  • Latest reply 3 years ago by frunch
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20180320_220710 (resized).jpg
20180222_215502 (resized).jpg
20180222_215450 (resized).jpg
IMG_1034 (resized).JPG

You're currently viewing posts by Pinsider necromancyr.
Click here to go back to viewing the entire thread.

#1 3 years ago

I was recently given a Wild Fyre by a friend due to a death in their family (and lack of desire to repair the machine by other family members). I've gone through the MPU-100 repair document (at TechDose) and been fairly successful in resurrecting the machine so far. The issue I'm having is the displays (LCDs?) for score and similar info don't light up at all - not even a flicker.

Details/symptoms:
- I get 6 flashes of the diagnostic LED, then it stays lit at a low level. After the 6th flash, there is a continuous 'noise' - almost an electronic hum - that is constant. However, I can run through diagnostics using the self-test button and everything I can test without the displays seem to work fine (e.g., sound test works, lights blink properly, solenoids all fire appropriately, etc.)
- No fuses appear to be blown.
- The battery is removed. I have not replaced it with a battery pack as of yet.

Any thoughts or direction people may have would be a HUGE help. There are one or two minor items that also need to be fixed (e.g., one of the kickers doesn't activate when the ball is in the hole, but activates during solenoid testing) - but if I can get the above fixed it really seems to just have 'minor' issues.

#3 3 years ago

It appears, at least at first check, that my power supply may be wonky. I'm getting nothing on the 230V test point - which I realized I never checked earlier (jumped the gun, thinking things would work). All fuses test as intact (i.e., have continuity) so...now I'm thinking by rectifier board may have some issues on the 230V portion of it.

Given that a replacement is only $65 or so, I'm wondering if it's worth just replacing or an easy fix - what I'm not certain of is how to diagnosis and confirm this is the origin of all issues (e.g., the 230V and 190V TP's being flat on the Solenoid board as well).

#5 3 years ago

Given I'm testing everything right (i.e., completely unplugged the solenoid board, left everything else plugged in - no LED flashes, but all the bulb-based lights lit up) - 13.5VDC on the second test point on the rectifier board vs. 0.8VDC with everything plugged in.

...also, no sound - which makes sense since all power goes through the solenoid board before the rest of the cabinet, correct?

#7 3 years ago

Getting the followiing:
TP1: 5.6vdc
TP2: 0.8vdc
TP3: 13.4vdc
TP4: 7.0vac
TP5: 44.6vdc

And I think I am getting the seventh flash - if I'm reading the flashes right. Basically, per the repair doc, I was thinking the first flash was the mentioned flicker. I'm not even seeing that but getting a flash, pause for 2-3 seconds, then 6 additional flashes about a second apart, then the game appears to be in attract mode (hard to determine 100% w/out the score displays working). There is a 'ping' sound (like a relay firing) between flash 4 and 5 - the flashes are so fast, that's when I'd place it. Could be simultaneous with the 5th flash.

No burnt pins on the rectifier or solenoid boards it appears.

These are the rest of my test point values as of now (everything fully connected)

Solenoid Board
TP1: 5.26vdc
TP2: - no reading/ground
TP3: 5.0vdc
TP4: - no reading/ground
TP5: 12.97vdc
TP6: 5.0vdc
TP7: 5.0vdc

Lamp Driver:
TP1: 5.26
TP2: Grounding correctly
TP3: 5.26

MPU:
TP1: 5.26vdc
TP2: 13.0vdc
TP3: 22.1vdc
TP4: Grounding correctly
TP5: 5.16vdc
TP6: 11.18 vdc

SB100 Sound Board (checks out per the techdose page on the SB100)
TP1: 5.14vdc
TP2: 2.58vdc
TP3: 2.56vdc
TP4: 0.016vdc (Ground)
TP5: 2.57vdc
TP6: 5.09vdc
TP7: 12.9vdc
TP8: Can't locate the test point...
TP9: 9.44vdc

#10 3 years ago

I apologize - mistyped data off the sheet I have where I've captured everything. TP5 on the rectifier board is at 44.6vdc. Given that is working, it seems like it's the 230V section is bad - guess I'm going to be digging into the schematics to test that section. This should be a learning experience.

I was guessing the caps on the SDB would need replacing - C23 and C26 are the large ones, correct? That seems like a straightforward fix.

*EDIT* So, CR1 diode appears to be shot, given I'm testing it right. Guess that could be it. Fingers crossed I have a suitable replacement to see if it's a single point fix before buying an entire kit.

#12 3 years ago

Yup. Looks like one of the diodes is shot. Now I just need to get replacement parts. No real way to order small numbers of parts is there?

#14 3 years ago

Thanks! Was looking on there and DigiKey. Bit overwhelming! Want to make sure I order the right parts to fix/maintain things without ordering things needlessly - or having to go back and get a small order again for one or two small items.

#15 3 years ago

Well, as an update - replacing one of the diodes (the definitely broken one) did nothing. Well, that's not true. I'm getting ~12vdc on TP2 now - and the diodes all test as fine. So....somewhat annoyed. I'm going to take it out again and try replacing everything else in that pathway and hopefully it'll resolve the issue. Not being able to take out the board without taking out the transformer is a PITA though, I must say.

#18 3 years ago

Yeah, I'm not that good at soldering and the placement means I'm leaning over around the side and it's at the back of the machine.

Is there a schematic available for the AS-2518-18? There seemed to be solder overflow between the one diode and another - it looked connected as part of the backside of the board itself so I wasn't concerned, but want to make sure I'm not misunderstanding how things are connected.

Also, shocked myself once . Lesson learned that the switch doesn't totally kill power to the PSU.

#21 3 years ago

OK, found the schematic in Dracula's schematic file - it's not in the WildFyre one for some reason.

Anyway, here's what I got so far:
- E5 is 180vac & E6 is 13vac
- R3 is 13vdc, both sides

Then I tested vDC on each side of the diodes and got (all vdc):
- CR1: 13/0.13
- CR2: 13/13
- CR3: 12.1/0
- CR4: 0/0

I'll have to pull a few things apart to get at the lugs and figure out what's what - it's behind a shield in the WildFyre. In looking at things, some wiring could be shot as well from age - that will be fun to replace .

#24 3 years ago

Ok, so...had a longer post but deleted it as I realized what I was testing in looking at images.

Yeah, the two AC lines/test points are at different voltages. One side of the transformer (white and green wire, goes to E5 I believe, tested it on the fuse) is 180vac. The other side (green wire, goes to E6 I believe) is at ~13vac. I'm guessing these are the right lugs, had to reverse engineer since there are no visible numbers on my transformer. (used this: http://stevekulpa.net/pinball/as-2518-18-wiring.htm).

#25 3 years ago
Quoted from oldschoolbob:

Removing the entire unit is easy - 4 screws for the board and 4 - 6 screws for the transformer.

Yeah, the issue is pulling it in and out to test. I don't have a test rig setup unfortunately, so in the machine is it at this point.

Also, due to being new I have hit my post limit. I'll check per the below post and update. :/ Thank you all for the help with this - it's a HUGE help and I'm learning a ton.

EDIT: VAC between E5/E6 is 187. (with and without fuse, tested from front of board) (Note, solenoid/voltage regulator board is disconnected per earlier posts to limit potential area of failure so that could be why it's a bit high). Also, should I be testing TP2 differently on this than the others test points (i.e., to ground)?

20180222_215450 (resized).jpg
20180222_215502 (resized).jpg

#31 3 years ago

So, I can post again (may not be able to after this for another period of time - I'm triggering the newbie post restrictions).

VAC between E5/E6 is 187. (with and without fuse, tested from front of board) Note, solenoid/voltage regulator board is disconnected per earlier posts to limit potential area of failure so that could be why it's a bit higher than standard. Based on this, seems the 180vac is correct and getting from the transformer to the board. Also, other boards aren't screwing things up since they aren't connected.

Next step is replacing all the diodes and the resistor I guess...since it has to be that circuit that's screwed up if I'm understanding things correctly?

Added pictures of a few things (above) as well. Can provide more if it would be helpful.

RE: testing outside the machine, I don't have a way to safely connect AC power to the pins w/out risking the board (or myself) using a jury-rigged alligator clip setup. So, at this moment, I'm stuck with this approach until I get a connector I can wire up as a safe way to connect power to it on the bench.

Also, should I be testing TP2 differently on this than the others test points (i.e., to ground)?

#33 3 years ago

Thanks for the help/insight on the TPs.

Just checked the diodes and the non-banded (upper side, in my case) only has 2.2vac so, seems SOMETHINGS screwed there (short of a short).

I've done tests to check for shorts across that circuit though and from what I've tested so far there doesn't APPEAR to be anything shorting out...but when I pull out the board I'll some more testing there.

Thank you all again for the help. Once I get some time over the weekend to do the reworking, I'll post again! Fingers crossed!

#36 3 years ago

I'm actually leaning towards that. I've seen replacements for $60ish (or $80 prewired), which would 100% eliminate the component as an issue. One thing I've been having trouble finding is a replacement for the actual transformer - or how much the transformer would even run. Would be nice to just completely replace that section and go from there.

(Also - I'm not verified and was locked out of this thread earlier because it's 'hot'. So, lack of response by me may be due to that. (Anyone want to verify me?))

3 weeks later
#39 3 years ago

So...rectifier board replaced! Test points are coming back with good voltage (bit high if anything, but close to what's appropriate)

Unfortunately same problems are still occurring. I need to do a bit more testing, but there's alot of flicker on the displays and they don't seem to be fully displaying correctly. I've rechecked all my test points and they look as follows. From what I can see, all looks fine (maybe a bit high on certain ones) except for the Solenoid Driver TP3, which seems to be grounding or close to it. Not sure why that's occurring unless the two large capacitors on it are dead and need replacing... The solenoids do not seem to be firing, however. The did before I replaced the rectifier...which has me worried.

I do NOT have a battery hooked up in my machine yet - that's my next thing to do. Didn't think I'd need it and not certain if that's causing any issues.

Any ideas would be welcome.

Rectifier
TP1 6.12
TP2 251.6
TP3 15.65
TP4 (AC) 7.14
TP5 45.8

Lamp Driver
TP1 5.35
TP2 0
TP3 5.35

MPU
TP1 5.01
TP2 15.56
TP3 22.6
TP4 0
TP5 5
TP6 13.8

SB100
TP1 5.05
TP2 2.6
TP3 2.6
TP4 0
TP5 2.61
TP6 5.12
TP7 15.56
TP8 N/A
TP9 9.77

Solenoid
TP1 5.32
TP2 190.7
TP3 0.4
TP4 250.8
TP5 15.5
TP6 0.13
TP7 0.24

#41 3 years ago

I don't believe so. Was considering doing it - but haven't yet. Was hoping things would work then I could do improvements/updates .

Still getting the odd constant buzzing noise as well from the speaker (that's controllable via the volume knob). Need to get another speaker to test and see if it's the speaker or something else.

#44 3 years ago

Possible a stupid question - how do you reflow the connectors? Just reheat and possible add some solder? (i.e., does reflow mean resolder?)

Re: Sound board - The game sounds actually work - it's a buzz/noise that's 'behind' all the normal sounds and is constant. So it's not a broken cone in the speaker, but could be something shorting somewhere possibly.

Re: TP1/TP2 on Driver Board - I read about the connection and tying them together. Always nervous about rewiring something like that - but I'll do that as well after rechecking the connectors.

Re: Flashes - I am getting all of the flashes I believe. One quick flash upon turning on, a pause, then the 6 flashes after - so it appears to fully boot. I'll try disconnecting the sound card and see what happens as well and report back later this evening.

#46 3 years ago

Woo-hoo! Seems it wasn't working because of my own stupidity. I didn't fully connect the one larger connector (smaller pins) on the right side of the solenoid board. Reseating it with a bit more force fixed the solenoid board problem completely! Thanks for the pointer on where to look! Still going to take the board out and do the TP1-TP3 jumpering once I have time to improve stability.

So now, three things to fix:
- Buzz noise from the sound board. (Which may be the capacitors on the sound board).
- The left two score displays seem to have errors. The upper left only shows the first digit (furthest left). The Lower left shows every digit except for the first one.
- One kicker (?) hole doesn't fire when the ball goes in it but DOES activate during the solenoid test.

Overall, I'm now thrilled. The score displays have me a bit worried that it may be expensive fixes.

One other question - what's the best way to take out the playfield on one of these? I lifted mine briefly, but it did't seem to have some way to prop it up safely. Am I correct in that it needs to be completely removed and placed onto it's side on something to be worked on?

#48 3 years ago

Thank you. Will try that with the displays. Figured it was the switch on the one kicker - and now I can try to get under the board if I can find the prop rod!

One other question - battery pack wise, did I do this correctly? The diode band is on the positive side of the 'first' battery slot, based on what I've read in a few posts/guides. My brain is having some issue parsing this though - basically which direction is blocked, how to install appropriately, etc.

20180320_220710 (resized).jpg

#50 3 years ago

Great, one more thing done!

Tested the displays and it's definitely the displays themselves. Pulled one and did a quick check of the resistors highlighted in the repair guide and they all seem good (unfortunately). So, time to test all the resistors, the transistors, and reflow the connectors.

Also found a repair/test guide from Stern that has you shorting things (http://www.papinball.com/tips/Stern_Classic_SB_15.pdf) on the transistors...but not exactly sure how to do that while it's connected without either (a) electrocuting myself or (b) accidentally frying something.

EDIT: Make that two things done!

Reseated the connector on one display and it's working fine. Reflowed the connector on the other one and it was working except for one segment not coming up on anything. Per the repair manual I tried shorting one of the transistors and...get this...it started working completely right after that. Turned the machine off and back on...working fine. I don't get HOW this fixed it but...it did.

Now just the audio and one kicker switch and it's fully functional! (Once I clean up the playfield a bit and protect it somehow).

Very exciting!

1 week later
#51 3 years ago

So another week, another update. Ordered a bunch of parts from Great Plains Electronics and they came in yesterday - so I immediately replaced the caps on the SB-100. Outcome was good - not 100%, but good. The very loud buzz noise that overpowered everything has been replaced by some white noise/staticy background noise but the game sounds are much louder, clearer and very crisp. Overall, a 90% improvement that puts it into "playable" sound from my perspective even if not perfect.

I also tried pulling up the playfield to work on it - there's definitely no prop stick unfortunately. There looks like a metal rail on the right side of the internal body that used to have something there to prop, but...nothing's there now.

I soldiered on and tested the one kicker/solenoid that isn't firing - but I'm not certain how to fix. The switch looks like one of these: http://www.marcospecialties.com/pinball-parts/SW-1A-130 and the plastic piece at the end (where the ball hits) is worn down a bit. However, the switch doesn't seem to be 'staying on' - and it seems each kicker hole scores 3 times (i.e., 3 noises) then 'activates'. If I hold the switch down manually, it seems to take a bit of time to kick on and is intermittent. I'm going to check the underside a bit better once I can get the entire playfield out, but from what I could see the switch is definitely closed when a ball is in the hole - so something else is broken/shorting in that path...which doesn't sound fun to figure out. Any ideas on trouble shooting would be appreciated.

1 week later
#53 3 years ago

zacaj - that was it! So I had some time and did a few of the things I needed to, so getting REALLY close. Some updates:

- Fixed Display! - Replaced a transistor on one display (Q13 to be specific) and it's now functioning correctly. So, all 4 displays working right!
- Found the prop - Yes, it has one. Yes I'm an idiot for not realizing what it was.
- Replaced the capacitors (the two big ones) on the solenoid board, stupidly using the wrong one for one of them (150uF vs 160uF). Put the old one back in and al works fine. (The 150uF resulted in solenoids not fiding).
- Fixed the switch for the one kicker! Seems it was REALLY dirty and once I found the prop, I could hold up the playfield, remove the switch, take a look at it and give it a light sanding on the contacts to fix. So, golden.

Just need to add the battery pack and, mechanically/electronically, the machine is fully working!

So, my next big question is - how do I protect the playfield? Wax? Something else?

#55 3 years ago

Thanks Zacaj, that helps a ton.

No idea with the capacitor - switching it back DEFINITELY fixed it...though...who knows. Maybe I screwed up a connector. It's working now so I'm not messing with it. If and when the cap dies, I have a replacement to try I guess.

And...damn on the sanding. Guessing just use the business card/money to lightly buff the contacts? Only did one so...should be ok (can always change that leaf switch if needed completely).

I'm debating doing a bit of minor refurb to the field first (touch up some black areas, nothing major) and then I'll wax it to keep further damage from occurring. And I've read about the mylar/plastic overlay but many comments seemed negative on them - it seemed overkill if I didn't do a full restore first at least.

You're currently viewing posts by Pinsider necromancyr.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside