New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 201229)

Who Dunnit from HE77: slot reel issue / DMD animation


By jadziedzic

3 years ago



Topic Stats

  • 6 posts
  • 4 Pinsiders participating
  • Latest reply 3 years ago by CadillacMusic
  • No one calls this topic a favorite

You

Linked Games

#1 3 years ago

I've been fighting a switch matrix issue with a Who Dunnit and am ready to throw in the towel; this one has me stumped.

At certain points during the game the software will dim general illumination and start all three reels spinning, and will then stop the reels one at a time from left to right; the DMD animation shows the high score initials while the reels are spinning, and as the reels stop the symbols on the reels are displayed on the DMD. OCCASIONALLY the reels don't stop, and the game software seems to be stuck in an odd state: if I manually activate any playfield switch the software "sort of" responds (e.g., it may play a different audio clip, GI comes back on briefly), but the slot reels keep spinning. The software doesn't enter ball search mode or give any indication it thinks anything is out of order.

I've found that pulling the connector from the left reel index opto "breaks" the game software out of this odd state, the DMD animation changes to display the (now stopped) reel symbols, and things go back to normal. I've replaced the index opto (no change), and have carefully examined all switches on the row/column of the left reel index opto for issues, but nothing seems amiss. The reel test diagnostic passes with no issues, and 99% of the time the interaction with the slot machine works just fine. If I disable the slot machine via the game settings the game software never gets into the odd state.

My assumption is the game software is waiting for a switch closure indication from the left reel index opto, and for some reason it is not getting one. The reel index optos are directly driven from the switch matrix just as with the Twilight Zone clock optos; the same part number are used in W?D and TZ.

I've tried both software versions for the game (problem still occurs), and have swapped out both the CPU and power driver boards with known good spares (problem still occurs). I also tried bizarre things like disconnecting all GI and controlled lamps and running the game with the room lighting off on the odd chance stray light leakage is confusing the left index opto receiver. This appears to be a switch matrix issue that is interfering with the left index opto, but I've run out of ideas.

Has anyone seen this issue with W?D, or have any thoughts on a possible solution (other than a stick of dynamite)? Oddball theories are most welcome at this point.

#2 3 years ago

Once in a while, optos will read through a "solid" plastic piece. I'd say try putting a white piece of paper on the inside of your reel. Hopefully it won't change the appearance of the reel, but will be enough to block an opto that might register incorrectly as open. My usual suggestion is black electrical tape, but I think this would make the left reel look different from the other two. White electrical tape might do it, if you can get some.

#3 3 years ago

The reels on my game would spin endlessly after I put new (officially licensed) repro stickers on the reels. My friend Dave fixed the problem by painting the edge of the reels black

Jody

#4 3 years ago

my W?D would randomly do what your describing when the slots were energized they would not stop unless you cycled power off and back on. I could not find anything wrong with the game ,i did a factory reset and that seemed to lessen the amount of times it happened . I sent the cpu and driver board to coin op cauldron and have not had this problem since they refurbished them

#5 3 years ago

Thanks for the input, especially the "spin endlessly" experience. I pulled the reel assembly and ran a strip of white electrical tape along the inside of each reel on the edge with the index opto cutout, put things back in - and the game is now working great! Apparently there was enough stray light leakage through the reel strip to keep the phototransistor in an odd state.

I compared my "officially licensed" reproduction reel strip stickers with the originals on the damaged reels, and it's pretty obvious there are many areas where the reproductions are missing black ink around the symbols on the strips (and it also appears the background silver mask is not as opaque as the original). I'll send a note to Planetary Pinball in hopes they may actually do something about the issue.

Thanks again! Glad to get this one out of my basement!

#6 3 years ago

Yeah, I discovered this with a Gilligan's Island island that wouldn't sync right. That's dark green plastic, and it had no issue going right through. Optos are weird.

Promoted items from the Pinside Marketplace
$ 26.50
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods
$ 16.00
From: $ 9.99
Eproms
Matt's Basement Arcade
Wanted

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside