(Topic ID: 221870)

Whirlwind Switch Not Working - Feel like I've tried everything...

By PinballGiant

3 years ago



Topic Stats

  • 8 posts
  • 3 Pinsiders participating
  • Latest reply 3 years ago by CollinT
  • No one calls this topic a favorite

You

Linked Games

#1 3 years ago

Have a whirlwind that has been having some ball through switch issues. When I first got it a few months ago it wouldn't start a game and said "pinball missing" despite three balls being in the game. I found an internally broken wire between the outhole and ball through #3 and replaced it. That seemed to solve most of the problems. However, the "pinball missing" issue still happens occasionally, but if I turn the machine off and come back in a couple hours or days the problem often seems to have magically vanished. Today I investigated further and found the ball through #2 and #3 switches not working (they're in the same column) in the switch edges test. After a lot of messing around, the ball through #3 has begun working. I think this was a cold solder joint. The ball through #2 is still not working. I've reflowed the solder on each lead of the switch, replaced the diode, checked for continuity between other switches in its respective column and row (tested fine) and checked the switch itself (also tested fine). What am I missing? Below is a link to the switch matrix.

https://www.pinitech.com/switch_database.php?name=Williams_Whirlwind

Thanks in advance.

#2 3 years ago
Quoted from PinballGiant:

What am I missing?

Poor connection from switch to board in the head ?

LTG : )

#3 3 years ago

LTG Would a poor connection to the board not present as an entire column or row out?

#4 3 years ago
Quoted from PinballGiant:

Would a poor connection to the board not present as an entire column or row out?

Not necessarily. I'd just start eliminating stuff.

LTG : )

#5 3 years ago
Quoted from LTG:

Not necessarily. I'd just start eliminating stuff.

So I went back and looked over everything and turns out I was focusing on the ball through issue so much that I didn't realize there were two entire rows of switches out. I've found the following after testing:

1. If I take the playfield out of the equation entirely and use alligator clips with a diode to trigger the switch rows, the CPU is working just fine
2. If I put a paper clip into the female J8 and J10 connectors, I have continuity to the playfield switches that are not working
3. If I try to bypass the connector by connecting an alligator clip between a paper clip inserted into the female J10 connector and the male pin, the rows still do not work. I can get the other rows to work just fine by doing this.

These results are confusing. Continuity to the female connector suggests that it is not a playfield wiring issue, but testing the rows directly with the connectors off and seeing that the CPU is working suggests that it is not a board issue.

The only thing I can think of is that there is a cold solder joint on the J10 connector that works in the alligator clip/diode test but that is failing under load when the connector is plugged in normally? This is consistent with the initially intermittent nature of the issue. Also of note is that when everything is hooked up like normal and I depress a non-working switch I can hear a subtle change in the electronic hum of the machine. Not sure what to make of this.

Any advice appreciated and thanks for the suggestions already.

#6 3 years ago

Is there a transistor on the CPU for that switch? Might be blown.

My pop bumper switch in Taxi wasn't working and traced it back to the transistor to see it had been blown.

#7 3 years ago

Thanks for all the suggestions. I think I've finally figured it out and it's nothing I would have expected. My previous post about key findings was correct in that it was neither a CPU or a wiring problem. I've realized that I have a reimport game from France. It has a C220 electronic coin mechanism that takes Francs. This coin unit has its own circuit board mounted inside the cabinet beneath the playfield. The wires for the left, center, and right coin switches all go to this board. These three switches are on the rows that have been giving me issues. Measuring the voltage on an open switch in one of these rows gave me 44 VDC! I'm very happy my switch matrix wasn't torched. Unplugging J10 on the interconnect board in the backbox would fix the switch problem and make the voltage on an open switch drop down to 0 VDC. Removing the J10 connector fixed the problem because it was outputting the 44V to to the electronic coin accessory. Inspecting the coin door board showed that it had been worked on extensively in the past. In fact, the schematics to the board were still in the bottom of the cabinet. There' something wrong with the board itself because removing the input connectors did not fix the problem, but removing the output connectors did. Because I have no interest in my machine taking Francs and if I want to make it take quarters I will probably need to rewire it anyway, I just capped off the 44 VDC input to the coin door board and left everything else hooked up like it was on free play. Machine is working great now.

#8 3 years ago

Glad you got it figured out!

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside