(Topic ID: 139501)

Need Help: Whirlwind Solenoid/Music Issues - SOLVED


By wxforecaster

3 years ago



Topic Stats

  • 17 posts
  • 3 Pinsiders participating
  • Latest reply 3 years ago by wxforecaster
  • Topic is favorited by 3 Pinsiders

You

Linked Games

#1 3 years ago

Ever think you purchased a great game, only to get tangled in a rats nest? Word to the wise, you control the purse strings and take as much time as you need when testing a game.

Anyways, here's my issue:
In test mode or actualy game play, I cannot get solenoids 17,19,21,22 (EDIT BLOWN F3 fuse due to Coil 17, which locks on during test/gameplay, but not at startup)...and 23 through 27 to fire. The latter group are the 25V sound overlay solenoids. Additionally, on diagnostic test #8 (the relay test), I get a Side C Error. I thought this was odd because the switched solenoids (01-08A and 01-08C) work just fine and I can hear and see the A/C relay click. Coil test 12 for the A/C relay also works.

Of additional importance, I also have no music during game play, but have all sounds/effects. Figured I'd address that later, but now think it's related.

On the auxiliary driver board, when I tested the voltages across the J11 connector in attract mode, I was getting approx. 39V DC on the active relay circuits, and about 1.5-1.7V (low) on the others.

I'm going to assume that 39V is WAYYYYY too high? Or is that normal (if so why are the circuits listed at 25V) for the rectified input AC voltage? I'd hate to think that every single downstream coil/flash lamp is fried (although I see nothing visually).

I'm just blissfully (ignorant) stumped on how to proceed here. Bad bridge rectifier? Caps? Something completely unrelated on another board?

#2 3 years ago
Quoted from wxforecaster:

I'm going to assume that 39V is WAYYYYY too high? Or is that normal (if so why are the circuits listed at 25V). Is every single solenoid downstream of this circuit fried?

I get 41VDC on my Taxi (System 11B as well) ...so I think you are o.k. there.

Quoted from wxforecaster:

Additionally, on diagnostic test #8 (the relay test), I get a Side C Error. I thought this was odd because the switched solenoids (01-08A and 01-08C) work just fine and I can hear and see the A/C relay click. Coil test 12 for the A/C relay also works.

Hmmm, might not actually be a problem...take a close look in the pg 35 in the manual at how this test operates. I have to depart now, I'll be checking back on this thread later.

#3 3 years ago

OK, I'm back, with more questions than answers.

1.) None of those solenoids worked because F3 was blown. But here's what I don't understand, F1 and F3 are tied together on the Aux driver board. I have continuity between them, and furthermore I have continuity on J11 between all pins 8 through 12, which includes the 25V special sound overlay solenoids, the 25V controlled solenoids and the 25V special solenoids. See pages 95/96 in manual for reference.
- How did the controlled solenoids (9,10,11,12,15,16) still work with F3 blown?
- Why are there two separate fuses (F1 - 5A and F3 2.5A) if they're in the same circuit.

So I replaced F3 and I think what follows is the summation of behavior I'm seeing.

2.) When I turn on the game, the blanking LED is out. The system 11 repair guides say 'on', but I don't recall ever having seen this on my prior System 11B games.

3.) The top left pop-bumper locks on, but ONLY when entering test mode. I've cut the wire for now. This is on a separate circuit and solenoid bank, but would like to know how to troubleshoot this.

4.) Now the strange part. Those who own system 11s know that when you turn on the game, one of two things inexplicably happens. You either get the single "bong" and attract mode (or) you get the single "bong", a firing of coils (like the knocker), and then into attract mode.

If the first happens, the 25V sound overlay solenoids never fire - not in game play or test mode. These are the back lightning flashers, the blower and spinning discs.

If the second happens, the 25V sound overlay solenoids 23-27 all fire and lock on during attract mode (and stay locked on during game play and in test mode).

5.) In diagnostic mode, on test 8, I get a Side C Err.

6.) I still have no music

#4 3 years ago

1)Fuses F1 and F3 are tied together at only one end, if one blows, the other still conducts current. This is a function of branches in basic electronics. Page 96 power wiring diagram shows the fuses on the right side of the aux power driver board and denotes which solenoids each protects. From your solenoids indicated, they should not be on when F3 is blown. Perhaps there is a miswiring or short to an incorrect solenoid. Just a guess at this point

2)Blanking LED should be on - solid on. If it's out - either a blanking circuit problem or dead LED itself. I'd lean toward the LED simply being out if your score displays are coming on and she boots up.

3)Questionable behavior there. Maybe an upper level logic problem?

4)If you are getting a bunch of coils firing such as the knocker, and locking on - that's not good. If a ball is not found such as due to a bad switch indication, the game may sequentially fire playfield coils to "look for the ball". But they should never lock on. Having such a large group of solenoids lock on occasionally is a good indicator of logic circuit problems on the MPU. Not really a beginner type of repair.

I would go through the power supply thoroughly to make certain it is in specs before doing anything else. Has this MPU ever had any battery leakage or evidence of corrosion? This is a tough call, I don't want you to get too alarmed, but I think you might want to send this board in to a pro for diagnosis and repair.

#5 3 years ago

Will replace the blanking LED. It's gotta be out. Displays are fine (other than a common missing segment across the bottom display elements).

#3... I agree it's gotta be a PIA somewhere. If it were the transistors, the coil would lock on when you fire the game.

#4... I've owned a Whirlwind and other Sys11s and have seen them all fire coils upon turning on the game (no ball search issues). It's a seemingly random occurrence (about 25% of the time) and well documented here when I did a search for this issue. The issue I have is that all 5 sound overlay solenoids "work", but when/how they are getting turned on is not correct. Therefore I don't think the issue is with the aux driver board (all components test good, output voltages are correct), and I don't think it's the sound overlay board either. If all the transistors were bad (which would be one helluva coincidence), they also would ALWAYS lock on when you fired up the game.

That leaves me, with like you said, an upstream MPU issue. YES the board did have battery leakage issues. However, it was neutralized by the previous owner (and re-neutralized by me just to be sure). While thought I had verified continuity across all the traces, perhaps that's not the case.

I'm also stumped as to the Side C Err on test 8, while I hear the relay click and all the A/C switching solenoids work great.

I have no problem with doing any level of board repair or diagnostics (have DMM, logic probe, etc...). Just need some schematic reading guidance. Tracing the sound overlay solenoids from the Aux Driver back through the sound overlay board to the MPU via the ribbon cable... am I correct in thinking that U42 might be the problem? The no music issue seems to jive with this as well. Oddly enough, I don't get a U42 error when I start up the game though, so maybe I DO in fact have trace issues.

Maybe it's simply time for a new MPU :/ I'd really like to get this board working though.

#6 3 years ago

The "random occurrence" of firing all coils: I don't agree that this is normal thing. IMHO, My first suspicion is that is power supply related. I have three System 11s and I have never had that happen. However, I have not researched the documented cases you are describing.

Since you have confirmed battery leakage in the past, I would be highly suspicious of lingering damage - especially what you can't see. That stuff creeps into the legs of IC's and can wreck them internally. It could look clean on the outside, but the damage is done. I'd be really suspicious of the PIAs nearest the battery holder (such as U41,U42) if I had to point a finger, or the fine traces under the pack. Just some hunches, though.

The Six PIA's and What they Control.
U10: Sound output selects, solenoid drives, CPU board flipper relay K1.
U38: Switch matrix columns and rows, special solenoids A & D.
U41: Score display data (1J22), special solenoids B & C.
U42: Sound board (1J21)
U51: Score display circuit (1J1, 1J2, 1J3).
U54: Lamp matrix columns and rows, special solenoids E & F.

Perhaps you might try replacing the PIAs first. Leon's guide might help if you want to DIY. Troubleshooting this kind of problem gets even more complicated when the board doesn't do the same thing every time it is powered up. Good luck.
http://www.system11.org/tech/system11_cpu.html

#7 3 years ago

Oddly, the visible corrosion was to the "right" of the battery back (U44/U45 and those SRCs) and that area is all functional. I don't see anything to the left, nor did I test there.

I do think there's a tie. Note I have no music (U42) and the solenoids that aren't firing ARE the sound overlay solenoids (also U42) which collectively go through the 1J21 ribbon cable.

I have verified everything is correct with the power supply, and there are two other groups of solenoids on that 25V circuit that work fine.

I'm going to start with U42 and see what happens. Doesn't hurt to socket a chip!

#8 3 years ago

Well what a collossal waste of time that was. The only POSITIVE change was that the blanking LED was in-fact toast.

As a reminder here are the issues I had before...
1.) All 5 25V sound overlay solenoids either didn't work at all or locked on when you turned on the machine. Which of these two scenarios occurs is seemingly random.
2.) The h' segment on the lower display was missing for all digits
3.) No music

I removed the replacement battery holder and created an off-board one. There was no distinct corrosion directly beneath the battery holder itself.

I removed U42 and socketed it. Using the schematic, I verified continuity from all 40 pins to their correct up/downstream locations. I popped in another 6821 chip and again verified continuity from all 40 legs.

Now I'm even worse off. All the issues above remain *AND* now I have NO display. I intentionally flipped the display to 1J22 ribbon cable and got garbled characters. Another ribbon cable out of my Funhouse gave the same results.

I have verified all voltages coming out of both power supplies as good.

Anyone have any further ideas??

#9 3 years ago

I'd recommend to send it to one of the pros here for an evaluation. Alkaline damage on System 11s is always worse than it looks. I've repaired a lot of Bally boards dead from corrosion, and usually pass on damaged Sys 11s. You could also replace the board as a last option.

#10 3 years ago

I love fixing things, but this is ridiculous.

With a logic probe, does anyone know how each pin should read on U41/U42?? It's possible the U42 6821 chip I put in was bad as it was from a donor board, although highly unlikely. A cheap source for known working chips??

Has anyone ever seen those SRC packs fail? Is there any way to test them?

I'm stumped. I would think that having continuity would indicate that corrosion issues do not exist. Getting REALLLY sick of taking this MPU in and out of the game. 8 screws, 20 connectors, calloused hands LOL.

I here ya on the passing issue, but the price I paid was REALLY fair considering the playfield is cherry beneath the mylar. There was no access to the backbox when I picked it up. Regardless, some of the tests that didn't pass I should have paid more attention to. It is what it is. I'd just hate to spent a ton of money getting it repaired, and then finding out it was something so stupid I should have been able to find it in 10 minutes.

#11 3 years ago
Quoted from wxforecaster:

With a logic probe, does anyone know how each pin should read on U41/U42??

I think you will need the test ROMs to do this:
http://pinwiki.com/wiki/index.php?title=Leon_Borre_Williams_System_11_Repair

Quoted from wxforecaster:

Has anyone ever seen those SRC packs fail? Is there any way to test them?

When testing a BUSSED resistor network, first find pin 1. This pin will have a white square around it, to isolated it from the rest of the pins. Use a DMM set to ohms, and put one lead on pin 1. Put the other lead on each pin 2 and up. The same reading should be seen for each pin 2 and up. Note "in circuit" (resistor network installed in the board) some networks may have pins that measure differently than the other pins (for example, pin 10 of SR17 which measures about half what the other pins measure). Out of circuit (resistor network not installed in the board) all pins should measure the same.

When testing an ISOLATED (discrete) resistor network, put the DMM leads on the two adjacent pins furthest to the right or left, and note the reading. Then move both DMM leads down two pins. The same value should be seen. Continue down the resistor, moving both DMM leads two pins at a time, until all adjacent pins are tested. Again note "in circuit" (resistor network installed in the board) some pins may measure differently than the actual value. Out of circuit (resistor network not installed in the board) all pins should measure the same.

Note: Testing resistors/capacitor networks "in circuit" is may not be conclusive. A bad resistor network which is soldered into the circuit board can test as "good", but in fact be bad. This does happen (but pretty rare). My advice is this: if the resistor network tests "strange" (as shown below), probably best to replace it. Note SR9, SR10 and SR11 are the most commonly failed resistor networks in system11 CPU boards (but luckily these are easy to test in-circuit). The SRC resistor/cap SIPs are a bit more tricky to measure in-circuit.
http://illinoispinball.webs.com/williamssys911part3.htm

-1
#12 3 years ago

Had a problem on a TFTC that was similar. Long story short it was a bad PSB. Replaced it with a X Pin board. Also needed to replace a fuse, tip36c and a resistor on the powers driver board. All is well now. Sometimes a low 5v can cause some of these weird symptoms. Good luck with the fix.

#13 3 years ago

Earlier in the post he stated "verified all voltages coming out of the power supply as good"

What exactly did you measure? Should be around +5VDC +/- .3 VDC @< .5 VAC AC ripple?

#14 3 years ago

Well I got the display back. 1J21 pin 2 and 1J22 pin 2 should be linked (blanking circuit). They weren't.
So now I have my display back, missing the h' element on the bottom display (all segments).

Essentially I'm back to where I started.

+5V is 4.99V on the MPU test pin. AC ripple is 0.002V. It doesn't get any better than that.

#15 3 years ago

Alright, big news on the diagnostics front. I took all my boards up to the Pennsylvania Coin-Op Hall of Fame this afternoon and one-by one swapped them in.

1.) Display. The h' (diagonal from top left to middle) missing segment across the lower display carried over to the other machine, isolating THAT issue to the display itself. When I supplied 5V at pin 3 (h'), I got continuity at U7 pin 6 to pin 7. Good. That carries to U20, and since I have continuity from the output of U20 for h' to the display (across R64 which tests good), I have to assume that the UDN7180 at U20 is bad for that pin. [EDIT: I didn't realize you could diode test these high powered chips. I'll do that to confirm it's U20, but nothing else makes sense]. Now to find a source for those chips. Any ideas where I can get a 7180 that's not expensive or a chinese gamble?

2.) Swapped the audio board. All music worked perfectly in the other machine (as did everything else).

3.) Swapped the sound solenoid overlay board. All music and solenoids worked perfectly in the other machine (as did everything else).

4.) Swapped aux driver board. Everything continued to work perfectly in the other machine.

5.) Swapped in MPU. Once again, no music, no 25V sound overlay solenoids, and F3 blows on the aux driver board. Interestingly enough, solenoid 17 (top left bumper) locked on in test mode/game play on my machine and also blew F3. I clipped that wire to diagnose it later, but it's now clear that's also an MPU issue. Swapped back in other MPU (and replaced F3), working 100%.

So, at least I've isolated all my problems to the MPU board. No voltage/cable issues. I have a test ROM enroute. I'm also going to swap out SRC 3 & possibly 1 just since those were in the corrosion area and I'm not sure that continuity across them is conclusive of them working.

#16 3 years ago

So, last night I went through the painstaking trouble of logic probing all the PIAs to assess a baseline state and see if anything stuck out.

Given the behavior of the music/speech and the 25V sound solenoid overlays all going through MPU 1J21, I decided to replace a couple related SRC packs.

I was also getting HI on the blanking circuit at U43 at startup, and although probably not related, I replaced Q50 and U43 and now I get a perfect LO for 2 seconds then HI.
Leon's TEST rom passed pins 2-17 on all the chips, so the problem has to be downstream.

Back to the drawing board.

1 week later
#17 3 years ago

A much needed update. After weeks of probing in the wrong place, I got this solved. Sadly, as you will see below, if I had sent out my boards for repair, they would have (or should have) all been returned back as good. The few repairs I did were harmless, and possibly unnecessary other than to ensure the corrosion wasn't at play.

Totally pissed. However, in this "fun" process I became an expert at schematics, logic chips, circuitry, flow, and could probably fix any System 11B board - seriously.

So to recap, this Whirlwind board had two primary issues that I thought were related,
1.) Sound Overlay Solenoids all locked on at startup or never worked at all
2.) The music/speech didn't work, but the second test for the sounds all worked.

This board had prior battery corrosion, but it was neutralized, the traces looked OK, and all pinned out OK with continuity.
I replaced U42 (unnecessarily) -- although was on the right track.
I replaced the blanking circuit -- probably not related, but necessary.
I replaced SRC 1 and 3 (possibly necessary in the corroded area to clean up the board).
I took all the boards up to the arcade except the MPU. Everything swapped into another Whirlwind worked perfectly, meaning the MPU was at fault.
I purchased Leon's TEST ROM and everything checked out perfectly at the PIAs down to the output pins. Sigh.

Last night I was using the sound solenoid overlay board to try knocking out the bizzarre solenoid lock on or failure to work issue. I knew the problem was with the MPU, but I figured I'd work backwards. The U1 74LS374 chip was ending up in a seemingly "locked" with different results from when the solenoids were locked on vs. not working at all. The clock signal was HI, but after reading the data sheet on this flip-flop chip, it kept talking about the clock going low to high in transition, which got me thinking this morning that maybe it's supposed to be pulsing.

MD0-4 coming off pins 3-7 on 1J21 on the MPU are the solenoids, while MD5,6 and 7 (pins 8,9,10 on 1J21) drive connect via ribbon cable to 5J2 on the sound solenoid overlay board. MD5/6/7 all control both the clock on U1 and are also somehow used at U20 to work with the sound board.

Oddly enough, when I probed all the pins on 5J2 last night, I made an annotation next to pin10 (MD7) because the probe read HI, but it was "fuzzy" sounding as if there was a subtle pulse in there. AHA!!! I checked it again just now and sure enough, it's bizzare.

OK, back to the MPU. MD7 comes from U42, pin 17, which is PULSING CLEANLY!! I then check SRC pack 1, pin 9 next in line (which I had replaced last week). CLEAN. I check 1J21 pin 10. CLEAN. I check the other end of the ribbon cable at pin 10. HI and scratchy. ARE YOU F--KING KIDDING ME?!!

The problem: A bad ribbon cable. I jumped 1J21 pin 10 to 5J2 pin 10 and now all the music speech works perfectly and the solenoids behave perfectly!!

Lesson Learned: Logic probe signals should be clean - LO, HI, PULSE. I'm not sure how I could have saved any time here. None of my other games used a 20-pin ribbon cable to borrow from. In this case the test ROM passed, no errors with the game ROM, which despite my thinking the issue was at the PIA , pointed to something else. One would have easily suspected the corroded area, and despite confirmations of a strong continuity signal across the MPU traces, I replaced parts that looked suspect (probably good to get rid of the corrosion anyways). After that I used the game manual to understand the flow to the solenoids, and noticed that 74LS374 appeared "locked" in the turn on state, which is not how a flip-flop chip should behave. I noticed that the MD7 signal seemed off, and the key to all of this was the logic probe. After noticing the LS374 clock and the music were joined at that MD7 signal, it was then finding out how I was going from strong pulse to "scratchy hi".

Promoted items from the Pinside Marketplace
$ 50.00
$ 399.95
$ 369.00
Cabinet - Decals
Mircoplayfields
$ 839.00
Flipper Parts
Mircoplayfields
11,990 (Firm)
Machine - For Sale
Hauppauge, NY
3,900
Machine - For Sale
Gardner, MA
$ 30.00
Playfield - Decals
Metal-Mods
From: $ 16.95

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside