New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 248218)

Welcome To The Jurassic Park Prem/LE Club!!


By EightBallTexas

1 year ago



Topic Stats

  • 6,095 posts
  • 525 Pinsiders participating
  • Latest reply 1 hour ago by Manny65
  • Topic is favorited by 249 Pinsiders

You

Linked Games

Topic poll

“What is the first MOD you will buy??”

  • Toppers 59 votes
    46%
  • New Jeep 51 votes
    40%
  • Plastic Characters 18 votes
    14%

(128 votes)

This poll has been closed.

Topic Gallery

There have been 1,436 images uploaded to this topic. (View topic image gallery).

20200725_121524 (resized).jpg
screenshot.3529 (resized).jpg
IMG_20201022_195700244 (resized).jpg
IMG_20201022_195706719 (resized).jpg
IMG_20201022_195624934 (resized).jpg
IMG_20201022_184424842 (resized).jpg
IMG_20201022_173919862 (resized).jpg
IMG_20201022_195644825 (resized).jpg
IMG_20201022_195654842 (resized).jpg
IMG_20201022_173928352 (resized).jpg
IMG_20201022_173934074 (resized).jpg
IMG_20201022_193602961 (resized).jpg
pasted_image (resized).png
20201007_225941 (resized).jpg
20201007_225954 (resized).jpg
20201007_232300 (resized).jpg

Topic index (key posts)

12 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 6095 posts in this topic. You are on page 95 of 122.
#4701 7 months ago
Quoted from MrMikeman:

wrong thread maybe? There’s no house in Jurassic Park!

Your right! Uhg, sorry wrong thread...wanted to ask the same question with Elvira.

#4702 7 months ago

Just got Chaos MB, 2x playfield, and T-Rex Chase going at the same time.

This machine (premium) deserves consideration for the #1 spot. It’s #1 in my book.

66F9A92A-7F01-4C80-BEEE-A7CEE300AE3D (resized).jpeg
#4703 7 months ago

Rampage is the TRex mode which really gives value

20200222_124038 (resized).jpg
#4704 7 months ago
Quoted from WJxxxx:

Rampage is the TRex mode which really gives value[quoted image]

Damn

#4705 7 months ago

Can you not adjust the coil strength on the flippers? I can't find it?

#4706 7 months ago
Quoted from WJxxxx:

Rampage is the TRex mode which really gives value[quoted image]

Geesuz!!!

#4707 7 months ago
Quoted from LoganJK:

Can you not adjust the coil strength on the flippers? I can't find it?

You can, it is there (sorry at work atm)

Edit: Ok believe the flipper coil strength adjustment settings are numbers 208-210

#4708 7 months ago
Quoted from LoganJK:

Can you not adjust the coil strength on the flippers? I can't find it?

In menu select Adj, then Game, and then the flipper strength adjustments are somewhere around adjustment #290-300. Go backwards from #1 to find it fastest.

#4709 7 months ago

Is there a documented list somewhere of the menu items, to make finding the specific setting quicker?

#4710 7 months ago
Quoted from Manny65:

Is there a documented list somewhere of the menu items, to make finding the specific setting quicker?

Page 6 of the manual will show standard adjustments. I don't think there's a list of all the feature adjustments though...

#4711 7 months ago

Just picked up a premium with a build day of 2/20/20. Playfield has a lot less clear and plays fast! The playfield looks really nice. The adjustment menu is quite large for this game. You have a lot of options to choose from. The game came with the latest 1.00 code. This is my favorite game by far right now. I had been playing a pro near me for the last few months. The premium is the way to go. The Dino is so cool! Highly recommend you get a newer premium!

#4712 7 months ago

Is there any setting to change the T-Rex multiball start so it HAS to be in the mouth? I suppose I could go look, but I'm not sure there is one?

Rob

#4713 7 months ago
Quoted from Manny65:

Is there a documented list somewhere of the menu items, to make finding the specific setting quicker?

That would be really handy.

#4714 7 months ago
Quoted from Manny65:

2. The post that sits at the tip to the upper right flipper also changed from the original Pro run, where by the replacement post (post fix kit 502-7110-00) is slightly longer to support a nylon nut (and has a washer possibly for the topside of the playfield). [quoted image]

This is the only one of the changes I am not sure if I could spot. Anyone have a pic of the original vs the fix? Or at the least...a pic after the replacment post and accessories?

#4715 7 months ago
Quoted from DugFreez:

This is the only one of the changes I am not sure if I could spot. Anyone have a pic of the original vs the fix? Or at the least...a pic after the replacment post and accessories?

There’s a ‘nylock’ nut on the underside of the post (playfield) on the newest version of the post. The old post does not go through the playfield.

#4716 7 months ago

As Rob_G asked above, I’m also curious if there is a menu settings adjustment to change the T-Rex multiball start so it has to be in the T-Rex mouth?

Does anyone know if this setting is an option and if so, where it’s located?

Haven’t seen it myself in the menu settings but I may have missed it.
Thanks!

#4717 7 months ago

Just an update.
I received the new metal left ramp protector with the hole for the opto from Stern today. Very easy install. Played about 6 games and the left ramp shot registered as it should each time (before the registration from left ramp shots were hit or miss). Direct shots to the T-Rex caught each time as well in those 6 games (but note I have been pretty lucky to have direct shots to the T-Rex mouth registering pretty well after calibration performed soon after I got the game a couple months back). I'm just happy about the left ramp shots registering consistently now.

10
#4718 7 months ago

Just joined the club - stoked to play this great game!

B4AA17CF-259C-4443-9310-254D00F43C1E (resized).jpeg
#4719 7 months ago

What are you guys getting quoted for street price On a premium? I just got $7400, seems high but I did not press as the stock is about a month out. Have not bought a stern since Maiden, prices have changed since then.

#4720 7 months ago
Quoted from 2000_Alum:

What are you guys getting quoted for street price On a premium? I just got $7400, seems high but I did not press as the stock is about a month out. Have not bought a stern since Maiden, prices have changed since then.

That’s a good price. Take it.

#4721 7 months ago
Quoted from Alattig:

That’s a good price. Take it.

+1

#4722 7 months ago

So after about 1000 plays our left flipper is very weak. The coil and sleeve both look normal and clean. Is step 1 replace the coil and see if that fixes it?

#4723 7 months ago
Quoted from LoganJK:

So after about 1000 plays our left flipper is very weak. The coil and sleeve both look normal and clean. Is step 1 replace the coil and see if that fixes it?

First step is replacing the coil stop. Common fail point.

#4724 7 months ago
Quoted from LoganJK:

So after about 1000 plays our left flipper is very weak. The coil and sleeve both look normal and clean. Is step 1 replace the coil and see if that fixes it?

I’d check the coil stop first. There have been a lot of issues with them. Here’s a post showing a picture of the problem. If it looks like the rivet is there still take it off to check it though because it the rivet could be there and look secure when it’s actually not attached anymore.

https://pinside.com/pinball/forum/topic/jurassic-park-stern-2019-owners-club-welcome-to-jurassic-park/page/48#post-5275530

#4725 7 months ago
Quoted from EaglePin:

I’d check the coil stop first. There have been a lot of issues with them. Here’s a post showing a picture of the problem. If it looks like the rivet is there still take it off to check it though because it the rivet could be there and look secure when it’s actually not attached anymore.
https://pinside.com/pinball/forum/topic/jurassic-park-stern-2019-owners-club-welcome-to-jurassic-park/page/48#post-5275530

Agreed, check the coil stop. With the play field raised operate/move the flipper by hand while watching the rivet on the coil stop. If the rivet moves, it’s kaputt and needs to be replaced. If the rivet is not there, it’s *definitely* kaputt!

#4726 7 months ago

You guys are great, thanks!

#4727 7 months ago
Quoted from cooked71:

That would be really handy.

While the manual has the standard adjustments listed in section 1.2, the feature (game) adjustments aren't listed. I shot off an email to Stern and have heard back that they are currently working on getting the feature adjustment’s added in the near future.

#4728 7 months ago

I am having an issue where when I shoot the ball into TREX he wont drop the ball ~50% of the time. After testing various software versions from 0.96 through 1.0. I've determined that the issue is only when the TREX drops it by throwing. It always works when TREX gently places it on the rails. Only way to continue playing is to wait for a ball search, he'll then move right and drop it. Has anyone had this issue and know how to fix?

Thanks

Added 8 months ago:

Here is a video of it in action


Stern is currently looking into this. If they have a solution I'll post it here.

#4729 7 months ago
Quoted from blardo:

I am having an issue where when I shoot the ball into TREX he wont drop the ball ~50% of the time. After testing various software versions from 0.96 through 1.0. I've determined that the issue is only when the TREX drops it by throwing. It always works when TREX gently places it on the rails. Only way to continue playing is to wait for a ball search, he'll then move right and drop it. Has anyone had this issue and know how to fix?
Thanks

Added today: Here is a video of it in action
Stern is currently looking into this. If they have a solution I'll post it here.

So, with this video, I think the explanation is the following :
1. due to a mechanical Problem, probably an adjustment, the ball remains in the Trex mouth.(Augmenter la pente serait une solution)
2. As there is no detector in the Trex mouth, the software doesn't know the the ball is still in the mouth.
3. Due to this the ball remains in it.
4. Until there is no ball in play;

#4730 7 months ago
Quoted from Jeanclaudev:

So, with this video, I think the explanation is the following :
1. due to a mechanical Problem, probably an adjustment, the ball remains in the Trex mouth.(Augmenter la pente serait une solution)
2. As there is no detector in the Trex mouth, the software doesn't know the the ball is still in the mouth.
3. Due to this the ball remains in it.
4. Until there is no ball in play;

I tested the switch in the TREX mouth and it works fine. The TREX will drop the ball every time when its set to just drop the ball on the wire ramp. Its only when it is in this 'rampage' mode that it doesnt drop the ball.

#4731 7 months ago

I’ve adjusted the left position bias on my trex but she still gets extremely close to the left side wall and moved the fence post when rampaging. Does anyone have any other suggestions?

#4732 7 months ago
Quoted from Jodannar:

I’ve adjusted the left position bias on my trex but she still gets extremely close to the left side wall and moved the fence post when rampaging. Does anyone have any other suggestions?

I have this issue also. I don’t know the fix though. Mainly concerned about it leaving a permanent mark on the side of the trex as the fence has plenty of give it seems.

11
#4733 7 months ago

I'm very proud to join this club. Arrived today and I'm having a hard to believing it. It was born on Feb, 24 2020 and it's stunning.

Jurassic Park (resized).jpg
10
#4734 7 months ago
Quoted from snappahead:

I'm very proud to join this club. Arrived today and I'm having a hard to believing it. It was born on Feb, 24 2020 and it's stunning.

Congrats! Just got mine last night as well with a 02/20 D.O.B.

I was pleasantly surprised to see everything is 100% working as intended. There were some ball trails on the inlanes and the TREX had been adjusted outside of factory settings, so that demonstrates to me Stern thoroughly play-tested this.

GREAT. F'ing. GAME!

17DCFD73-F650-4FB3-AF0C-E4A22A542049 (resized).jpeg
#4735 7 months ago
Quoted from GorillaBiscuits:

Congrats! Just got mine last night as well with a 02/20 D.O.B.
I was pleasantly surprised to see everything is 100% working as intended. There were some ball trails on the inlanes and the TREX had been adjusted outside of factory settings, so that demonstrates to me Stern thoroughly play-tested this.
GREAT. F'ing. GAME![quoted image]

Whoa, nice lineup you have there. Yeah, mine came ready to go out of the box and I'll count my blessings on that front. And agreed. It's an incredible game. When you get the combos going, it's the most satisfying shooter I've ever played and that T Rex has to be one of if not the coolest toy in pinball. Congrats to you too!

#4736 7 months ago
Quoted from GorillaBiscuits:

Congrats! Just got mine last night as well with a 02/20 D.O.B.
I was pleasantly surprised to see everything is 100% working as intended. There were some ball trails on the inlanes and the TREX had been adjusted outside of factory settings, so that demonstrates to me Stern thoroughly play-tested this.
GREAT. F'ing. GAME![quoted image]

Congrats!! Some sweet pins there, blaspheme cutting out your Quicksilver though!!

#4737 7 months ago
Quoted from Flynnyfalcon:

Congrats!! Some sweet pins there, blaspheme cutting out your Quicksilver though!!

I spotted the Quicksilver too and I wondered how your resto was going ... clearly ya spending too much time playing JP

12
#4738 7 months ago

Just got mine yesterday as well! Had Robert Stone powder coat it Illusion Orange Cherry.
I got the armor swapped, sub installed, pingraffix installed and shaker installed
Game is amazing to play ... better than I expected and my expectations were high.
Born on Feb 25 to a spelling challenged Stern Pinball (check out the "febraury")

IMG_7425 (resized).jpgIMG_7441 (resized).jpgIMG_7428 (resized).jpgIMG_7433 (resized).jpgIMG_7435 (resized).jpgIMG_7436 (resized).jpgIMG_7437 (resized).jpgIMG_7438 (resized).jpgIMG_7442 (resized).jpg

IMG_7405 (resized).jpg
#4739 7 months ago
Quoted from MT45:

Just got mine yesterday as well! Had Robert Stone powder coat it Illusion Orange Cherry.
I got the armor swapped, sub installed, pingraffix installed and shaker installed
Game is amazing to play ... better than I expected and my expectations were high.
Born on Feb 25 to a spelling challenged Stern Pinball (check out the "febraury")
[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

Very nice...love the orange.

#4740 7 months ago

Anyone ever had a small glitch on launching your first ball and getting an instant map credit, followed by what seems to be an auto launch or a coil in the right side triggering... Hardly ever happens but every once in a while... Running latest code, never happened until version 1.0...

#4741 7 months ago
Quoted from fooflighter:

Anyone ever had a small glitch on launching your first ball and getting an instant map credit, followed by what seems to be an auto launch or a coil in the right side triggering... Hardly ever happens but every once in a while... Running latest code, never happened until version 1.0...

I'd be interested to know if our issues are similar.
When launching (auto or manual) once in a while the game will launch another ball.
Seems only to happen if the ball passes the helicopter blades
If I short plunge and skip the upper wireform (blades) it does not do it
Its also not consistent but I know it's not normal because it happens on the first ball. It's not like I've earned the second ball.

Anyone have any knowledge of the helicopter driving this behavior??

#4742 7 months ago
Quoted from MT45:

I'd be interested to know if our issues are similar.
When launching (auto or manual) once in a while the game will launch another ball.
Seems only to happen if the ball passes the helicopter blades
If I short plunge and skip the upper wireform (blades) it does not do it
Its also not consistent but I know it's not normal because it happens on the first ball. It's not like I've earned the second ball.
Anyone have any knowledge of the helicopter driving this behavior??

OK ... further investigation this morning shows that "Ball Save" pops up on the screen every time this happens
Also, its not tied to helicopter like I originally thought, and it's not tied to just during a ball launch (but does happen a ton at ball launch). This sometimes also happens in the middle of the game at random times
Whenever it does, "Ball Save" appears on the LCD and another ball is launched thus leaving 2 balls in play

Trough optos? Switch?
Anyone have another Stern game of this period that this happened to?

Maddening and makes the game unplayable (at least for me)
Thx for any advice!

#4743 7 months ago
Quoted from MT45:

Trough optos? Switch?
Anyone have another Stern game of this period that this happened to?

Maddening and makes the game unplayable (at least for me)
Thx for any advice!

Sounds like a trough issue to me. If ball save flashes on maybe the game thinks the first ball it launched went out of play. Same if the game goes dead in the middle of playing a ball.

First thing I'd do is reseat the connectors to the trough boards (sometimes they work themselves loose). If that doesn't fix it then start going through the switch tests and see if you have an intermittent opto somewhere.

#4744 7 months ago
Quoted from paul_8788:

Sounds like a trough issue to me. If ball save flashes on maybe the game thinks the first ball it launched went out of play. Same if the game goes dead in the middle of playing a ball.
First thing I'd do is reseat the connectors to the trough boards (sometimes they work themselves loose). If that doesn't fix it then start going through the switch tests and see if you have an intermittent opto somewhere.

You got me thinking about the switches - thx ... which are also the easiest to test.
I tested both outlanes and wouldn't you know it - Nedry is at it again!
The right (Nedry) outlane switch was set too tight at factory. Sometimes it was staying closed at launch which would automatically serve another ball
Pulled it, adjusted it so the switch mech could fully open in its uncompressed position and all is good now!
IMG_7479 (resized).jpgIMG_7480 (resized).jpg
IMG_7468 (resized).jpg

#4745 7 months ago

Just updated to 1.0 code. No new adverse issues I've noticed with regular gameplay.
That said...I installed the new metal left ramp protector with the updated opto hole this past week....after about 20 games now I'll say there is still quite a large number of left ramp shots that still don't register!! Ugh...guess I'm gonna have to take off those black spacers in front of the left ramp (hadn't done that yet in hopes of better routine performance with the new metal ramp guide, oh well).

On another note, with the new code I briefly went into settings to try that Neblar challenge, and man o man, what a rush!!
At the current time, is there a setting to choose regular gameplay vs. Neblar challenge upon start up, of do you have to go to settings to choose one or the other only??

#4746 7 months ago
Quoted from ChipScott:

Just updated to 1.0 code. No new adverse issues I've noticed with regular gameplay.
That said...I installed the new metal left ramp protector with the updated opto hole this past week....after about 20 games now I'll say there is still quite a large number of left ramp shots that still don't register!! Ugh...guess I'm gonna have to take off those black spacers in front of the left ramp (hadn't done that yet in hopes of better routine performance with the new metal ramp guide, oh well).
On another note, with the new code I briefly went into settings to try that Neblar challenge, and man o man, what a rush!!
At the current time, is there a setting to choose regular gameplay vs. Neblar challenge upon start up, of do you have to go to settings to choose one or the other only??

Escape Nublar Challenge
- To select what mode you want to play at the start of a game, activate hold both flipper buttons during attract mode (with credits on machine or free play enabled) and select "CHALLENGE" with the flipper buttons and press start (up to 4 players).
- If you always want to run the challenge, set Standard Adjustment #45 'GAME MODE ON START' in the SPI adjustments. Defaults to STANDARD, set to CHALLENGE to always start Escape Nublar Challenge.

#4747 7 months ago

I don't know if I have it set up wrong or what, but I'm getting a ton of sdtm drains from the control room return. It happens about 50% of the time. I'll either just barely catch it on the tip of the flipper or it drains. Seems like a crazy high percentage of this happening.

#4748 7 months ago
Quoted from snappahead:

I don't know if I have it set up wrong or what, but I'm getting a ton of sdtm drains from the control room return. It happens about 50% of the time. I'll either just barely catch it on the tip of the flipper or it drains. Seems like a crazy high percentage of this happening.

Make sure your game is level, and consider increasing the pitch.

#4749 7 months ago

New post on my blog - "Find Nedry!" - My journey to buying a Stern Jurassic Park

https://thepinballloft.com/

IMG_7437 (resized).jpg
#4750 7 months ago
Quoted from accidental:

Make sure your game is level, and consider increasing the pitch.

It's level, but what pitch should I have it at. I just have it at the Stern recommended setting.

Promoted items from the Pinside Marketplace
$ 48.00
Cabinet - Other
ModFather Pinball Mods
8,950 (Firm)
Machine - For Sale
Cumming, GA
$ 65.00
Lighting - Backbox
Arcade Upkeep
From: $ 35.99
There are 6095 posts in this topic. You are on page 95 of 122.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside