New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 248218)

Welcome To The Jurassic Park Prem/LE Club!!


By EightBallTexas

1 year ago



Topic Stats

  • 6,123 posts
  • 525 Pinsiders participating
  • Latest reply 7 hours ago by Green-Machine
  • Topic is favorited by 248 Pinsiders

You

Linked Games

Topic poll

“What is the first MOD you will buy??”

  • Toppers 59 votes
    46%
  • New Jeep 51 votes
    40%
  • Plastic Characters 18 votes
    14%

(128 votes)

This poll has been closed.

Topic Gallery

There have been 1,439 images uploaded to this topic. (View topic image gallery).

image (resized).jpg
image (resized).jpg
image (resized).jpg
20200725_121524 (resized).jpg
screenshot.3529 (resized).jpg
IMG_20201022_195700244 (resized).jpg
IMG_20201022_195706719 (resized).jpg
IMG_20201022_195624934 (resized).jpg
IMG_20201022_184424842 (resized).jpg
IMG_20201022_173919862 (resized).jpg
IMG_20201022_195644825 (resized).jpg
IMG_20201022_195654842 (resized).jpg
IMG_20201022_173928352 (resized).jpg
IMG_20201022_173934074 (resized).jpg
IMG_20201022_193602961 (resized).jpg
pasted_image (resized).png

Topic index (key posts)

12 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 6123 posts in this topic. You are on page 28 of 123.
#1351 1 year ago
Quoted from lodgingdolphin:

Here is a other one for you. #272

Noted and will update later.

Have fun and congrats.

We need some pics of pins in there new habitats.

#1352 1 year ago
Quoted from spandol:

So, my head grabbed the ball a lot more when I first set it up. Now it doesn't grab it most of the time. Some of those times it sets off T-Rex MB, but the ball goes in the mouth and out. Didn't someone adjust the mouth opto in here? Wondering if this is what I should do and how much of a pain it is. I'm thinking the opto isn't tripping so the magnet isn't grabbing the ball.

Anyone do this?

#1353 1 year ago

Finally

075377E2-CB17-4334-BBED-14F81A31084B (resized).jpeg
#1354 1 year ago

I already have my LE and I'm still eagerly awaiting the production and delivery of the premiums. I can't wait to hear from all those people when they find out how good this game really is.

#1355 1 year ago

I played an LE last night and really enjoyed this game.

One question, where is the ball supposed to go after hitting the edge of the post coming out of that inner orbit at the upper flipper? The one I was playing was going straight to the left outlane quite often. Is it supposed to go to the left slingshot? I was thinking possibly the upper flipper was set a little too far to the right?

#1356 1 year ago
Quoted from SMI3:

Finally[quoted image]

Nice Pic.

#1357 1 year ago

Here is my final set up.

I am missing one translite that I will pick up in Chicago. Lighted frame is lonely and waiting.

Who can find the easter egg? Gonna take a sharp eye.

IMG_0931 (resized).jpg
#1358 1 year ago
Quoted from DCFAN:

I played an LE last night and really enjoyed this game.
One question, where is the ball supposed to go after hitting the edge of the post coming out of that inner orbit at the upper flipper? The one I was playing was going straight to the left outlane quite often. Is it supposed to go to the left slingshot? I was thinking possibly the upper flipper was set a little too far to the right?

Mine hits around the top left bumper usually. I would always suggest checking the level, (side-to-side in the fron and in the rear, as well as front-to-back) before making a mechanical adjustment like that.

#1359 1 year ago
Quoted from EightBallTexas:

Who can find the easter egg? Gonna take a sharp eye.[quoted image]

The keychain?

#1360 1 year ago

Finally got to play an LE- wow! Great pin, I really enjoyed playing. I’d love to have a pro for my brewery location

2C17FEC6-F0B6-4570-834D-15B4C10FB3D7 (resized).jpeg
#1361 1 year ago

I was able to play the Pro and LE this weekend. I think it is a great game and will be ordering a Premium. I wasn't sure how to progress through the map as I don't think I got too far but did score 290M. I think the moving T-Rex is a great toy but also really liked the added gameplay of the Raptor pen on the LE. It took me a while to dial in hitting the "s" shot. It seems to have to be a clean shot to make it up and over that loop. I am going to check up on the rules before I play it again. I might pick up some mods before I get the game but trying to decide what would be best. I have been trying to dial back spending on Mods lately but there seems to be a lot of good ones out there.

#1362 1 year ago
Quoted from Peanuts:

The Pinball Universe ones are neat, I use them.
[quoted image]

Would these work with a JJP WOZ? I find there to be almost no clearance between the playfield and cabinet walls. I have already screwed up a set of decals and don't want to do that again.

#1363 1 year ago
Quoted from RebelGuitars:

Installed the tower, fence and ramp sign mods from Mezel. So much nicer looking than the factory plastics.[quoted image][quoted image][quoted image]

Where did you get the green rubbers for the flippers? What size and material did you get. My stock ones are already looking rough!

IMG_2123 (resized).jpg
#1364 1 year ago
Quoted from Peanuts:

The keychain?

Nope but great guess. LOL. I might need to take another picture.

#1365 1 year ago
Quoted from marksf123:

I was able to play the Pro and LE this weekend. I think it is a great game and will be ordering a Premium. I wasn't sure how to progress through the map as I don't think I got too far but did score 290M. I think the moving T-Rex is a great toy but also really liked the added gameplay of the Raptor pen on the LE. It took me a while to dial in hitting the "s" shot. It seems to have to be a clean shot to make it up and over that loop. I am going to check up on the rules before I play it again. I might pick up some mods before I get the game but trying to decide what would be best. I have been trying to dial back spending on Mods lately but there seems to be a lot of good ones out there.

Don't get me started. I am the worst, already have 10 mods in mind. lol

#1366 1 year ago
Quoted from Gotfrogs:

Would these work with a JJP WOZ? I find there to be almost no clearance between the playfield and cabinet walls. I have already screwed up a set of decals and don't want to do that again.

I specifically bought mine due to a JJPOTC having zero playfield clearance and messing up the art blades. Now I use them all the time on all pins.

#1367 1 year ago
Quoted from spandol:

So, my head grabbed the ball a lot more when I first set it up. Now it doesn't grab it most of the time. Some of those times it sets off T-Rex MB, but the ball goes in the mouth and out. Didn't someone adjust the mouth opto in here? Wondering if this is what I should do and how much of a pain it is. I'm thinking the opto isn't tripping so the magnet isn't grabbing the ball.

Quoted from spandol:

Anyone do this?

Funny you said that it seemed to grab the ball better when you first started playing. I also only noticed the lack of it after a few games. I haven't touched the mouth opto just verified it "works." Unsure what setting changes that opto if there is one in 0.90.0. In quotes because yes that and the ramp optos works but the mouth/magnet doesn't not unless the ball makes it into the furthest back point of the mouth--which means you have to at least have the T-Rex's position perfect on the ramp, which it never is for my machine. Changes time to time, sometimes centered, sometimes left side, sometimes right side of the ramp. See mine and multiple other folks posts about T-rex issues in this topic.

Might be time to start a separate topic about LE/Prem T-Rex specific issues. This has been the most frustrating issue about the game. There are adjustments in the menu that many have tweaked to resolve. I've tried them all to the point where one setting makes it better for a play, then the next it's as if what I did made it worse. I'm personally at the point where I'm done with both hardware and software tweaks, providing video's etc. I've convinced Stern to send me a whole new assembly. If you want to mess with it software-wise, yes there are ways to "improve" it from some fine folks advice. Unfortunately none have fully resolved the issue for my machine.

#1368 1 year ago
Quoted from Gotfrogs:

Where did you get the green rubbers for the flippers? What size and material did you get. My stock ones are already looking rough![quoted image]

Same... Pretty lame after just over 50 games. All 3 of mine look like this: https://pinside.com/pinball/forum/topic/welcome-to-the-jurassic-park-le-club/page/27#post-5253801
Wondering why LE's don't come with silicone or at least replacement rubber.

#1369 1 year ago

What’s with the filthy flipper rubbers after 50 plays? Is there more grinding metal dust on this than other games? Maybe from any of the mechs?

#1370 1 year ago

This is a bitch working your way through the pathways!

Haven’t made it to mini wizard yet. Still learning but it might take a while to get there and that’s a good thing like TWD

I’m starting to obsessively play this pin. Freaking love it

#1371 1 year ago

Complaining about replacement rubber? That’s about all you can do on this game. LOL

#1372 1 year ago

Waiting for mine, ICE....painful!!!

#1373 1 year ago

Mine has not worked since day one... still awaiting Sterns reply... sorta disappointed it’s been a week and nothing.

My flippers also look like those posted.

Still a fun pin, but a little conflicted with the growing pains.

Quoted from timlah79:

Funny you said that it seemed to grab the ball better when you first started playing. I also only noticed the lack of it after a few games. I haven't touched the mouth opto just verified it "works." Unsure what setting changes that opto if there is one in 0.90.0. In quotes because yes that and the ramp optos works but the mouth/magnet doesn't not unless the ball makes it into the furthest back point of the mouth--which means you have to at least have the T-Rex's position perfect on the ramp, which it never is for my machine. Changes time to time, sometimes centered, sometimes left side, sometimes right side of the ramp. See mine and multiple other folks posts about T-rex issues in this topic.
Might be time to start a separate topic about LE/Prem T-Rex specific issues. This has been the most frustrating issue about the game. There are adjustments in the menu that many have tweaked to resolve. I've tried them all to the point where one setting makes it better for a play, then the next it's as if what I did made it worse. I'm personally at the point where I'm done with both hardware and software tweaks, providing video's etc. I've convinced Stern to send me a whole new assembly. If you want to mess with it software-wise, yes there are ways to "improve" it from some fine folks advice. Unfortunately none have fully resolved the issue for my machine.

#1374 1 year ago
Quoted from scooterd:

Mine has not worked since day one... still awaiting Sterns reply... sorta disappointed it’s been a week and nothing.
My flippers also look like those posted.
Still a fun pin, but a little conflicted with the growing pains.

I'm a newbie to pin ownership but what I've seen with mine isn't growing pains but overall bad quality control. The t-rex and flippers are only two of 4 issues that shouldn't be issues IMHO. I'm also in the broken raptor club. The newest I've uncovered is a downright wrong drilling position of a drop target. Again I'm a newbie but I also spent my entire savings on this machine, an LE, so I expect it to be fully assembled and functional, as designed, right out of the box. I've been working with my seller and Stern since day one, pushing and prodding them as professionally and patiently as I can be, yet all issues remain. I'm super thankful for everyone who's given me tips but this is a brand new purchase. Why am I spending so much time troubleshooting rather than playing has become a question anyone should ask themselves. I hope to bring good news back to this forum soon as I do love this machine.

#1375 1 year ago

Just got our LE #408! Great game!!

07ADA971-920F-4584-8F7A-2B6ABF30DEDA (resized).jpeg
#1376 1 year ago

My right flipper seems to have a slight delay and seems a little weak from time to time. Anyone else having this issue?

#1377 1 year ago
Quoted from Wickerman2:

What’s with the filthy flipper rubbers after 50 plays? Is there more grinding metal dust on this than other games? Maybe from any of the mechs?

I don’t know I have three new pins with red flipper rubbers, including JJ POTC. Every one gets dirty almost immediately. You can clean it with Naptha and that won’t do any damage.

#1378 1 year ago
Quoted from GamerRick:

I don’t know I have three new pins with red flipper rubbers, including JJ POTC. Every one gets dirty almost immediately. You can clean it with Naptha and that won’t do any damage.

If you don’t have naphtha, a little warm water and dish soap will also do the trick.
I recommend removing the flipper rubbers from the pin, first.
: )

#1379 1 year ago
Quoted from timlah79:

Funny you said that it seemed to grab the ball better when you first started playing. I also only noticed the lack of it after a few games. I haven't touched the mouth opto just verified it "works." Unsure what setting changes that opto if there is one in 0.90.0. In quotes because yes that and the ramp optos works but the mouth/magnet doesn't not unless the ball makes it into the furthest back point of the mouth--which means you have to at least have the T-Rex's position perfect on the ramp, which it never is for my machine. Changes time to time, sometimes centered, sometimes left side, sometimes right side of the ramp. See mine and multiple other folks posts about T-rex issues in this topic.
Might be time to start a separate topic about LE/Prem T-Rex specific issues. This has been the most frustrating issue about the game. There are adjustments in the menu that many have tweaked to resolve. I've tried them all to the point where one setting makes it better for a play, then the next it's as if what I did made it worse. I'm personally at the point where I'm done with both hardware and software tweaks, providing video's etc. I've convinced Stern to send me a whole new assembly. If you want to mess with it software-wise, yes there are ways to "improve" it from some fine folks advice. Unfortunately none have fully resolved the issue for my machine.

Yes, exactly right. Mine will sometimes start MB without grabbing the ball. That’s actually better than hitting the shot and it not registering. I kinda assumed this would be an issue before buying.

#1380 1 year ago
Quoted from Chambahz:

If you don’t have naphtha, a little warm water and dish soap will also do the trick.
I recommend removing the flipper rubbers from the pin, first.
: )

Leave the rubber on and use Novus 2. A few wipes and good as new!

Rob

#1381 1 year ago
Quoted from KevinG:

My right flipper seems to have a slight delay and seems a little weak from time to time. Anyone else having this issue?

Check the coil stop - lots of dodgy ones around.

#1382 1 year ago
Quoted from EightBallTexas:

Who can find the easter egg? Gonna take a sharp eye.[quoted image]

Well, there’s a big green egg on your patio, but that’s about as obvious as I’m gonna get... if you got it around Easter!

#1383 1 year ago

Favorite shot right now is hitting the right orbit and when it comes around flipping the upper flipper just enough to scoop it fast and smoothly around for a second orbit. Super fun.

#1384 1 year ago

Just a quick look at JP LE and Elvira

#1385 1 year ago
Quoted from KevinG:

My right flipper seems to have a slight delay and seems a little weak from time to time. Anyone else having this issue?

Check the contact gap for your flipper button, you may need to bend a little to get a smaller gap to make sure it makes up sooner. Also the right side flipper button has a secondary set of contacts for the upper flipper that may need adjusted.

#1386 1 year ago
Quoted from BlueIrocGuy:

Well, there’s a big green egg on your patio, but that’s about as obvious as I’m gonna get... if you got it around Easter!

That was a fantastic guess and I think you should be the winner.

One Beer and one hot dog on me in Chicago.

#1387 1 year ago
Quoted from RETROCENGO:

Just a quick look at JP LE and Elvira

Copenhagen checking in. I think you are the first from outside North America. Please share the LE serial number.

Congrats.

#1388 1 year ago

New list update. We are moving along. I see our first person from Copenhagen posted up a picture.

001 ???
002 ???
003 ???
004 ???
005 EightBallTexas
006 ???
007 ???
008 ???
009 ???
010 ???
011 cjmjmm2006

026 da_topper
044 medfly
049 PDX-Mike
068 Troutfarm
073 Pickleric
075 Cdonnerusmc
078 charliew65
097 bemmett
099 PiperPinball

101 youdontknowme
107 Pinball-NJA
106 Chambahz
119 zavadoza
120 youdontknowme
121 youdontknowme
122 younginvisions
130 hassellcastle
135 blimpey
153 Iceman44
154 Mummite
159 catchlight
161 mthirkell
172 Tatman9999
176 Jerol
177 Carz5811
188 Chappie101
191 MikeHogue

200 peanuts
218 Arcadem
232 Pingod
242 gotfrogs
252 vongator
260 t7
263 Aukraut
269 MSLOW
270 C_Presley
272 LodgingDolphin
274 TheGunnett
278 breger1
290 HawkMoon77

301 FrankMac
310 SunFox
311 JMK
313 scooterd
327 AdamRoss
332 Banker
348 Tacreno
349 EVH347
350 tuflyf
357 NavyStan
362 TimLah79
363 TradesMan
375 dylanfan71
378 coindropper
380 Pinstein
382 RacerX61

408 KevinG
418 BANE
421 Paragon07
442 Gmanrulz46
453 Iceman44
458 GnOsls
475 ToddW
498 Jints56

Have a great day Guys.

#1389 1 year ago

Has it been confirmed if premiums are going on the line this week and if they are being produced at a normal run rate?

#1390 1 year ago
Quoted from Gotfrogs:

Where did you get the green rubbers for the flippers? What size and material did you get. My stock ones are already looking rough![quoted image]

Remove all the black, stock bands and replace with Titan or Super Bands from Pinball Life>orange look great on JP.
The Stern stock black bands leave all black shit everywhere. And over time ball trails.
First thing I do is remove all the stock black bands and throw them away.

#1391 1 year ago

JPLE #99 owner here.

All the posts in my pin where loose.
Highly recommend before you start playing your new pin. Is to lift up the pf and tighten all the posts and all other screws/nuts.

Not sure how this passed QC at Stern? But lots of adjustments need to be made on NIB pins lately. Some loose connectors too> probably came loose during shipping.

Super fun pin.

And anyone having issues with the Raptor gate not going all the way down on the right side? Its not level, and has a little lip to it. Sometimes the ball gets stuck behind the lip behind the raptor gate. We adjusted it but still not 100%. Thoughts?

-Dan

#1392 1 year ago
Quoted from PiperPinball:

The Stern stock black bands leave all black shit everywhere. And over time ball trails.
First thing I do is remove all the stock black bands and throw them away.

Is that what's doing it? Good to know.

#1393 1 year ago
Quoted from PiperPinball:

JPLE #99 owner here.
All the posts in my pin where loose.
Highly recommend before you start playing your new pin. Is to lift up the pf and tighten all the posts and all other screws/nuts.
Not sure how this passed QC at Stern? But lots of adjustments need to be made on NIB pins lately. Some loose connectors too> probably came loose during shipping.
Super fun pin.
And anyone having issues with the Raptor gate not going all the way down on the right side? Its not level, and has a little lip to it. Sometimes the ball gets stuck behind the lip behind the raptor gate. We adjusted it but still not 100%. Thoughts?

-Dan

Nice number, agent 99 of control.

#1394 1 year ago
Quoted from Wickerman2:

Is that what's doing it? Good to know.

yes. I didn't know this either up and until a few years ago.
Not sure why Stern still uses these crap black bands, but over time they breakdown and leave a mess on your pf.

#1395 1 year ago
Quoted from chet218:

Has it been confirmed if premiums are going on the line this week and if they are being produced at a normal run rate?

I just received an invoice for final payment from my distributor, so I guess that’s a good sign?!?

#1396 1 year ago

If anyone is having any trouble with either plunger (manual or autolauncher) not completing the horseshoe ramp, there's a simple fix.
You need to raise the left fork of the ramp slightly, forcing the ball to the right side of the lane.
We did this today at my buddy's place and had 100% accuracy thereafter, and I've just done the same for mine.
(Mine was near perfect but occasionally, the ball would dribble back down the ramp and hit the top of the right sling.)
We just undid both screws, lifted the fork slightly, then placed a small nut under the left side. The screw on the left side fed through the nut and back into the playfield. When you're standing above, looking straight down, it's barely noticeable so I took a photo much closer to playfield level. (It really looks exaggerated in the photo.)

image0 (resized).jpeg
#1397 1 year ago
Quoted from SMI3:

Finally[quoted image]

Awesome!!! Man you had Elvira in Copenhagen the weekend of the EPC?!?!

How did you get them so quick? Did your distributor air freight them?

#1398 1 year ago

My LE is on the boat to the UK a should arrive two weeks today hopefully!

#1399 1 year ago
Quoted from NeilMcRae:

My LE is on the boat to the UK a should arrive two weeks today hopefully!

Nice.........post up the umber once you get it .

Congrats.

#1400 1 year ago

Anyone else notice? JP LE ranked #1 in pinside top 100. At least for now.

Promoted items from the Pinside Marketplace
$ 29.95
Playfield - Toys/Add-ons
ULEKstore
Wanted
Machine - Wanted
Surrey, BC
$ 16.95
Playfield - Toys/Add-ons
ULEKstore
There are 6123 posts in this topic. You are on page 28 of 123.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside