(Topic ID: 248218)

Welcome To The Jurassic Park Prem/LE Club!!

By EightBallTexas

2 years ago


Topic Heartbeat

Topic Stats

  • 8,693 posts
  • 730 Pinsiders participating
  • Latest reply 7 hours ago by PinMonk
  • Topic is favorited by 368 Pinsiders

You

Linked Games

Topic poll

“What is the first MOD you will buy??”

  • Toppers 59 votes
    46%
  • New Jeep 51 votes
    40%
  • Plastic Characters 18 votes
    14%

(128 votes)

This poll has been closed.

Topic Gallery

View topic image gallery

2B3C73E0-4E5C-458C-B9F7-146AB3C74851 (resized).jpeg
5497A775-10E7-4411-A4B6-91A0C9672C65 (resized).jpeg
JP T-Rex controllers (resized).jpg
32978F8A-CD4C-490B-927C-613670BDE628 (resized).jpeg
5F502A63-8BA4-4A5D-9DAD-625B79CF8A8F (resized).jpeg
359B1BCD-ECF8-46D6-8228-0620579AC8E8 (resized).jpeg
597DEEF3-CBED-4223-9583-F48E5FCB1269 (resized).jpeg
7A051F98-4071-469A-A24B-5DDB45F53D43 (resized).jpeg
1B0FCFD1-0EC7-4231-8629-549CA3BC490F (resized).jpeg
4DB66C26-029C-40B1-82B0-D5DD0DE41010 (resized).jpeg
6279D80D-1873-4784-B331-2E1525A73F40 (resized).jpeg
eyes.gif
3.jpg
2.jpg
1.jpg
20220518_150211 (resized).jpg

Topic index (key posts)

18 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 8,693 posts in this topic. You are on page 174 of 174.
#8651 39 days ago
Quoted from CTHOMAS1998:

Good Morning PinMonk I tried applying pressure, and had no luck. When machine is on, and all 6 leds are lit, when manually kicking a ball out to the shooter lane, the left led goes out, and when the ball return, it comes back on, as it should. Just doesn't recognize thr balls are in there.

So, it sounds like the trough board itself is registering that the opto is triggering (based on the trough board lights coming on and off correctly), it's just not communicating that to the machine?

At this point I'd swap node 9 and Node 8 boards (change the dip switches on each board to the opposite board's settings so they know their new role) and see if the problem moves to the left ramp sign and the dino, because that's what CN14 operates on Node 9. If your trough resolves, but the problem has moved, then that node board was likely damaged and will need to be repaired.

#8652 38 days ago
Quoted from PinMonk:

So, it sounds like the trough board itself is registering that the opto is triggering (based on the trough board lights coming on and off correctly), it's just not communicating that to the machine?
At this point I'd swap node 9 and Node 8 boards (change the dip switches on each board to the opposite board's settings so they know their new role) and see if the problem moves to the left ramp sign and the dino, because that's what CN14 operates on Node 9. If your trough resolves, but the problem has moved, then that node board was likely damaged and will need to be repaired.

Good Afternoon PinMonk . I will pull those boards and swap them Saturday morning. A tech from Stern had me swap the cables between CN2 and CN3 on node board 8 to see if the trough problem went away, and an issue started on the leds, but there was no change so I put it back. I'll do as you suggest 1st thing Saturday morning. That was going to be my install time for my Tibetan Breeze Flipper kit, and my magnet and diverter cooling kit....

#8653 35 days ago

Good Afternoon PinMonk. I found it. It was a pinched wire that was really hard to see. The pinch was on one wire, and that wire was tight up against another in the harness, covering up the pinch. Just got luck and saw a little anomaly I. The way the wires looked. Took a closer look and verified it. Cut, soldered, and heat shrunk it. All good now!

#8654 35 days ago
Quoted from CTHOMAS1998:

Good Afternoon PinMonk. I found it. It was a pinched wire that was really hard to see. The pinch was on one wire, and that wire was tight up against another in the harness, covering up the pinch. Just got luck and saw a little anomaly I. The way the wires looked. Took a closer look and verified it. Cut, soldered, and heat shrunk it. All good now!

Awesome. Glad you finally tracked it down!

#8655 34 days ago

I had a Jurassic Park Premium for 6 months, and yesterday I found that the T-Rex Multi-ball sometimes would get registered even without my ball even close to its mouth. This happens in almost every game, but sometimes the T-Rex Multi-ball gets registered correctly. It wasn't like this before. I tested the opto sensors, and they recognize the ball when the ball triggers it. The T-Rex has no problem picking up the ball, and the magnet is working. The problem is that something is falsely triggering the T-Rex multi-ball. I also checked the setting #23 (initiate Multi-ball when ball enter ramp...), and it is off. Is this likely a software issue or a hardware issue? Anyone else experienced this? How can I fix this? Thanks!

#8656 34 days ago
Quoted from acakoning:

Hi all, i have also purchased the Stern Jurassic Park Premium pinball ! Of course i only did so after reading every single comment in here and the ratings
I bought it brand new from SCHWAB Spielautomaten here in Switzerland. They have a delivery package which includes installing, software update, and testing. While the game is stunning, there were immidiately 3 things wrong with the game. I don't think SCHWAB Spielautomaten did a great job at all in testing the machine because:
1. The Kinetic ball with the car is difficult (heavy and not freely moving) to rotate and the ball gets stuck a LOT..
2. One of the soldering points on a motor from the T-rex is just OPEN! Not connected at all.
3. The Raptor cannot move because its tail is stuck behind the the metal plate next to it.
Wondering if these things are considered NORMAL for a brand new Stern machine..
Kind regards, A
[quoted image]

I have 2 of the issues above, and below is how I fixed them.
1) The kinetic ball was difficult to rotate and would get stuck -- this happened 4 months after i bought the machine. Cleaning it and adding some lubrication fixed that.
3) The raptor cannot move and the tail was stuck under plate -- this happened since day 1 I got the machine new in the box. I disassemble that part of the machine 3 times and tried to fix it before it was successful. At first, I thought the plastic raptor toy was not made correctly and the angle wasn't right. It was leaning forward and to one side, causing the tail to get caught under a plate. I bought a heat gun and soften the legs on the plastic raptor, so that I can make it stand straight. It was fixed for a day, and then the next day it would lean forward and to one side again. I finally realize that this is caused by the plastic material being too soft and flexible, and it is not strong enough to hold the posture. The weight of the raptor is not balanced, and the 2 legs would bend and make the raptor lean. The only way to fix this is to support the raptor's right knee with something and make it stand tall and straight. I ended up just using a piece of transparent hot glue and support its right knee with it. Now it's working great. Hope this helps.

#8657 33 days ago
Quoted from Toner75:

I had a Jurassic Park Premium for 6 months, and yesterday I found that the T-Rex Multi-ball sometimes would get registered even without my ball even close to its mouth. This happens in almost every game, but sometimes the T-Rex Multi-ball gets registered correctly. It wasn't like this before. I tested the opto sensors, and they recognize the ball when the ball triggers it. The T-Rex has no problem picking up the ball, and the magnet is working. The problem is that something is falsely triggering the T-Rex multi-ball. I also checked the setting #23 (initiate Multi-ball when ball enter ramp...), and it is off. Is this likely a software issue or a hardware issue? Anyone else experienced this? How can I fix this? Thanks!

Covered many times in this thread. Even with setting 23 to off, the Trex MB will always initiate on ramp entry. Designed that way to enable an easy first MB. So to recap, setting 23 only applies to TREX modes AFTER the first one (TREX MB).

#8658 33 days ago

I've had a few people ask about my sling dino eye illumination mod, so I thought I would do another run of them.

Price is $30 for the pair of eye lights (includes US shipping). Order includes the full set of 2 eye lights with everything needed to connect them. Please PM me if interested in getting in on this run.

PLEASE PM ME IF YOU ARE INTERSTED IN PURCHASING - ORDERS WILL BE CLOSED THIS FRIDAY, 5/25 AT NOON CENTRAL.

I make the pair of lights using a special 3D printed casing (different for each side), and the lights are installed without any disassembly of the sling plastics (full instructions are provided), and work with or without plastic protectors. The bulbs I utilize are non-ghosting, and are connected via alligator clips (i.e. non-destructive and easily removable) under the playfield to the lower sling LED socket. This way the eyes will flash when the sling flashes and be solid when the sling lighting is solid.
1.jpg2.jpg3.jpgeyes.gif

#8659 32 days ago

Firm cutoff at noon central tomorrow if you are interested in purchases my sling dino eye mod.

If you've not already PM'd me regarding your interest, please do so as soon as possible.

#8660 31 days ago

Sling dino eye light mod ordering is closed. Thank you to everyone who purchased. I will order components today and should be able to ship in two weeks or less.

#8661 26 days ago

I'm proud to be an official member of the club. My premium just arrived and the box is perfect. Now the fun begins!

#8662 26 days ago
Quoted from SimpleSkin:

I'm proud to be an official member of the club. My premium just arrived and the box is perfect. Now the fun begins!

Resist the urge to spend all your time adding mods to it, and really have fun PLAYING the machine!!! (The main exceptions are listed below) It's pretty amazing and you'll grow to love and/or hate the various shots and strategies involved in such a deep game. Almost all the other mods are cosmetic.

1. Consider adding some kind of a shooter lane protector has that lane wood takes a beating.
2. You might find yourself having to grind down the left tower flap screw if it contacts the ball as it interferes with the tower shot otherwise.
3. Most people find the shaker add-on to be almost essential since it it SO tightly coordinated with the playfield action.

There are a ton of other cosmetic mods, some amazing (like Stern's amber lighted shooter, ULEK's control room plastic, WizBlades 'blue' side blades, custom Apron cards or Mezel's Tower replacement and raptor pit), and some less amazing (a hundred kitchy mods to choose from)! But modding is the realm of art, so enjoy the ride and splash on a hint of your own personality if you like! 8-)

#8663 26 days ago
Quoted from Markharris2000:

Resist the urge to spend all your time adding mods to it, and really have fun PLAYING the machine!!! (The main exceptions are listed below) It's pretty amazing and you'll grow to love and/or hate the various shots and strategies involved in such a deep game. Almost all the other mods are cosmetic.
1. Consider adding some kind of a shooter lane protector has that lane wood takes a beating.
2. You might find yourself having to grind down the left tower flap screw if it contacts the ball as it interferes with the tower shot otherwise.
3. Most people find the shaker add-on to be almost essential since it it SO tightly coordinated with the playfield action.
There are a ton of other cosmetic mods, some amazing (like Stern's amber lighted shooter, ULEK's control room plastic, WizBlades 'blue' side blades, custom Apron cards or Mezel's Tower replacement and raptor pit), and some less amazing (a hundred kitchy mods to choose from)! But modding is the realm of art, so enjoy the ride and splash on a hint of your own personality if you like! 8-)

Thanks for the tips. I've already installed the shaker motor and will be installing the amber shooter rod and art blades in the coming days. That's it. I prefer to keep my games factory. Cliffys on order. Def. turned down the trough eject and can probably turn it down more. Now to dig into the rules and learn the shots and modes.

#8664 26 days ago
Quoted from SimpleSkin:

Thanks for the tips. I've already installed the shaker motor and will be installing the amber shooter rod and art blades in the coming days. Cliffy's on order. That's it. I prefer to keep my games factory. Def. turned down the trough eject and can probably turn it down more. Now to dig into the rules and learn the shots and modes.

#8665 26 days ago

A batch of these is shipping to folks like me; so please be patient with us new owners.

New owners, check the key posts. There's lots of good stuff in there, particularly around dealing with the TRex and Raptor gate.

#8666 26 days ago
Quoted from SimpleSkin:

Thanks for the tips. I've already installed the shaker motor and will be installing the amber shooter rod and art blades in the coming days. That's it. I prefer to keep my games factory. Cliffys on order. Def. turned down the trough eject and can probably turn it down more. Now to dig into the rules and learn the shots and modes.

I have my trough eject on the minimum setting and it still has more than enough power to kick out the ball - possibly worth dropping yours all the way (if it won't kick out in test you can up the power until you find the point at which kick outs are consistent).

1 week later
#8667 17 days ago

My new build had 0 glass issues, so I'm not sure what the variable is that's causing some folks to have such challenges; that said, it's definitely not every game.

T-Rex has been pretty good so far, but it's very noisy when it moves. Is that normal?

Raptor gate got stuck mid-up/down once, but I managed to reset it.

Typical ball launch inconsistencies.

Where I AM having an issue is with the "C" shot. I get tons of rejects and rattles on what feel like clean shots. Even if It triggers the C, it's not clean. Maybe "Play better" is the answer, but that is definitely the 2nd hardest shot on my game to hit consistently aside from "O".

Imperfect build so far, but 98% of the game seems to be working great.

#8668 17 days ago
Quoted from BrewinBombers:

My new build had 0 glass issues, so I'm not sure what the variable is that's causing some folks to have such challenges; that said, it's definitely not every game.
T-Rex has been pretty good so far, but it's very noisy when it moves. Is that normal?
Raptor gate got stuck mid-up/down once, but I managed to reset it.
Typical ball launch inconsistencies.
Where I AM having an issue is with the "C" shot. I get tons of rejects and rattles on what feel like clean shots. Even if It triggers the C, it's not clean. Maybe "Play better" is the answer, but that is definitely the 2nd hardest shot on my game to hit consistently aside from "O".
Imperfect build so far, but 98% of the game seems to be working great.

T Rex noise is normal. C lane is tough and slight changes to pitch and flipper power can help dial it in a bit. But it’s still tough.

#8669 17 days ago

Joined the club a couple days ago. Great game! Glass slide is perfect. No complaints about my build. Pinball machines always need a little tlc tweaking here and there. This game is no different. Nothing unusual so far except how fun it is. What a terrific design. So many excellent and challenging shots!

#8670 16 days ago

Ditto on the t-rex noise—curious if that’s normal and just something one can’t hear in an arcade.

As to the C shot—I had the same issue. I lifted the playfield and bent the switches toward each other a little from underneath. It’s now registering every time.

I’m also having a ton of shots jump off the t-rex ramp. Is this just a matter of 6.5 degrees not being steep enough on an Elwin game?

Quoted from BrewinBombers:

My new build had 0 glass issues, so I'm not sure what the variable is that's causing some folks to have such challenges; that said, it's definitely not every game.
T-Rex has been pretty good so far, but it's very noisy when it moves. Is that normal?
Raptor gate got stuck mid-up/down once, but I managed to reset it.
Typical ball launch inconsistencies.
Where I AM having an issue is with the "C" shot. I get tons of rejects and rattles on what feel like clean shots. Even if It triggers the C, it's not clean. Maybe "Play better" is the answer, but that is definitely the 2nd hardest shot on my game to hit consistently aside from "O".
Imperfect build so far, but 98% of the game seems to be working great.

#8671 16 days ago
Quoted from scottgreenmagic:

Ditto on the t-rex noise—curious if that’s normal and just something one can’t hear in an arcade.
As to the C shot—I had the same issue. I lifted the playfield and bent the switches toward each other a little from underneath. It’s now registering every time.
I’m also having a ton of shots jump off the t-rex ramp. Is this just a matter of 6.5 degrees not being steep enough on an Elwin game?

My C shot registers when hit, but anything but a perfect shot rattles out just short of the target. I'll tweak the pitch a bit, but turning down the flippers a smidge has definitely helped other things.

#8672 16 days ago
Quoted from scottgreenmagic:

I’m also having a ton of shots jump off the t-rex ramp. Is this just a matter of 6.5 degrees not being steep enough on an Elwin game?

Try turning down the flipper power or as you mentioned increase the pitch

#8673 16 days ago
Quoted from BrewinBombers:

My C shot registers when hit, but anything but a perfect shot rattles out just short of the target. I'll tweak the pitch a bit, but turning down the flippers a smidge has definitely helped other things.

Have you checked that the control room up-post sits flush with the PF? If not flush it can cause the ball to deviate and reduces the ball’s momentum - this might be contributing to your issue

#8674 14 days ago

Hi All,

I'm new to the club as of last week when my prem arrived! In the anticipation of my game arriving I've been a long time lurker and have greatly appreciated the tips that have been shared. I have a slight issue that I haven't seen anyone post on and wonder if I'm alone in this. I added the amber shooter rod but it seems that the power of the rod isn't there to get the ball to the upper level in lane ramp, maybe 1 out of 10 will it get up there. I know the original shooter rod did much better.

thinking maybe the spring was too weak I swapped out he spring from the original to the amber with no change. Has anyone else experienced this? Any corrective suggestions?

#8675 14 days ago
Quoted from hlpatterson:

Hi All,
I'm new to the club as of last week when my prem arrived! In the anticipation of my game arriving I've been a long time lurker and have greatly appreciated the tips that have been shared. I have a slight issue that I haven't seen anyone post on and wonder if I'm alone in this. I added the amber shooter rod but it seems that the power of the rod isn't there to get the ball to the upper level in lane ramp, maybe 1 out of 10 will it get up there. I know the original shooter rod did much better.
thinking maybe the spring was too weak I swapped out he spring from the original to the amber with no change. Has anyone else experienced this? Any corrective suggestions?

In the Pro thread a lot of people have had this issue. I ended up getting a red spring and problem solved.

#8676 14 days ago

Is there a way to disable having the action button act as another start button? We keep accidentally starting games leaning on it. I looked in the manual but couldn’t find a setting for this.

#8677 14 days ago
Quoted from pinheadpierre:

Is there a way to disable having the action button act as another start button? We keep accidentally starting games leaning on it. I looked in the manual but couldn’t find a setting for this.

Yes. It's in the settings. I did this all the time as well and it's annoying. You can disable. Sorry I don't have the exact setting number and menu in memory.

#8678 14 days ago

I’ve been modding my JP Premium lately.

1B0FCFD1-0EC7-4231-8629-549CA3BC490F (resized).jpeg32978F8A-CD4C-490B-927C-613670BDE628 (resized).jpeg359B1BCD-ECF8-46D6-8228-0620579AC8E8 (resized).jpeg4DB66C26-029C-40B1-82B0-D5DD0DE41010 (resized).jpeg597DEEF3-CBED-4223-9583-F48E5FCB1269 (resized).jpeg5F502A63-8BA4-4A5D-9DAD-625B79CF8A8F (resized).jpeg6279D80D-1873-4784-B331-2E1525A73F40 (resized).jpeg7A051F98-4071-469A-A24B-5DDB45F53D43 (resized).jpeg
#8679 14 days ago
Quoted from crwjumper:

I’ve been modding my JP Premium lately.

Looks great! I like it.

#8680 13 days ago
Quoted from BrewinBombers:

My new build had 0 glass issues, so I'm not sure what the variable is that's causing some folks to have such challenges; that said, it's definitely not every game.

I think there's one worker that really likes to tighten those side rail screws down extra good. After loosening the 2 middle screws on both sides, my glass went from nearly impossible to get off, even with suction cups, to just a little tight. It won't slide out on its own, but I can easily get it off and on now.

#8681 13 days ago
Quoted from crwjumper:

I’ve been modding my JP Premium lately.
[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

Not enough trees. j/k.

#8682 13 days ago
Quoted from SimpleSkin:

Yes. It's in the settings. I did this all the time as well and it's annoying. You can disable. Sorry I don't have the exact setting number and menu in memory.

Found it. Game adjustment #60

#8683 13 days ago

After just a few days of being in the club, my Trex has stopped working entirely. I’m also having trouble even testing it in the diagnostics due to crappy menu buttons on the coin door.

When the menu buttons do work, it seems like the horizontal test goes okay, but the vertical test does absolutely nothing.

I emailed Stern, but thought I’d ask here too in hopes that someone here has run into this and could offer some advice.

#8684 13 days ago
Quoted from pinheadpierre:

After just a few days of being in the club, my Trex has stopped working entirely. I’m also having trouble even testing it in the diagnostics due to crappy menu buttons on the coin door.
When the menu buttons do work, it seems like the horizontal test goes okay, but the vertical test does absolutely nothing.
I emailed Stern, but thought I’d ask here too in hopes that someone here has run into this and could offer some advice.

A local guy had the horizontal controller board die, if you're getting no vertical movement in test mode (or game mode) then potentially the vertical controller board could be the issue. I know the horizontal board has diag LEDs on the board, so guessing the vertical one has as well - check if you have any LEDs on?

JP T-Rex controllers (resized).jpg
#8685 13 days ago

Nice! Great machine!!

#8686 13 days ago
Quoted from Manny65:

A local guy had the horizontal controller board die, if you're getting no vertical movement in test mode (or game mode) then potentially the vertical controller board could be the issue. I know the horizontal board has diag LEDs on the board, so guessing the vertical one has as well - check if you have any LEDs on?
[quoted image]

I checked the horizontal and vertical boards. Like you said, the horizontal board has two red diagnostic leds. Both leds on the horizontal boards are fine.

There appears to be two similar leds on the vertical board. Neither of those are lit.

Another question: I noticed that I can easily and freely move the trex side to side by hand, but it won’t budge vertically. Is that normal?

#8687 12 days ago
Quoted from pinheadpierre:

I checked the horizontal and vertical boards. Like you said, the horizontal board has two red diagnostic leds. Both leds on the horizontal boards are fine.
There appears to be two similar leds on the vertical board. Neither of those are lit.
Another question: I noticed that I can easily and freely move the trex side to side by hand, but it won’t budge vertically. Is that normal?

Eddie at Stern solved this for me. Just needed to reseat a connector. Here’s the full explanation:

“You should be able to move the assembly by hand horizontally, but not vertically.

Reseat the CN5 connector on lamp board 9A. From 9A, it goes to the serial motor driver board, this controls the vertical movement.
The horizontal movement is controlled by the stepper motor driver board.”

Great, prompt help from Eddie!

#8688 6 days ago

Time to get intimate with my Trex! The lower jaw just flew off mid-game. Judging by the holes in the jaw, I’m on the hunt for three screws somewhere in my game. If/when I find the screws, how do I access the underside of the jaw to put it back together?

5497A775-10E7-4411-A4B6-91A0C9672C65 (resized).jpeg
#8689 6 days ago

Finding the screws was easy. No wonder they came loose! They only stick through the lower jaw by about 1/16th of an inch. Wondering if I should get some slightly longer screws or use locktite and cross my fingers.

#8690 6 days ago

Well that was easy. Hopefully it stays put. I put some blue locktite on each of the screws and got the screws back in with my trusty offset Phillips screwdriver that I bought over 30 ago. I originally bought it to remove the lock hasp from the Art Department roof at my college. My friends and I would go up there on hot summer nights and take in the night, always being careful to cover our tracks and put the lock back on when we were done.

2B3C73E0-4E5C-458C-B9F7-146AB3C74851 (resized).jpeg
#8691 9 hours ago

Can I get a couple pics of people's wire guide protecting the raptor mechs in the "C" shot?

#8692 8 hours ago

JP SIDE ARMOR FOR SALE.
Not cheap.
I bought 3 and paid alot for all three.
If you would like to investigate please message me.

#8693 7 hours ago
Quoted from pinheadpierre:

After just a few days of being in the club, my Trex has stopped working entirely. I’m also having trouble even testing it in the diagnostics due to crappy menu buttons on the coin door.

Stern will replace that coin door button block for the menu/diagnostics. They've had a lot of crappy ones that barely work or that you have to play with to make the buttons work make it out of QA into the field. No excuse for it. If you're under warranty ask for a new service button block.

Promoted items from the Pinside Marketplace
11,000 (OBO)
Machine - For Sale
Bowling Green, KY
From: $ 20.00
Cabinet - Other
Filament Printing
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 7.50
Playfield - Protection
Pin Monk
$ 74.00
Lighting - Backbox
Arcade Upkeep
There are 8,693 posts in this topic. You are on page 174 of 174.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!