(Topic ID: 248218)

Welcome To The Jurassic Park Prem/LE Club!!

By EightBallTexas

2 years ago


Topic Heartbeat

Topic Stats

  • 8,219 posts
  • 695 Pinsiders participating
  • Latest reply 19 hours ago by Shredso
  • Topic is favorited by 347 Pinsiders

You

Linked Games

Topic poll

“What is the first MOD you will buy??”

  • Toppers 59 votes
    46%
  • New Jeep 51 votes
    40%
  • Plastic Characters 18 votes
    14%

(128 votes)

This poll has been closed.

Topic Gallery

View topic image gallery

pasted_image (resized).png
2277CDDE-674C-4BBA-8295-F2304DE8BBBC (resized).jpeg
pasted_image (resized).png
PXL_20211022_143515266 (resized).jpg
ps (resized).jpg
Ball stuck (resized).jpg
JP Lighting (resized).jpg
JP ramp plastic with donuts 2 (resized).jpg
JP ramp plastic with donuts 1 (resized).jpg
JP ramp plastic with donuts 3 (resized).jpg
CBDF5FFE-03E3-486E-9F2A-D21A9313B3B0 (resized).jpeg
PXL_20211010_205406826 (resized).jpg
pasted_image (resized).png
IMG_7253 (resized).jpg
pic1b (resized).jpg
77B6CCCA-326A-4AED-A69E-672DFAF12F7C (resized).jpeg

Topic index (key posts)

13 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 8219 posts in this topic. You are on page 162 of 165.
#8051 45 days ago
Quoted from jake35:

I have removed and thrown away 3 sets of pin stadium garbage since they have been putting out their made in china, overpriced and obnoxious product. The owner enjoys spamming the forums on a daily basis with his trashy product, I will tell everyone my opinion and why I throw them away when they come on my machines.

That's some funny shit right there!

I have them on all my pins...they made a night and day difference if installed correctly.

Good lucky finding anything close to them on the market. To each their own but any time I've ever had a question Scott emailed me right back.

#8052 45 days ago

I agree, PinStadium lighting looks like crap on this pin. Heck before I added them to my JP, I didn't have to look at any of the center playfield graphics, and now I can see everything. It was also great seeing the ball disappear in various spots before I added them - who needs to follow the ball anyway? I also was upset that much of the glare on the glass was removed after installing mine due to the backlighting. Overall, extra ambient lighting on a dark playfield is a terrible idea.

JP (resized).jpg

#8053 45 days ago
Quoted from MrMikeman:

Ahh here we go. Complaining by someone that’s never actually OWNED pinstadiums and knows nothing about how they work. Your opinion is based on what exactly?

Why would I own them if I hate them? I've played lots of games at shows with Pinstadiums and I think they destroy the ambience (for lack of a better word) of the game. It blows out the insert lights in my experience. Pinball should be played in a dark room and I've never had a problem seeing a ball (except for WOZ which I corrected with a few spots). We'll just agree to disagree...but my opinion is certainly a valid one.

#8054 45 days ago
Quoted from beelzeboob:

Why would I own them if I hate them? I've played lots of games at shows with Pinstadiums and I think they destroy the ambience (for lack of a better word) of the game. It blows out the insert lights in my experience. Pinball should be played in a dark room and I've never had a problem seeing a ball (except for WOZ which I corrected with a few spots). We'll just agree to disagree...but my opinion is certainly a valid one.

I get your point, and it does come down to preference. I like playing pinball in a dark room, but I also really like the playfield being illuminated to the point where I can see all elements and the artwork. Correctly done, PinStadium lights achieve this without adding "color puke" to the game. Case in point is my favorite pin title, Attach from Mars. I absolutely love this pin for a multitude of reasons, with the theme being near the top. However, I absolutely abhor Revenge from Mars. What it comes down to is I can't stand loosing sight of the ball every time it goes on the upper third of the playfield due to the pitch black area to support the Pin2000 monitor reflection. It completely kills the game flow losing a travelling ball and waiting for it to reappear.

#8055 45 days ago

Does anyone except from having stuck balls at the bumpers ? I attached a picture from the ball guide which causes the problem . Tried to bend it when it’s installed but can’t get it hold in position . After 3 plays or so the problem came back .
9EB747E1-F440-46EA-9518-DE5AA21DB097 (resized).jpeg

#8056 45 days ago
Quoted from max_pinball:

Does anyone except from having stuck balls at the bumpers ? I attached a picture from the ball guide which causes the problem . Tried to bend it when it’s installed but can’t get it hold in position . After 3 plays or so the problem came back .
[quoted image]

Not heard of or seen a ball hang there - double check your PF is level side-to-side and what pitch do you have your game setup at? While the manual states the standard 6.5 degrees, Keith posted that he'd designed the game to be played at 7 degrees

#8057 44 days ago
Quoted from Manny65:

Not heard of or seen a ball hang there - double check your PF is level side-to-side and what pitch do you have your game setup at? While the manual states the standard 6.5 degrees, Keith posted that he'd designed the game to be played at 7 degrees

Set to 7 degrees and leveled side to side. When I’m bending the guide a little bit to the left the ball goes throw .

#8058 44 days ago

I read some of the above posts about the shaker motor rattle. I will add tape to the glass & back glass but some mention a setting in the software to adjust the motor runtime. I can't find it. Can someone guide me to it.
Thanks

#8059 44 days ago

Tilt Topper (I think I snagged the last NIB one) finally installed. I wasn’t comfortable with just 2-sided tape for installation so I created a base.

0CB23E72-11CB-4160-8D82-0DAEBD34506F (resized).jpeg3BD8DF80-ED1F-41BA-8ABB-4602C261768B (resized).jpegB1917289-9FF7-4551-B345-DAFEEC781016 (resized).jpeg

#8060 43 days ago

I used rare earth magnets for mine, and I can barely pull it off.

Quoted from Guinnesstime:

Tilt Topper (I think I snagged the last NIB one) finally installed. I wasn’t comfortable with just 2-sided tape for installation so I created a base.
[quoted image][quoted image][quoted image]

#8061 43 days ago

Hi! Need some help: I have a JPPE and recently the Jeep with the NewtonMail Will not move all the way around when hit. It stops midway. Tried some WD 40 but didn’t help. Anyone had the same issue?

Added some pictures. Even when it moves all the way, it doesn’t quite rest on the Newton ball…

13C7205B-535E-4BD2-A848-8E20B65CB582 (resized).jpeg98E740E3-78A6-46DC-8D49-DFFF061B4EE4 (resized).jpegF317B6C6-9F16-40EE-9702-FC45AE6EB351 (resized).jpeg
#8062 43 days ago
Quoted from Skhantom2:

Hi! Need some help: I have a JPPE and recently the Jeep with the NewtonMail Will not move all the way around when hit. It stops midway. Tried some WD 40 but didn’t help. Anyone had the same issue?

Very common problem,you need to take the jeep off and clean it up . Try not to use Wd 40 on your machine, better off using a small amount of 100% silicone liquid.
Just search this thread, there's a ton of info to get your Jeep working like new again.
Post # 4785 and 4786 should get your jeep rotation issue solved in no time . Just go to the other Jurassic Park club thread. Don't know why someone thought having two club threads was a good idea?

#8063 43 days ago
Quoted from ralphs007:

Very common problem,you need to take the jeep off and clean it up . Try not to use Wd 40 on your machine, better off using a small amount of 100% silicone liquid.
Just search this thread, there's a ton of info to get your Jeep working like new again.
Post # 4785 and 4786 should get your jeep rotation issue solved in no time . Just go to the other Jurassic Park club thread. Don't know why someone thought having two club threads was a good idea?

Thanks a bunch. Will try that!!

#8064 43 days ago
Quoted from Skhantom2:

Thanks a bunch. Will try that!!

Please inform Stern first. They like to hear about the Reoccurring problems found on NIB pins….

#8065 43 days ago
Quoted from Green-Machine:

Please inform Stern first. They like to hear about the Reoccurring problems found on NIB pins….

#8066 42 days ago
Quoted from Skhantom2:

Hi! Need some help: I have a JPPE and recently the Jeep with the NewtonMail Will not move all the way around when hit. It stops midway. Tried some WD 40 but didn’t help. Anyone had the same issue?
Added some pictures. Even when it moves all the way, it doesn’t quite rest on the Newton ball…
[quoted image][quoted image][quoted image]

Although you might be able to just clean it up and be good to go, you MIGHT find that someone at the factory over-tightened the allen screw on the collar underneath while it was mis-positioned. Doing so has not only caused the post to have no vertical play (space), but they may have tightened the allen screw so tight that it sank a divet into the flat surface on the post itself damaging it. The damaged post with the set screw divet no longer allows any adjusting of the vertical play as the allen set screw only has one place to land-- in the divet! As a comparison, think of the gap required when rebuilding any flipper assembly and how you need to be able to slide a credit card between the playfield and the bat to test the vertical play before you tighten it down. The Jeep assembly actually uses the SAME BUSHING PART as any flipper, so no wonder it has the same gap requirement.

Easy fix but will take a few minutes of carefully repairing the flat surface on the post with a flat file. (Look at post 7440 where I wrote about this). And if you are going to be dis-assembling the JEEP post anyway, you might want to order an "F7-13M" steel bearing to replace the plastic one STERN uses. (Amazon has them too)

#8067 42 days ago
Quoted from max_pinball:

Does anyone except from having stuck balls at the bumpers ? I attached a picture from the ball guide which causes the problem . Tried to bend it when it’s installed but can’t get it hold in position . After 3 plays or so the problem came back .
[quoted image]

Is it stuck on the ball guide or the gate? I had to lift one side of the gate to prevent slow rolls around the orbit from getting stuck.

#8068 42 days ago
Quoted from Flipstream:

Is it stuck on the ball guide or the gate? I had to lift one side of the gate to prevent slow rolls around the orbit from getting stuck.

It was the ball guide . Took it out and bend it since then no problems .
I am disappointed with Sterns quality . Just saw this on my last game
D5EE90D2-6CBA-405E-B29F-84BC167DCF72 (resized).jpeg

#8069 41 days ago

Finally in the club! I had some issues out of the box, and didn't want to post until my game was actually working. My main issue was that the exit ramp opto-sensor was bad out-of-the-box, and I didn't have any spares on hand. Took about 3 weeks to get the part from Stern. I should have just ordered one myself while I was waiting. But lesson learned.

Game is shooting very smooth and everything is working well now. Time to start putting on all the fun mods and accessories!

20210913_172546 (resized).jpg

#8070 41 days ago
Quoted from max_pinball:

It was the ball guide . Took it out and bend it since then no problems .
I am disappointed with Sterns quality . Just saw this on my last game
[quoted image]

What are we looking at?

#8071 41 days ago
Quoted from yzfguy:

What are we looking at?

Correct me if I’m wrong but this is not normal . Checked it that is no light reflection or something like that . Control room up post

72097385-C6D7-4489-BDC4-EC8CDD98C189 (resized).jpeg
#8072 41 days ago

Ooh. Is it chipped? Weird that the metal would wear rather than the wood. Maybe the coul sleeve is missing/ cracked? Either way I'd rather that than playfield damage!

#8073 41 days ago
Quoted from yzfguy:

Ooh. Is it chipped? Weird that the metal would wear rather than the wood. Maybe the coul sleeve is missing/ cracked? Either way I'd rather that than playfield damage!

I will ask my distributor. Just 200 plays until now. To me it seems chipped

#8074 41 days ago

The king needs his crown!

20210913_221406 (resized).jpg

I think the topper looks pretty nice in person, and it's got some nice lighting effects that don't come across in photos. Plus, I think stylistically it works best on the Premium. On the LE, it mirrors the art too much.

#8075 41 days ago

Ok it was my bad . I checked the post and it was just dirt or something like that . So embarrassed that I wrote it here ‍♂️

#8076 41 days ago
Quoted from DakotaMike:

The king needs his crown!
[quoted image]
I think the topper looks pretty nice in person, and it's got some nice lighting effects that don't come across in photos. Plus, I think stylistically it works best on the Premium. On the LE, it mirrors the art too much.

I agree, it looks amazing in person.

#8077 39 days ago

Anybody have any helpful hints on how to get the Cliffy carbon fiber ramp flaps properly oriented for installation? I’m guessing the adhesive backing is going to hinder sliding it around to get it perfect. I’m working on the tower ramp right now. It’s hard to get at. All I got is using some long tweezers, drop it and hope for the best. TIA

#8078 36 days ago

Hi all. Long time JP LE owner here. Got a couple odd issues popping up that I'm curious if anyone knows about. Apologies if answers are already in this thread, I did some searching and couldn't find anything specific to my issues.

1. T-Rex catches ball, magnet holds it, she chomp chomps then once she roars with her mouth open and begins to turn again, the ball falls out of her mouth. Is it possible that my magnet is wearing out? My t-rex software settings are all set to stock if that helps.

2. Upper right flipper: I don't know if its been this way all along but I noticed the flipper not triggering. From testing it appears that as we speak, the right flipper button must be pressed in all the way for the upper flipper to flip. Pressed in partially = the lower right flipper flips but the upper does not. Press it fully = both the lower and upper flippers flip. Does this sound like an intended design or do you think something has gone awry with my machine?

#8079 36 days ago
Quoted from timlah79:

Hi all. Long time JP LE owner here. Got a couple odd issues popping up that I'm curious if anyone knows about. Apologies if answers are already in this thread, I did some searching and couldn't find anything specific to my issues.
1. T-Rex catches ball, magnet holds it, she chomp chomps then once she roars with her mouth open and begins to turn again, the ball falls out of her mouth. Is it possible that my magnet is wearing out? My t-rex software settings are all set to stock if that helps.
2. Upper right flipper: I don't know if its been this way all along but I noticed the flipper not triggering. From testing it appears that as we speak, the right flipper button must be pressed in all the way for the upper flipper to flip. Pressed in partially = the lower right flipper flips but the upper does not. Press it fully = both the lower and upper flippers flip. Does this sound like an intended design or do you think something has gone awry with my machine?

#2 is referred to as "stage flipping" and is an intended design.
With enough practice it can allow you to cradle a ball on the right flipper but still have access to the "o" shot from the left flipper.

#8080 35 days ago

This fell out of my raptor pit while trying to take off my raptor… where does it go?

5F10EB59-5DF5-4504-B12E-AC7CDE97DF45 (resized).jpeg
#8081 35 days ago
Quoted from nicoy3k:

This fell out of my raptor pit while trying to take off my raptor… where does it go?[quoted image]

It protects the front edge of the raptor pit plastic. It goes under the front edge of 830-1034-16 (#1) on this diagram from the manual (part is not shown, but orientation should be obvious).

pasted_image (resized).png

#8082 33 days ago

whats a good re-sale price for a premium? i am thinking of letting mine go.

#8083 33 days ago
Quoted from rolandthoms:

whats a good re-sale price for a premium? i am thinking of letting mine go.

10 million

#8084 32 days ago
Quoted from rolandthoms:

whats a good re-sale price for a premium? i am thinking of letting mine go.

There is one in the market right now listed at $8500 and sale pending. There is one at $9500 that has not moved yet. Most of the typical mods found on a machine don't return their cost in resale, so be careful setting the bar too high if you decide to sell. So you might have a hint at the acceptable range for buyers right now.

#8085 32 days ago
Quoted from VindictiveX:

T-REX not Grabbing ball Consistently SOLVED.
Hey guys,
Just wanted to post this here as it may help some of you who are also having problems with the T-Rex not grabbing the ball consistently.
First of all, I did the mechanical adjustments that were listed previously in this thread by Keith and other posters regarding proper alignment of the T-rex. I ensured that when the T-rex opened his mouth that his jaw was resting lightly on the ramp and adjusted the T-rex left and right bias to make her jaw line up with the middle of the ramp. However, she still only grabbed the ball about 20% of the time. The other times it would just go in her mouth come back out and not even start the event. This made me realize that she was not being activated to grab the ball.
I went into switch mode and tested the opto on the trex ramp. it would trigger only if I placed a pinball directly on the ramp. If i raised the pinball even 1/8th of an inch off the ramp the the opto would disengage. I then tested the opto in the "O" lane. I could raise the ball 1/4 to 1/2 and inch and the opto would still be engaged. so with this information I realized I needed to raise the optics on the ramp because my pinball was jumping over the opto 70% of the time. However, there was no easy way to raise the opto as it is attached directly to the ramp. At this point I called Chaz at Stern, explained the problem, and asked if he knew of a way to raise these optics. He did not and suggested write a email and send pictures so he could forward to engineering.
However, once I got off the phone and realized there was not going to be an easy way to raise the optics, I started to think of other solutions. What I came up with is not elegant, but it works.
I covered the bottom half of the opto with tape.(see tape on ramp in the pictures below). This effectively raised the optics without physically moving it.
Now when in switch mode, i could raise the ball about 1/4 to half an inch off the ramp and the opto would still engage.
I then tested in game. Now, once the Trex opens her mouth to start a Trex mode, 100% of the shots to the ramp are recognized(starting the Trex event) and she grabs the ball about 80% - 90% of the time.
This is obviously not a permanent solution, but will work until I think of something else or Stern gets back to me.
hope this helps![quoted image][quoted image]

Thanks heaps for this, solved my problem 100%
Any permanent solution from Stern yet? Pretty ordinary they haven't resolved this yet, mine was only delivered a couple weeks ago and has this fault.

#8086 32 days ago
Quoted from dukejensen:

Thanks heaps for this, solved my problem 100%
Any permanent solution from Stern yet? Pretty ordinary they haven't resolved this yet, mine was only delivered a couple weeks ago and has this fault.

The good thing is that you solved the issue, so you can enjoy you game. Stern did release a fix for T-Rex around a year ago and all new games have it included - the left ramp protector now has the opto hole (the original version was shaped to avoid the opto), which they adjusted up to address this. So it would seem that your particular game and setup is causing slightly more air on the ball to most - if you don't want the tape that covers the lower part of the opto hole to be as visible, you could remove the left ramp protector and put the tape on the back side of the protector.

#8087 32 days ago
Quoted from timlah79:

T-Rex catches ball, magnet holds it, she chomp chomps then once she roars with her mouth open and begins to turn again, the ball falls out of her mouth. Is it possible that my magnet is wearing out? My t-rex software settings are all set to stock if that helps.

Bumping this conundrum to see if anyone has had an issue like this with their T-Rex magnet/hold?

#8088 30 days ago

Has anyone had problems where the ball doesn’t roll out from the raptor trap when the door goes down? It gets stuck on the left side and you have to shake the machine for it to come out? See picture for example. Really slows down that intense multi ball! Any ideas on this? Any adjustments that can be made?

B9596C6E-E88B-47DB-ACCB-12321D64D0B9 (resized).jpeg

#8089 30 days ago
Quoted from R_O_S_S:

Has anyone had problems where the ball doesn’t roll out from the raptor trap when the door goes down? It gets stuck on the left side and you have to shake the machine for it to come out? See picture for example. Really slows down that intense multi ball! Any ideas on this? Any adjustments that can be made?
[quoted image]

You need to adjust the raptor gate such that it is flush with the PF when in the down position - there are screws at the bottom of the gate mech that set the height. From the photo it looks like the top of your gate might be angled slightly, rather than being flat & level with the PF surface - you don't want there to be a lip at the front of the gate but equally it needs to be level at the back such that the ball doesn't rest in the gap. Anyway start with adjusting the height screws to see if that resolves the issue

#8090 30 days ago
Quoted from R_O_S_S:

Has anyone had problems where the ball doesn’t roll out from the raptor trap when the door goes down? It gets stuck on the left side and you have to shake the machine for it to come out? See picture for example. Really slows down that intense multi ball! Any ideas on this? Any adjustments that can be made?
[quoted image]

I also had this problem. It is easy to adjust, lift up the Playfield and you should be able to figure it out.

#8091 30 days ago
Quoted from Manny65:

You need to adjust the raptor gate such that it is flush with the PF when in the down position - there are screws at the bottom of the gate mech that set the height. From the photo it looks like the top of your gate might be angled slightly, rather than being flat & level with the PF surface - you don't want there to be a lip at the front of the gate but equally it needs to be level at the back such that the ball doesn't rest in the gap. Anyway start with adjusting the height screws to see if that resolves the issue

This worked beautifully, thanks both for your quick help!

#8092 30 days ago

your up post seems a little below the playfield too. You may want to adjust that even though it is not causing your issue.

#8093 29 days ago

My Jeep mech is not turning freely anymore! I think I lost an iyem (with the metal balls/ rollers in)
I forgot the name but I think it fell out when I tried to fix the jeep angle.

Anyone has a drawing and a partnumber of the jeep mech?

Thank you!

#8094 29 days ago
Quoted from PinPeet:

My Jeep mech is not turning freely anymore! I think I lost an iyem (with the metal balls/ rollers in)
I forgot the name but I think it fell out when I tried to fix the jeep angle.
Anyone has a drawing and a partnumber of the jeep mech?
Thank you!

It's in the game manual:

https://sternpinball.com/wp-content/uploads/2020/04/JurassicPark_LE_Pre_web.pdf

#8095 29 days ago
Quoted from PinPeet:

My Jeep mech is not turning freely anymore! I think I lost an iyem (with the metal balls/ rollers in)
I forgot the name but I think it fell out when I tried to fix the jeep angle.
Anyone has a drawing and a partnumber of the jeep mech?
Thank you!

Note that the washers and ball race are not listed in the manual - an unfortunate oversight. That said some owners have been switching out the factory one for a higher quality part. Check out Markharris2000 posts

https://pinside.com/pinball/forum/topic/welcome-to-the-jurassic-park-le-club/page/153#post-6381215
https://pinside.com/pinball/forum/topic/welcome-to-the-jurassic-park-le-club/page/155#post-6390245

#8096 29 days ago
Quoted from PinPeet:

My Jeep mech is not turning freely anymore! I think I lost an iyem (with the metal balls/ rollers in)
I forgot the name but I think it fell out when I tried to fix the jeep angle.
Anyone has a drawing and a partnumber of the jeep mech?
Thank you!

Here's the part Manny65 recommended. amazon.com link »

#8097 29 days ago
Quoted from timlah79:

Bumping this conundrum to see if anyone has had an issue like this with their T-Rex magnet/hold?

Sorry, can't help out, but good luck Tim! Sounds like maybe a wire or connection is loose, and when the Trex moves a certain way power is cut to the magnet? Just a guess.

#8098 29 days ago
Quoted from Manny65:

Note that the washers and ball race are not listed in the manual - an unfortunate oversight. That said some owners have been switching out the factory one for a higher quality part. Check out Markharris2000 posts
https://pinside.com/pinball/forum/topic/welcome-to-the-jurassic-park-le-club/page/153#post-6381215

https://pinside.com/pinball/forum/topic/welcome-to-the-jurassic-park-le-club/page/155#post-6390245

Thank you so much! Ordered

#8099 29 days ago
Quoted from DakotaMike:

Sorry, can't help out, but good luck Tim! Sounds like maybe a wire or connection is loose, and when the Trex moves a certain way power is cut to the magnet? Just a guess.

Thanks DakotaMike . I'm not sure if it's a loose connection as sometimes it doesn't even take much of a head turn for the ball to fall from the magnet. The ball sometimes falls out as she's raising her head vertically too. I'm not sure how to test the magnet appropriately either. If I go into coil test for the t-rex magnet, hold the button, the magnet holds the ball but as soon as I manually lower the jaw while still holding the test button, it falls out of her mouth. Unsure if that's expected or not. I also don't know if there's a magnet strength setting. The only setting I've found for something related is T-REX MAG THROW MAG OFF TICKS and T-REX JAW HOLD POWER. My guess is the former is just how long to hold the ball and the latter may have nothing to do with the magnet, just the jaw? Both are default and changing them doesn't seem to have any noticeable effect. I did try cleaning the magnet with contact cleaner. Maybe that will help. If not, I guess I should just replace the coil + magnet assembly. Really not sure.

#8100 28 days ago

Hey Folks. Searched the forum and couldn't find the answer to this problem. My raptor pen gate is raising and lowering just fine. However, on ball capture in the pen the metal bar is stopping the ball but the gate isn't raising to hold the it. The ball is released and play resumes - I still get the MB by hitting the pen a number of times. Just wondering why my gate isn't raising. Also, once game ends and i start a new game, the gate goes back up.

SMH. Thanks in advance for any guidance.

There are 8219 posts in this topic. You are on page 162 of 165.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside