Weird start button issue

(Topic ID: 238479)

Weird start button issue


By meeotch

5 days ago



Topic Stats

  • 2 posts
  • 1 Pinsider participating
  • Latest reply 2 days ago by meeotch
  • No one calls this topic a favorite

You

Linked Games

#1 5 days ago

Having a strange start button problem with my MM. For some reason, it takes several button presses to start a game initially. Sometimes as many as a dozen. The weird bit is that the switch doesn't seem to be intermittent - in the switch test, it works fine, every push. Also, holding it down shows solid in the test, no flickering. And once a game is started, adding extra players works fine, every time.

In fact, if I remove the wires from the switch and manually make the connection between green and yellow, I get the same results: it takes many connections for the first one to start a game, then it's fine after. Entering test mode and then back out to game mode seems to "reset" the behavior, and you have to hit the button a bunch of times again. I even tested it with the balls out, so that hitting start triggers the "locating balls" cycle instead of starting the game... This way, I verified that the first button press takes many tries, and then it works flawlessly. Everything I've tried seems to indicate that the switch & wiring are fine.

Is there something in the switch matrix that would account for this? Or am I missing something stupid? The other switches in that row and column work fine - but then again, the start button works fine in test mode as well. (n.b. - I currently have the machine in pieces, so there are some other switches that are currently not attached to the game. But I don't think that should make a difference.)

#2 2 days ago

For anyone who encounters this in the future: it turned out to be simpler than I thought. In fact, the start button was failing to start a game until some point during the first attract mode cycle on boot-up. Some time after the high scores are displayed, so 20-30sec after the boot tests complete. After I got all the ramps and everything reinstalled, the problem went away.

My suspicion is that the machine was looking for some switch or something that was missing (like one of the optos, which are normally closed), and spending time thinking about that without making any indication that it was confused. Anyway, good to know, if you're testing the game while it's not totally assembled.

One thing I discovered: the start button is in the switch matrix on paper, but in fact when you pull the row & column connectors, it still registers in the switch test. I'm still not 100% sure how the wiring works for that, as it's not listed as a "direct switch" to my knowledge.

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 369.95
Boards
PinSound
$ 98.00
Playfield - Other
ModFather Pinball Mods
$ 25.00
Gameroom - Decorations
Pinball Photos
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 44.00
Playfield - Toys/Add-ons
Lermods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 29.00
Boards
KAHR.US Circuits
7,200 (Firm)
Machine - For Sale
Clearwater, FL
€ 40.00
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 369.00
Cabinet - Decals
Mircoplayfields
7,995
Machine - For Sale
West Chicago, IL
From: $ 16.95
$ 25.00
Gameroom - Decorations
Pinball Photos
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 55.00
Gameroom - Decorations
Pinball Photos
7,500
Machine - For Sale
Edmond, OK
€ 95.00
Lighting - Led
FlipperLED
€ 197.00
$ 50.00
$ 36.99
Lighting - Interactive
Lee's Parts
$ 129.00
Lighting - Led
LED OCD

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside