New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 270253)

Weird problem with Black Rose flipper. Help!


By action76

4 months ago



Topic Stats

  • 5 posts
  • 3 Pinsiders participating
  • Latest reply 4 months ago by action76
  • Topic is favorited by 2 Pinsiders

You

Linked Games

#1 4 months ago

The flipper on my Black Rose works and flips in game but it will not work in test. You can play a game and it flips like it supposed to. However, I get a credit dot and the message "Check Switch F2 R. Flipper Button" every time the machine is started. Switch test does not register and flipper will not flip in test. You cannot use the right flipper button in video modes or to enter initials for high score or to lane change. The upper right flipper seems to work fine in game and test. I have swapped the flipper opto boards and the problem remains on the right side. I have also swapped the Fliptronics II board with no change. I am very confused. What could be causing this issue. Any help is greatly appreciated.

#2 4 months ago

Has it always been like that, or did it start happening recently?

Checked continuity from the opto board to the fliptronics?

#3 4 months ago

I just got this machine but I assume it did not always do this. The other owner said he just replaced the Fliptronics board with a Rottendog board and replaced the flipper opto board. He noticed that issue afterwards. He thought he had gotten a faulty opto board but that is apparently not it. I currently have and original Fliptronics board in it (thinking it might be the Rottendog board) but that did not help either.

#4 4 months ago

Does the cpu have battery damage? It could also be a ribbon cable issue, bad info from the Fliptronics board to cpu.

#5 4 months ago
Quoted from zacaj:

Checked continuity from the opto board to the fliptronics?

Good call. The Blue/Purple wire was not punched down well in the IDC connector on J905. It was one of the two wires that go to the R Flipper opto. I punched it back down and the error went away and now flips in test.

Quoted from grumppy:

It could also be a ribbon cable issue, bad info from the Fliptronics board to cpu.

Well while not exactly the problem, I was able to find the problem while I was examining and reseating the ribbon cable.

Thanks both of you for pointing me in the right direction.

Promoted items from the Pinside Marketplace
$ 19.99
Electronics
PinballElectronics.com
From: $ 369.95
Boards
PinSound
$ 87.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside