(Topic ID: 282707)

WCS Occasionally Sounds like all Switches are registering

By mbelofsky

10 months ago



Topic Stats

  • 8 posts
  • 2 Pinsiders participating
  • Latest reply 20 days ago by mbelofsky
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 10 months ago

I have searched pinside and the web. The problem is probably on the board but still trying to track this problem down.

I bought a World Cup Soccer. The batteries were on a connected board. The batteries were slightly corroded but only affected the black battery holder on the connected board. I replaced the battery holder with a remote battery holder. I checked the MPU and does not have any issues.

I kept the game on and played it for several days while testing it and looking for issues.

After a few days of owning the game, it sounded like the test buttons went crazy and it said "Ground Short Row 1 Switch closed". I tested all switches in row 1 and they were fine. I checked for grounded wires and bad diodes. Didn't see any. I did notice the white/ brown wire was disconnected from the coin interface board and well as the slam tilt was disconnected from the bottom of the interface board. This implies that this error has occurred in the past. I reconnected the wire and plugged in the connector. The slam switch in the cabinet and on the coin door worked without issue. The above message only occurred twice and never again.

I played the game for several days and put it in test mode T1. Switch Edges when not playing. Twice it made beeps. One time I could see a bunch of switches registering in switch test but too fast to see the row or column.

In T1. Switch Edges, I tested all switches. They register correctly and do not register multiple switches.

The one time in Switch Edges that I was looking, the whole 8X8 matrix closed. I assumed beeped 63 times or so and then went back to normal like nothing happened.

I disconnected the row and column connectors to the MPU and tested each combination with no issues.

I replaced the test button just because they were jerry-rigged and no changes.

I now have the game in T1 Switch edges test. I staged a ball in 7 locations 1. back VUK 2. TV Scoop 3. Top eject hole 4. Left eject hole 5. Right eject hole 6. Left outlane kicker 7. trough. I also placed a post near both slings in case they fire.

The last time it happened, I heard a few switches go off, heard one coil fire (don't know which one) and the game changed for being in T1. Switch Edges to beignet the menu selection for T1. Switch Edges.

I have tested the game with the play field in the normal position, up on the slides on the lock bar area and leaning agains the back box. I have tried to bang the play field, cabinet and backbone with no results.

There is no pattern to when and why this occurs.

So I think this has happened 6 times in the 5.5 days.

I now have the ramps off as well as the coin toss. This eliminates any switch in column 7 and the 3 opts on the coin toss mechanism.

Any other suggestions appreciated.

I know this is a long description, but my goal is to post the solution once I find it to help others with similar issues in the future.

#2 10 months ago

Additional info:

I let it run for an 3 hours and no switches engaged.

I turned off the game and thought I would try a Kahr.us daughter board (2017 version).

I added it in and turn on the game and it went crazy. I didn't even keep it on long enough to realize what was happening but it wasn't right.

I took the daughterboard out and plugged back the connectors.

I use the daughterboard to help expose issues. I sent this to Rob Kahr and he suggested that the 12 volts on the driver could be the issue. Which I actually should have thought about but was concentrating on the MPU. (I wrote this after I posted this as a follow up. I will follow up with the results of the replaced driver board in a new post below.)

Now it says "Ground Short Row 1 is stuck closed."

The coils are firing one at a time.

I hit the test button once. Coils stop. Screen says "Test Report" then all the test buttons stop working and I can go no further.

My ULN2803A is socketed. I replace it. I also disconnected the remote battery holder to take the boat out of the game.

I replace ULN2803A and reconnect in the game with the remote battery connected.

I turn on the game. It says "Factory Settings Restored". None of the test buttons work. U16 and U17 are the LM339s that control the dedicated switches and are not socketed. So I guess I need to take them out, add sockets and place back in to see what the next error is. I assume the other LM339s will also not work either.

#3 10 months ago

Thanks to the suggestion from Rob and a discussion with him, I swapped out the driver board. (Luckily I have 6 extra boards.)

The game booted up to Credit 0. I set the time and date and set free play using the test buttons and the tests all seem to work (although my game is apart and cannot test everything right now.)

So in summary, this intermittent switch issue which sometimes felt like test buttons going off or switches in the switch matrix all going off, was due to a faulty 12 volt power provided from the driver board.

By me using Rob's daughterboard to stress the 12 volt circuit (and probably also taking off and putting on connectors), this helped me isolate the problem to the driver board.

I will keep testing and report back here to help others (and maybe even myself) in the future. Thanks Rob!

#4 10 months ago

C2 (100uf 25v) on the driver driver board likes to leak and cause issues supplying 12volts to the switch matrix U20 IC. If it looks wet under or around C2, that is an issue and need to replace that capacitor. I also replace the 100uf 100v capacitor as well, which on occasion leaks but not as often as C2.

1 month later
#5 9 months ago

Have you replaced C2 yet?

#6 9 months ago
Quoted from PinballManiac40:

Have you replaced C2 yet?

I replaced the driver board with another I had and the game worked. I sent the board to a friend since he tests it all for me and he did replace C2 as well as other stuff. Thanks

#7 9 months ago
Quoted from mbelofsky:

I sent the board to a friend since he tests it all for me and he did replace C2 as well as other stuff. Thanks

So it is working now? What other parts?

8 months later
#8 20 days ago
Quoted from PinballManiac40:

So it is working now? What other parts?

Sorry for the delay. I didn’t see this. The driver board works. I don’t remember what else he did

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside