(Topic ID: 167138)

No Sound TAF -- What am I missing? *FIXED*


By The_Director

2 years ago



Topic Stats

  • 19 posts
  • 6 Pinsiders participating
  • Latest reply 2 years ago by The_Director
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

IMG_6669 (resized).JPG

#1 2 years ago

So, this one has been a test and I'm reaching out to see if anyone can offer some suggestion. This machine had a U9 RAM error on the sound board. Ribbon cable was first replacement. The RAM was socketed and replaced and this happened upon boot. I swapped sound boards with Fish Tales and Fish Tales works perfect with the repaired TAF sound board. TAF, with the perfectly working in Fish Tales sound board, did this again. Speakers and speaker wiring is fine. ROM was re-burned, same issue. ROM was re-burned on a different chip, same issue. 5v was a little low on sound board, known working power driver installed -- same issue. Could it be CPU? Known working CPU installed -- same issue. I'm running out of ideas and/or missing something obvious from looking at it too long. Let me know if any of you guys have seen this before. Doesn't seem the sound rev is being recognized either. All ROMs appropriately transferred to proper game, CPU ROM also re-burned.

#2 2 years ago

Very long boot sequence too, but no sound errors. Just no sound; otherwise, game plays fine.

#3 2 years ago

It made these same pop and click sounds when I owned it Director.

#4 2 years ago

No sound or bong though currently, that's the main issue. No error but no sound either.

#5 2 years ago

Disconnect ribbon cable from sound board.

See if you get a bong, and see if it boots up faster..?

#7 2 years ago

Bumping, any thoughts. Upon boot up, I do get a pulse from backbox speaker a few times. Getting 4.95v at sound board, little low but well within logic range generally.

#8 2 years ago

Did you check the simple things first?

If you have a loose wire to the big speaker at the bottom of the cabinet, your TAF will have no sound.

#9 2 years ago

Yeah, traced connections of both yellow-black wires and black wires on all three speakers back to connector with continuity test. Interestingly, this TAF is wired like some Hurricanes and T2s -- black/black yellow wires coming from both J504 and J505, with no interconnect.

#10 2 years ago

Bad audio amps on the sound board ?

#12 2 years ago

Could a blown tweeter cause the whole thing not to work?

#13 2 years ago
Quoted from The_Director:

Could a blown tweeter cause the whole thing not to work?

Yes. I had a T2 with this issue.

Maybe try swapping speakers.

#14 2 years ago

Replaced tweeter, still no luck. Have replaced other back box speaker too with known working and no luck. Only one is cab speaker that I haven't replaced.

#15 2 years ago

So, I finally got this thing to boot a sound rev, but still not work. This was the downloaded L-1 sound ROM burn from IPDB, but I'm getting Sound Rev P-7 which seems a little weird. Anyone know what's up with that?

IMG_6669 (resized).JPG

#16 2 years ago

since you are on a swap binge, why not swap the cab speaker also?

It's known that a loose wire will kill the sound, possibly a blown cab speaker would too.

#17 2 years ago

Just swapped cab speaker from FT, no luck :/. Does that sound rev look right?

#18 2 years ago

Well if the board works and the speakers work in another machine, I would say it's got to be a wiring issue 1st, then bad sound ROM 2nd. I would take all the speakers from TAF and put them in FT. If they work, then I would test continuity on all the speaker wiring and grounds in TAF. If that checks out I would get a new sound ROM. After that, I don't know, possibly mpu? Not sure that helps, but I checked mine. I have rev p-2 ,but mine is original.

#19 2 years ago

So, finally have the sound fixed. My best guess is that the L-1 sound ROM file on IPDB is corrupt or can only be burned on a certain size chip. We burned on multiple 4MB chips and tried several different game ROM configs and nothing would get that sound on. Ditched the normal TAF game rom and switched the machine over to 1 4MB TAFG game ROM and the two sound ROMs on 4MB chips and everything is working great. This issue has been a nightmare and think it was a bit part of several things, but might be worth looking into that L-1 sound EPROM on IPDB if someone has a known good file for it.

Promoted items from the Pinside Marketplace
$ 27.99
Playfield - Protection
Lee's Parts
$ 28.00
Wanted
Machine - Wanted
Mukwonago, WI
Wanted
Machine - Wanted
Fort Worth, TX
6,000
Sale Pending!
Des Moines, IA
$ 229.99
Lighting - Other
Lighted Pinball Mods
From: $ 175.00
Gameroom - Decorations
Pinball Photos
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 279.95
$ 58.00
Playfield - Toys/Add-ons
Lermods
From: $ 11.95
Playfield - Toys/Add-ons
ULEKstore
$ 29.99
Lighting - Interactive
Lee's Parts
$ 999.00
$ 14.95
$ 40.00
Lighting - Other
Rock Custom Pinball
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 39.99
Lighting - Interactive
Lee's Parts
€ 3.70
From: $ 149.00
Playfield - Toys/Add-ons
Sparky Pinball
€ 18.95
Hey modders!
Your shop name here

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside