New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 65979)

Vector Owners Club & Restorations Fans Also Welcome


By Hellfire

6 years ago



Topic Stats

  • 151 posts
  • 53 Pinsiders participating
  • Latest reply 41 days ago by cooperscooter
  • Topic is favorited by 25 Pinsiders

You

Linked Games

Topic Gallery

There have been 99 images uploaded to this topic. (View topic image gallery).

Screen Shot 2020-06-05 at 10.49.28 PM (resized).png
Screen Shot 2020-06-04 at 11.48.47 PM (resized).png
IMG_3815 (resized).jpg
VECTOR 3 (resized).JPG
VECTOR 2 (resized).JPG
VECTOR 1 (resized).JPG
20190916_192824 (resized).jpg
20190916_192828 (resized).jpg
20190916_192831 (resized).jpg
32AE2031-DAC9-4172-AAA4-797F03818E39 (resized).jpeg
77A6599A-D11A-4A12-89AC-D4FAEC0963F9 (resized).jpeg
6350EF04-9FF1-4F77-8689-81C6AA5E9EA9 (resized).jpeg
B22F04BA-96E8-4AF8-BEBE-087CA6B9EF9F (resized).jpeg
pasted_image (resized).png
pasted_image (resized).png
pasted_image (resized).png

There are 151 posts in this topic. You are on page 3 of 4.
#101 2 years ago
Quoted from schudel5:

Marco has the entire set including the defender targets. Fortunately they carry the Y and Z target separately, but unfortunately not the X. So if you want those you have to get the defender ones too in the set. I ended up replacing all the targets in mine and they are nice targets that drop well and never bricked for me at all.
http://www.marcospecialties.com/pinball-parts/A-3944-54SET

Awesome. All mine need replaced. Guess I’ll go with Marco on this order.

Another thing I need to do is get new tall screws for the ECU plastic over the ball locks. My game is missing half of them. I’m gonna go to the hardware store but wasn’t sure if there was a better way than that. I typically take one to the store and try to find a match.

#102 2 years ago
Quoted from JeffZee:

Hello Vector owners. I'm still looking for a better Vector picture for my Kmiec Red Post web page.

I restored the Kmiec red post sometime ago jeffzee but forgot to post.

20170409_103136 (resized).jpg

#103 2 years ago
Quoted from astyy:

I restored the Kmiec red post sometime ago jeffzee but forgot to post.

I was under the impression that Vector had a translucent red finned post as opposed to the old solid red. I have not seen many Vectors so I'm not sure what the consensus might be.

2 weeks later
#104 2 years ago
Quoted from JeffZee:

I was under the impression that Vector had a translucent red finned post as opposed to the old solid red. I have not seen many Vectors so I'm not sure what the consensus might be.

No idea, I've had 3 original/tatty condition ones through my hands (in UK) and none of them had it. Perhaps it's the stuff of folklore but I like the idea of it being an EM post.

1 month later
#105 2 years ago

I’m BACK in the club. 1st game I’ve owned twice, which is telling. Missed it!

Playfield has issues and hoping a repro comes. Plays well and original plastics are much nicer than my last game. Backglass is perfect.

Note: mini flipper

EB1EAE09-C937-447E-BAB3-12604C03E426 (resized).jpeg

9565CBE6-3452-4C5B-9D66-70A43EFE5EF0 (resized).jpeg

3 weeks later
#106 2 years ago

Whilst packing up my loan VECTOR today for a new home I noticed the rebound post between the flippers, my project VECTOR doesn't have this post or a hole in the playfield where it would have been installed. Subsequently looking at online images it seems common to have it or not and the pf diagrams in the manual shows it.

I wonder what the story is here, perhaps it was supplied for operator fit to make the game easier and some just were never fitted, perhaps it got removed from production at a later stage. I'm not keen on screwing new holes in playfields, what's the concensus is it needed?

#107 2 years ago

I am thinking of selling my Vector if anyone interested. Beautiful pf, auto cleared, perfect bg's, new driver board, new plastics, rubbers, and drops. All new lamp sockets. LEDs. Wiring at coin door could be cleaned up a bit. PM me for info.

#108 2 years ago

Some pics.

IMG_20180412_090042820 (resized).jpg

#109 2 years ago

IMG_20180412_090034651 (resized).jpg

#110 2 years ago

IMG_20180412_090057123 (resized).jpg

#111 2 years ago

IMG_20180412_090110933 (resized).jpg

#112 2 years ago

IMG_20180412_090115061 (resized).jpg

4 months later
#113 2 years ago

For the 7 digit in the attached picture here, is this a repair I can do? Does it involve just freshening up the solder connections on the board? Or is it something a bit more elaborate and pricey?

P_20180828_180753 (resized).jpg
#114 2 years ago
Quoted from s1500:

For the 7 digit in the attached picture here, is this a repair I can do? Does it involve just freshening up the solder connections on the board? Or is it something a bit more elaborate and pricey?
[quoted image]

as long as any digit works completely it can usually be fixed. read this to get an idea http://stevekulpa.net/pinball/bally_disp6r.htm

#115 2 years ago
Quoted from Cheddar:

as long as any digit works completely it can usually be fixed. read this to get an idea http://stevekulpa.net/pinball/bally_disp6r.htm

Taking a look at the page, it looks like some cold solder joints could use some freshening up. I know I had to do that to a small driver board on this, and after that, the wrong coils stopped firing. It became playable without unexpected multiball.

I have a feeling the non-working pop bumper is going to do a little more investigation.

#116 2 years ago
Quoted from Aeolus7:

Note: mini flipper

Note: All production Vectors where made with the large flipper on the top mini playfield.
----- The production engineer in charge of the entire run of Vector, from the Bally plant,
----- made the final decision on the test white wood playfield, in order to get the ball out
----- of the area and balance the playfield flow. The center plastic on the top playfield
----- was raised med-through the production run to keep the ball from getting stuck
----- between the glass and plastic.

8 months later
#117 1 year ago

Just picked up a Vector and now in need of one plastic. Does anyone have just the center plastic with all the designers names and the TV with the Adams family? Please let me know.
Mike

vector pl (resized).jpg
1 month later
#118 1 year ago

I'm restoring my Vector project, unfortunately it came with "alien" wiring looms that I'm adapting, the main backbox loom I believe to be from EBD. It is a good starting point and I can sort out most of the deltas by comparing schematics, however I'm stuck on how to route the following Gray/Brown (96) wire which according to the schematics goes from A1J2-23 (the White 24-pin plug to the Aux loom) to MPU A4 J4-16 to HV A3 J3-14

Below are some pics to help identify if - if anybody could help physically trace the wire from the 24-pin plug in their machine so I can install it, or even confirm continuity between those 3 points (schematics can be wrong!) I'd much appreciate it.

The wire shown in the schematic - I don't know where it's jumpered, I have the connection between MPU A4 J4-16 to HV A3 J3-14 (per EBD)
pasted_image (resized).png

I need to trace it from the A1J2 connector that plugs in here
pasted_image (resized).png

#119 1 year ago

^^^ solved. Bally stuffed two of the Gray/Brown wire onto a single pin at the back cab plug - surely an illegal crimp
pasted_image (resized).png

I traced the wire to the pf where it taps via a resistor into the Orange/Blue Switch Strobe 5 line at the X drop target switch. See photo below - I don't understand why an extra wire is connected to the switch matrix but interested if somebody can explain it.
pasted_image (resized).png

#120 1 year ago

Just joined the club!
Looking to buy the home eeproms without getting a stupid shippong quote (Am in Switzerland)
Any idea?

#121 1 year ago

Ok, 2 more questions

Voices volume is very low compared to sound FX. Have already turned the voice knob all the way up, but still quite faint. an amp is dying? Which one?

Second issue: it's kicking 2 balls, always. Only have 3 balls inside, checked the through switches, they look fine. any idea? Looks like it works ok with only 2 balls :-s

#122 1 year ago

Anyone have the Alltek MPU board in their Vector?? Thinking about putting one in mine, and reading the online instructions for the board it shows that it has the upgraded Vector ROM code as an option, however it says something about Free Play not working with the upgraded Vector code. Is that true??

1 week later
#123 1 year ago
Quoted from Nihonmasa:

Ok, 2 more questions
Voices volume is very low compared to sound FX. Have already turned the voice knob all the way up, but still quite faint. an amp is dying? Which one?
Second issue: it's kicking 2 balls, always. Only have 3 balls inside, checked the through switches, they look fine. any idea? Looks like it works ok with only 2 balls :-s

If the game starts w only 2 balls inside id say its your drain switch.A new game should have to have all 3 balls for the switch to activate and game to start,probably just needs readjusted as when lifting pf its real easy to grab and bend switch

#124 1 year ago

Thanks but both issues were solved
3rd saucer switch was always on

#125 1 year ago
Quoted from Nihonmasa:

Thanks but both issues were solved
3rd saucer switch was always on

Nice!

1 week later
#126 1 year ago

Im needing a couple things that were missing on my vector,the ball gate thats up top by energy storage and the post thats to the right of the vector ramp,a couple bad plastics too,any leads would be much appreciated thanks

1 month later
#127 1 year ago

I’m in the club. Bought a non working machine with a very nice cabinet, playfield and back glass. The boards look clean too. Now it’s time to get the multimeter out and get to testing before power up. My youngest can’t wait

B22F04BA-96E8-4AF8-BEBE-087CA6B9EF9F (resized).jpeg32AE2031-DAC9-4172-AAA4-797F03818E39 (resized).jpeg77A6599A-D11A-4A12-89AC-D4FAEC0963F9 (resized).jpeg6350EF04-9FF1-4F77-8689-81C6AA5E9EA9 (resized).jpeg
#128 12 months ago
Quoted from Phesson:

I’m in the club. Bought a non working machine with a very nice cabinet, playfield and back glass. The boards look clean too. Now it’s time to get the multimeter out and get to testing before power up. My youngest can’t wait

Welcome to the Bill Validator door club!!

#129 12 months ago
Quoted from pinfixer:

Welcome to the Bill Validator door club!!

I'm in

#130 12 months ago

A few pics from mine which I finished restoring.
Really happy with its look.

20190916_192824 (resized).jpg20190916_192828 (resized).jpg20190916_192831 (resized).jpg
#131 11 months ago
Quoted from astyy:

I don't understand why an extra wire is connected to the switch matrix but interested if somebody can explain it.

Bally ran out of PIA switch strobe lines...
The MPU has four dedicated continuous solenoid data lines
[ PB4, PB5, PB6, PB7 ]
PB4 is normally used to drive Q17
PB4 A4J4-5 is used now to drive ST5.
The resistor is used as a "pullup" to keep the line from floating.

5 months later
#132 6 months ago

Hello Vector fans ... can I ask someone to do me a favour?

My Vector is going for a car ride in a couple of days ... just need to know the approximate length of the cabinet for the guy (including shooter) as I’m away from home.

And a guess at the “head folded down” height as well.

Thanks in advance!

Dave.

#133 6 months ago
Quoted from rotordave:

Hello Vector fans ... can I ask someone to do me a favour?
My Vector is going for a car ride in a couple of days ... just need to know the approximate length of the cabinet for the guy (including shooter) as I’m away from home.
And a guess at the “head folded down” height as well.
Thanks in advance!
Dave.

Cab length inc. shooter < 140cm comfortable, + more if any op fitted skids to back.
Head folded down, widest height bottom of cab to top of bb plinth 55cm, + backbox width 24-27cm, so approx 80cm. In my VW Golf this is the problem and I have to remove the head to transport, length is fine.

I hope that helps

#134 6 months ago

Awesome man, thanks!

rd

2 months later
#135 4 months ago

I'm in... just got a Vector this weekend (traded my Embryon for it) and its a hard but fun machine.
Is there any advice on upgrades or owning this title in general?
Anyone put titan bands on theirs?
thanks.

VECTOR 1 (resized).JPGVECTOR 2 (resized).JPGVECTOR 3 (resized).JPG
#136 4 months ago
Quoted from Nihonmasa:

A few pics from mine which I finished restoring.
Really happy with its look.[quoted image][quoted image][quoted image]

looks good! did you add more lights to the playfield?

#137 4 months ago

Does anyone have a pair of sling plastics they’d part with?

1 week later
#138 3 months ago

I just got a Vector in great condition, but I'm having an issue with the front left row of drop targets (defenders). At the start of the game all drop targets come up, meaning defenders 1-6 and x,y,z. Defenders 4-6 should drop after coming up (at power on and again after pressing the start button), but do not. If I complete x,y,z in order one of the 1-3 defenders drops as it should, but all 4-6 defenders come back up.

I'm running the v5 ROM and I don't think that would have anything to do with it as I'm guessing many of you are using it as well for the added skillshots, scoring and enabling unused speech samples.

I've attached an image of how my 4-6 drop targets are wired if anyone is able to verify against their table.

Thanks everyone! Looks like this is going to be a great table!

IMG_3815 (resized).jpg
#139 3 months ago
Quoted from aragornsawyer:

I just got a Vector in great condition, but I'm having an issue with the front left row of drop targets (defenders). At the start of the game all drop targets come up, meaning defenders 1-6 and x,y,z. Defenders 4-6 should drop after coming up (at power on and again after pressing the start button), but do not. If I complete x,y,z in order one of the 1-3 defenders drops as it should, but all 4-6 defenders come back up.
I'm running the v5 ROM and I don't think that would have anything to do with it as I'm guessing many of you are using it as well for the added skillshots, scoring and enabling unused speech samples.
I've attached an image of how my 4-6 drop targets are wired if anyone is able to verify against their table.
Thanks everyone! Looks like this is going to be a great table!
[quoted image]

I think those are all run off an expander relay, i'd say start there. Make sure there is a good incandescent bulb installed next to it.
Screen Shot 2020-06-04 at 11.48.47 PM (resized).png

#140 3 months ago

Thank you. The solenoid tests all work as expected (setup and drop of targets) and numbers all match according to the manual, but the solenoid expander board has been making some strange buzzing and crackling noises. I found another post where someone said that it had to do with the power supply and the voltage it supplies to the feature lamps. His issue ended up being a fried bridge rectifier. I will keep digging.

#141 3 months ago

On the Solenoid Driver A3 board (AS-2518-22) TP's 1-4 test within range. TP5 ("All Coils") should be between 40-50VDC according to my research and I'm reading 13.2-13.7. Table is playable though. Still just having an issue with the 4-6 defenders not dropping when they should and coming back up when they shouldn't after completing the x,y,z drops. If the coils are running at 1/3rd of capacity might that explain some of my issues and also make slings and flippers a bit weak? Feels like a stretch...

#142 3 months ago
Quoted from aragornsawyer:

On the Solenoid Driver A3 board (AS-2518-22) TP's 1-4 test within range. TP5 ("All Coils") should be between 40-50VDC according to my research and I'm reading 13.2-13.7. Table is playable though. Still just having an issue with the 4-6 defenders not dropping when they should and coming back up when they shouldn't after completing the x,y,z drops. If the coils are running at 1/3rd of capacity might that explain some of my issues and also make slings and flippers a bit weak? Feels like a stretch...

Hmmm, TP5 says 11.9VDC?

rectifier board TP5 is supposed to be 43VDC. its unregulated but 13 seems low. What voltage do you have going into that rectifier?

Screen Shot 2020-06-05 at 10.49.28 PM (resized).png

#143 3 months ago
Quoted from mjalexan:

Hmmm, TP5 says 11.9VDC?

That test point is for the +5volt regulator. +12 to +15 volt should be normal.
It has nothing to do with the +43 volts for the games solenoid voltage.
The only +43 volt input, is from the J3-pin5 wire [30] yellow, from the
bottom bridge power supply board that supplies the voltage to the flipper relay.

#144 3 months ago
Quoted from vec-tor:

That test point is for the +5volt regulator. +12 to +15 volt should be normal.
It has nothing to do with the +43 volts for the games solenoid voltage.
The only +43 volt input, is from the J3-pin5 wire [30] yellow, from the
bottom bridge power supply board that supplies the voltage to the flipper relay.

right right, my point was i think he's looking for the wrong target voltage. the rectifier board in the bottom of the cabinet should have 43VDC at TP5. driver board in the backbox TP5 should be 11.9VDC.

#145 3 months ago

Thank you mjalexan & vec-tor. Sorry for the delay, I ended up blowing the 1A fuse in the playfield and it took me a while to track down. Well actually it appears that someone had put in a 2A, so I replaced with a 1A slo blo and I'm back in business. I was not looking at the rectifier board at the bottom of the cabinet which is pretty dumb as that's where the main power comes in. -I just didn't realize. My readings from the bottom are: TP1 6.86 TP2 233-239 TP3 14.6 TP4 6.85AC TP5 43.8-43.9 which all appear to be in range.

I actually have had the game lock up a few times on me. Usually of course when I am doing well and likely engaging more solenoids. Power off and back on seems to do the trick. Sometimes I have to wait a few minutes.

I'm going to try to roll back to the old roms and see if that makes a difference on the defender issue.

#146 3 months ago

Just wanted to provide a quick update. Resolution was a bad solenoid driver board!

#147 3 months ago
Quoted from aragornsawyer:

Just wanted to provide a quick update. Resolution was a bad solenoid driver board!

4 weeks later
#148 76 days ago

When I turn my Vector on and start a game the score goes nuts before I even launch the ball. I went through all the switches twice and still having the same issue. Could it be something with the driver board?

#149 76 days ago
Quoted from D8n-flipped:

When I turn my Vector on and start a game the score goes nuts before I even launch the ball. I went through all the switches twice and still having the same issue. Could it be something with the driver board?

Is the game score points with sounds?
If so, then you might have a bad switch capacitor.
Or you could have a drop target switch to close...
You could easily tell if it is a bad switch capacitor if the
lamp feature associated with the target/s is activated.

#150 75 days ago
Quoted from vec-tor:

Is the game score points with sounds?
If so, then you might have a bad switch capacitor.
Or you could have a drop target switch to close...
You could easily tell if it is a bad switch capacitor if the
lamp feature associated with the target/s is activated.

yes, points with sounds.
ill look for a bad cap. thanks.

Promoted items from the Pinside Marketplace
$ 30.00
Electronics
Third Coast Pinball
$ 90.00
From: $ 155.00
$ 9.00
Electronics
Yorktown Arcade Supply
From: $ 155.00
$ 9.00
Cabinet Parts
Third Coast Pinball
$ 149.00
3,000
Machine - For Sale
Morrisville, PA
From: $ 25.00
Boards
nvram.weebly.com
$ 49.99
Electronics
PinballElectronics.com
From: $ 14.00
Electronics
Third Coast Pinball
$ 149.95
Boards
Allteksystems
From: $ 45.00
Displays
PinballSolutions.eu
There are 151 posts in this topic. You are on page 3 of 4.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside