New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 213089)

Up the Irons - Stern Iron Maiden Owners and True Fans Club!


By AlexSMendes

2 years ago



Topic Stats

  • 7,527 posts
  • 631 Pinsiders participating
  • Latest reply 2 hours ago by Eskaybee
  • Topic is favorited by 294 Pinsiders

You

Topic Gallery

There have been 1,803 images uploaded to this topic. (View topic image gallery).

20201024_152954 (resized).jpg
1E5AF96D-E576-48FB-9102-41BD6CBA5820 (resized).jpeg
DB56F4E8-0B20-45D3-BCF9-947FDBA960A0 (resized).jpeg
121730661_943546726051585_1453785484841214343_n (resized).png
twitch golf stats bg (resized).png
IMG-0525 (resized).jpg
IMG_20201008_140939 (resized).jpg
IMG_20201008_140947 (resized).jpg
IMG_20201008_140935 (resized).jpg
IMG_20201008_140931 (resized).jpg
IMG_20201008_092400 (resized).jpg
IMG_20201008_092357 (resized).jpg
IMG_20201008_092354 (resized).jpg
IMG_20201008_092349 (resized).jpg
PXL_20201006_025916200 (resized).jpg
27AD53CE-AE3D-46E8-9FFC-A420E0214229 (resized).jpeg

Topic index (key posts)

10 key posts have been marked in this topic (Show topic index)

There are 7527 posts in this topic. You are on page 147 of 151.
#7301 40 days ago

Had a weird issue happen earlier. The right loop stopped registering for some reason so I checked everything and confirmed the opto was not functioning. I just got it a couple of weeks ago and it’s a new build so I figured a loose wire was the cause, but no dice. Was about to give up and make the call to get a new sensor when it all of a sudden it started working again. Has anyone ever had that happen? Also, is there a way to tweak the shooter lane so the auto plunge consistently makes it through the loop? Ends up either hitting the flipper or outside orbit entrance half the time, but a manual plunge works fine. Other than that, I’m having an absolute blast and can’t seem to get enough. Unfortunately my poor TMNT is starting to collect dust, lol.

#7302 40 days ago

I put a couple of layers of gun stain on it (it's wood filament), really brought out the details and made it look antique... stepped outside to smoke and let it dry before I put some poly on it..came back in to it being gone. I'm guessing one of the dogs ate it, but neither are fessing up. Back to the drawing board I guess, and another 1/2 day of printing. :/

#7303 40 days ago
Quoted from remf:

Had a weird issue happen earlier. The right loop stopped registering for some reason so I checked everything and confirmed the opto was not functioning. I just got it a couple of weeks ago and it’s a new build so I figured a loose wire was the cause, but no dice. Was about to give up and make the call to get a new sensor when it all of a sudden it started working again. Has anyone ever had that happen? Also, is there a way to tweak the shooter lane so the auto plunge consistently makes it through the loop? Ends up either hitting the flipper or outside orbit entrance half the time, but a manual plunge works fine. Other than that, I’m having an absolute blast and can’t seem to get enough. Unfortunately my poor TMNT is starting to collect dust, lol.

There is an adjustment screw along the shooter lane by the turn that can help, I also found adjusting the auto plunge power in the menu can help. I still get about 10% missing. I think there are some mods you can do as well that fixes the issue, either in this thread or the mod thread they mention them.

#7304 40 days ago
Quoted from Rik_:

There is an adjustment screw along the shooter lane by the turn that can help, I also found adjusting the auto plunge power in the menu can help. I still get about 10% missing. I think there are some mods you can do as well that fixes the issue, either in this thread or the mod thread they mention them.

After looking at it more it’s hitting the flipper almost every time. I turned down the power, but that didn’t work so I’ll try that. One thing I did notice is the flipper is slightly off center of the dot so I’m wondering if that’s part of the problem as well. I’ll try your way first and will go from there. Thanks for the tip.

#7305 40 days ago

pinmonk has an epic Anubis already...

https://pinmonk.com/collections/iron-maiden-stern/products/iron-maiden-3d-anubis-kit

Anubis_foam_packaging_1024x1024@2x (resized).jpg

#7306 40 days ago

Thanks for the plug. A little DIY never hurt anyone, though, and I'm jealous of his version's beefier ears. Going back and reinforcing the ones on mine is forever on my to-do list, I just never get it done. Those and the gem/crown over the brow are the only part of the model that's fragile.

#7307 40 days ago
Quoted from vireland:

Thanks for the plug. A little DIY never hurt anyone, though, and I'm jealous of his version's beefier ears. Going back and reinforcing the ones on mine is forever on my to-do list, I just never get it done. Those and the gem/crown over the brow are the only part of the model that's fragile.

I got the idea to try it out after seeing yours, yours is awesome! (And made of much better material!)

I would love to say it's my design, but it's not. It's from an undead egypt chess set I found on thingiverse, scaled up and the base sliced off. (So no, I am not selling them to who ever asked that earlier...at least I hope that's what you were mentioning lol)

#7308 40 days ago

Man get your minds out of the gutter it was a field of dreams reference lmao

#7309 40 days ago

I paid about $75-80 for all of these with shipping (they're all from different shops).

Get them all now for $50 USD and free shipping anywhere in Canada or the US.

Pharoah plastic protector - $15
https://mezelmods.com/products/iron-maiden-pinball-pharaoh-plastic-protector?variant=12353715241057

Opto and ball trap kit - $18
https://www.pinballlife.com/iron-maiden-upgrade-kit.html

Cliffy scoop protector - $21

PM if interested.

IMG_20200917_015209 (resized).jpg

#7310 40 days ago
Quoted from remf:

After looking at it more it’s hitting the flipper almost every time. I turned down the power, but that didn’t work so I’ll try that. One thing I did notice is the flipper is slightly off center of the dot so I’m wondering if that’s part of the problem as well. I’ll try your way first and will go from there. Thanks for the tip.

I replaced my upper flipper with a lightning flipper. Made a world of difference and the loop shot geometry didn’t seem to change much.

#7311 40 days ago
Quoted from Eskaybee:

I replaced my upper flipper with a lightning flipper. Made a world of difference and the loop shot geometry didn’t seem to change much.

That is a pretty good idea, I'll have to give it a try as I had to adjust the angle on my upper flipper to keep it from being struck by the ball launch.

#7312 38 days ago
Quoted from atrainn:

So I finally got to put some time into my Maiden and am noticing some pretty distinct speaker crackling. It doesn't seem to happen on the music, only on the SFX and things that use a lot of bass. I've seen some references to people putting in a dedicated amp for crackling at high volume, but I'm only playing at around volume 9... Is an amp the solution here or is there something else that could be causing this?

I've noticed some similar issues for a long time as well, I think since the last code update. The music sounds a bit hollow or distant, and some of the sound effects seem mixed too loud and cause a bit of distortion or crackling. The voice callouts sound perfect though. It hasn't been significant enough for me to try much besides messing with audio settings a bit, which didn't really help much. I'm also not playing it overly loud either, volume 11.

Did you end up finding a solution without adding/changing hardware? Anyone else feel free to chime in also.

#7313 38 days ago
Quoted from EricR:

I've noticed some similar issues for a long time as well, I think since the last code update. The music sounds a bit hollow or distant, and some of the sound effects seem mixed too loud and cause a bit of distortion or crackling. The voice callouts sound perfect though. It hasn't been significant enough for me to try much besides messing with audio settings a bit, which didn't really help much. I'm also not playing it overly loud either, volume 11.
Did you end up finding a solution without adding/changing hardware? Anyone else feel free to chime in also.

I do not understand why Stern doesn't mix the sound in software to prevent additive clipping. It makes no sense. A software mixer with auto limiting would stop all the clipping nonsense and they could use it as a plug-in on every title.

#7314 38 days ago
Quoted from vireland:

I do not understand why Stern doesn't mix the sound in software to prevent additive clipping. It makes no sense. A software mixer with auto limiting would stop all the clipping nonsense and they could use it as a plug-in on every title.

Cost

#7315 38 days ago

But you only pay the software development cost ONCE. It would pay for itself within the first year, two at the most. It would save all the time spent chasing clipping audio problems on every new title and all of it would sound better overall because all the sources would be properly mixed before being sent to the amplfier and speakers. Transparently.

#7316 37 days ago
Quoted from vireland:

But you only pay the software development cost ONCE. It would pay for itself within the first year, two at the most. It would save all the time spent chasing clipping audio problems on every new title and all of it would sound better overall because all the sources would be properly mixed before being sent to the amplfier and speakers. Transparently.

The answer is not cost. They just don't give a shit. Demand for shit products is high.

Sound engineer: "Gary, we really gotta fix this sound. It's clipping. Listen to this."

Gary: "Are you kidding? These guys would buy it if the only sounds were clipped burps and farts. And I have a tee time in 20. Ship it!"

#7317 37 days ago

I can't believe that no one else has had this problem? This is now my second piece of mind eddie that has slowly bent over. The plastic/rubber/whatever it is, just isn't rigid enough to support its own weight...this is mind blogging.

20200920_113003 (resized).jpg

20200920_113254 (resized).jpg

20200920_113425 (resized).jpg

#7318 37 days ago
Quoted from Gogdog:

I can't believe that no one else has had this problem?

There have been other posts about this, though it's been awhile.

#7319 37 days ago
Quoted from wontwa:

There have been other posts about this, though it's been awhile.

I remember someone posting about the robot Eddie's guns sagging, from memory cause they are close to a light source. I don't recall the piece of mind Eddie sagging though.

#7320 36 days ago

Just got my NIB Iron Maiden pro and love it!
Looking for Mummy Fist side Rails if anyone knows of any it's appreciated

DEE5B976-4B44-4675-8298-812430A01E78 (resized).jpeg
#7321 36 days ago
Quoted from PunishersLEMC:

Just got my NIB Iron Maiden pro and love it!
Looking for Mummy Fist side Rails if anyone knows of any it's appreciated [quoted image]

Welcome to the club. Looks great beside Rob Zombie. Now you need a Metallica to complete the Metal Trifecta! Enjoy the pin.

#7322 36 days ago
Quoted from Deyanks98:

Welcome to the club. Looks great beside Rob Zombie. Now you need a Metallica to complete the Metal Trifecta! Enjoy the pin.

It's in the other side Thank you

#7323 36 days ago
Quoted from wontwa:

There have been other posts about this, though it's been awhile.

Yeah...it was my own posts from the first time that it happened....

#7324 36 days ago
Quoted from Gogdog:

I can't believe that no one else has had this problem? This is now my second piece of mind eddie that has slowly bent over. The plastic/rubber/whatever it is, just isn't rigid enough to support its own weight...this is mind blogging.
[quoted image]
[quoted image]
[quoted image]

That’s crazy. I recall someone else having that problem as well. I’ve had mine on my pro at least a year, and no problems

#7325 35 days ago

Hi Everyone, question for everyone. My ramp screws on my Iron Maiden keep loosening up. I was thinking of using Loctite but I thought it might be a little too strong to undo at a later date. Any suggestions?

Thanks

#7326 35 days ago
Quoted from Mancave:

I remember someone posting about the robot Eddie's guns sagging, from memory cause they are close to a light source. I don't recall the piece of mind Eddie sagging though.

Yeah that was me. " hunch back Eddie"
I purchased one of these for my pro from pinball life. I thought something looked off. They compared this to the others they had in stock and said they were all like that . Way to go stern!
I ended up getting a proper standing one from another Pinside member.

#7327 35 days ago
Quoted from arkin:

Hi Everyone, question for everyone. My ramp screws on my Iron Maiden keep loosening up. I was thinking of using Loctite but I thought it might be a little too strong to undo at a later date. Any suggestions?
Thanks

Which screws?

#7328 35 days ago

Got this from Pinball Heaven (uk) today - don’t go without folks!

Kudos to PH as I’m the second owner so no obligation to support me.

14380AE4-0E29-488A-AEEE-2AE7F2F6EDB6 (resized).jpeg
#7329 35 days ago
Quoted from Meegis:

Which screws?

The three screws that cover the ramp for the underworld.

#7330 35 days ago
Quoted from arkin:

The three screws that cover the ramp for the underworld.

Go ahead and apply a little Blue Loctite to those, won't be an issue to remove them later. Don't use Red though.

#7331 35 days ago

Anyone hear anything about code update? Been a while since any chatter about it

#7332 34 days ago

"Where's the code Keith!?!?"

#7333 33 days ago

Can someone explain the left light in the pop bumpers. First I thought it was a bad light board, but it comes on every now and then. Looking at a couple of videos of other peoples games, it seems this is a feature, not a bug, but for the life of me I don't understand the logic of when that pop bumper light comes on, why it is off to begin with, etc. Teach me pinball wizards.

Mike

#7334 33 days ago
Quoted from mikeflan:

Can someone explain the left light in the pop bumpers. First I thought it was a bad light board, but it comes on every now and then. Looking at a couple of videos of other peoples games, it seems this is a feature, not a bug, but for the life of me I don't understand the logic of when that pop bumper light comes on, why it is off to begin with, etc. Teach me pinball wizards.
Mike

It's a flasher, not a standard light.

#7335 33 days ago

I believe it flashes when Power Pops is active.

#7336 33 days ago

Best game yet ...still no battle but it’s coming !!

9C460DF0-7A1E-488B-B647-6926C8EF00F2 (resized).jpeg
#7337 33 days ago
Quoted from mikeflan:

Can someone explain the left light in the pop bumpers. First I thought it was a bad light board, but it comes on every now and then. Looking at a couple of videos of other peoples games, it seems this is a feature, not a bug, but for the life of me I don't understand the logic of when that pop bumper light comes on, why it is off to begin with, etc. Teach me pinball wizards.
Mike

Thanks for asking this question as I was literally looking at my pin closer last night and I was like why is that pop bumper light not on. I was ready to replace the bulb so glad to hear that it’s normal for that to be off when it’s idle.

#7338 33 days ago

Code update coming to fix a huge exploit! Credit to World Champion Escher Lekoff.

Credit to Zach Parks for telling me about this and credit to Zach McCarthy for figuring out the best way of maximizing the scoring.

To keep things short, you can completely freeze every timer in flight of icarus. Not only does the mode timer not run, the combo timer wont run either meaning you can get insane scores very quickly. I’m not 100% sure if playfield X’s time out or not, but there’s a chance they will freeze as well.

The set-up is actually quite easy. All you have to do is start mummy stacked in with icarus (works on both prem and pro). You immediately cradle up and time out the ballsaver. Hit the right ramp once and drain one of the balls and cradle up again without hitting anything. The animation of the Mummy total will come up, and now the game is temporarily soft-locked.

Now the catch to it is that it is very delicate, and random things will unlock you from the state. For example, sometimes completing a power jackpot will unlock the game, and other times it will not. Any major animation will unlock it like collecting a power jackpot or locking a trooper ball. Hitting both flippers together will unlock it and sometimes it will random unlock itself.

The scoring potential is insane, and Zach McCarthy already has multiple games over the 10b mark. I would love to see a game get past a trillion before it gets patched. Let me know if you have any questions on getting it to work and I can provide a video if needed. Good luck!

Stern is already aware of the bug, and it will hopefully be patched soon.

Zach McCarthy’s best, 2b icarus and 16b in TMTM.

#7339 33 days ago

Have to make a huge shout-out to arkin for helping he get my anubis looking absolutely amazing!!!

Thanks so much...

And of course, vireland for making the anubis in the first place.

You guys rock!

PXL_20200926_154856684 (resized).jpg
#7340 33 days ago

Now just need to find time to install. Came to abement to do it, but got called upstairs immediately.... The joys of having a toddler on a Saturday.

#7341 33 days ago
Quoted from Meegis:

Have to make a huge shout-out to arkin for helping he get my anubis looking absolutely amazing!!!
Thanks so much...
And of course, vireland for making the anubis in the first place.
You guys rock!
[quoted image]

That looks incredible, very nice! Mine’s still sitting in the box because I don’t have the nerve to mess it up with my lack of painting skills

#7342 33 days ago
Quoted from darkryder:

That looks incredible, very nice! Mine’s still sitting in the box because I don’t have the nerve to mess it up with my lack of painting skills

I totally hear you on that, hence I had arkins help. Love local camaraderie

#7343 32 days ago
Quoted from Meegis:

Have to make a huge shout-out to arkin for helping he get my anubis looking absolutely amazing!!!
Thanks so much...
And of course, vireland for making the anubis in the first place.
You guys rock!
[quoted image]

Wow. I wouldn't have the paitence to do that level of detailing!

Quoted from darkryder:

That looks incredible, very nice! Mine’s still sitting in the box because I don’t have the nerve to mess it up with my lack of painting skills

The easiest thing to do is just make a black wash by mixing a little acrylic paint with water and then wiping it over the figure so the black gets into the cracks and ages it. It's very forgiving because if you don't like how it turned out, you can just rinse it off before it dries and try again. Once it dries it's permanent.

#7344 32 days ago

Iron Maiden fun fact I never noticed - the upper right flipper coil is a LOT bigger than the two main lower flipper coils. I've been doing coil temp testing for the cooling kit and was adding the upper coils to the test and was like, "whoa, I never noticed how much bigger this coil is!"

#7345 32 days ago
Quoted from PunishersLEMC:

Just got my NIB Iron Maiden pro and love it!
Looking for Mummy Fist side Rails if anyone knows of any it's appreciated [quoted image]

I do believe pu-parts.com have the side rails on stock. They are located in Germany is must add.

#7346 31 days ago

IMG_0709 (resized).JPG

#7347 31 days ago

exploit in IMDN. start icarus, start mummy, cradle up, wait for ball save to expire, let a ball drain, you've now frozen all the timers. I simply hit left and right ramps a few times and was getting 1B and 2B a shot. double flip, anything that plays an animation will kill it. stern know...

#7348 31 days ago

2ACAC31B-C6BA-4DDF-8A71-CE1AA29D23C3 (resized).jpeg

Big scores now being put up.

#7349 31 days ago

Running into a weird issue with my right ramp opto that hopefully someone can help out with. For some reason it stopped working a few games ago so I looked at the wiring and nothing was out of the ordinary. Checked the soldering and no issues there. The one thing I did notice though is the little red led light is dimmer than the left ramp opto. It will get bright from time to time during game play so I’m wondering if it’s a power issue or the is opto dying. Are optos on Stern’s prone to having issues?

#7350 31 days ago
Quoted from remf:

Running into a weird issue with my right ramp opto that hopefully someone can help out with. For some reason it stopped working a few games ago so I looked at the wiring and nothing was out of the ordinary. Checked the soldering and no issues there. The one thing I did notice though is the little red led light is dimmer than the left ramp opto. It will get bright from time to time during game play so I’m wondering if it’s a power issue or the is opto dying. Are optos on Stern’s prone to having issues?

Yes.

It sounds like the wire to the opto has broken, at least partially, inside the insulation and is making intermittent contact. This is not unusual for Stern optos. Try wiggling the wires to the opto while in switch test to see if it triggers them.

Promoted items from the Pinside Marketplace
$ 7.95
$ 24.00
Playfield - Other
Pin Monk
5,899
Machine - For Sale
Milford, CT
There are 7527 posts in this topic. You are on page 147 of 151.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside