(Topic ID: 213089)

Up the Irons - Stern Iron Maiden Owners and True Fans Club!


By AlexSMendes

1 year ago



Topic Stats

  • 5,735 posts
  • 536 Pinsiders participating
  • Latest reply 1 hour ago by Rock914
  • Topic is favorited by 237 Pinsiders

You

Topic Gallery

There have been 1,426 images uploaded to this topic. (View topic image gallery).

E7208D41-7B9C-4559-A5AD-CB2CCF53B505 (resized).jpeg
IMG_5828 (resized).jpg
20191112_231317 (resized).jpg
20191112_231309 (resized).jpg
IMG_5823 (resized).jpg
B2E5C2EF-3996-41D6-A58F-D6F0E4B98001 (resized).jpeg
7FDF8CCA-6CC2-48FB-99A7-81FD4E7AF4D4 (resized).jpeg
CADDE0F3-6629-450B-9043-00BF821B4BDB (resized).jpeg
8D66DB48-AE18-46B5-B232-04A59E279ACB (resized).jpeg
B413E82B-92D0-49B1-ACE4-A1771BE84B28 (resized).jpeg
3B316D3C-128C-4018-B83D-8D3606DBF985 (resized).jpeg
Annotation 2019-11-12 130813 (resized).png
IMG_20191111_232128 (resized).jpg
IMG_20191111_233915 (resized).jpg
IMG_20191111_233814 (resized).jpg
20191111_113347 (resized).jpg

Topic index (key posts)

8 key posts have been marked in this topic (Show topic index)

There are 5735 posts in this topic. You are on page 103 of 115.
#5101 3 months ago

Damn, I was happy to get 300 million. You still on 3 balls with all factory settings and open left/right outlanes? That's just insane. The world champion got like 800 million on IM.

#5102 3 months ago
Quoted from mjruser:

Damn, I was happy to get 300 million. You still on 3 balls with all factory settings and open left/right outlanes? That's just insane. The world champion got like 800 million on IM.

I earned 3 extra balls(1 from finishing 2power pyramids, 1 from loops which I ended up with 91 total and 1 from tomb treasures)so technically it was a 6 ball game which helped a lot. The first thing I go for now is loops on every ball during ball save and multi ball especially since I get credit for all loops now. What a good game.

#5103 3 months ago
Quoted from mjruser:

Damn, I was happy to get 300 million. You still on 3 balls with all factory settings and open left/right outlanes? That's just insane. The world champion got like 800 million on IM.

500-800 million games are pretty common for me on the premium. If you get the right combination of things lined up, blowing it up to over a billion isn't out of reach. Robert Gagno blew it up to 3.7 Billion earlier this year.

#5104 3 months ago

insane!

#5105 3 months ago

Okay... It seems the time has come for my first minor servicing for my Iron Maiden Prem. Right now I am having problems with the underworld scoop not registering every time. Some games it'll be like 4-5 in a row no issues and then I'll run into issues of it not registering 2-4 times in a row. And then it goes on so on and so forth.
I hope this is a simple fix, and just curious what I should be looking for.

I then have a second issue. Its more minor, but still annoying.
One of the LEDs the quarter million loop insert LED(the lowest level one) is not displaying right. One the pregame light show it shows as being out.
But, during the actual game it can be lit solid at times. And other times it can flash but its really weak. Hoping that is a simple fix as well and I'd just like to know what I should look for in that as well. I figure for that one, it might be a loose connection, and might just need to re-attach a wire or something... I hope I don't need to replace an entire LED board just to fix one minor and really unnecessary issue.

Help would be appreciated as I'm getting better fixing my machines, but still really suck at doing so.
Thanks in advance.

#5106 3 months ago
Quoted from Diospinball:

Okay... It seems the time has come for my first minor servicing for my Iron Maiden Prem. Right now I am having problems with the underworld scoop not registering every time. Some games it'll be like 4-5 in a row no issues and then I'll run into issues of it not registering 2-4 times in a row. And then it goes on so on and so forth.
I hope this is a simple fix, and just curious what I should be looking for.
I then have a second issue. Its more minor, but still annoying.
One of the LEDs the quarter million loop insert LED(the lowest level one) is not displaying right. One the pregame light show it shows as being out.
But, during the actual game it can be lit solid at times. And other times it can flash but its really weak. Hoping that is a simple fix as well and I'd just like to know what I should look for in that as well. I figure for that one, it might be a loose connection, and might just need to re-attach a wire or something... I hope I don't need to replace an entire LED board just to fix one minor and really unnecessary issue.
Help would be appreciated as I'm getting better fixing my machines, but still really suck at doing so.
Thanks in advance.

The LED might be a loose connection, but it sounds like a bad LED. I'd try reflowing the solder first to see if that fixes it. If that DOESN'T, you can swap it with another LED board nearby and see if the problem travels. If it does, you know you have a bad board.

#5107 3 months ago
Quoted from vireland:

The LED might be a loose connection, but it sounds like a bad LED. I'd try reflowing the solder first to see if that fixes it. If that DOESN'T, you can swap it with another LED board nearby and see if the problem travels. If it does, you know you have a bad board.

Never swapped out an LED board before... Is it simple or complex?

#5108 3 months ago

My goodness, PinballMix is pretty awesome. If you want to remove or freshen up your Maiden music(or any game for that matter), check out PinballMix. I’m just a new customer of his product, and me and my fiancé dig it!

#5109 3 months ago
Quoted from Diospinball:

Never swapped out an LED board before... Is it simple or complex?

Super easy, barely an inconvenience.

These single LED boards just have a couple circuit board pads with wires soldered to them. Take pictures before unsoldering so you don't get the wire colors wrong when you put them back. As long as you know how to solder, you're good to go.
LED Board (resized).jpg

#5110 3 months ago
Quoted from vireland:

Super easy, barely an inconvenience.
These single LED boards just have a couple circuit board pads with wires soldered to them. Take pictures before unsoldering so you don't get the wire colors wrong when you put them back. As long as you know how to solder, you're good to go.
[quoted image]

Where do you get a replacement board at. Just curious. Just in case I need to buy one. But, yes. I know that is putting cart before the horse.

#5111 3 months ago
Quoted from Diospinball:

Where do you get a replacement board at. Just curious. Just in case I need to buy one. But, yes. I know that is putting cart before the horse.

Marco has them.

https://www.marcospecialties.com/pinball-parts/520-5307-00

If you haven't had the machine a year, I'd see if Stern will send you one free first.

But I'd swap with a known good single LED board first (the white 2 wire ones only, not the RGB ones) to make sure it's the board that's bad.

#5112 3 months ago
Quoted from vireland:

Marco has them.
https://www.marcospecialties.com/pinball-parts/520-5307-00
If you haven't had the machine a year, I'd see if Stern will send you one free first.
But I'd swap with a known good single LED board first (the white 2 wire ones only, not the RGB ones) to make sure it's the board that's bad.

Sadly I've had it for like 2-3 months over a year now. No big deal.
Especially since I want to order a gottlieb flipper repair kit and also some flipper coils. So I might order all at once to save on shipping.

#5113 3 months ago
Quoted from Diospinball:

Sadly I've had it for like 2-3 months over a year now. No big deal.
Especially since I want to order a gottlieb flipper repair kit and also some flipper coils. So I might order all at once to save on shipping.

Well, at the very least, do the board swap first to verify it is the board that's the problem.

#5114 3 months ago
Quoted from vireland:

Well, at the very least, do the board swap first to verify it is the board that's the problem.

yep. I will give that a go.

#5115 3 months ago
Quoted from vireland:

Super easy, barely an inconvenience.

Switching out led boards is tight!

#5116 3 months ago
Quoted from Diospinball:

Where do you get a replacement board at. Just curious. Just in case I need to buy one. But, yes. I know that is putting cart before the horse.

Cointaker also has them in stock, different colors as well. https://cointaker.com/products/stern-spike-led

#5117 3 months ago

Might be joining the club with a premium.

Wondering if any has powder coated, and could share a photo. I saw one on a bronze/gold that looked pretty cool.

Also thinking about installing the pyramid themed side blades, and was hoping to see a photo of that installed.

Cheers

#5118 3 months ago
Quoted from djreddog:

My goodness, PinballMix is pretty awesome. If you want to remove or freshen up your Maiden music(or any game for that matter), check out PinballMix. I’m just a new customer of his product, and me and my fiancé dig it!

Wow, thanks for the kind words. For anyone waiting on me to get back on more info or orders, hang in there. Drove overnight 11 hours to get home from Replay, and now I am going to see Maiden in Montreal!!!!

I got super lucky and won FTTB on the fan club. Gonna be real close to the stage!

Up the Irons!!!!!!

#5119 3 months ago
Quoted from Diospinball:

Okay... It seems the time has come for my first minor servicing for my Iron Maiden Prem. Right now I am having problems with the underworld scoop not registering every time. Some games it'll be like 4-5 in a row no issues and then I'll run into issues of it not registering 2-4 times in a row. And then it goes on so on and so forth.
I hope this is a simple fix, and just curious what I should be looking for.

I had the screws holding the scoop switch come loose, pop the hood and check it out

#5120 3 months ago
Quoted from BMore-Pinball:

I had the screws holding the scoop switch come loose, pop the hood and check it out

where would that be located?
Any suggestions on how to proceed to check out that switch?

#5121 3 months ago

Am looking at ordering Titan rubbers, keen to see pics or hear suggestions of colours that would suit a Maiden Pro?

#5122 3 months ago

I'm debating adding a Flipper Fidelity or Pinball Pro sub kit to my IMDN Premium. Has anyone else already done this? Is it worth it?

#5123 3 months ago
Quoted from Diospinball:

where would that be located?
Any suggestions on how to proceed to check out that switch?

under the kickout at the top of the playfield (bottom if it's lifted). Find the switch that triggers there and look on the side of it for two small, long, thin screws. Often times, one comes loose and the switch swings away on the remaining screw's pivot point.

#5124 3 months ago
Quoted from vireland:

under the kickout at the top of the playfield (bottom if it's lifted). Find the switch that triggers there and look on the side of it for two small, long, thin screws. Often times, one comes loose and the switch swings away on the remaining screw's pivot point.

I had this happen, 1 screw was missing and the coil movement broke the micro switch. I put blue lock tight on new screws and switch. All good now.

#5125 3 months ago
Quoted from robm:

Am looking at ordering Titan rubbers, keen to see pics or hear suggestions of colours that would suit a Maiden Pro?

I have all these titan and pinball life colored rings and nearly always end up going with the translucent. That goes for almost any location that has lights behind the ring. I really dig how it lets some additional light through. I did clears in a few key spots and put in comet warm white leds. I think it fits really well with the colors on the game.

#5126 3 months ago
Quoted from robm:

Am looking at ordering Titan rubbers, keen to see pics or hear suggestions of colours that would suit a Maiden Pro?

I did Dk. Blue from Titan. Forgot about the translucent or I might have done that for the slings. I like the dark blue though as it fit in with the play field. If you go to post 2971, I have pictures.

#5127 3 months ago
Quoted from Hammerhead:

I'm debating adding a Flipper Fidelity or Pinball Pro sub kit to my IMDN Premium. Has anyone else already done this? Is it worth it?

I installed the Flipper Fidelity 10" kit w/back box speakers. Sounded so good I ended up buying the kit for my Ghostbusters and Spiderman. Sounds way better. With the 10" sub, you can put in for a little more bass and not need a shaker as it will shake enough

#5128 3 months ago
Quoted from Diospinball:

where would that be located?
Any suggestions on how to proceed to check out that switch?

Flip up the playfield and look directly under the scoop
Switch on my machine actually fell off and was hanging by the wires - screws were down in the cabinet

#5129 3 months ago

Anyone replace the Mylar at the backside of the jump ramp? Mine's chewed to death. If so, how are you removing it? What about below the lifting ramp? Mine looks as though it is cutting through.

#5130 3 months ago
Quoted from Tranquilize:

Anyone replace the Mylar at the backside of the jump ramp? Mine's chewed to death. If so, how are you removing it? What about below the lifting ramp? Mine looks as though it is cutting through.

Interested as well. I saw someone else had posted that Stern sent them a replacement piece.

#5131 3 months ago
Quoted from DudeRegular:

Interested as well. I saw someone else had posted that Stern sent them a replacement piece.

+1. I bought a huo model and the ball actually got hung up in the Mylar at one point before I increased the pitch more.

#5132 3 months ago
Quoted from BMore-Pinball:

Flip up the playfield and look directly under the scoop
Switch on my machine actually fell off and was hanging by the wires - screws were down in the cabinet

Thanks. I'll give it a go.

#5133 3 months ago

Hey guys what was the final verdict on the auto launch issue mine finally started doing it

#5134 3 months ago

Picked up a new premium today, thinking about some sort of candy orange for the armor. Anyone tried gold chrome for t-molding? Wondering how it might look with the colors of the premium.

#5135 3 months ago
Quoted from mandelbloom:

Hey guys what was the final verdict on the auto launch issue mine finally started doing it

Are you talking about the auto-launch hitting the post instead of going through the loop?

#5136 3 months ago
Quoted from mjruser:

Are you talking about the auto-launch hitting the post instead of going through the loop?

Correct!!

#5137 3 months ago
Quoted from mandelbloom:

Hey guys what was the final verdict on the auto launch issue mine finally started doing it

New stronger coil, turn town the coil strength after the change. Key post index at the top has link to which coil to get.

#5138 3 months ago

I did the new coil and adjusted the settings. A slight bend or adjustment of the ball guide helped me as well. I had manual launches working well and was having trouble getting autolaunches to go correctly until I did that.

#5139 3 months ago

Our auto-launch was working perfect @ 6 degrees with 220 power. We changed to 6.5 degrees and no power setting would work. We took off the right return wire and a couple of pieces of plastic to expose the screw behind the upper bend. Then loosened the screw and had my son push on the ball guide so the radius was increased allowing the ball to take a higher path. Then tightened the screw. There was just enough play in the mounting tab for this to work.

#5140 3 months ago

6 must be super floaty. I keep mine at or just above 6.5 but I know many keep this game at 7

#5141 3 months ago

Check that the back of your playfield is level left to right. Anytime my plunge seems off, it usually is fixed with a simple leg adjustment

#5142 3 months ago
Quoted from Graysonsdad:

Check that the back of your playfield is level left to right. Anytime my plunge seems off, it usually is fixed with a simple leg adjustment

Hmmmm, never really thought of that. Didn't think a tad here or there would affect the plunge that much.

#5143 3 months ago
Quoted from Graysonsdad:

Has anyone here installed those little plastic blinders for the loop opto? Do they work? My game is only registering about 2/3 of the loops when they get going fast.
I can hit about 5-6 in a row now but I sometimes collect as little as 3.

The opto kit works great. My loop shots register every single time now. Well worth the money, which isnt much, like 12 bucks if i remember correctly?

#5144 3 months ago
Quoted from Who-Dey:

The opto kit works great. My loop shots register every single time now. Well worth the money, which isnt much, like 12 bucks if i remember correctly?

Did you just install the Opto part or the ball diverter as well?

#5145 3 months ago
Quoted from mjruser:

Did you just install the Opto part or the ball diverter as well?

I didnt install the ball diverter because my game had that fix installed from the factory.

#5146 3 months ago
Quoted from Who-Dey:

I didnt install the ball diverter because my game had that fix installed from the factory.

Mine didn't, guess I'll install that too. Thanks who-dey

#5147 3 months ago
Quoted from mjruser:

Mine didn't, guess I'll install that too. Thanks who-dey

What is the "ball diverter" fix?

#5150 3 months ago
Quoted from mjruser:

Mine didn't, guess I'll install that too. Thanks who-dey

Yw, let us know how them optos are registering.

Promoted items from the Pinside Marketplace
$ 69.00
$ 15.00
Lighting - Led
3D MODS
5,200 (OBO)
There are 5735 posts in this topic. You are on page 103 of 115.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside