(Topic ID: 249496)

United/Williams '65 Pyramid Shuffle Bowl -keeps blowing 15a fuse


By SweetStash

10 months ago



Topic Stats

  • 15 posts
  • 8 Pinsiders participating
  • Latest reply 9 months ago by MD_Pinball_Dude
  • Topic is favorited by 1 Pinsider

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    There have been 5 images uploaded to this topic. (View topic image gallery).

    20190815_1622161 (resized).jpg
    20190815_1622411 (resized).jpg
    20190815_1622161 (resized).jpg
    20190815_1622411 (resized).jpg
    20190814_180305 (resized).jpg

    #1 10 months ago

    I just set up a Williams Pyramid shuffle bowl game up that I purchased yesterday. After hooking everything up it worked great. I was adding multiple players to the game and now it keeps blowing a 15A fuse. If I replace the fuse and turn the power back on, it instantly blows the fuse..The 1 thru 6 players do not light up and the arrows on the lane do not light up either. I have no clue where to even start looking. Any help is greatly appreciated...

    20190815_1622161 (resized).jpg20190815_1622411 (resized).jpg
    #2 10 months ago
    20190814_180305 (resized).jpg
    #3 10 months ago

    You have a short some where start with looking at if any of the light bulb holders are bent to far causing a short.
    Raff

    #4 10 months ago

    Please post a photo of the fuse block.

    #5 10 months ago

    4th fuse down

    20190815_1622161 (resized).jpg20190815_1622411 (resized).jpg
    #6 10 months ago

    Check your schematic to see what runs thru there, and start checking for shorts.

    #7 10 months ago

    I'd suggest you make one of those circuit breaker fuses. It'll help you to find the issue and save your money and sanity.

    Did the problem only occur when you tried multiple players? It was working fine on single player?

    #8 10 months ago

    It worked before I purchased it and moved it. I hooked it up and it worked but I didn't plug in the plug for the lane sensors, so the pins didn't go up. I undid the bolts and slid it apart the get the plug and hook it back up. After that it started to blow the fuses. I have been looking at maybe a crimped wire or something. But nothing sticks out that it's bad.

    The game works with multiple players like it should. And tracks scores correctly, it just doesn't light up the players or lane arrows anymore

    #9 10 months ago

    Where do I get a circuit breaker fuse for this? Is it something I can find easily or order?

    #10 10 months ago

    Solder a blown fuse to a circuit breaker.

    There's a pinwiki on it, and I think Vid did something on it also here.

    Sorry I don't have a link.

    Search circuit breaker fuse on this forum and look for the pinwiki thread.

    #12 10 months ago
    Quoted from SweetStash:

    I undid the bolts and slid it apart the get the plug and hook it back up.

    What bolts try to explain abit better so we can help you.
    Raff

    #13 10 months ago

    Just The bolts that hold the lane to the upright cabinet. Nothing that would effect the electrical. So I thought. Then plugged it in and that when it started popping fuses. Besides the lighting not operating, everything else seems to be working

    3 weeks later
    #14 10 months ago

    Did you find the issue?

    #15 9 months ago

    Maybe open it back up with a new fuse installed and see if it blows at startup. If it stays intact, look for a pinched wire along the sides? If it blows, look down into whatever stepper puts the game into multiplayer and see if you have something that may have fallen into the clockworks?

    Promoted items from the Pinside Marketplace
    $ 20.00
    Playfield - Decals
    Flashinstinct
    $ 41.25
    Playfield - Toys/Add-ons
    The MOD Couple
    $ 139.00
    Playfield - Toys/Add-ons
    Sparky Pinball
    £ 50.00
    Playfield - Decals
    Sillyoldelf Mods
    $ 10.95
    From: $ 175.00
    Gameroom - Decorations
    Pinball Photos
    $ 67.00
    Playfield - Toys/Add-ons
    Lermods
    From: $ 9.99
    Eproms
    Matt's Basement Arcade
    $ 9.95
    Playfield - Plastics
    ULEKstore
    From: $ 99.99
    Cabinet - Other
    Lighted Pinball Mods
    $ 65.00
    Cabinet - Armor And Blades
    Texas Pinball
    £ 59.00
    Playfield - Other
    PinballToys
    $ 99.99
    Playfield - Toys/Add-ons
    Lighted Pinball Mods
    $ 218.00
    $ 159.99
    Lighting - Other
    Lighted Pinball Mods
    $ 69.95
    Cabinet - Shooter Rods
    Super Skill Shot Shop
    $ 8.00
    Electronics
    Third Coast Pinball
    $ 159.99
    Lighting - Other
    Lighted Pinball Mods
    From: $ 45.00
    Displays
    PinballSolutions.eu
    $ 2.50
    Various Novelties
    Pinball Wheezer
    $ 125.00

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside