(Topic ID: 160908)

Twister reset with blinking lights

By dellice45

6 years ago



Topic Stats

  • 6 posts
  • 2 Pinsiders participating
  • Latest reply 6 years ago by dellice45
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 6 years ago

My Twister is experiencing an issue. When I turn it on I hear a clicking sound and lights on the play field blink. I looked at the schematic and removed J16 and tried testing the pins for voltage and get 5 volts.

One of the two LEDs stay on . It's the top one of the two.

If anybody can help please let me know it will be greatly appreciated !

#2 6 years ago

What you are hearing is the blanking circuit kicking in. The MPU isn't booting.

Check for alkaline corrosion beneath the battery holder. Yikes!
--
Chris Hibler - CARGPB #31
http://ChrisHiblerPinball.com/contact/
http://webpages.charter.net/chibler/Pinball/index.htm
http://www.PinWiki.com - The new place for pinball repair info

#3 6 years ago

The battery pack is wired in , I checked the batteries are fine, no damage and the wire was long enough it sat at the bottom of the back box . The wire had snapped off while checking and I took the board off to re solder and maybe my solder job sucked last night, I'll check it later today again .

Would you know of anything else just in case ?

Thanks for your response

#4 6 years ago

Update - I went to test the voltage after replacing the batteries. I turned the game on and a capasitor blew.

#5 6 years ago

i think there maybe a reason for the reset . We took the battery pack off the game, it has a NVRAM , this was not pushed in corectly and came loose. So once I replace the blown CAP which i ordered tonight. I can see if these things fix the issues , ill update once part replaced .

1 week later
#6 6 years ago

I replaced the cap and when i powered it on the reset went away, but a new problem has come about and the cap may have caused it. The NVRAm seemed to be the cause of the rest.

New Problem *

The coil isn't firing off for the ball lock in the trough and is blowing fuse 21 . When i was putting a new fuse the auto plunger and then coil to pop the ball up to the shooter worked, but magnet wouldn't spin and trough lock wouldn't fire and would blow the fuse. I am thinking some transistors need to be replaced , which i ordered online along with a new rotten dog board as well , this way i can have a back up and i ordered a bran new coil as well for the trough lock .* More updates to follow !

Promoted items from the Pinside Marketplace
$ 18.95
Eproms
Pinballrom
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 23.95
Eproms
Pinballrom
$ 74.00
Lighting - Backbox
Arcade Upkeep
$ 99.00
Playfield - Other
Arcade Upkeep
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 49.99
Cabinet - Shooter Rods
Pinball Shark
From: $ 22.00
Apparel - Men
Pinside Shop
$ 59.99
Cabinet - Shooter Rods
Pinball Shark
From: $ 389.95
Boards
PinSound
$ 17.00
Cabinet - Decals
Nordic Pinball Supply

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!