(Topic ID: 63352)

Twilight Zone Owner's club


By Caucasian2Step

6 years ago



Topic Stats

  • 8,158 posts
  • 602 Pinsiders participating
  • Latest reply 1 hour ago by Navystan
  • Topic is favorited by 323 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,075 images uploaded to this topic. (View topic image gallery).

tz (resized).jpg
01AE5527-6D4D-49DE-9C57-80C586A51999 (resized).jpeg
B36D165E-5F52-493B-AE65-E93BCFFD21E3 (resized).jpeg
TZ J133-9 (resized).JPG
206 plug (resized).JPG
BA8E9AEE-92DF-4277-B2D5-4E3645E2220D (resized).png
IMG_7388 (resized).JPG
IMG_7387 (resized).JPG
IMG_7385 (resized).JPG
IMG_7386 (resized).JPG
IMG_7384 (resized).JPG
Capture (resized).JPG
rps20180825_082254 (resized).jpg
229FC2DF-25FF-47A2-95D1-937B92C6A7C6 (resized).jpeg
92FCAE0A-F456-4971-9E2A-B61E41CC84AD (resized).jpeg
386E8858-9EC7-4BF3-9CCD-FC302AB6F2E4 (resized).jpeg

You're currently viewing posts by Pinsider mad_dog_coin_op.
Click here to go back to viewing the entire thread.

#5865 1 year ago

Hello all - new member here. I just pick up my Twilight Zone Friday. Somebody has butchered it a little and I'm in the process of sorting it out. I have a backboard question. Please see photo. The middle piece was my backboard and the top peice was shoved in front of it to block the view of the wires. The bottom peice is my homemade replacement. Has anybody seen a short backboard like this before? Also, what are the metal brackets for. I can't figure out when they would come into play but I saw them on other TZs so I installed them on my replacement. Thanks in advance.

20180519_183752 (resized).jpg

20180520_141303 (resized).jpg

#5870 1 year ago

Still sorting out my “new to me” TZ. Got a question about how the mini playfield is attached. Looking at the sticker on the bottom of the cabinet it says to loosen nut A and B and removed screw C. My A connection doesn’t have a bracket attached to it. Only the B side does. I think I’m missing the A side bracket. Does anyone have a photo of it or a source to purchase it?

#5871 1 year ago

Forgot the diagram.

20180521_152539 (resized).jpg

#5874 1 year ago
Quoted from Coyote:

I will go through my teardown pics tonight. I have one somewhere.
Bother side front starposts should have a bracket attachment, yes.

I thought it should. Any help is greatly appreciated.

#5876 1 year ago

Oh Yeah - That's it. Any idea where a can score one? Haven't seen it at the "usual" places.

#5877 1 year ago

It seems like the mini playfield bracket I’m missing is a bit of a problem child to source. Please see above photo. Can someone maybe sketch it out with measurements so I can make one? Thanks in advance.

#5894 1 year ago
Quoted from Coyote:

Looking from the back of the playfield. (Front of playfield towards top of image.)

Things are looking up. Thanks to Coyote for providing me the picture of my missing mini playfield bracket. Because of the picture I new what it looked like and since I have the game a was able to figure out the height it needed to be. I first made a paper template and then cut a new one out of sheet metal. The end result turned out fairly good.

9C51E08A-7303-4249-B812-72954C29BA90 (resized).jpeg
88530172-C849-427B-8FA0-AB34393E69D3 (resized).jpeg

#5908 1 year ago

Hello All - I was thinking about getting a new Twilight Zone Mirco Repro Playfield set for my game. How is the quality? Wanting to get some feedback before I pull the trigger on it. Also, I was wondering which one I should get (the 2 magnet or 3 magnet version). Your input is greatly appreciated.

#5912 1 year ago

OK - I'm sold on the Twilight Zone Mirco Repro Playfield product. Now, which repro TZ playfield should I buy (the 2 magnet or 3 magnet version? If I go with the 3 magnet version - what else do I have to purchase?

Thanks

3 weeks later
#6001 1 year ago

Hello all,
I need a little help here. I’ve had my TZ for month now and just finished with my “to do list”. It looks great now. Of course, as you're working through any good “ to do list” you always find other things to do. That leads me to my current problem. The last thing I did was rebuild my playfield clock. The thing passes all tests and works as it should. It even shows the time set on the pinballl machine. The problem is, the time never advances on my MPU. It holds the time I set but never advances the time or date so my playfield clock always shows the same time when the game is in attract mode. If I change the time on the mpu it changes my time on the playfield clock but neither will advance on their own. Anybody have any ideas?

#6003 1 year ago

No NVRam here. Just have the remote battery pack on this one. I think I’ll pull the batteries and let it go back to factory settings. Don’t think I have ever done it on this game since I’ve had it. Who knows, I might get lucky.

2 months later
#6193 1 year ago
Quoted from Scotty_K:

As had been mentioned to me by Coyote, the recommended fix for this is to cut off the connectors at both ends, twist the wires, and solder the wires directly to the pins. I did this with my glitchy sensor, and I have not had a problem since.

I totally agree. Cutting off the connectors sounds like a hack but it is a necessary evil. Those wimpy pins can't hold up to the vibration of all the coil activity in that area of the playfield. I directly soldered a single twisted pair of data line to the underside of the two little boards and never had a problem again. Doing it to the underside of the boards always gives you the option of going back to the cable with the connectors if so desired.

#6211 1 year ago

There has been a lot of talk about flashers lately and it got me thinking about my game. All my flashers work as they should with a big pop of light when I run the flasher test except one. The one in question is in the light pole. There is actually 2 bulbs that flash when testing that circuit (the one in the bottom of the mini playfield and the one in the light pole). The mini playfield works perfectly while the light pole flasher barely does anything. Is this normal? Thanks in advance.

#6213 1 year ago

Yes, I have tried different bulbs both LED and old school with no change.

1 week later
#6242 1 year ago
Quoted from jgadzia:

Where does this plugin I cant find a plug
[quoted image]

I think that one goes to the switch on the ramp. Here is a couple shots of mine.

20180831_165721 (resized).jpg20180831_165855 (resized).jpg
#6244 1 year ago

Hey TZ fans. I bought this little guy awhile ago and was trying to figure out where to stick him in the game. He is just static but I think he adds the correct vibe to the game. Took me a while to figure out how to get him to stay in that spot. I finally decided to run stainless steel wire through the inside of his clothes to keep him secure and to hold his pose. I haven't seen one added to a TZ before and thought it looked kind of cool.

#6245 1 year ago

Sorry, the photo was on my phone. Had to make a second post.

20180901_154930 (resized).jpg
#6246 1 year ago

Here is the back side. He is connected in two spots.

20180901_153920 (resized).jpg
#6248 1 year ago
Quoted from Durzel:

I would stick him in the base of the cabinet, right at the back.

Tried that first. The viewing angle was wrong. Couldn't see the face while playing. My next choice was next to Robbie in the middle back. That was ok but the two toys were kind of close to each other.

1 week later
#6293 1 year ago
Quoted from jgadzia:

tried an original 555 bulb and does not work. used the light in the start button and it doesnt work in the buy in button slot. when i measure the voltage in the socket i am only getting abou 1.5 volts max. If i measure the voltage in front of the diode i get 7 volts. I used a 1n4004 diode is that the correct diode. not sure what else to check here? any help greatly appreciated!

The bulb should be a 555. Funny, I don't remember a diode on that switch. I'll check mine out tomorrow.

#6297 1 year ago
Quoted from jgadzia:

tried an original 555 bulb and does not work. used the light in the start button and it doesnt work in the buy in button slot. when i measure the voltage in the socket i am only getting abou 1.5 volts max. If i measure the voltage in front of the diode i get 7 volts. I used a 1n4004 diode is that the correct diode. not sure what else to check here? any help greatly appreciated!

So the buy in button has a diode while the start button does not. Interesting. Anyway, I bet your socket is just flaky. Install a known good 555 bulb and start the light test for that light only. Jiggle the terminals on the back of the buy in switch while the test is running. I bet you can get it to work. Seems like those sockets are a little unreliable in my opinion. If that doesn't work you have a broken wire or a bad transistor.

20180911_120529 (resized).jpg
2 weeks later
#6388 1 year ago

Hey TZ fans - I have a strange issue or maybe I don't. I'm not really sure. My game plays great. I have a newer Rotten Dog MPU installed with the remote battery pack and fresh batteries. About every 10 to 15 power ons the game reports "factory settings restored". The funny thing is my settings are all still there including free play. I just ignore it and continue to play on until it show up the next time. Is this one of the undocumented features????? Anybody else seeing this?

#6400 1 year ago
Quoted from jawjaw:

Hmm... Didn't know that Rottendog mpu's had a history with draining batteries. That would explain why my Congo went through fresh lithium batteries in less than a year lately. Expected them to last a long time but only went around 9 months.
If you are having worst problems with batteries, I would look into nvram. Not sure if that is a pain to put in a Rottendog board but it sure is nice not to have to deal with batteries. You loose some features like the clock telling the correct time but I wouldn't call that a big deal if you have to change batteries often.

It does seems like the Rotten Dog board is eating my batteries. The batteries are testing weak after only a couple months. Got to have my clock working so NVRam isn’t an option on TZ for me. Has anybody tried a memory capacitor on a Rotten Dog MPU? In theory I think it should work.

#6407 1 year ago
Quoted from jawjaw:

Your clock is still going to work with nvram. It just won't show the correct time in attract mode since the time will reset every time you power cycle the game.

Yeah - I realize that but want I it to display the correct time because I’m anal like that.

5 months later
#6884 11 months ago
Quoted from Ben38:

Hi
The vertical wood plate at the end of the playfield is missing on my TZ.
Can anyone give me the dimensions of this plate?
The height and thickness. So I will be able to build a new one.
Thanks

Check my post 5865 in this thread. I had the same issue. The plywood is 3/4” thick and it is 6 1/2” tall. The width is the same as the playfield.

#6888 11 months ago
Quoted from Ben38:

Thanks a lot for the informations ! I will have a look to the post you suggest.

No problem but I told you the worng thickness. It should be 1/2".

1 week later
#6943 11 months ago
Quoted from MMP:

I don't think its so bad... it's not like detailed board soldering. It can be done with a basic soldering iron and basic skills. Youtube has some tutorial videos.
Hey, I have a question for anyone who has rebuilt the clock mech. I am assembling now after cleaning and I am wondering if the plastic gears should be lubricated or if they are better left alone.

Lube them. Your clock will be much quieter. I use teflon made for skateboard bearings. Works great.

1 month later
#7014 9 months ago

You also should consider replacing that cap if you haven’t already. Old caps can cause all sorts of sound issues.

3 weeks later
#7104 9 months ago
Quoted from Pesmerga:

Hello guys my TZ is missing the bracket that goes under the mini playfield. It is this two-part assembly in the attached pics, do anyone has a spare that could sell to me? Or can you suggest a website that sells it?? Thanks!!
[quoted image][quoted image][quoted image][quoted image][quoted image]

Did anybody chime in on this? I need the smaller of the two parts also. Had to fabricate my own but would love an original.

#7128 9 months ago
Quoted from Scotty_K:

As someone may have mentioned before, that might not be sufficient. It will work perhaps in the short term, but as time goes on, with vibration and all, it might work its way loose again. See how it goes, but the only true solution is to solder the wires directly to the pins on one end, twisting the wires, and then soldering the other end.

I totally agree with this. The problem will return until the wires have been soldered in place. I soldered to the backside of the boards. It seemed a little less offensive visually.

4 months later
#7550 4 months ago

Is it just me or do others feel my pain? Lifting the playfield on my TZ is challenging. It’s doable but takes some effort. I think it is just because it is a wide body and there is so much stuff mounted on the playfield. The playfield also likes to bind along the sides on the way up and down. For that reason I would never consider using art blades on this title. I always cringe when I use the playfield prop stick. Seems like it is being stressed to the limit. It is very rare that i can get the playfield to locked into place on the first try.

1 week later
#7596 4 months ago
Quoted from mathiaswallin:

My mini-playfield stopped working all of a sudden, magnets doesnt move balls anymore. Entry-switch as well as magnets works in test. I'm clueless.
Could it be something as simple as the balls or where should I start?
Also the gum ball Popper doesnt work, How do I check if the Opto is broken or clogged or whatever the fault might be?
Could it all be connected and its something with the opto-board?

Start by checking all the fuses with a multi meter. My TZ likes to pop a solenoid fuse if I lift the playfield will the balls installed in the gumball machine. Because of that I always remove all the balls before lifting the playfield and never had a problem again. If you lift the playfield with the balls in the gumball machine one always falls into the opto sensor path and causes the solenoid to fire when you turn on the game. It seems that extra power draw is just enough to pop the fuse.

#7617 3 months ago
Quoted from Durzel:

I might be going mad but I turned on my TZ this morning to check something, and whilst the Grand Champion score was right, the other ones were default scores. I'm almost certain they weren't the last time I used it as it would be pretty fantastical to have a GC score with none below it. The game booted without complaint or error (so not "Factory Settings Restored" or anything). Any ideas?

Are you still using AA batteries? Weak batteries can cause issues. You start losing some settings while others remain. You can swap them while the game is tuned on if you're careful. That lets you retain the settings / scores you have left.

Promoted items from the Pinside Marketplace
$ 75.00
$ 229.99
Lighting - Other
Lighted Pinball Mods

You're currently viewing posts by Pinsider mad_dog_coin_op.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside