(Topic ID: 63352)

Twilight Zone Owner's club


By Caucasian2Step

6 years ago



Topic Stats

  • 8,219 posts
  • 604 Pinsiders participating
  • Latest reply 1 day ago by Manny65
  • Topic is favorited by 324 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,092 images uploaded to this topic. (View topic image gallery).

20200221_062832 (resized).jpg
TZ (resized).png
PF rails TZ (resized).JPG
PF rails TZ 2 (resized).JPG
7fb3335899d17e1f0c7bd20ecec7ea5ad7e8b8ae (resized).jpeg
IMG_0393 (resized).jpeg
IMG_0398 (resized).jpeg
IMG_0395 (resized).jpeg
IMG_0394 (resized).jpeg
IMG_0392 (resized).jpeg
IMG_0371 (resized).jpeg
IMG_0368 (resized).jpeg
60359377469__3DAC472B-9E66-45FE-A146-7BFC3F5CE802 (resized).jpeg
IMG_0366 (resized).jpeg
IMG_0365 (resized).jpeg
IMG_0360 (resized).jpeg

You're currently viewing posts by Pinsider harig.
Click here to go back to viewing the entire thread.

#7058 9 months ago

just joined the club yesterday
member of the DYWC (dangling yellow wire club) as well
anyone found the purpose of the "dangling yellow wire" ?

Added 9 months ago:

link to the original post: https://pinside.com/pinball/forum/topic/twilight-zone-owners-club/page/120#post-4455844

1 week later
#7081 9 months ago
Quoted from Coyote:

No purpose, other than a test point, and/or a break in the wire.
(Since it's one of the longest wires, the automated wire-harness
machines may have needed something to continue that line.)

thanks!

1 week later
#7131 9 months ago

having issues with (I think) game adjustments:

I use the latest 9.4CH rom and do not manage to ever get an extra ball awarded:
* "lite extra ball" door panel is always lit right from the beginning
* Robot shots just award the camera

the game is NOT set to tournament mode

gone through all the settings-any ideas which of the settings could cause that behaviour?

thx!

#7136 8 months ago
Quoted from Marvin:

EB works fine on CH. is there a particular EB that you are not getting or in general?

hm...seems there is different opinions on that topic.

I do not own that machine for a long time and recently changed to the 9.4CH ROM.
I do not get any extra ball at all (might be related to no being a good player) or maybe some adjustments not being correct...but could not find them

IIRC with the old ROM the game came with I could at least lite the extra ball insert at the lock ramp.

#7139 8 months ago

Seems I finally found it: A1-03 max E.B. count was set to 0

Looks ok now...havent tested much

Thk

3 weeks later
#7244 8 months ago

just for the records-might help someone at some point:

my TZ was driving me crazy with following sympthoms:

- ending the game altough ball was still in play
- firing a coil (ball feeder?) during game in play
- sometimes feeding 2 balls into shooter lane

after some investigations and struggles I cleaned the ballthrough, readjusted the switches but finally it seems the balls were manetized which caused the balls to get "stuck" in the through and not moving to the far right end...all the issues were gone after exchanging the balls with some new low magnetic ones...

3 months later
#7503 4 months ago
Quoted from Parker_tz:

On my Twilight zone about half the time I skill shot the ball into the rocket it bounces out. It does not ever launch it just hits the ball Guide and falls out. It is nothing to do with the adjustable ball Guide because I set it right in the middle of the hitchhiker under the mini playfield. Does any one have any tips of how to fix it?

had the same issue. Added a very thin rubber sheet (maybe something like a bike tire inner tube works?) to the adjustable ball guide and got rid of that issue...

1 month later
#7691 3 months ago
Quoted from lanfeust:When the ball goes into the rocket kick out, does it go straight to the camera when ejected or not? thanks.

not to the camera but the "hole" below (is it the hitchhiker?)

1 week later
#7706 83 days ago
Quoted from Neal_W:

I see www.pinball.center sells various pieces.

DonĀ“t expect too much from those...they are often poor quality...

1 month later
#7889 37 days ago

Go to "switch test" and see if the switch is registering...test with the ball also not only with your finger.
No resitor on the switch but a diode. 1N4004 or similar...basically any standard diode will do the job

3 weeks later
#8097 16 days ago
Quoted from Pugsley:

On another topic related to The Twilight Zone... I have been sorting videos for the past month and 2 have caught my attention. Surprisingly by the same artist:

Has anybody used the first song in a game before as a replacement for the main theme? Could go a long way towards a Techno version of the game if all new SFX were added.

They were my heroes when I was young

Promoted items from the Pinside Marketplace
6,895 (OBO)
Machine - For Sale
San Jose, CA
$ 65.00
Boards
Pinball Haus
$ 5.00
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs

You're currently viewing posts by Pinsider harig.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside