(Topic ID: 63352)

Twilight Zone Owner's club


By Caucasian2Step

5 years ago



Topic Stats

  • 7,211 posts
  • 536 Pinsiders participating
  • Latest reply 2 days ago by Durzel
  • Topic is favorited by 283 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,883 images uploaded to this topic. (View topic image gallery).

IMG_2821 (resized).jpeg
81DECA32-55F7-4B79-8829-7F884607E798 (resized).jpeg
61635733-40B4-4AAC-8F9C-989DFFB107E3 (resized).jpeg
20190610_220742 (resized).jpg
60DC3E76-0003-4C1B-AA77-58041CA1CC6C (resized).jpeg
IMG_2432 (resized).jpeg
UNADJUSTEDNONRAW_thumb_95a (resized).jpg
UNADJUSTEDNONRAW_thumb_95b (resized).jpg
UNADJUSTEDNONRAW_thumb_955 (resized).jpg
47946391218_f18c9a747b_z (resized).jpg
47946412756_1e1b02b9fe_k (resized).jpg
47946382432_5949fec132_k (resized).jpg
21703874-61D7-4FE3-8251-6F80EF886114.jpeg
20190522_095611 (resized).jpg
IMG_8660 (resized).JPG
3 (resized).jpg

There are 7211 posts in this topic. You are on page 143 of 145.
#7101 30 days ago

Hello guys my TZ is missing the bracket that goes under the mini playfield. It is this two-part assembly in the attached pics, do anyone has a spare that could sell to me? Or can you suggest a website that sells it?? Thanks!!

20190415_101154 (resized).jpg20190415_101213 (resized).jpg20190415_191827 (resized).jpg20190415_193315 (resized).jpg20190415_193322 (resized).jpg
#7102 30 days ago
Quoted from jawjaw:

If I can replace a part cheaply and get things working right quickly, I am going to do that.

That makes sense, but keep in mind that sometimes the issue is that they just need cleaning, and you can also swap them around to left or right, or with another pin and see if anything changes.

#7103 30 days ago

PINBALL TECH : TWILIGHT ZONE RIGHT UPPER FLIPPER FLASHER LOCKED ON : VIDEO REPAIR

While playing my Twilight Zone pinball machine the other day, I noticed some smoke starting to come from the playfield. I quickly turned off the machine and removed the glass. First thing I can notice is that the plastic right above the right upper flipper looked melted. Looking more closely at that area, I was able to see a burn mark in the plastic and figured a bulb had locked on underneath causing the damage.

Blog Post :
https://pinballsupernova.wordpress.com/2019/05/21/pinball-tech-twilight-zone-right-upper-flipper-flasher-locked-on-video-repair/

YouTube Video :

2 (resized).jpg3 (resized).jpgTitle (resized).jpg
#7104 30 days ago
Quoted from Pesmerga:

Hello guys my TZ is missing the bracket that goes under the mini playfield. It is this two-part assembly in the attached pics, do anyone has a spare that could sell to me? Or can you suggest a website that sells it?? Thanks!!
[quoted image][quoted image][quoted image][quoted image][quoted image]

Did anybody chime in on this? I need the smaller of the two parts also. Had to fabricate my own but would love an original.

#7105 30 days ago

Does anyone here who has completed a restoration or a teardown of TZ still have their reference photos from that process? I usually take hundreds of pictures as I'm taking things apart, but the one I am restoring was damaged/incomplete in many ways. I'm close to the point where I need to start putting things back together, but I know I'm going to hit an informational wall especially when I'm reconstructing the playfield.

My restoration is being documented here if anyone is interested:
https://pinside.com/pinball/forum/topic/twilight-zone-restoration-2

#7106 29 days ago

I'm currently in the process of a full resto as well -
https://pinside.com/pinball/forum/topic/twilight-zone-restoration-1

I'm happy to help if u need some extra pics

Quoted from McSquid:

Does anyone here who has completed a restoration or a teardown of TZ still have their reference photos from that process? I usually take hundreds of pictures as I'm taking things apart, but the one I am restoring was damaged/incomplete in many ways. I'm close to the point where I need to start putting things back together, but I know I'm going to hit an informational wall especially when I'm reconstructing the playfield.
My restoration is being documented here if anyone is interested:
https://pinside.com/pinball/forum/topic/twilight-zone-restoration-2

#7107 29 days ago
Quoted from Mneubey:

I'm currently in the process of a full resto as well -
https://pinside.com/pinball/forum/topic/twilight-zone-restoration-1
I'm happy to help if u need some extra pics

Thanks a ton! ill definitely need some. My game is likely missing parts I dont even know exist. So putting it back together is going to be a challenge.

I'll be following along with your work. Good luck to us both!

#7108 29 days ago

Same to you! Ive been enjoying your thread so far! Your playfield looks great now. Hit me up when u get to that point

Quoted from McSquid:

Thanks a ton! ill definitely need some. My game is likely missing parts I dont even know exist. So putting it back together is going to be a challenge.
I'll be following along with your work. Good luck to us both!

#7109 29 days ago

Having issues with the powerball not being detected in the trough. What opt or board needs to be replaced?

#7110 29 days ago
Quoted from pacman11:

Having issues with the powerball not being detected in the trough. What opt or board needs to be replaced?

There’s a eddy sensor right by the trough with a wire that goes to a little board. Try reseating that wire in the board, that usually fixes the issue for me.

#7111 29 days ago
Quoted from gunstarhero:

There’s a eddy sensor right by the trough with a wire that goes to a little board. Try reseating that wire in the board, that usually fixes the issue for me.

The board and sensor solder joints at the connectors are also prone to breaking away. You should inspect the solder joints. Most
People end up soldering the wires directly to the boards and bypassing the connectors.

You also need to make sure the sensor is close enough to the trough
To detect the metal balls. I just replaced my sensor and it took a bit of testing to make sure the sensor was tripped. It's VERY close to the trough and I was worried a ball would smash into it, but it seems fine

#7112 29 days ago

Here's an irritating issue I've had for awhile: When a ball gets sent from the ball trough outhole kicker to the shooter, the ball (more often than not) strikes the little post and bounces back into the trough instead of going to the shooter. This happens sometimes 3-4 times before it finally gets to where it needs to go. Is this a leveling issue (the table seems level), something screwy with the kicker/trough itself, or just another quirk of this game? Looking for some ideas on where to start.

Thanks in advance!

#7113 29 days ago

Could your wire gate that keeps it from rolling back into the trough be broken? Ive had that happen a few times

Quoted from Adipocere:

Here's an irritating issue I've had for awhile: When a ball gets sent from the ball trough outhole kicker to the shooter, the ball (more often than not) strikes the little post and bounces back into the trough instead of going to the shooter. This happens sometimes 3-4 times before it finally gets to where it needs to go. Is this a leveling issue (the table seems level), something screwy with the kicker/trough itself, or just another quirk of this game? Looking for some ideas on where to start.
Thanks in advance!

#7114 29 days ago
Quoted from Mneubey:

Could your wire gate that keeps it from rolling back into the trough be broken? Ive had that happen a few times

Hmm. What is this wire gate you speak of? A cursory examination of my trough does not show one. Perhaps this is the issue...

Pic below. I also scanned Marco real quick: am I possibly missing this part, or another one?

https://www.marcospecialties.com/pinball-parts/12-6542

IMG_8660 (resized).JPG

#7115 29 days ago

Yep, thats the one. If u take off the apron its pretty easy to access. It just keeps the ball from rolling back. Just a thought, may be it

Quoted from Adipocere:

Hmm. What is this wire gate you speak of? A cursory examination of my trough does not show one. Perhaps this is the issue...
Pic below. I also scanned Marco real quick: am I possibly missing this part, or another one?
https://www.marcospecialties.com/pinball-parts/12-6542
[quoted image]

20190522_095611 (resized).jpg
#7116 29 days ago

Actually, sorry .. After rereading, it may not be ur issue. The gate just keeps it from falling back out of the trough when its kicked into the trough after a drain. Worth taking off the apron to see if anytging else could be adjusted though

#7117 28 days ago

I’ve had the same issue of the ball eject and then go back in the trough. It’s happened on my Pinbot as well. I bent the top angle of the eject trough just a hair and VOILA! Perfect eject every time. Just a little tweak with some pliers to make it eject more at an angle towards the plunger. Try that. Just did it to my TZ yesterday. At the same time, make sure to tighten up the small hex screw to the lane diverter. Mine was not tight and wobbly

#7118 28 days ago
Quoted from Mneubey:

Actually, sorry .. After rereading, it may not be ur issue. The gate just keeps it from falling back out of the trough when its kicked into the trough after a drain. Worth taking off the apron to see if anytging else could be adjusted though

I suppose so. The ball basically is striking the white rubber in the pic and going right back into the trough, then rinsing and repeating until it finds the correct angle. Some sort of gate WOULD make sense but I don't see a spot for one. Guess I'll go through the adventure of removing the apron and seeing what might be loose or off-kilter. Thanks for the help!

#7119 28 days ago

Here is your pic showing the piece to bend just slightly.

Quoted from Adipocere:

Hmm. What is this wire gate you speak of? A cursory examination of my trough does not show one. Perhaps this is the issue...
Pic below. I also scanned Marco real quick: am I possibly missing this part, or another one?
https://www.marcospecialties.com/pinball-parts/12-6542
[quoted image]

21703874-61D7-4FE3-8251-6F80EF886114.jpeg
#7120 28 days ago
Quoted from Adipocere:

I suppose so. The ball basically is striking the white rubber in the pic and going right back into the trough, then rinsing and repeating until it finds the correct angle. Some sort of gate WOULD make sense but I don't see a spot for one. Guess I'll go through the adventure of removing the apron and seeing what might be loose or off-kilter. Thanks for the help!

Try removing that rubber.

#7121 28 days ago
Quoted from JWJr:

Try removing that rubber.

When i got mine, the rubber was removed. I assumed this is why.

#7122 28 days ago
Quoted from JWJr:

Try removing that rubber.

I've considered that. I am also wondering if using black rubber there might accomplish the same thing with less bounce back.

#7123 28 days ago

It is a common issue on TZ that the ball guide sometimes needs to be bent a little like shown above to resolve kickout issues. (It has been documented many times in this tread.)

#7124 28 days ago
Quoted from Neal_W:

It is a common issue on TZ that the ball guide sometimes needs to be bent a little like shown above to resolve kickout issues. (It has been documented many times in this tread.)

Thanks. I tried this and indeed it seems to work! I did try and do a search of the thread earlier, but it is possible I was using the wrong keywords.

#7125 28 days ago

Thanks guys I made sure the connection was tight on the eddy board and everything is working good now.

#7126 27 days ago
Quoted from pacman11:

Thanks guys I made sure the connection was tight on the eddy board and everything is working good now.

As someone may have mentioned before, that might not be sufficient. It will work perhaps in the short term, but as time goes on, with vibration and all, it might work its way loose again. See how it goes, but the only true solution is to solder the wires directly to the pins on one end, twisting the wires, and then soldering the other end.

#7127 27 days ago
Quoted from Scotty_K:

As someone may have mentioned before, that might not be sufficient. It will work perhaps in the short term, but as time goes on, with vibration and all, it might work its way loose again. See how it goes, but the only true solution is to solder the wires directly to the pins on one end, twisting the wires, and then soldering the other end.

Yeah will see how long it goes for.. I used a tiny regular screw driver and push the wires back into the connectors which seemed loose.

#7128 27 days ago
Quoted from Scotty_K:

As someone may have mentioned before, that might not be sufficient. It will work perhaps in the short term, but as time goes on, with vibration and all, it might work its way loose again. See how it goes, but the only true solution is to solder the wires directly to the pins on one end, twisting the wires, and then soldering the other end.

I totally agree with this. The problem will return until the wires have been soldered in place. I soldered to the backside of the boards. It seemed a little less offensive visually.

#7129 27 days ago
Quoted from Mad_Dog_Coin_Op:

I totally agree with this. The problem will return until the wires have been soldered in place. I soldered to the backside of the boards. It seemed a little less offensive visually.

Actually there is another fix that I used and have not had a problem since. Twist the wire 8-10 times and then connect it again. Mine has stayed on nice and snug ever since. No need to solder.

#7130 23 days ago

I ran into a little drama with my TZ recently. During play, (mainly with multiball) all of a sudden I loose my flippers, display, and credit dot city. I'm thinking hmmm I find F116 blown. Replace it and we are playing again. Then randomly boom it blows again. This was going on and off for maybe 2 weeks. So now I get to a point where I put the fuse in, start a game and boom pops the fuse. I noticed the clock on start up was freaking out a little so I inspect around that and sure enough, some clown at one point maybe replaced the motor and just spun the wires and a touch of electrical tape. Well over time the wire slowly moved near the wireform and sure enough the damn thing is barely touching the wireform! Nothing like sending 12 volts to ground!!! Some solder, heatshrink, and we are back in business! If I didn't hear that clock make a funky sound on start up I would have never looked there! I started pulling mods, thinking the main board needs a rebuild, reset circuit, and it seemed to happen around when I was going in the gumball machine so I thought that was my issue as well... NOPE! all I can say is take your time and fix the games properly! I know who worked on this pin at several times over the years before I bought it and I'm kinda surprised to find this kinda repair. Well I can look back and laugh now and sure enough TZ was so happy I fixed it, I had my highest game ever on it! Everybody happy happy happy again!

47946382432_5949fec132_k (resized).jpg47946391218_f18c9a747b_z (resized).jpg47946412756_1e1b02b9fe_k (resized).jpg
#7131 23 days ago

having issues with (I think) game adjustments:

I use the latest 9.4CH rom and do not manage to ever get an extra ball awarded:
* "lite extra ball" door panel is always lit right from the beginning
* Robot shots just award the camera

the game is NOT set to tournament mode

gone through all the settings-any ideas which of the settings could cause that behaviour?

thx!

#7132 23 days ago

Maybe try using 9.4H instead and your problems might go away?

If I recall correctly "Camera + Extra Ball" is a setting that adjusts itself based on how well players have been playing the game? I seem to recall the lock shot being Camera only when I first started playing, but changed to Camera + Extra Ball when the game realised how bad I was at the game

In other news...

On my TZ I installed some yellow plastic protectors for the outlanes, slingshots, rocket and slot machine that were made by a guy in the UK (very cost effective compared to most places). Very happy with how it came out..

UNADJUSTEDNONRAW_thumb_955 (resized).jpg

UNADJUSTEDNONRAW_thumb_95b (resized).jpg

UNADJUSTEDNONRAW_thumb_95a (resized).jpg

His name is colywobbles if anyone is interested in getting some I don't benefit in any way from the recommendation, just thought I'd pass it along.

#7133 22 days ago
Quoted from harig:

having issues with (I think) game adjustments:
I use the latest 9.4CH rom and do not manage to ever get an extra ball awarded:
* "lite extra ball" door panel is always lit right from the beginning
* Robot shots just award the camera
the game is NOT set to tournament mode
gone through all the settings-any ideas which of the settings could cause that behaviour?
thx!

Remove 9.4CH, and install 9.4H.
The idiot that made 9.4CH (or BH, depending on when you got it) introduced an error in the Spot Panel adjustment setting because they didn't know what they were doing. You are seeing this bug.

#7134 22 days ago
Quoted from Coyote:

Remove 9.4CH, and install 9.4H.
The idiot that made 9.4CH (or BH, depending on when you got it) introduced an error in the Spot Panel adjustment setting because they didn't know what they were doing. You are seeing this bug.

Concur. 9.4CH is bad news

#7135 22 days ago
Quoted from harig:

having issues with (I think) game adjustments:
I use the latest 9.4CH rom and do not manage to ever get an extra ball awarded:
* "lite extra ball" door panel is always lit right from the beginning
* Robot shots just award the camera
the game is NOT set to tournament mode
gone through all the settings-any ideas which of the settings could cause that behaviour?
thx!

EB works fine on CH. is there a particular EB that you are not getting or in general?

#7136 22 days ago
Quoted from Marvin:

EB works fine on CH. is there a particular EB that you are not getting or in general?

hm...seems there is different opinions on that topic.

I do not own that machine for a long time and recently changed to the 9.4CH ROM.
I do not get any extra ball at all (might be related to no being a good player) or maybe some adjustments not being correct...but could not find them

IIRC with the old ROM the game came with I could at least lite the extra ball insert at the lock ramp.

#7137 22 days ago
Quoted from Durzel:

Maybe try using 9.4H instead and your problems might go away?
If I recall correctly "Camera + Extra Ball" is a setting that adjusts itself based on how well players have been playing the game? I seem to recall the lock shot being Camera only when I first started playing, but changed to Camera + Extra Ball when the game realised how bad I was at the game
In other news...
On my TZ I installed some yellow plastic protectors for the outlanes, slingshots, rocket and slot machine that were made by a guy in the UK (very cost effective compared to most places). Very happy with how it came out..
[quoted image]
[quoted image]
[quoted image]
His name is colywobbles if anyone is interested in getting some I don't benefit in any way from the recommendation, just thought I'd pass it along.

Hey, nice protectors ! Love them. Will try to buy them, thanks.

#7138 21 days ago
Quoted from harig:

hm...seems there is different opinions on that topic.
I do not own that machine for a long time and recently changed to the 9.4CH ROM.
I do not get any extra ball at all (might be related to no being a good player) or maybe some adjustments not being correct...but could not find them
IIRC with the old ROM the game came with I could at least lite the extra ball insert at the lock ramp.

do you get extra ball for getting enough robots? I know I get EBs on my game. take the glass of to test things. see if you get the EB to light by following the rule sheet on IPDB.

#7139 21 days ago

Seems I finally found it: A1-03 max E.B. count was set to 0

Looks ok now...havent tested much

Thk

#7140 21 days ago

does anyone know who makes a custom lockdown bar that's engraved (robot and sprial as I recall)? I saw one posted on facebook the other day and can't find it now and was curious who made them and if available.

#7141 20 days ago

Does anyone know if you can buy the bracket for the proximity trough sensor for TZ? I have failed to find it anywhere.

#7142 20 days ago

Does anyone know if you can take a eprom 9.4H from one TZ and switch with another TZs eprom L-4? Is it as easy as unplugging them and swapping?

#7143 20 days ago
Quoted from Green-Machine:

Does anyone know if you can take a eprom 9.4H from one TZ and switch with another TZs eprom L-4? Is it as easy as unplugging them and swapping?

It is, but you really need to be careful removing the rom without a rom tool. Lift each side 1mm (1/16 inch?? ) at a time. Be careful toward the end as it will start to come out easier. If you lift one side to much compared to the other, you'll bend all the pins. You'll likely bend them a little, but it's easy to bend them back. Too much pressure on one side, and you can bend them so much that they'll break as you try to bend them back. Patience is key.

I use a small flathead screwdriver to lift either side, but I've heard others argue against that method. I've swapped many roms without an issue.

#7144 20 days ago
Quoted from Tranquilize:

It is, but you really need to be careful removing the rom without a rom tool. Lift each side 1mm (1/16 inch?? ) at a time. Be careful toward the end as it will start to come out easier. If you lift one side to much compared to the other, you'll bend all the pins. You'll likely bend them a little, but it's easy to bend them back. Too much pressure on one side, and you can bend them so much that they'll break as you try to bend them back. Patience is key.
I use a small flathead screwdriver to lift either side, but I've heard others argue against that method. I've swapped many roms without an issue.

Thank you very much! I will give it go.

#7145 20 days ago

By any chance did you have info on purchasing a bracket for proximity trough sensor?

#7146 20 days ago
Quoted from Tranquilize:

It is, but you really need to be careful removing the rom without a rom tool. Lift each side 1mm (1/16 inch?? ) at a time. Be careful toward the end as it will start to come out easier. If you lift one side to much compared to the other, you'll bend all the pins. You'll likely bend them a little, but it's easy to bend them back. Too much pressure on one side, and you can bend them so much that they'll break as you try to bend them back. Patience is key.
I use a small flathead screwdriver to lift either side, but I've heard others argue against that method. I've swapped many roms without an issue.

Echoing this. I changed the ROMs in my TAF, and am generally careful, but I still managed to bend the pins on 2 of the 3 chips I removed, and one pin actually came off in my hand as I put the chip down.

Definitely go with the chip puller.

#7147 20 days ago
Quoted from Durzel:

Echoing this. I changed the ROMs in my TAF, and am generally careful, but I still managed to bend the pins on 2 of the 3 chips I removed, and one pin actually came off in my hand as I put the chip down.
Definitely go with the chip puller.

Thanks! Where can I buy a chip puller?

#7148 20 days ago
Quoted from Green-Machine:

Thanks! Where can I buy a chip puller?

Something like this would be safer:

https://www.marcospecialties.com/pinball-parts/77-ICE

I should say that I haven't bought or used a chip puller myself, I'm just relaying my experiences of trying to do it carefully with a mini screwdriver - as others suggested I should do.

The chips will probably be quite stiff in their sockets, particularly if they've never previously been removed. It would be easy to apply too much twisting force on a screwdriver and bend some pins. As said, I did it on two chips - which fortunately I did not need to keep, and I consider myself to be very careful.

This was my actual chip afterwards...

IMG_2432 (resized).jpeg

#7149 20 days ago

NOTE: When you remove the chip, pay attention to the notch on one end of the chip. INSERT THE NEW CHIP IN THE SAME EXACT WAY.

Since the chip is concentric, you can easily put it in backwards, which will result in smoking the chip and permanent damage.

Always note where that notch is, and insert the new chip with the notch on the same side. Normally, the silk screening on the PC board shows the direction of that notch. Also, the socket that the chip is inserted into will have its own notch on one end only. And usually all other socketed chips lie on the PC board in the same direction with notches all on the same ends.

Read the above twice so you understand that doing it wrong will destroy the new chip.

#7150 20 days ago

Thanks ramegoon And Durzel! You guys rock!

Promoted items from the Pinside Marketplace
$ 14.95
$ 279.95
From: $ 45.95
Playfield - Toys/Add-ons
pinballmod
$ 39.00
Playfield - Toys/Add-ons
Lermods
7,500 (OBO)
Machine - For Sale
Carolina Forest, SC
$ 14.95
$ 20.99
Lighting - Interactive
Lee's Parts
$ 40.00
Lighting - Other
Rock Custom Pinball
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 22.50
7,000 (OBO)
Machine - For Sale
Charlottesville, VA
Trade
Machine - For Trade
Mooresville, NC
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
7,500 (OBO)
Machine - For Sale
Ashton-sandy Spring, MD
$ 279.95
$ 15.45
Gameroom - Decorations
KAHR.US Circuits
$ 49.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 999.00
$ 279.95
$ 999.00
Pinball Machine
Mircoplayfields
€ 3.70
$ 159.95
Playfield - Toys/Add-ons
pinballmod
$ 57.95
Playfield - Toys/Add-ons
PinBoss Mods
$ 16.00
There are 7211 posts in this topic. You are on page 143 of 145.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside