(Topic ID: 63352)

Twilight Zone Owner's club


By Caucasian2Step

5 years ago



Topic Stats

  • 7,386 posts
  • 552 Pinsiders participating
  • Latest reply 6 hours ago by Adipocere
  • Topic is favorited by 289 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,917 images uploaded to this topic. (View topic image gallery).

Untitled (resized).jpg
Screenshot_20190824-124646 (resized).png
DAC1310D-A323-4CD0-B42E-82DAF14210CD (resized).jpeg
FJIMG_20190824_014647 (resized).jpg
IMG_20170328_2341432531(1) (resized).jpg
Screen Shot 2019-08-12 at 9.57.01 AM (resized).png
FJIMG_20190811_150319 (resized).jpg
TZ058 (resized).jpg
TZ057 (resized).jpg
TZ059 (resized).jpg
TZ056 (resized).jpg
TZ054 (resized).jpg
TZ055 (resized).jpg
TZ041 (resized).jpg
TZ040 (resized).jpg
TZ039 (resized).jpg

There are 7386 posts in this topic. You are on page 11 of 148.
#501 4 years ago

Polished stainless hands with the proto clock face would look great. You plan on tempting us with photos of your one-off project, or would you consider selling a few pairs of the stainless hands?

#502 4 years ago

I don't think I have posted yet here, but I recently picked up a nice TZ. It was nice, but I wanted to make it perfect... so I purchased some chrome trim, new cabinet, HSA play field restore, etc.

I am currently in the process of cleaning all of the playfield parts while that is getting restored.

All the medium/small metal is being tumbled, not sure what I am going to do with plastics yet. probably replacing with a new set.

I keep meaning to put up a restoration post to show my work... I took hundreds of pictures so far to document everything, mainly so I can put it back together properly!

Anyway, I have also been looking at mods to do, so I will have to go though this thread and see what else has been done.

One mod I am currently working on if you have not seen it yet: https://pinside.com/pinball/forum/topic/new-ish-tz-tv-mod-w-beautiful-video-playback

Putting an LCD with full video playback inside the Hallmark TV mod. If anyone is interested in picking one up in the next batch, just let me know.

#503 4 years ago

I've been doing a LOT of deep cleaning on my TZ over the course of the last few months. Most recently, I took apart the whole left/rear of the playfield(gumball machine, all the plastics in that area, and the mini playfield). It was absolutely disgusting under there. I cleaned and rebuilt everything. My problem is not taking before pictures. Not for remembering where everything goes, but for how dirty everything was. The main problem comes from not remembering how many bulbs were out/dirty before and how much of a difference to expect when I'm done.

While I admit that area of my TZ was filthy(hell, the whole thing was filthy, this was just the last major area to clean), I don't remember it being this well lit(from behind)!

If this is how it's supposed to be, I've been missing out!

Along with all the cleaning come some new dangers(speed) and new places to get the ball stuck, apparently. Don't know that I've seen this "stuck spot" yet.

IMG_7436.JPGIMG_7437.JPG

#504 4 years ago

Has anyone tried patching the game roms with the non-ghosting patch? TZ seems to have a pretty major issue with LED ghosting, so before I get the LED OCD board I would rather just patch the roms.

The patch did wonders on my TAF and ToM, but I haven't tried it on my TZ yet.

#505 4 years ago
Quoted from swedishc:

Has anyone tried patching the game roms with the non-ghosting patch? TZ seems to have a pretty major issue with LED ghosting, so before I get the LED OCD board I would rather just patch the roms.
The patch did wonders on my TAF and ToM, but I haven't tried it on my TZ yet.

There's one for the TZ?

Once my playfield is sent off and returned, I'm just going to bite the bullet and get the OCD board.

Why?

Because my power-driver board over-drives the LEDs, burning them out withing a few games. (Anyone else have this? Or is my game 'special'?)

#506 4 years ago
Quoted from Coyote:

There's one for the TZ?
Once my playfield is sent off and returned, I'm just going to bite the bullet and get the OCD board.
Why?
Because my power-driver board over-drives the LEDs, burning them out withing a few games. (Anyone else have this? Or is my game 'special'?)

I would verify that the voltage is correct, at the lamp sockets that are burning out.

All of my backbox lighting is LEDs, with the exception of the blinkers. I have a few of them in playfield inserts, but I haven't had a problem with any of them burning out. There are a few that blink differently during attract mode.

#507 4 years ago

I have the Cointaker premium LED set in mine, and they have worked consistently.

#508 4 years ago
Quoted from Craig:

I have the Cointaker premium LED set in mine, and they have worked consistently.

Actually, the Cointaker's are the only ones I've ordered. And they're the ones burning out. They've offered replacements, at their cost (hey, that makes them good people, in my book), but I didn't take them up on it, as it's obviously an issue with my game.

Quoted from TrainH2o:

I would verify that the voltage is correct, at the lamp sockets that are burning out.
All of my backbox lighting is LEDs, with the exception of the blinkers. I have a few of them in playfield inserts, but I haven't had a problem with any of them burning out. There are a few that blink differently during attract mode.

Lamp voltage is 17v at the feed, and using a scope, I get a pulsing 17v, which I believe is correct - the 6.8v is an averaged out reading of the on/off pulses? (Which also causes the flicker in the LEDs..)

I didn't try any of the GI sockets, just the controlled lamps. (I do have some of the blinking "545" replacement LEDs in the backbox - those are fine.)

D'oh - I forgot to mention - my power driver board is a PinLED, as well - NOT the standard WMS board. (Another reason I didn't accept Cointaker's offer to replace them, as as far as I know, it could be the 3rd-party board causing it.)

#509 4 years ago

So your issue is with the controlled lamps, not GI?

#510 4 years ago
Quoted from swedishc:

Has anyone tried patching the game roms with the non-ghosting patch? TZ seems to have a pretty major issue with LED ghosting, so before I get the LED OCD board I would rather just patch the roms.
The patch did wonders on my TAF and ToM, but I haven't tried it on my TZ yet.

Depends what rom your running but the home rom has a patch in it and stopped my game from ghosting once installed

#511 4 years ago

Well i just entered the twilight Zone Now its time to get it up & running

#512 4 years ago
Quoted from 2Kaulitz:

Well i just entered the Twilight Zone Now its time to get it up & running

Good luck buddy hopefully its not to bad she can be a pain sometimes

#513 4 years ago
Quoted from Coyote:

There's one for the TZ?

I have the program for patching a rom file.

#514 4 years ago
Quoted from bigd1979:

Depends what rom your running but the home rom has a patch in it and stopped my game from ghosting once installed

Awesome. Thanks!

#515 4 years ago
Quoted from TrainH2o:

So your issue is with the controlled lamps, not GI?

Correct - the only LEDs I have in GI are the blinkers, and they work fine; no burnouts.

Quoted from 2Kaulitz:

Well i just entered the Twilight Zone Now its time to get it up & running

Congrats. It's a hell of a game.

#516 4 years ago

A video of the led conversion of my TZ.
Included is a never before seen mod, see if you can spot it

#517 4 years ago
Quoted from webdiddy:

A video of the led conversion of my TZ.
Included is a never before seen mod, see if you can spot it
ยป YouTube video

Very well made video!

#519 4 years ago

... Is it still a mod if it came from the factory that way?
IMG_20141107_212240.jpg

#520 4 years ago
Quoted from Coyote:

... Is it still a mod if it came from the factory that way?

In my opinion, those are the best "mods" to add to a pin. The ones that Bally and Williams were too cheap to put on all production pins, like the door panel flashers and the Spiral sign. I also add those that improve game play, or protect from plastic or playfield breakage.

The only true cosmetic mods I have added are the plastic gumballs, and recently I changed out the amber pop bumper cap for one that truly looks orange.

I did order Ingo's clock board, simply because I am tried of fixing my OEM clock boards. I also plan to create and add my own graphics to the very back of the playfield.

#521 4 years ago
Quoted from TrainH2o:

In my opinion, those are the best "mods" to add to a pin. The ones that Bally and Williams were too cheap to put on all production pins, like the door panel flashers and the Spiral sign. I also add those that improve game play, or protect from plastic or playfield breakage.
The only true cosmetic mods I have added are the plastic gumballs, and recently I changed out the amber pop bumper cap for one that truly looks orange.
I did order Ingo's clock board, simply because I am tried of fixing my OEM clock boards. I also plan to create and add my own graphics to the very back of the playfield.

Me too - I (we?) are probably in the minority, but I don't care for mods. The only non-factory one on my game is the laser-cut streetlight over the powerfield.

I unfortunately lost my left spiral sign, I may have to make my own, and yes, once my playfield comes back, I'll be getting Ingo's clock as well, mine's just about had it.

#523 4 years ago
Quoted from Coyote:

Me too - I (we?) are probably in the minority, but I don't care for mods. The only non-factory one on my game is the laser-cut streetlight over the powerfield.

That streetlight does look nice.

I am not opposed to anyone modding their pins, I just prefer a more traditional look on mine. I forgot that I did add the decorative decal to the diverter.

#524 4 years ago

Anyone know were i can get a bracket for the Proximity boards ? My project is missing that and the new board set does not come with it.

#525 4 years ago

Early change?

So, this is something I've always wondered about, but haven't been able to ask anyone about.

My TZ's made in early April, but my playfield is dated early March, and had the door flashers, magnet, and optos wired from the factory. Bumper posts weren't installed, but neither were the plastic plugs.

Now, if you look at the PR photo of the playfield, if you look at the plastic to the left of the bumpers (where the flasher is), you'll see that the top plastic is red. (In samples and prod games, it was re-colored to the purplish roof tiles design.) You will notice, however, it's larger than the plastic underneath. While the coloring was changed, the shape was never modified.

Now, while the shape/size of the plastic is odd, the one underneath doesn't seem to match. However, the top one - the one that changed - does seem to line up to an unknown, patched hole in my playfield. (See attached picture.)

I'd hazard a guess that the middle star post for the plastic (the T-nut in the pic) used to be over some, more towards the pop bumper, but was moved.

Thoughts? What's your playfield have there? Anyone have a different lower plastic that would give any hints?

IMG_20141109_113849.jpg

--M.

#527 4 years ago
Quoted from 2Kaulitz:

Anyone know were i can get a bracket for the Proximity boards ? My project is missing that and the new board set does not come with it.

Honestly, I'd look into getting a small piece of metal (from like Home Depot) and bending a new bracket. Would probably be your cheapest bet. (Alternatively, keep an eye out on eBay for someone parting a game?)

My replacement boards - from WMS, years ago! - also came without a bracket, so at least current makers are following in WMS's footsteps.

#528 4 years ago

For those that have LEDs in their game, a question -

I purchased a Warm White (anti-ghosting from Cointaker), and have been testing it in various inserts. On white ones, it looks fine. The white's a little.. well, whiter. However, when I put it in an amber-colored insert (Super Skill, Door Panel, etc), it made the insert look *yellow*. So yellow I questioned if I should even worry about LEDs then..!

#529 4 years ago

So far, I have only put red LEDs in my red inserts. It really makes the color pop.

Yellow has been a disaster. I don't like the cool or warm white in the yellow inserts, so I still have the standard 555s. Amber; I have not tried yet. I might try the Comet Sunlight, next time I need to order lamps.

I would like to put an orange in the orange insert for the mini playfield. It needs to look a little more orange.

#530 4 years ago
Quoted from Coyote:

Honestly, I'd look into getting a small piece of metal (from like Home Depot) and bending a new bracket. Would probably be your cheapest bet. (Alternatively, keep an eye out on eBay for someone parting a game?)
My replacement boards - from WMS, years ago! - also came without a bracket, so at least current makers are following in WMS's footsteps.

Thx for the info and now I gotta find flipper bracket and u channel too.

1 week later
#531 4 years ago

Just had an amusing issue, and the fix:

A couple of nights ago, was playing a game, and locked my first ball. Game says "watch for kickout", then POWERBALL. However, no ball appears, and the powerball is actually visible in the gumball machine. So it kicks off a ball search, then seemingly gives up and auto-fires one from the trough. Game continued normally after that, so I just filed it away to look at later.

Another game tonight, I started multiball, but that multiball only had two balls kick out. Hmmm. Time to investigate.

First place I looked was at all the trough switches, then all the lock switches. Also cleaned the lock optos while I was at it. No issues were noted with any of the switches. So I did an "empty balls" operation from the menu just to see if I hadn't somehow had a ball gone missing somewhere.

That was where the problem became apparent. The game would only kick one ball out of the trough, even though there were three in there. Turns out that the ball popper mechanism itself was gummed up and not returning to rest position when it kicked (at least, not right away... eventually it would get there).

So, it was an easy fix. Pop out the mechanism and thoroughly clean and degrease it. No further issues, and no parts needed replacing. Not sure how it ended up with grease in there, but at any rate, it is all good now.

#532 4 years ago

thanks Neurok. Always good to hear about problems and their fixed. Poor confused TZ, amazing how well it coped with it's gummed up kicker - not sure I'd be that comfortable if mine was gummed up.

#533 4 years ago

in between owning or playing TZ for a while, it always blows my mind when the power ball pops out into the shooter lane....''oh yeah...it's got this crazy thing in it''...

great game.

#534 4 years ago

Love my TZ! Please check out my Twilight Zone Pinball:Gameplay tutorial.

Video is also posted here on pinside.

#535 4 years ago

I've seen an errantly reported Powerball a few times on mine, but then it's shortly followed by a switch matrix meltdown, blown F115 fuse & U20 chip on the MPU...or worse...blah...

But, I did start losing balls in the game somewhere at one point--they were nowhere to be found--I was down to 3 out of 6!

Turns out that that the ejector to the right of the robot lock ramp was launching the balls *up* & they were getting pinched between 2 pieces & suspended, dangling in a pinch hold above the PF just to the right of that hole! It was a region that I couldn't disassemble to tweak, so just a little filing with a jeweler's file gave it just enough clearance that the balls don't get stuck up in the air there anymore. It was amusing when I found where all those balls had been hiding...

-Jason

Quoted from neurokinetik:

Just had an amusing issue, and the fix:
A couple of nights ago, was playing a game, and locked my first ball. Game says "watch for kickout", then POWERBALL. However, no ball appears, and the powerball is actually visible in the gumball machine. So it kicks off a ball search, then seemingly gives up and auto-fires one from the trough. Game continued normally after that, so I just filed it away to look at later.
Another game tonight, I started multiball, but that multiball only had two balls kick out. Hmmm. Time to investigate.
First place I looked was at all the trough switches, then all the lock switches. Also cleaned the lock optos while I was at it. No issues were noted with any of the switches. So I did an "empty balls" operation from the menu just to see if I hadn't somehow had a ball gone missing somewhere.
That was where the problem became apparent. The game would only kick one ball out of the trough, even though there were three in there. Turns out that the ball popper mechanism itself was gummed up and not returning to rest position when it kicked (at least, not right away... eventually it would get there).
So, it was an easy fix. Pop out the mechanism and thoroughly clean and degrease it. No further issues, and no parts needed replacing. Not sure how it ended up with grease in there, but at any rate, it is all good now.

#536 4 years ago

This is my 3rd time in the club. This will be the one I keep.

20141122_191315.jpg
#537 4 years ago
Quoted from BowlingJim:

This is my 3rd time in the club. This will be the one I keep.

Welcome back club-hopper

#538 4 years ago

Figured I'd post in here since you guys all own one.

I am looking to purchase a TZ. Preferably in the New Jersey area. If you know of anyone please let me know. I can pick up immediately. Good way to get a little extra cash before the holidays PM me!

#539 4 years ago
Quoted from Doostur:

Figured I'd post in here since you guys all own one.
I am looking to purchase a TZ. Preferably in the New Jersey area. If you know of anyone please let me know. I can pick up immediately. Good way to get a little extra cash before the holidays PM me!

Hey!! we want NEW members not switch-members ...
anyway
Good luck in your hunt

#540 4 years ago

hello , new in the club , greetings from Belgium .DSCN2086.JPG

1 week later
#541 4 years ago

Signed in!

#542 4 years ago

Anyone here not having optos as flipper switches on TZ?
I have leaf switches and I wonder if that's maybe an early version of TZ.

#543 4 years ago

or maybe a pissed off previuos owner

#544 4 years ago
Quoted from ALY:

Anyone here not having optos as flipper switches on TZ?
I have leaf switches and I wonder if that's maybe an early version of TZ.

As far as I know, no TZs were ever sent out with leaf switches for flipper buttons.

#545 4 years ago

Hi there!
I'd like to set pinball in a way I can compare my records with other pinballers..
Can someone help me? Thanks!

#546 4 years ago
Quoted from JDee:

Hi there!
I'd like to set pinball in a way I can compare my records with other pinballers..
Can someone help me? Thanks!

Are you talking about all the feature settings in the menu? If so, I simply go with the factory defaults, with the exception of the minimum volume and power saver GI level overrides set to on.

#547 4 years ago

ok thanks!
And do I have to set tournament?
What does tournament mode implies?

#548 4 years ago
Quoted from JDee:

ok thanks!
And do I have to set tournament?
What does tournament mode implies?

See the manual, page 1-31. It's a setting to make score *in the same game* more representative/balanced. It won't do a thing for you if you're comparing your scores to other owners'.

#549 4 years ago

thanks!

#550 4 years ago

Me personally, I don't care how my scores compare to others - mainly because for me, the condition and feel of the game can alter my score hugemongously. I like playing more than hitting the start button, so I set Replays & Specials to Extra Balls.

Promoted items from the Pinside Marketplace
7,200
Machine - For Sale
Kinnelon, NJ
$ 5.00
There are 7386 posts in this topic. You are on page 11 of 148.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside