(Topic ID: 150388)

Twilight zone jet bumper not working

By dzrossi

5 years ago


Topic Heartbeat

Topic Stats

  • 13 posts
  • 4 Pinsiders participating
  • Latest reply 5 years ago by GRUMPY
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider dzrossi.
Click here to go back to viewing the entire thread.

#1 5 years ago

I am looking for ideas. I just bought a twilight zone the lower jet bumper is not working. Upper bumpers work. At coil I have 70 volts at each prong which indicates I have power and I believe coil is good. Power board is rotten dog replacement. Q52 transistor test good. No errors reported by game. When I test nothing happens. When I test Switch it works. I am out ideas. Should I try swapping coils to make sure coil not bad. Should I replace transistor ?

#3 5 years ago

i believe it is q52 which is the solenoid 12 circuit. I check connectivity of the wire running from coil to 127-5 connector to board. It appeared to be good.

#8 5 years ago

When I check connectivity of wire I did reseat the J 127 connector. No luck. The transistor is a TIP102. I did not ground when machine was powered on. I did when it was off. There was no connectivity which I believe indicated transistor is not shorted out. Coil is not engerizing at all so not surprise by result. I am apprehensive about completing circute when powered on as it is 70 volts DC. Is there a way to test pre transistor. Is there a way to test address decoder (never heard of that) Board is a Rotten Dog after market so I assume it is good

#11 5 years ago

thanks for everyones suggestions when I get home from my current business trip I plan to test the coil and transistor as suggested above.

#12 5 years ago

Update. I grounded the q52 transistor and the bumper coil energized and did not shut off. I called Jim at Rotten Dog to confirm what transistor was on the board. I am glad I did Jim was extremely helpful. As it turns out transistor was not a TIP102 it was a IRL520. There are no pre transistors on the board so that is all I have to replace. Jim suggested I replace coil as that might have caused the issue to begin with. Better safe than sorry. So I order transistor from great planes electronics. And coil from marco specialties.

You're currently viewing posts by Pinsider dzrossi.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside