(Topic ID: 275898)

Twilight Zone Gumball Machine Malfuntion??


By qbass187

4 months ago



Topic Stats

  • 9 posts
  • 4 Pinsiders participating
  • Latest reply 4 months ago by RonH
  • No one calls this topic a favorite

You

Linked Games

#1 4 months ago

Hey guys,
I noticed the Gumball machine on my TZ all of a sudden stopped working. It will not dispense the balls. Everything else seems in order. All switches work and register in switch test. When I try to get it to run in Test mode I get "Geneva Switch Malfunction" after about 15 seconds. No motor hum or anything.
The Geneva Switch registers in Switch Edge tests so I'm kinda at a loss here...

#2 4 months ago

Geneva switch isn’t activating at the proper time during gameplay, it’s a pain but needs to be adjusted.

#3 4 months ago
Quoted from jchristian11:

Geneva switch isn’t activating at the proper time during gameplay, it’s a pain but needs to be adjusted.

How would one do something like that?

#4 4 months ago

If you get no motor-whir in test mode BEFORE the error, that means that your motor isn't running.
Check the motor and the motor control board, make sure everything there is plugged in, has power, etc.

#5 4 months ago
Quoted from Coyote:

If you get no motor-whir in test mode BEFORE the error, that means that your motor isn't running.
Check the motor and the motor control board, make sure everything there is plugged in, has power, etc.

I checked the connections at the motorboard under the PF and reseated all the connections initially. Nothing changed.
I'm wondering if the motor just died... any way to check ?

#6 4 months ago

Did you check fuse F111, on my machine the motor was not running as well. I found out the F111 is connected to the flashers and gumball motor. My fuse was blown by a broken led flasher, thus leading to the gumball motor and Geneva switch error...

#7 4 months ago
Quoted from RonH:

Did you check fuse F111, on my machine the motor was not running as well. I found out the F111 is connected to the flashers and gumball motor. My fuse was blown by a broken led flasher, thus leading to the gumball motor and Geneva switch error...

I’ll take a look! Thanks

#8 4 months ago
Quoted from RonH:

Did you check fuse F111, on my machine the motor was not running as well. I found out the F111 is connected to the flashers and gumball motor. My fuse was blown by a broken led flasher, thus leading to the gumball motor and Geneva switch error...

BINGO!!!!
Ron, you’re the man!
That did the trick. Thanks everyone for all your help!

#9 4 months ago
Quoted from qbass187:

BINGO!!!!
Ron, you’re the man!
That did the trick. Thanks everyone for all your help!

You're welcome !

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 65.00
Boards
Pinball Haus
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
Wanted
Machine - Wanted
Monson, MA
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside